Andreas C Kazmierczak

Drawing with CAD.direct
M.Sc.Eng. Andreas Ch Kazmierczak is the founder and developer of Print2CAD Software. He has been developing software since 1982. He gained his knowledge of software development over the course of his university career followed by post grad training.

Andreas attended the Technical University in Aachen, Germany where he earned his Master Degree in Engineering. During his studies at the University of Aachen, he gained foundational knowledge of numerical mathematics, 3D geometry and efficient programming techniques. He worked on doctor as an scientific assistant in the Department of Hydrology and Statistics where he created successful programs in the computer in different computer languages.

He gave lectures and training sessions on artificial intelligence and statistics methods in hydrology. His academic career has enabled him to successfully invent conversion programs and fostered his creativity in this area. After many years of learning and training, Andreas Kazmierczak's software is now known and used worldwide.

Andreas Kazmierczak holds many patents in data security and exchange methods. In March 1993, Andreas Kazmierczak founded the company Kazmierczak Inc, specializing in commercial software for building and the exchange of data between different CAD (Computer Aided Design) systems.
In 1997, Andreas Kazmierczak founded the Lions Consulting Inc. in Danzig, Poland.
In 2008, Andreas Kazmierczak develop Print2Cad Software.
In 2009, Andreas Kazmierczak founded the company BackToCAD Technologies LLC, located in Clearwater, Florida.
In 2014, Andreas Kazmierczak founded the company Expert Robotics Inc. located in Smyrna, Georgia.

His software has been used by over 100,000 clients and over 1,500,000 users.

Andreas Kazmierczak is currently a member of the Association of Consulting Engineers. The Association of Consulting Engineers VBI is the leading professional organization of independent consulting and planning engineers in Germany. The VBI has the highest requirements for professional qualifications, independent consultant status, and integrity of its members. Andreas Kazmierczak is constantly seeking advancements in CAD software to ensure the best possible upgrades.
Contents

1. Introduction 21
   1.1 About CAD.direct Drafter and other CAD software 22
       1.1.1 Using AutoCAD legacy drawings 23
       1.1.2 Using AutoCAD commands with CAD.direct Drafter 24
   1.2 Comparing CAD.direct Drafter and CAD to manual drafting 24
       1.2.1 Drawing to scale 24
       1.2.2 Using tools 25
       1.2.3 Organizing information 26
       1.2.4 Drawing accurately 26
       1.2.5 Drawing efficiently 28
       1.2.6 Reusing CAD drawings and entities 30
       1.2.7 Making changes 31
       1.2.8 Working with other data and programs 31
   1.3 Using advanced CAD features 32
       1.3.1 Using the CAD.direct Drafter Explorer 32
       1.3.2 Editing multiple documents simultaneously 32
       1.3.3 Editing multiple entities 32
       1.3.4 Using the Customize dialog box 32
       1.3.5 Performing unlimited undo and redo 32
   1.4 Getting more information 33
   1.3 Working with sample drawings 33
   1.4 New in CAD.direct Drafter 8 33
       1.4.1 Working with Files 33
       1.4.2 Performance Enhancements 34
       1.4.3 Text 34
       1.4.4 Working with Entities 34
       1.4.5 Viewing and Rendering Drawings 34
       1.4.6 More Features 34
       1.4.7 System Variables 35
       1.4.8 Performance Enhancements 35
       1.4.9 User Interface 35
       1.4.10 Printing 35
       1.4.11 Viewing Drawings 36
       1.4.12 Working with Entities 36
       1.4.13 APIs 36
       1.4.14 System Variables 36
   1.5 New in CAD.direct Drafter 8.0 37
       1.5.1 Working with Files 37
       1.5.2 Viewing drawings 37
2. Getting started

2.1 System requirements
2.2 Installing CAD.direct Drafter
2.3 Starting CAD.direct Drafter
2.4 Working in CAD.direct Drafter
  2.4.1 Displaying commands on a shortcut menu
  2.4.2 Displaying and hiding the ribbon
  2.4.3 Displaying and hiding menus
  2.4.4 Displaying and hiding toolbars
  2.4.5 Using the command bar
  2.4.6 Using the status bar
  2.4.7 Using prompt boxes
  2.4.8 Using workspaces
2.5 Selecting commands
  2.5.1 Using commands
  2.5.2 Starting commands using the ribbon
  2.5.3 Starting commands using toolbars
  2.5.4 Starting commands using menus
  2.5.5 Starting commands using the command bar
  2.5.6 Repeating a command
  2.5.7 Nesting a command
  2.5.8 Modifying a command
  2.5.9 Using the Prompt History window
  2.5.10 Using mouse shortcuts
  2.5.11 Using keyboard shortcuts
  2.5.12 Using scripts
2.6 Correcting mistakes
2.7 Customizing CAD.direct Drafter
2.8 Getting online Help
2.9 Saving a drawing
2.10 Exiting CAD.direct Drafter
3. Working with drawings

3.1 Creating a new drawing

3.2 Opening a drawing
   3.2.1 Opening an existing drawing
   3.2.2 Opening a damaged drawing

3.3 Setting up a drawing
   3.3.1 Setting the current layer
   3.3.2 Setting the current entity color
   3.3.3 Setting the current linetype
   3.3.4 Setting the linetype scale
   3.3.5 Setting the current lineweight
   3.3.6 Setting the current print style
   3.3.7 Setting drawing units
   3.3.8 Understanding scale factors
   3.3.9 Setting up annotation scaling
   3.3.10 Customizing the scales list
   3.3.11 Customizing styles to be annotative
   3.3.12 Setting the text height
   3.3.13 Setting the drawing limits

3.4 Working with colors
   3.4.1 Using index colors
   3.4.2 Using true colors
   3.4.3 Using color books
   3.4.5 Creating color books
   3.4.6 Modifying color books
   3.4.7 Loading color books

3.5 Using the grid, snap alignment, and cursor restriction
   3.5.1 Setting a reference grid
   3.5.2 Setting snap spacing
   3.5.3 Changing the snap and grid angle and base point
   3.5.4 Using isometric snap and grid
   3.5.5 Using orthogonal locking
   3.5.6 Using polar tracking

3.6 Using entity snaps
   3.6.1 Setting entity snaps
   3.6.2 Nearest Snap tool
   3.6.3 Endpoint Snap tool
   3.6.4 Midpoint Snap tool
   3.6.6 Perpendicular Snap tool
   3.6.7 Tangent Snap tool
   3.6.8 Quadrant Snap tool
   3.6.9 Insertion Point Snap tool
   3.6.10 Node Snap tool
3.6.11 Parallel Snap tool 107
3.6.12 Apparent Intersection Snap tool 108
3.6.13 Quick Snap command 109
3.6.14 Clear Entity Snaps tool 110
3.6.15 From Point tool 110
3.6.16 Temporary Tracking Point tool 111
3.6.17 Mid Between 2 Points tool 111
3.6.18 Using fly-over snapping 112
3.6.19 Setting up fly-over snapping 113
3.6.20 Using entity snap tracking 114

3.4. Saving your drawing 117
3.4.1 Saving a drawing 117
3.4.2 Saving a drawing with a new name or file format 119
3.4.3 Saving a drawing with a password 120

4. Creating simple entities 121
4.1 Drawing lines 121
4.2 Drawing circles 123
4.3 Drawing arcs 126
4.4 Drawing ellipses 130
4.5 Drawing elliptical arcs 131
4.6 Drawing point entities 132
  4.6.1 Drawing points 132
  4.6.2 Changing the size and appearance of point entities 133
4.7 Drawing rays 135
4.8 Drawing infinite lines 136
4.9 Drawing freehand sketches 138
  4.9.1 Creating freehand sketches 138
  4.9.2 Erasing freehand sketch lines 139
  4.9.3 Setting the sketch method and accuracy 140

5. Creating complex entities 142
5.1 Drawing rectangles and squares 142
5.2 Drawing polygons 144
  5.2.1 Drawing polygons by vertex 144
  5.2.2 Drawing polygons by side 145
  5.2.3 Drawing polygons by specifying the length of an edge 146
5.3 Drawing polylines 147
  5.3.1 Drawing a polyline with straight segments 147
  5.3.2 Drawing a polyline with arc segments 148
5.4 Drawing multilines 150
  5.4.1 Drawing a multiline 150
  5.4.2 Specifying justification and scale 151
5.6 Drawing traces 152
5.7 Drawing splines 153
  5.7.1 Specifying fit tolerance 154
  5.7.2 Drawing a closed spline 154
5.8 Drawing helices 155
5.9 Drawing donuts 157
5.10 Creating planes 159
5.11 Drawing wipeouts 161
  5.11.1 Drawing a wipeout 161
  5.11.2 Creating a wipeout using existing polygons and polylines 162
  5.11.3 Turning wipeout frames on or off 162
5.12 Drawing revision clouds 164
  5.12.1 Drawing a revision cloud 164
  5.12.2 Creating a revision cloud using existing entities 165
  5.12.3 Customizing default revision cloud settings 165
5.13 Creating boundary polylines 166
  5.13.1 Understanding boundary polylines 166
  5.13.2 Using islands and island detection 168
  5.13.3 Creating a boundary polyline 169
5.14 Adding hatching 170
  5.14.1 Specifying a hatch pattern 171
  15.4.2 Selecting entities for hatching 176
  15.4.3 Selecting areas for hatching 178

6 Viewing your drawing 182

  6.1 Redrawing and regenerating a drawing 182
  6.2 Moving around within a drawing 183
    6.2.1 Using scroll bars 183
    6.2.2 Panning a drawing 183
    6.2.3 Orbiting the drawing in real time 186
  6.3 Changing the magnification of your drawing 187
    6.3.1 Understanding zoom 188
    6.3.2 Zooming in to an area using a window 188
    6.3.3 Zooming in to one or more entities 189
    6.3.4 Zooming in real time 189
    6.3.5 Zooming using a mouse with a wheel 190
    6.3.6 Displaying the previous view of a drawing 190
6.3.7 Zooming to a specific scale 191
6.3.8 Combining zooming and panning 191
6.3.9 Displaying the entire drawing 192

6.4 Changing the view of annotative entities 193
6.4.1 Turning on scaling of annotative entities 193
6.4.2 Changing the scale of annotative entities 196
6.4.3 Displaying and hiding certain annotative entities 197
6.4.4 Returning scale views of annotative entities to their default positions 197

6.5 Displaying a drawing with a visual style 198

6.6 Displaying multiple views 199
6.6.1 Working with multiple views of a single drawing 199
6.6.2 Opening a new window of the same drawing 199
6.6.3 Dividing the current window into multiple views 200
6.6.4 Saving window configurations 203
6.6.5 Working with multiple drawings 203

6.7 Controlling visual elements 205
6.7.1 Displaying solid fills 205
6.7.2 Displaying quick text 206
6.7.3 Displaying highlighting 207
6.7.4 Displaying blips 208
6.7.5 Displaying lineweights 208

7. Working with coordinates 210

7.1 Using Cartesian coordinates 210
7.1.1 Understanding how coordinate systems work 210
7.1.2 Understanding how coordinates display 213
7.1.3 Finding the coordinates of a point 214

7.2 Using two-dimensional coordinates 214
7.2.1 Entering absolute Cartesian coordinates 214
7.2.2 Entering relative Cartesian coordinates 215
7.2.3 Entering polar coordinates 216

7.3 Using three-dimensional coordinates 218
7.3.1 Using the right-hand rule 218
7.3.2 Entering x,y,z-coordinates 219
7.3.3 Entering spherical coordinates 219
7.3.4 Entering cylindrical coordinates 220

7.4 Using xyz point filters 221
7.4.1 Using point filters in two dimensions 221
7.4.2 Using point filters in three dimensions 222
7.5 Defining user coordinate systems
   7.5.1 Understanding user coordinate systems
   7.5.2 Defining a user coordinate system
   7.5.3 Using a preset user coordinate system

8 Working with CAD.direct Drafter Explorer
   8.1 Using CAD.direct Drafter Explorer
     8.1.1 Displaying CAD.direct Drafter Explorer
     8.1.2 Copying settings
     8.1.3 Deleting settings
     8.1.4 Purging elements
   8.2 Organizing information on layers
     8.2.1 Understanding layers
     8.2.2 Displaying layer information in CAD.direct Drafter Explorer
     8.2.3 Creating and naming layers
     8.2.4 Filtering and finding layers
     8.2.5 Searching layers by name
     8.2.6 Filtering layers by property
     8.2.7 Filtering layers by group
     8.2.8 Inverting layer filters
     8.2.9 Importing and exporting layer properties filters
     8.2.10 Setting the current layer
     8.2.11 Controlling layer visibility
     8.2.12 Locking and unlocking layers
     8.2.13 Controlling layer printing
     8.2.14 Setting the layer color
     8.2.15 Setting the layer linetype
     8.2.16 Setting the layer lineweight
     8.2.17 Setting the layer transparency
     8.2.18 Setting the layer print style
     8.2.19 Working with layer states
     8.2.20 Displaying layer states in the Layer States Manager
     8.2.21 Creating layer states
     8.2.22 Applying a layer state
     8.2.23 Displaying layer states in CAD.direct Drafter Explorer
     8.2.24 Importing and exporting layer states from files
   8.3 Working with linetypes
     8.3.1 Understanding linetypes
     8.3.2 Displaying linetype information in CAD.direct Drafter Explorer
     8.3.3 Setting the current linetype
     8.3.4 Loading additional linetypes
     8.3.5 Creating and naming linetypes
     8.3.6 Creating a new simple linetype
     8.3.7 Creating a new complex linetype
8.3.8 Syntax for a complex linetype definition 265
8.3.9 Modifying linetypes 268

8.4 Working with text styles 269
  8.4.1 Understanding text styles 269
  8.4.2 Displaying text style information in CAD.direct Drafter Explorer 269
  8.4.2 Creating and naming text styles 270
  8.4.3 Modifying text styles 272
  8.4.4 Setting the current text style 272

8.5 Working with coordinate systems 273
  8.5.1 Understanding coordinate systems 273
  8.5.2 Displaying coordinate system information in CADconv Connect Explorer 274
  8.5.3 Defining and naming user coordinate systems 275
  8.5.4 Setting the current user coordinate system 275

8.6 Using named views 276
  8.6.1 Displaying views in the CAD.direct Drafter Explorer 276
  8.6.2 Saving and naming views 277
  8.6.3 Restoring named views 278
  8.6.4 Changing named view properties 279

8.7 Working with layouts 279
  8.7.1 Displaying layouts in the CAD.direct Drafter Explorer 280
  8.7.2 Creating and naming layouts 281
  8.7.3 Creating and naming layouts 281
  8.7.4 Specifying page setup options for a layout 282

8.8 Working with blocks 283
  8.8.1 Understanding blocks 283
  8.8.2 Displaying block information in CAD.direct Drafter Explorer 284
  8.8.3 Creating and naming blocks 286
  8.8.4 Inserting a block 289
  8.8.5 Inserting a drawing as a block 289
  8.8.6 Saving a block as a separate drawing 290

8.9 Working with references to external files 290
  8.9.1 Displaying information about referenced files in CAD.direct Drafter Explorer 291
  8.9.2 Attaching referenced files 292
  8.9.3 Modifying the settings for referenced files 292

8.10 Working with dimension styles 294
  8.10.1 Displaying dimension style information in CAD.direct Drafter Explorer 294
  8.10.2 Creating and naming dimension styles 295
  8.10.3 Copying dimension styles 296

8.11 Working with groups 297
  8.11.1 Displaying information about groups in d Explorer 297
  8.11.2 Creating a new group using CAD.direct Drafter Explorer 297
  8.11.3 Modifying groups 298
9. Getting drawing information

9.1 Specifying measurements and divisions
  9.1.1 Understanding measurements and divisions
  9.1.2 Measuring intervals on entities
  9.1.3 Dividing entities into segments

9.2 Calculating areas
  9.2.1 Calculating areas defined by points
  9.2.3 Calculating areas of closed entities
  9.2.4 Calculating combined areas
  9.2.5 Viewing calculated area details

9.3 Calculating distances and angles
  9.3.1 Calculating the distance between two points and their angle
  9.3.2 Viewing calculated distance details

9.4 Displaying information about your drawing
  9.4.1 Displaying information about entities
  9.4.2 Displaying the drawing status
  9.4.3 Tracking time spent working on a drawing

10. Modifying entities

10.1 Selecting entities
  10.1.1 Understanding when to select entities
  10.1.2 Understanding entity-selection methods
  10.1.3 Selecting entities by clicking them
  10.1.4 Selecting entities by drawing a selection window
  10.1.5 Selecting entities using a fence
  10.1.6 Filtering entity selection
  10.1.7 Selecting entities by property
  10.1.8 Selecting proxy entities using a filter
  10.1.9 Selecting blocks of the same name
  10.1.10 Selecting entities by type
  10.1.11 Selecting entities by value
  10.1.12 Deselecting entities
  10.1.13 Using grips
  10.1.14 Selecting grips for editing
  10.1.15 Turning grips on and off
  10.1.16 Displaying selected entities highlighted

10.2 Modifying the properties of entities
  10.2.1 Modifying entity properties
  10.2.2 Modifying the properties of multiple entities
  10.2.3 Changing multiple properties to ByLayer

10.3 Deleting entities

10.4 Copying entities
10.4.1 Copying entities within a drawing 332
10.4.2 Copying between drawings 333
10.4.3 Copying between spaces 334
10.4.4 Making parallel copies 335
10.4.5 Mirroring entities 337
10.4.6 Arraying entities 338

10.5 Rearranging entities 342
10.5.1 Moving entities 342
10.5.2 Moving entities between spaces 344
10.5.3 Rotating entities 344
10.5.4 Reordering entities 346

10.6 Resizing entities 347
10.6.1 Stretching entities 347
10.6.2 Scaling entities 349
10.6.3 Extending entities 350
10.6.4 Trimming entities 353
10.6.5 Editing the length of entities 356

10.7 Splitting and combining entities 357
10.7.1 Breaking entities 357
10.7.2 Joining entities 359
10.7.3 Exploding entities 360
10.7.4 Grouping entities 362
10.7.5 Creating groups 362
10.7.6 Modifying groups 363
10.7.7 Ungrouping entities 365

10.8 Editing polylines 365
10.8.1 Converting an entity to a polyline 366
10.8.2 Opening and closing polylines 366
10.8.3 Curving and recurving polylines 367
10.8.4 Joining polylines 368
10.8.5 Changing the polyline width 369
10.8.6 Editing polyline vertices 370

10.9 Chamfering and filleting entities 372
10.9.1 Modifying the chamfer and fillet settings 372
10.9.2 Chamfering entities 373
10.9.3 Chamfering two entities using the distance-distance method 374
10.9.4 Chamfering two entities using the distance-angle method 375
10.9.5 Chamfering all vertices in a polyline 376
10.9.6 Chamfering selected vertices in a polyline 376
10.9.7 Filleting entities 377
10.9.8 Filleting two entities 377
10.9.9 Filleting an entire polyline 378
10.9.10 Filleting selected vertices in a polyline 379
11 Working with text
11.1 Creating line text 381
11.2 Creating paragraph text 382
11.3 Working with text styles 384
11.4 Formatting text 386
11.4.1 Setting the line text style 386
11.4.2 Setting the paragraph text style 386
11.4.3 Setting the line text alignment 387
11.4.4 Setting the paragraph text alignment 388
11.4.5 Including special text characters 389
11.5 Changing text 390
11.5.1 Changing line text 390
11.5.2 Changing paragraph text 390
11.5.3 Finding and replacing text 391
11.5.4 Converting line text to paragraph text 393
11.6 Checking the spelling 394
11.6.1 Checking the spelling of text 394
11.6.2 Customizing the spelling words 396
11.6.3 Changing the dictionary 397
11.7 Using an alternate text editor 399
11.7.1 Selecting an alternate text editor 399
11.7.2 Creating paragraph text in an alternate text editor 400
11.8 Working with text written in different languages 401
11.8.1 Using Unicode characters 401
11.8.2 Specifying character sets for drawings 401

12. Dimensioning your drawing 403
12.1 Understanding dimensioning concepts 403
12.2 Creating dimensions 405
12.2.1 Creating linear dimensions 405
12.2.2 Creating angular dimensions 409
12.2.3 Creating arc dimensions 411
12.2.5 Creating diametral and radial dimensions 412
12.2.6 Creating ordinate dimensions 414
12.2.7 Creating leaders and annotations 415
12.2.8 Dimensioning model space entities in paper space 416
12.3 Editing dimensions 417
12.3.1 Making dimensions oblique 417
12.3.2 Editing dimension text 418
12.4 Using dimension styles and variables 420
12.4.1 Creating a dimension style 420
12.4.2 Selecting a dimension style 421
12.4.3 Renaming a dimension style 422
12.4.4 Deleting a dimension style 422
12.4.5 Controlling line settings 423
12.4.7 Controlling dimension text 426
12.4.9 Controlling primary dimension units 430

12.5 Adding geometric tolerances 434
12.5.1 Understanding geometric tolerances 434
12.5.2 Adding a geometric tolerance 436
12.5.3 Controlling dimension tolerances 438

13 Working with other files in your drawings 440
13.1 Working with blocks 440
13.1.1 Understanding blocks 440
13.1.2 Creating blocks 441
13.1.3 Saving blocks 443
13.1.4 Inserting blocks 447
13.1.5 Redefining blocks 449
13.1.6 Editing blocks in-place 450
13.1.7 Exploding blocks 451
13.2 Working with attributes 452
13.2.1 Defining Attributes 452
13.2.2 Editing attribute definitions 455
13.2.3 Attaching attributes to blocks 455
13.2.4 Editing attributes attached to blocks 455
13.3 Working with external references 459
13.3.1 Understanding external references 459
13.3.2 Attaching external references 460
13.3.3 Viewing the list of external references 462
13.3.4 Opening external references 463
13.3.5 Removing external references 464
13.3.6 Reloading external references 465
13.3.7 Changing the path for external references 465
13.3.8 Binding external references to drawings 466
13.3.9 Clipping external references 467
13.3.10 Adding clipping boundaries 468
13.3.11 Turning clipping boundaries on and off 470
13.3.12 Deleting clipping boundaries 470
13.3.13 Editing external references in-place 471
13.4 Attaching underlays created in other file formats 472
13.4.1 Attaching a PDF underlay 473
13.4.2 Attaching a DWF underlay 473
13.4.3 Attaching a DGN underlay 474
13.4.4 Attaching a point cloud underlay 474

13.5 Working with images 475
13.5.1 Attaching images 475
13.5.2 Modifying images 477
13.5.3 Changing the display of images 479
13.5.4 Turning image frames on or off for all images 479
13.5.5 Clipping images 480
13.5.6 Clipping images in the shape of a rectangle 480
13.5.7 Clipping images in the shape of a polygon 481
13.5.8 Turning clipping on or off for images 481
13.5.9 Removing clipping from images 482
13.5.10 Unloading and reloading images 482
13.5.11 Changing the path for images 483
13.5.12 Deleting images 484

14 Printing drawings 485
14.1 Getting started printing 485
14.2 Defining layouts for printing 486
14.2.1 Understanding layouts 486
14.2.2 Understanding paper space and model space 487
14.2.3 Viewing drawings in paper space and model space 489
14.2.4 Displaying the Model and Layout tab 490
14.2.5 Creating a new layout 490
14.2.6 Reusing layouts from other files 491
14.2.7 Managing layouts in a drawing 492
14.2.8 Working with layout viewports 493
14.2.9 Understanding layout viewports 493
14.2.10 Creating layout viewports 494
14.2.11 Viewing and scaling layout viewports 495
14.2.12 Modifying layout viewports 497
14.2.13 Clipping layout viewports 498

14.3 Customizing and reusing print settings 500
14.3.1 Working with page setups 500
14.3.2 Creating a page setup 501
14.3.3 Modifying an existing page setup 504
14.3.4 Deleting a page setup 504
14.3.5 Setting the paper size and orientation 505
14.3.6 Selecting a printer or plotter 506
14.3.7 Setting the scale and view 506
14.3.7 Specifying print options specifically for layouts 509
14.3.8 Specifying shaded viewport print options 510
14.3.9 Specifying pen and line printing options 511
14.3.10 Using printer configuration files 511
14.3.11 Using plotter drivers 513

14.4 Using print styles 513
14.4.1 Understanding print style tables 513
14.4.2 Implementing print style tables 515
14.4.3 Assigning print style tables 517
14.4.4 Creating new print style tables 518
14.4.5 Modifying print style tables 519
14.4.6 Copying, renaming, or deleting print style tables 522
14.4.7 Changing the print style table type of a drawing 522
14.4.8 Converting print style tables 524
14.4.9 Turning print style tables on or off 524

14.5 Printing or plotting your drawing 525
14.5.1 Previewing a drawing before printing 525
14.5.2 Printing a drawing 527
14.5.3 Saving print settings for a model or layout 528

14.6 Publishing drawings 529
14.6.1 Creating a sheet list to publish 529
14.6.2 Modifying an existing sheet list 530
14.6.3 Publishing a sheet list 531

15. Drawing in three dimensions 533
15.1 Viewing entities in three dimensions 533
15.1.1 Setting a new viewing direction 534
15.1.2 Setting a viewing direction dynamically 535
15.1.3 Displaying a plan view of the current drawing 537

15.2 Creating three-dimensional entities 537
15.2.1 Applying elevation and thickness 538
15.2.2 Creating three-dimensional faces 542
15.2.3 Creating rectangular meshes 543
15.2.4 Creating polyface meshes 544
15.2.5 Creating ruled surface meshes 545
15.2.6 Creating extruded surface meshes 546
15.2.7 Creating revolved surface meshes 547
15.2.8 Creating edge-defined Coons surface patch meshes 548
15.2.9 Creating boxes 549
15.2.10 Creating wedges 550
15.2.11 Creating cones 551
15.2.12 Creating pyramids 552
15.2.14 Creating spheres 556
15.2.15 Creating dishes 558
15.2.16 Creating domes 559
15.2.17 Creating tori 560
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>15.2.18 Creating regions</td>
<td>561</td>
</tr>
<tr>
<td>15.2.19 Creating extruded solids</td>
<td>562</td>
</tr>
<tr>
<td>15.2.20 Creating revolved solids</td>
<td>563</td>
</tr>
<tr>
<td>15.2.21 Creating lofted solids and surfaces</td>
<td>564</td>
</tr>
<tr>
<td>15.2.22 Creating swept solids and surfaces</td>
<td>565</td>
</tr>
<tr>
<td>15.2.23 Creating polysolids</td>
<td>566</td>
</tr>
<tr>
<td>15.2.24 Creating composite solids</td>
<td>567</td>
</tr>
<tr>
<td>15.3 Editing in three dimensions</td>
<td>569</td>
</tr>
<tr>
<td>15.3.1 Rotating in three dimensions</td>
<td>569</td>
</tr>
<tr>
<td>15.3.2 Arraying in three dimensions</td>
<td>570</td>
</tr>
<tr>
<td>15.3.3 Mirroring in three dimensions</td>
<td>572</td>
</tr>
<tr>
<td>15.3.4 Aligning in three dimensions</td>
<td>573</td>
</tr>
<tr>
<td>15.4 Editing three-dimensional solids</td>
<td>576</td>
</tr>
<tr>
<td>15.4.1 Chamfering and filleting solids</td>
<td>576</td>
</tr>
<tr>
<td>15.4.2 Sectioning and slicing solids</td>
<td>577</td>
</tr>
<tr>
<td>15.4.3 Modifying faces</td>
<td>578</td>
</tr>
<tr>
<td>15.4.4 Modifying edges</td>
<td>584</td>
</tr>
<tr>
<td>15.4.5 Imprinting solids</td>
<td>586</td>
</tr>
<tr>
<td>15.4.6 Separating solids</td>
<td>586</td>
</tr>
<tr>
<td>15.4.7 Shelling solids</td>
<td>587</td>
</tr>
<tr>
<td>15.4.8 Cleaning solids</td>
<td>588</td>
</tr>
<tr>
<td>15.4.9 Checking solids</td>
<td>588</td>
</tr>
<tr>
<td>15.4.10 Converting solids to polyface meshes</td>
<td>588</td>
</tr>
<tr>
<td>15.5 Hiding, shading, and rendering</td>
<td>589</td>
</tr>
<tr>
<td>15.5.1 Creating hidden-line images</td>
<td>589</td>
</tr>
<tr>
<td>15.5.2 Creating shaded images</td>
<td>590</td>
</tr>
<tr>
<td>15.5.3 Creating rendered images</td>
<td>591</td>
</tr>
<tr>
<td>15.5.4 Creating custom rendered images</td>
<td>592</td>
</tr>
<tr>
<td>15.5.5 Printing a rendered image</td>
<td>593</td>
</tr>
<tr>
<td>15.5.6 Rendering in Artisan Renderer</td>
<td>594</td>
</tr>
<tr>
<td><strong>16 Working with other programs</strong></td>
<td>597</td>
</tr>
<tr>
<td>16.1 Saving and viewing snapshots</td>
<td>597</td>
</tr>
<tr>
<td>16.1.1 Creating snapshots</td>
<td>597</td>
</tr>
<tr>
<td>16.1.2 Viewing snapshots</td>
<td>598</td>
</tr>
<tr>
<td>16.2 Using data from other programs in CAD.direct Drafter drawings</td>
<td>599</td>
</tr>
<tr>
<td>16.2.1 Embedding objects into drawings</td>
<td>599</td>
</tr>
<tr>
<td>16.2.2 Linking objects to drawings</td>
<td>601</td>
</tr>
<tr>
<td>16.3 Editing an embedded or linked object from within CAD.direct Drafter</td>
<td>602</td>
</tr>
<tr>
<td>16.3.1 Importing files created in other formats</td>
<td>603</td>
</tr>
<tr>
<td>16.4 Using CAD.direct Drafter data in other programs</td>
<td>605</td>
</tr>
<tr>
<td>16.4.1 Embedding drawings</td>
<td>605</td>
</tr>
</tbody>
</table>
16.4.2 Editing an embedded CAD.direct Drafter object in place 606
16.4.3 Linking drawings 607
16.4.4 Dragging CAD.direct Drafter drawings into other programs 608
16.4.5 Exporting drawings 609
16.4.6 Exporting to a PDF format file 610
16.4.7 Exporting to a DWF format file 611
16.4.8 Exporting to a DGN format file 612
16.4.9 Exporting to an ACIS format file 612
16.4.10 Converting drawings to other file versions and formats 613
16.4.11 Sending drawings through e-mail 615

16.5 Using CAD.direct Drafter with the Internet 616
16.5.1 Adding hyperlinks to a drawing 616
16.5.2 Publishing drawings to the Internet 618
16.5.3 Inserting drawings from a Web site 618
16.5.4 Accessing the CAD.direct Drafter Web site during a drawing session 618

17. Customizing CAD.direct Drafter 619
17.1 Setting and changing options 619
17.1.1 Changing the options on the General tab 620
17.1.2 Setting the experience level 621
17.1.3 Saving your drawings automatically 621
17.1.4 Setting the default SaveAs format 622
17.1.5 Setting how drawings are opened 623
17.1.6 Setting error reporting options 624
17.1.7 Disabling VBA CommonProject macros 624
17.1.8 Specifying the user paths 625
17.1.9 Changing the default system files 626
17.1.10 Changing the options on the Display tab 628
17.1.11 Setting how the command bar works 628
17.1.12 Customizing how suggestions display in the command bar 629
17.1.13 Setting the main window options 632
17.1.14 Setting colors of the main window 633
17.1.15 Setting mouse options 636
17.1.16 Setting how menus display 636
17.1.17 Setting user interface options 637
17.1.18 Changing the options on the Profiles tab 639
17.1.19 Creating profiles 640
17.1.20 Loading a profile 641
17.1.21 Restoring the default settings 642
17.1.22 Managing profiles 643
17.1.23 Working with profiles on multiple computers 644
17.1.24 Changing the options on the Printing tab 645
17.1.25 Setting the default printer 646
17.1.26 Setting default print styles 646
1. Introduction

Using CAD.direct Drafter is part of an integrated documentation set that includes this manual and a comprehensive collection of help resources to give you the information you need to create drawings in CAD.direct Drafter.

About CAD.direct Drafter and other CAD software. This manual is organized into chapters that parallel how you work in CAD.direct Drafter, according to the tasks you might perform. The tasks are divided and organized into the following work-focused chapters:

Introduction: Chapter 1.

An overview of the key features of CAD.direct Drafter plus basic concepts of computer-aided design (CAD) as they apply to CAD.direct Drafter.

Getting started: Chapter 2.

Installing CAD.direct Drafter, starting and exiting CAD.direct Drafter, working with toolbars, and selecting commands.

Working with drawings: Chapter 3.

Opening and saving an existing drawing and starting a new drawing. Using drawing settings to establish paper size, scale factors, and text height. Working with colors in your drawings. Using drawing aids such as entity snaps and orthogonal mode to draw accurately.

Creating entities: Chapters 4–5.

Working with simple entities such as lines, circles, and arcs and with complex entities such as polygons, spline curves, planes, wipeouts, boundary hatches, and more.

Viewing your drawing: Chapter 6.

Moving around in the drawing, changing its magnification, creating multiple views, and saving arrangements of windows of the drawing.

Working with coordinates: Chapter 7.

Working with Cartesian coordinate systems, specifying two-dimensional and three-dimensional coordinates, and defining your own user coordinate systems.

Working with the CAD.direct Drafter Explorer: Chapter 8.

Using the CAD.direct Drafter Explorer to manage your drawings: controlling layers, linetypes, text styles, coordinate systems, views, and blocks and copying information between drawings.
Getting drawing information: Chapter 9

Working with the additional information in CAD.direct Drafter drawings, calculating areas and distances, and displaying other drawing information.

Modifying entities: Chapter 10.

Selecting, copying, rearranging, resizing, and editing entities.

Annotating and dimensioning your drawing: Chapters 11–12.

Using text to annotate drawings; using dimensions to annotate the measurement of entities.

Working with blocks, attributes, and external references: Chapter 13.

Using blocks and external references to combine entities and data for reuse; creating attribute information to extract for use in other programs.

Formatting and printing drawings: Chapter 14.

Combining drawings into finished lay-outs, customizing print options, and printing copies.

Drawing in three dimensions: Chapter 15.

Creating and editing three-dimensional entities. And visualizing them using hidden line removal, shading, and photo-realistic rendering.

Working with other programs: Chapter 16.

Sharing drawings and data with other users, documents, and programs.

Customizing CAD.direct Drafter: Chapter 17.

Customizing the appearance and operation of the program to suit your needs.

Understanding AutoCAD compatibility: Appendix Describes similarities and differences between CAD.direct Drafter and AutoCAD.

This section introduces you to CAD.direct Drafter®, its features, and its comprehensive capabilities for creating drawings of various types.

1.1 About CAD.direct Drafter and other CAD software

CAD.direct Drafter is designed for anyone who wants a fast and efficient CAD program with all the power and versatility of standard programs such as AutoCAD by Autodesk, Inc., or MicroStation by Bentley Systems, Inc., at an affordable price. Using today’s advanced technology, CAD.direct Drafter integrates the Microsoft Windows interface with a powerful CAD engine.
CAD.direct Drafter provides unparalleled compatibility with AutoCAD, using most of the same file formats including those for drawings (.dwg files), commands, linetypes, hatch patterns, and text styles. You can also use AutoCAD menu files and run Autodesk AutoLISP programs. If you have written your own ADS (Autodesk AutoCAD Development System) programs, simply recompile them to link with the CAD.direct Drafter libraries. Many third-party ADS programs already support CAD.direct Drafter. If you have a program that is not already supported, ask your software vendor to provide an CAD.direct Drafter-compatible version of the program.

CAD.direct Drafter is more compatible with the AutoCAD program than any other CAD product, delivers additional tools with advanced CAD features, and has a seamless Microsoft Windows integration. This powerful program provides a superb combination of features for CAD users like architects, engineers, and designers.

CAD.direct Drafter incorporates standard features found in other CAD programs, along with features and capabilities you won’t find anywhere else. Its multiple-document inter-face (MDI) lets you open and work with several drawings at the same time. You can easily copy drawing entities between drawings. In addition, the powerful CAD.direct Drafter Explorer lets you manage information and settings and quickly copy layers, linetypes, and other information between drawings.

1.1.1 Using AutoCAD legacy drawings

CAD.direct Drafter fully supports AutoCAD legacy drawings. CAD.direct Drafter reads and writes .dwg files in their native format without any loss of data, from AutoCAD 2007 back to Version 11, including AutoCAD LT®. Because CAD.direct Drafter uses Autodesk DWGê format as its native file format, no translation is required.

CAD.direct Drafter provides you with the appropriate tools for your experience level —whether you are a beginner, intermediate, or advanced CAD user. If you are just starting out with CAD, you may want to use the beginner level, which provides toolbars containing the basic tools such as lines, arcs, and circles. As you become more experienced, you can move to the intermediate level and then to the advanced level, which gives you access to more than 300 commands through toolbars, menus, and keyboard entries. You can change the experience level in the Options dialog box on the Tools menu.

CAD.direct Drafter supports three-dimensional wireframes and surfaces. Three-dimensional drawings can be displayed in wireframe, hidden-line view, and surface shading. Some versions of CAD.direct Drafter also support creating and editing 3D solids; all versions display 3D solids, along with limited editing features.

Some versions of CAD.direct Drafter support displaying and working with raster images in your drawings. However, CAD.direct Drafter does not display images located inside of blocks and externally referenced drawings (xrefs). When drawing containing proxy entities is loaded into CAD.direct Drafter, a message displays indicating that some entities will not display, however, the entities reappear when you open the drawing later in AutoCAD.
It's easy to customize CAD.direct Drafter. You can modify menus and toolbars, create custom menus, dialog boxes, command aliases, and scripts, and add custom programs written in any of several programming languages, including DRX (the program’s Autodesk® ARX-compatible language), LISP (the program’s Autodesk AutoLISP-compatible language), and SDS™ (Solutions Development System™, the program’s Autodesk ADS-compatible language). There is also Microsoft® Visual Basic for Applications (VBA).

You can run existing Autodesk® AutoLISP applications in CAD.direct Drafter with little or no modification. CAD.direct Drafter uses the Appload command so you can easily load LISP programs. CAD.direct Drafter reads files that contain dialog control language (DCL) statements as well, which makes CAD.direct Drafter compatible with dialog boxes created for AutoCAD.

### 1.1.2 Using AutoCAD commands with CAD.direct Drafter

Because CAD.direct Drafter supports hundreds of AutoCAD commands, you use the commands you already know. For example, to draw a circle, use the Circle command. To copy a circle, use the Copy command.

When you press Enter or the spacebar, you activate the command—just like in Auto-CAD. CAD.direct Drafter accepts the special characters used by AutoCAD, such as point filters (for example, .xy), relative coordinates (the @ symbol), and the apostrophe (the ' prefix) for transparent commands. CAD.direct Drafter function keys are also similar to those used in AutoCAD.

Because you do not need to learn a new set of commands, you are immediately productive with CAD.direct Drafter.

### 1.2 Comparing CAD.direct Drafter and CAD to manual drafting

CAD.direct Drafter greatly reduces the time and effort it takes to create and revise drawings. Not only can you produce accurate drawings faster, you can also reuse the information in your drawings. These are the primary reasons for making the transition to CAD from traditional, manual drafting on paper.

As with any tool, however, to use it effectively, you need to be familiar with some of the specific features, functions, and concepts of CAD. If you are familiar with manual drafting, you'll find some conceptual similarities in CAD as well as some differences.

#### 1.2.1 Drawing to scale

In traditional, manual drafting, you usually determine the scale of the drawing before you even start to draw, because you are working with a sheet of paper of a fixed size. You may have to reduce or enlarge the entity you are drawing to fit within the confines of the paper.
When you create a drawing in CAD.direct Drafter, you draw everything full-size. You determine the type of units in which your drawing is measured. If you are drawing a building, 1 drawing unit might equal 1 inch. If you are drawing a map, 1 drawing unit might equal 1 mile. Your drawing environment and the CAD drawing file itself are not limited to the size of a sheet of paper.

As you draw, you can use commands such as Pan and Zoom to work on different portions of the drawing and to magnify the display of the drawing to view intricate details. These commands have no effect on the actual size of the entities in your drawing; they affect only the way the drawing is displayed on your screen. Only when you print or plot your drawing do you need to set the scale so that the printed drawing fits within a specific paper size.

1.2.2 Using tools

In manual drafting, you use tools such as pencils, rulers, T-squares, templates, erasers, and so on. When you create a drawing in CAD.direct Drafter, you use a mouse instead of a pencil, and you use the mouse to select
other tools—commands you select from a menu or a toolbar.

You use some tools to create basic entities, such as lines, circles, and arcs, and other tools to modify existing entities (for example, to copy or move them or to change properties such as color and linetype).

### 1.2.3 Organizing information

In traditional drafting, you often separate elements such as walls, dimensions, structural steel members, and electrical plans onto separate, translucent overlays. When you want to print the working drawings, you can create several different drawings by combining different overlays.

When you create a drawing in CAD.direct Drafter, you use layers to organize elements in a similar manner. However, the layers feature in CAD offers numerous advantages over physical transparencies. The number of overlays you can combine to print a manually drafted drawing is limited by the printing process. There is no such limitation in CAD. With CAD.direct Drafter, you can define an unlimited number of layers, any of which can be visible or invisible at any time. You can name each layer and assign each its own color, linetype, lineweight, and print style. You can also lock individual layers to ensure that information on those layers isn’t altered accidentally.

1.2.4 Drawing accurately

When you create a manual drawing, ensuring accuracy typically requires a lot of manual calculations and rechecking. By contrast, CAD.direct Drafter offers a number of drawing aids that ensure accuracy from the start. For example, you create and modify entities based on an underlying Cartesian coordinate system. Every
location in the drawing has its own x,y,z-coordinates. You can also display a grid as a visual reference to your coordinate system.

![Diagram showing a 3D coordinate system with grid lines and sample points.](image)

Every location in the drawing has its own x,y,z-coordinates within the underlying Cartesian coordinate system. Point 5,2,0 is 5 units to the right (along the x-axis), 2 units up (along the y-axis), and 0 units (along the z-axis) from the origin (the 0,0,0 point).

Settings such as snap and entity snap allow you to draw accurately without specifying coordinates. The snap setting forces the selected points to adhere to the grid increment or to any other increment you set. Entity snaps let you snap to precise geometric points on existing entities—for example, the endpoint of a line or the center of a circle. Another setting, orthogonal, constrains lines so that they are drawn parallel to the vertical and horizontal axes.

![Diagram showing a line drawn parallel to the axes using orthogonal setting.](image)

Paper-based drawings lack the high degree of accuracy possible when using CAD. Lines often overlap or fail to meet adjacent lines.
1.2.5 Drawing efficiently

In paper-based, manual drafting, you often have to redraw the same entity several times at different scales or from different vantage points. You may also need to redraw the border and title block on each new sheet.

One of the most powerful features of CAD.direct Drafter is that when you create a drawing, you can reuse individual entities, borders, and title blocks as often as you want. You need draw an entity only once; the final printed drawing can show the entity at several different scales and viewpoints.

You usually begin drawing in model space on the Model tab, creating the drawing (a floor plan, a map, or a three-dimensional part) without regard to the final layout on paper. When you are ready to print your drawing, you have the option to switch to paper space on a Layout tab, where you lay out the drawing as you want it to appear on a sheet of paper. For example, you can insert a drawing file that contains the standard border and title block that you created. You can define and arrange multiple views of the drawing at appropriate scales and with specific portions visible or invisible—again, without having to redraw the border and title block for each view.
You create the basic drawing in model space on the Model tab.

When you're ready to print or plot your drawing, you can switch to paper space on a Layout tab, where you provide a layout of the drawing as you want it to appear on a sheet of paper.
1.2.6 Reusing CAD drawings and entities

When you create a paper drawing manually, you can draw repetitive symbols by tracing a plastic template. After you draw a symbol in CAD.direct Drafter, you can reuse that symbol without having to redraw it. You simply save the symbol as a block. You can then insert copies of that block anywhere in your drawing. You can also save the symbol as a separate drawing for use in other drawings.

In addition, you can reuse entire drawings and insert individual drawings into other drawings. You can also use an external reference, which acts as a pointer to another drawing rather than a copy of the entire drawing. Using an external reference has an added advantage: when you update the externally referenced drawing, each drawing that references it can be automatically updated.
1.2.7 Making changes

To make changes to a paper drawing, you erase and then redraw. With CAD.direct Drafter, you use commands to modify entities in the drawing. You can move, rotate, stretch, or change the scale of entities. When you want to remove an entity, you can delete it with a single click of the mouse. If you make a mistake while creating or modifying your drawing, you can easily reverse your actions.

![Diagram](image)

You can easily change an entity using commands such as move, rotate, stretch, and scale instead of redrawing the entity.

1.2.8 Working with other data and programs

Traditional paper drawings serve only as a means of communicating information between the person who created the drawing and the person viewing the drawing. The drawings contain no more information than what is visually imparted by the creator and seen by the viewer.

Traditional paper drawings serve only as a means of communicating information between the person who created the drawing and the person viewing the drawing. The drawings contain no more information than what is visually imparted by the creator and seen by the viewer.

CAD.direct Drafter offers rich possibilities for analyzing drawings and attaching additional data to them. For instance, although it may be impractical to count entities in a complex paper drawing, this task is simple in CAD. CAD.direct Drafter can calculate the number of entities in a drawing and compute area and distance.

CAD drawings can also contain information in addition to visible entities. You can attach invisible database information to visible drawing entities and extract the information for analysis in a database or spreadsheet. (Working with information in a data-base requires a program from a third-party vendor, or you can create your own means of exporting the data in LISP or SDS. Or, you can also use VBA.)
CAD.direct Drafter provides in-place editing of Microsoft objects, such as those created in Microsoft Word and Microsoft Excel software programs. In-place editing makes it easy to share data with other users and programs. For example, you can include Intel-liCAD drawings in files created using Microsoft Word, and you can insert files created using Microsoft Word into your CAD.direct Drafter drawings.

1.3 Using advanced CAD features

In addition to being compatible with AutoCAD, CAD.direct Drafter goes several steps further by providing you with innovative features to increase your productivity.

1.3.1 Using the CAD.direct Drafter Explorer

The CAD.direct Drafter Explorer has an interface similar to the Windows Explorer, allowing you to view and manage the elements of multiple, open drawings, such as layers, blocks, linetypes, views, user coordinate systems, and text styles.

1.3.2 Editing multiple documents simultaneously

With CAD.direct Drafter, you can open and edit multiple drawings simultaneously. You can also copy and paste elements between open drawings.

1.3.3 Editing multiple entities

CAD.direct Drafter allows you to change most of the properties of all selected entities using a single, tabbed dialog box.

1.3.4 Using the Customize dialog box

CAD.direct Drafter has a single, tabbed dialog box for changing toolbars, menus, keyboard shortcuts, and command aliases. You can also use the drag-and-drop method to customize toolbars, including flyouts. The simple, point-and-click action lets you easily create new menu items and keyboard shortcuts—no programming or manual text editing required.

1.3.5 Performing unlimited undo and redo

CAD.direct Drafter increases your power with unlimited undo and redo of editing actions.
1.2 Getting more information

In addition to the CAD.direct Drafter documentation, much of the assistance you need as you use CAD.direct Drafter is specific to the commands you work with on the screen. To obtain immediate information as you work, use these additional sources of information:

- **Tooltips** — To find out what a specific tool on a toolbar does, pause the cursor over it for a moment. A ToolTip appears on the screen.
- **Status bar** — To find out more detailed information about a tool when you pause the cursor over it, look on the status bar at the bottom of the screen.
- **Online help** — CAD.direct Drafter online help is available on the screen when you press F1, choose a command from the Help menu, or click the question mark in a dialog box. The online help also presents information that does not appear in this manual, including a programming reference that describes how to program in DRX, LISP, DCL, SDS, and DIESEL. The programming reference also describes programming in VSTA and VBA.

1.3 Working with sample drawings

With the CAD.direct Drafter program, you can create a variety of drawings, including two-dimensional architectural drawings, electrical schematics, and mechanical drawings. Viewing and working with sample files can be an easy way to quickly learn how to use various CAD.direct Drafter features.

To access the sample files

Choose File > Open, and then open the Samples folder.

1.4 New in CAD.direct Drafter 8

1.4.1 Working with Files

- Export to a 3D .pdf file.
- Export to a 2D .pdf file now includes new compression modes, image clipping, and gradient hatches.
- For .pdf, dwg, and .dgn underlays, new support includes monochrome, fade, back-ground color adjust, show, and show clipped properties.
- Export to a .bmp file now supports visual styles.
- Some versions of CAD.direct Drafter include the ability to open, save, create, and edit .dgn files.
1.4.2 Performance Enhancements

- Increased performance when working with many external references.
- Increased performance for PDF creation and reduction of resulting .pdf file size.
- Increased selection performance in drawings with complex blocks.
- Improved pan and zoom speed for very large drawing files.
- New CACHEFILES will externally cache layout data to enhance layout switching performance and memory usage.

1.4.3 Text

New multiline text editor allows you to edit multiline text in place. However, not all multiline text features are implemented in the new editor. To switch to the older dialog box version of the multiline text editor, set the MTEXTED system variable to „old editor“.

New Field command allows you to create a field as multiline text.

1.4.4 Working with Entities

- New dialog box for the REFEDIT command and new -REFEDIT command.
- New dialog box for the ARRAY command and new -ARRAY command.
- New TEXTTOFRONT command moves text, dimensions, and leaders to the front of other entities.

1.4.5 Viewing and Rendering Drawings

- Users who previously used Ctrl + Left mouse click and drag to orbit the drawing should now use Shift + Middle mouse (or wheel) click and drag to orbit. Ctrl + Left mouse click and drag is now used to move and copy selected entities.
- New integration with Artisan Renderer for some versions of CAD.direct Drafter allows you to create a photo realistic image of your model quickly using a wide range of preset materials and lighting setups combined with the ability to create custom lights and realistic materials.
- New commands VPMAX and VPMIN allow you to maximize and minimize viewports.

1.4.6 More Features

- For CAD.direct Drafter versions that include a ribbon, the ribbon now includes panel expanders, versioning support, can be customized using the CUSTOMIZE command.
• Entity snapping for underlays are now accessible using the Options command.
• Updated .NET API with new functions.
• NET plugins can now be autoloaded.
• Many new LISP functions.

1.4.7 System Variables

• Added or updated: ARTISAN LICENSE, AUDIONOTETOOLTIP, BLOCKCACHE, CACHEFILES, CACHEMAXFILES, CACHEMAXTOTALSIZE, DGNOSNAP, DRAWINGTYPE, DTEXTED, DWFOSNAP, HYPERLINKBASE, LAYLOCKFADECTL, ORBITPREVIEWDELAY, PDFOSNAP, RENDERPLANARENTS, SHOWGRIPMENUS, SKETCHMODE, UNDERLAYFADEDEFAULT, WNDCUSDLGPOS, WNDCUSDLGSIZE, WSAUTOSAVE, XDWGFADECTL, XFADECTL.
• Removed: AUDIONOTE, CTRLMOUSE, DYNORBITCTR, HYPERLINKICON, and SELECTCLOSEDENTS.

1.4.8 Performance Enhancements

Multi-core support for opening and regenerating files, which provides 1.5 to 3 times performance improvement on multi-core computers.

1.4.9 User Interface

• New ribbon interface that can be used with or without the menus.
• New icons throughout CAD.direct Drafter.
• Updated status bar.
• Autocomplete commands when typing at the command line.
• Updated Properties pane.
• Support for workspaces.
• Color schemes are now available.

1.4.10 Printing

• New Publish command.
• New ability to print to DWF/DWFx files.
• New ability to print to PNG and JPG files.
• Advanced options added for print stamps.
1.4.11 Viewing Drawings
New support for annotation scaling.

1.4.12 Working with Entities
- New Helix command.
- New Revision Cloud command.
- New XPLODE command.
- Tab through commands when hovering over a grip.
- New Z-axis orthomode support.
- New Match Properties Options dialog box.
- New Text to Multiline Text command.
- New dialog box for the BLOCK command.
- New 3D entity commands: Loft, Sweep, Polysolid.
- New Set to ByLayer command.

1.4.13 APIs
- CAD.direct Drafter 8.1 uses Teigha version 4.0.1 from the Open Design Alliance.
- New .NET API.
- New IcUi API for creating CAD.direct Drafter based MFC dialogs or special dialog controls.

1.4.14 System Variables
Added or updated: ANNNOALLVISIBLE, ANNNOSCALELIMIT, AUTO-COMPLETETFILTER, AUTOCOMPLETEMODE, AUTOCOMPLETEOP-TIONS, AUTOCOMPLETETDELAY, AUTOCOMPLETETTRANS, AUTOCOMPMINTEXTLEN, CANNOSCALE, CANNOSCALEVALUE, CUR-RENDAFFINITYMASK, DIMANNO, HPANNOTATIVE, LOCALEROOT-PREFIX, LOFTANG1, LOFTANG2, LOFTMAG1, LOFTMAG2, LOFTNORMALS, LOFTPARAM, MSLTScale, MTMODE, MULTICORE, PICKFIRSTFLAGS, PRINTTRANSPARENCY, PSLTSCALE, PSOLHEIGHT, PSOLWIDTH, SELECTIONANNODISPLAY, SETBYLAYERMODE, STAT-BAR-STYLE, and SURFACEMODELINGMODE.
1.5 New in CAD.direct Drafter 8.0

1.5.1 Working with Files

- Open, save, and work with .dwg files of version 2014.
- Work with image files in both CAD.direct Drafter Professional and Standard versions. Additionally, more raster image formats are supported in CAD.direct Drafter Standard.
- Create custom rendering materials and mapping projection planes in both CAD.direct Drafter Professional and Standard versions.
- Import Collada (.dae files).
- Improved support for DGN overlays, Civil3D, ADT, and mechanical object enablers.
- Attach MrSID MG4 compressed raster images. Performance Enhancements

CAD.direct Drafter is available in 64-bit in addition to 32-bit.

- Increased cursor speed.
- Improved PDF export performance and reduced resulting file size.
- Improved performance for multiple sessions on multi-core machines.
- Improved Print Preview zoom performance.

1.5.2 Viewing drawings

- The grid can be drawn as lines or dots, can display beyond the drawing extents, and can be adaptive, which includes automatic resizing and subdivision based on the zoom level.
- The Dynamic Viewpoint command was enhanced to include multiple ways of selecting a point from which to view three-dimensional entities.
- The 3D Orbit command allows you to orbit a drawing, that is, rotate the view. Commands includes Constrained Orbit, Free Orbit, Continuous Orbit, Constrained X Orbit, Constrained Y Orbit, and Constrained Z Orbit.

1.5.3 Layers

- Manage layers with layer states.
- Search for layers by name.
- Filter layers.
- Layer properties include Transparency and Viewport Freeze. New Layer Tools menu and toolbar.
### 1.5.4 Rendering

- Rendering interface redesigned and enhanced.
- Complete rendering features are now available in CAD.direct Drafter Professional and Standard versions.

### 1.5.5 APIs

- CAD.direct Drafter 8.0 uses Teigha version 3.9.1 from the Open Design Alliance.
- CAD.direct Drafter 8.0 uses VBA 7.1.
- Script command execution uses the DDE API.
- New LISP method (protect) to create protected LISP files.
- New LISP method (acad_truecolorDlg) supports true color selection. The old method (acad_colorDlg) will continue to call up only the index color dialog.
- New SDS method sds_truecolorDialog() supports true color selection. The old method sds_colorDialog() will continue to call up only the index color dialog.
- New LISP method to convert RGB color string to an index integer (rgbtoindex). This method has an SDS equivalent: sds_rgbtoindex().
- New LISP method to convert RGB color string to an index integer (sds_indextorgb). This method has an SDS equivalent: sds_indextorgb().
- sds_rgbstrtocolorref changed from a string to a long.

### 1.5.6 More New Features

CUI menu files supported.

Many user interface enhancement features, including more efficient menu and toolbar organization, slimming of toolbars to create more drawing space, and more.

- Many improvements to paperspace, such as UCS icon changes, ease in which modelspace viewports are created, and more.
- All color assignments for screen items, such as background color, icon color, etc., can now be made by choosing Tools > Options > Display tab, then clicking Color Scheme.
- New Quick Select command.
- All color assignments for screen items, such as background color, icon color, etc., can now be made by choosing Tools > Options > Display tab, then clicking Color Scheme.
• New Quick Select command.
• Image Attach command supports embedded world file data in MrSID image files. New PRINTOPTIONS command for easy accessibility to Print Options.
• New XOPEN command to allow quick editing of attached xref files.
• New Draw Order options to quickly push back or bring forward annotation and hatches.
• Enhanced CUSTOMIZE command eases menu and toolbar customization.

1.5.7 System Variables

Added or updated: 3DORBITMODE, CUSTOMICONSPATH, EXPLAYERFILTER-TERWIDTH, FACETRES, GRIDCOLORMAJOR, GRIDCOLORMINOR, GRIDDISPLAY, GRIDMAJOR, GRIDMODE, GRIDPOINTSMAX, GRID-STYLE, LAYERINVERTFILTER, LAYOUTCREATEVIEWPORT (which replaced and deprecated PSPACEVIEW), LISSPATH, ORBITCOLOR, PRINTTILESIZ-ESIZE, PSICONCOLOR, QSELECTLISTVALUES, TEXLIBPATH, TRI MALLMAXNESTEDBLOCKLEVEL, UITHEME.

All color-related system variables were changed to support RGB and index color values: APERTURECOLOR, AUDIOICONCOLOR, AUTOTRACKCOLOR, BKGCOLOR, BLIPCOLOR, COLORX, COLORY, COLORZ, DZOOME-COLOR, DZOOMSCOLOR, DZOOMVCOLOR, HIGHLIGHTCOLOR, HYPERLINKICONCOLOR, MODELTOOLTIPCOLOR, MODELTOOLTIPBKGCOLOR, OLEBKGCOLOR, PICKBOXCOLOR, PSPACEBCOLOR, PSPACEMCOLOR, PSPACEPCOLOR, SELCROSSINGAREACOLOR, SEL-CROSSINGFRAMECOLOR, SELWINDOWAREACOLOR, SELWINDOWFR-AMECOLOR, SNAPCOLOR, VIEWPORTLOCKBORDERCOLOR.
2. Getting started

This section helps you get started using CAD.direct Drafter software by explaining how to install it and providing basic information about how to use it.

This guide assumes that you have working knowledge of Windows-based programs. If necessary, see the documentation that came with your operating system for information about Windows terminology and techniques.

2.1 System requirements

You need the following software and hardware to install and run CAD.direct Drafter:

- Microsoft® Windows 10, Windows 8, Windows 7, Windows Vista®, including 32-bit and 64-bit
- For 32-bit operating systems, install the 32-bit version of CAD.direct Drafter.
- For 64-bit operating systems, install either the 32-bit or 64-bit version of IntelliCAD. The 64-bit version of CAD.direct Drafter runs slightly faster, but can use all available system memory to handle large drawing files. CAD.direct Drafter 32-bit can access up to 3GB of RAM on 32-bit operating systems and up to 4GB of RAM on 64-bit operating systems.
- Intel® Pentium® 4 or comparable, faster processor recommended
- 1 gigabyte (GB) of RAM minimum for 32-bit and 2 gigabytes (GB) of RAM minimum for 64-bit Windows 10, Windows 8, and Windows 7, 1 gigabyte (GB) of RAM minimum for Windows Vista
- 700 MB of free hard disk space recommended for typical installation
- 1024 x 768 VGA or higher resolution, video adapter, and monitor
- Graphics card compatible with OpenGL Version 1.4 or higher Keyboard and mouse, or other pointing device
- CD-ROM or DVD drive for installation, if installing from a CD or DVD

2.2 Installing CAD.direct Drafter

A setup program guides you through the CAD.direct Drafter installation process. The program transfers files to a folder that it creates on your hard disk. The program also creates a menu item on the Start menu.

Installation starts automatically after you insert the CAD.direct Drafter compact disc into your CD-ROM drive. If installation does not start, you can install CAD.direct Drafter by using the following procedure.
To install CAD.direct Drafter from a compact disc

1. Insert the CAD.direct Drafter compact disc into your CD-ROM drive. Do one of the following:
   - Wait for the autorun feature to start.
   - Choose Start > Run and in the Open field, type d:\setup, where d is the letter assigned to your CD-ROM drive. Click OK.

2. Follow the instructions on your screen.

Some CAD.direct Drafter versions may not come with a compact disc.

For example, if you downloaded the program from the Internet, follow the instructions that came with the program.

2.3 Starting CAD.direct Drafter

To start CAD.direct Drafter, choose Start > All Programs > ITC > CAD.direct Drafter (may vary, depending on your operating system).

When you start CAD.direct Drafter, the program opens a new, blank drawing based on a default template, icad.dwt. Using a template as the basis for a new drawing has several advantages:
   - You can use predetermined units of measure, grid settings, text heights, and other settings appropriate for the type of drawing you’re creating.
   - You can redefine special layers.
   - You can redefine the type of print style table.
   - You can include predefined title blocks and borders.

Each time you start CAD.direct Drafter, a Tip of the Day appears on your screen. To display the Tip of the Day dialog box at any time, choose Help > Tip of the Day. To prevent the Tip of the Day dialog box from being displayed, click the check box for Show Tips On StartUp to clear it.

2.4 Working in CAD.direct Drafter

You can work with the CAD.direct Drafter window and its elements in a variety of ways. For example, you can display and rearrange the toolbars, display the command bar, and enable the status bar. The toolbars and command bar can also be floated anywhere on the screen or docked to the edges of the main CAD.direct Drafter window.
2.4.1 Displaying commands on a shortcut menu

Shortcut menus provide quick access to specific commands. A shortcut menu displays when you right-click an entity, toolbar, status bar, the Model tab name, or a Layout tab name. The selections presented in the shortcut menu depend on what you right-clicked.

When you right-click the drawing, you can choose from a wide range of commands, including recently used commands. When you right-click a toolbar, the program displays a shortcut menu that lets you toggle the command bar, status bar, and various toolbars on and off. If you select one or more entities and then right-click, the program displays a shortcut menu from which you can choose a command to modify the selected entities. To display a shortcut menu from which you can choose an entity snap, press and hold down the Shift key, and then right-click anywhere within the drawing window.

2.4.2 Displaying and hiding the ribbon

The ribbon contains several areas from which to choose commands:

- **Application button** — The Application button in the upper left corner contains file-related commands, such as New, Open, Import, Export, and more.
- **Quick Access toolbar** — Contains common commands. Click the Quick Access toolbar down arrow to choose which commands display and to customize various visual elements of the drawing window.
- **Tabs** — Contains related commands grouped together, for example, on the tabs named Home, Edit, Draw 2D, etc.
- **Panels** — Contains sub-categories of commands within a tab, for example Draw, Modify, and Layers on the Home tab.
To customize the Quick Access toolbar

1. To add a command to the Quick Access toolbar, right-click the command in the ribbon, then choose Add to Quick Access Toolbar.

2. To remove a command from the Quick Access toolbar, right-click the command to delete, then choose Remove from Quick Access Toolbar.

To customize a tab in the ribbon

1. Right-click anywhere in the tab of the ribbon you want to customize.

2. Do one of the following:
   - Choose Show Tab, then choose the tabs you want to display or hide.
   - Choose Show Panel, then choose the areas that you want to display or hide for that tab.

The ribbon can be customized in other ways.

You can use the Customize command or manually edit the .cui file for the ribbon. For more details, see “Customizing the ribbon” on page 616. Also see “Customizing the main window using a .cui file” on page 642.

To minimize the ribbon

1. Click the down arrow on the Quick Access toolbar.

2. Choose Minimize the Ribbon.

To show both the ribbon and menus at the same time

1. Right-click anywhere in the ribbon.

2. Choose Menu Bar.

To hide the ribbon and use menus instead

1. Right-click anywhere in the menus or ribbon.

2. Choose Switch to Menu Bar.
To display the ribbon if using only menus

1. Right-click a menu or any toolbar.

2. Choose Switch to Ribbon.

When using the ribbon, switch between drawings on the status bar.

On the status bar, choose Show Window menu.

Workspaces also can control the ribbon.

The CAD.direct Drafter Classic workspace shows toolbars and the Drafting and Annotation workspace shows the ribbon. For more details about workspaces, see “Using work-spaces” on page 30 in this chapter.

2.4.3 Displaying and hiding menus

Related commands are grouped together on menus. You can use the menus with or without the ribbon.

To customize the menus

1. Right-click anywhere in the menus or ribbon.

2. Choose Show Menu, then choose the menus you want to display or hide.

There are more ways to customize menus.
You can use the Customize command or manually edit the .mnu file for the menus. For more details, see “Customizing menus” on page 610. Also see “Customizing the main window using a .cui file” on page 642.

To display or hide menus when using the ribbon

For CAD.direct Drafter versions that have a ribbon.

1. Right-click anywhere in the menus or ribbon.

2. Choose Menu Bar.
2.4.4 Displaying and hiding toolbars

When you start CAD.direct Drafter the first time, multiple toolbars are displayed. CAD.direct Drafter provides more than a dozen toolbars, which you can customize by adding and deleting tools. You can also move and resize toolbars, and you can create new toolbars. You can use a shortcut menu to display or hide toolbars.

You can also choose whether toolbars are displayed large or small and in color. You can choose to display or hide ToolTips, which provide descriptions of tools that display when you pause the cursor over them. Go to View > Toolbars to make these selections.

Toolbars are either docked or floating. A floating toolbar has a title bar and a Close box, can be located anywhere on the screen, and can be resized. A docked toolbar does not display a title or Close box, cannot be resized, and is attached along one of the edges of the drawing window.

• To dock a toolbar, drag it to the perimeter of your drawing; to undock it, drag it away from the perimeter.
• To position a toolbar in a docking area without docking it, press Ctrl while you drag it.
• To move a toolbar, drag it to a new location.
• To resize a toolbar, move your cursor to the edge until it changes to a resize arrow, and then drag.

To choose which toolbars to display

1. Do one of the following:
   • On the ribbon, choose View > Toolbars (in Display)
   • On the menu, choose View > Toolbars.
   • Right-click anywhere on a toolbar (docked, undocked, or the toolbar area at the top of the window) to display the toolbar shortcut menu, and then choose Toolbars. You can also select the toolbars you want displayed directly on the shortcut menu.
   • Type tbconfig and then press Enter.

2. In the Select Toolbars dialog box, choose the toolbars you want displayed, and then click OK.
2.4.5 Using the command bar

The command bar is a dockable window in which you type CAD.direct Drafter commands and view prompts and other program messages. By default the command bar displays the three most recent lines of prompts, but you can extend the window to display more lines. Move or resize the command bar by dragging it.

To display or hide the command bar

- On the ribbon, choose View > Command Bar (in Display).
- On the menu, choose View > Display > Command Bar.

When the command bar is docked or floating, you can drag the top or bottom of the window to change the number of lines of text it displays. You can dock the command bar at the top, bottom, left, or right of the drawing. You can auto-hide and auto-display the command bar in its current location by clicking its pin button.

When you type in the command bar, CAD.direct Drafter suggests names of matching commands as you type. The suggested names appear in an AutoComplete window. Simply select the desired command in the list. In addition to command names, suggestions can include names of external commands, system variables, aliases, and LISP functions.
To turn on AutoComplete for typing in the command bar

Do one of the following:

- On the menu, choose View > Display > AutoComplete.
- Right-click the command bar and then choose AutoComplete.
- Type autocomplete, press Enter, then choose AutoComplete.
- Choose Tools > Options, click the Display tab, then mark Enable AutoComplete.

When turned on, the AutoComplete automatically displays when you type in the command bar, and then automatically closes when you activate a command.

For more details about customizing settings for the AutoComplete window, see “Customizing how suggestions display in the command bar” on page 587.

2.4.6 Using the status bar

If you elect not to use the command bar, the status bar displays information about the selected command or tool. It also displays the current cursor coordinates, the name of the current layer, mode settings, and other information about current settings.

In addition to displaying information, the status bar is a quick way to access many features. You can click status bar items to make changes, and right-click items to display short-cut menus that allow you more choices.

To change the items that display on the status bar

1. Right-click an empty area of the status bar.

2. Select an item to add or remove it.

To change the setting of an item on the status bar

Do one of the following:

- Double-click the status bar item.
- Right-click the status bar item you want to change, and then select the desired setting.
To display or hide the status bar

Do one of the following:

- On the ribbon, choose View > Status Bar (in Display).
- On the menu, choose View > Display > Status Bar.
- Type statbar and then press Enter.

2.4.7 Using prompt boxes

CAD.direct Drafter commands often provide several options. These options appear in the status bar or command bar and also in a prompt box (called a context menu in Auto-CAD) initially displayed in the upper right corner of the screen. You can move the prompt box by dragging it; future prompt boxes will appear where you last placed it. The options appear as menu selections. Choose the appropriate option by selecting it in the prompt box. To close a prompt box, click the Close box.

The prompt box is displayed by default. To turn off the display of prompt boxes, choose Tools > Options, click the Display tab, and then click the Display Prompt Boxes check box to clear it.

2.4.8 Using workspaces

Workspaces are a convenient way to customize the display of commands in the CAD.direct Drafter main window. Each workspace stores visibility settings for the following:

- Menus — Visibility settings are saved for each top-level menu (for example, the Draw menu) and each nested menu (for example, the Draw > Arc submenu).
- Toolbars — Visibility settings are saved for each toolbar, its orientation at the top, bottom, left, right, or floating, number of button rows, x-coordinate, and y-coordinate.
- Ribbon — For CAD.direct Drafter versions that have a ribbon, visibility settings are saved for whether the ribbon itself displays, along with visibility settings for each ribbon tab (for example, the Home tab) and each panel (for example, Home > Modify).
To create a workspace

1. Do one of the following:
   Type workspace and then press Enter.
2. Organize the menus, toolbars, and ribbon the way you want them.
3. Choose Save As.
4. Enter the name of the new workspace.

To switch to a workspace

1. On the status bar, click Switch Between Workspaces.
2. Choose the desired workspace.

2.5 Selecting commands

Select commands using any of these methods:

- Choose a command from the ribbon.
- Choose a command from a menu.
- Click a tool in a toolbar.
- Type the command in the command bar.

Some commands remain active until you end them, so you can repeat an action without having to select a command repeatedly. You can end a command by clicking Done in the prompt box or by pressing Esc.

2.5.1 Using commands

You can use most commands while another command is active. For example, while drawing a line, you may want to use the Pan command to move the drawing across the screen to select the endpoint of the line. You can also change the settings of drawing aids such as snap or grid while other commands are active.

2.5.2 Starting commands using the ribbon

To start a command from the ribbon, choose it from the list of options available. If a command has an arrow, click the arrow to see related commands. For example, choose Home, then click the arrow for Array (in Modify) to choose the 3D Array command.
2.5.3 Starting commands using toolbars

To start a command from a toolbar, click a tool and respond to the prompts.

The available toolbars depend on the experience level that is set.

To change the current experience level, choose Tools > Options, and then click the General tab.

Some tools, such as Line or Arc, contain flyouts, which are options either for using the basic tool with different methods or that contain other, related tools. Flyouts are indicated by a small triangle in the lower right corner of a tool. To display a flyout, click the tool and hold down the mouse button. To select a tool from a flyout, point to the tool you want and then release the mouse button. The tool you select on the flyout becomes the default tool on the toolbar.

2.5.4 Starting commands using menus

To start a command from a menu, choose it from the list of menu options available.

The available menu options depend on the experience level that is set. To change the current experience level, choose Tools > Options, and then click the General tab.

2.5.5 Starting commands using the command bar

Type a command, and then press Enter. If the command bar is displayed, the command you typed appears there. If the command bar is not displayed, the command you typed appears in the status bar.

Quickly start commands using the command bar by copying, cutting, and pasting text.

In the command bar or Prompt History window, right-click to select various cut, copy, and paste commands.

2.5.6 Repeating a command

You can repeat a command you used previously without having to reselect it.

To repeat the command you just used

Do one of the following:

- Press the spacebar.
- Press Enter.
- Click the right mouse button in the drawing.
To repeat commands you used previously

Do one of the following:

• In the command bar or Prompt History window, press Ctrl and double-click the previous command text.
• In the command bar or Prompt History window, right-click, choose Recent Commands, and then choose the desired command.
• Press Ctrl + K, repeat until you get back to the desired command, and then press Enter. Press Ctrl + L to move forward to the desired command, and then press Enter.
• Use the Up and Down arrows to display previously used commands, if Use Up/ Down Arrows for Command History Navigation is selected in Tools > Options.

Run a command multiple times using the command bar.

If you are using the command bar to type commands, you can type multiple before starting some commands (Circle, Arc, and Rectangle, for example) to repeat a command indefinitely. When you are done with a command, press Esc.

2.5.7 Nesting a command

If you are working in the command bar, you can use another command from within a command, called nesting. To use a command inside an active command, type an apostrophe before you type the command, such as ‘circle, ‘line, or ‘pyramid. You can nest commands indefinitely in CAD.direct Drafter. Many menu and toolbar macros work this way by default; for example, select color, reference grid, zoom, and snap. When you have finished with the nested command, the original command resumes.

2.5.8 Modifying a command

If you are working in the command bar, there are special ways that you can modify a command as you work. You can modify the active command using any of the following options:

• Entity snaps — Type an entity snap command, such as nearest or midpoint, to enable a one-time entity snap for a single selection. You can also use a one-time entity snap to override a running entity snap.
• Extension snaps — Type int after selecting a command, such as Line or Circle, to enable a one-time snap to the logical location where two entities would intersect if they were of infinite length. Type app to enable a similar one-time snap if the extensions would not intersect in three-dimensional space but would intersect in the current view.
• Midpoint snaps — Type m2p or mtp to enable a one-time snap to the midpoint of two points that you specify.
2.5.9 Using the Prompt History window

The Prompt History window displays a history of the commands and prompts issued since you started the current session of CAD.direct Drafter. By default, the program tracks up to 256 command lines. There is no limit to the number of command lines you can track, but program performance may be degraded if you choose to track an excessively high number of lines.

To display or close the Prompt History window

Press F2.

To view entries in the Prompt History window

Do one of the following:

- Use the scroll bars.
- Press Ctrl + K to browse backward; press Ctrl + L to browse forward.
- Use the Up and Down arrows to display previously used commands, if Use Up/ Down Arrows for Command History Navigation is selected in Tools > Options.

To copy or paste text in the Prompt History window

1. If copying text, do one of the following:
   - Highlight text using your mouse.
   - Press Ctrl + Shift + arrow keys to highlight text.
2. Right-click and choose whether to copy or paste.

You can also copy the entire command history or the last command line. Choose Copy History or Copy Last Line.

To change the number of command lines to track

1. Do one of the following:
   - Choose Tools > Options, and then click the Display tab.
   - Type options and then press Enter. Click the Display tab.
2. In the Command Lines To Track field, type the number of command lines you want to display, and then click OK.
### 2.5.10 Using mouse shortcuts

You can use your mouse, often combined with the keyboard, to start commands and perform other actions.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Hold and drag left mouse button</td>
<td>Copy and move selected entities</td>
</tr>
<tr>
<td>Ctrl + Hold and drag right mouse button</td>
<td>Constrained Z Orbit command</td>
</tr>
<tr>
<td>Ctrl + Left-click mouse</td>
<td>Cycle select entities located below the cursor</td>
</tr>
<tr>
<td>Ctrl + Shift + Hold and drag left mouse button</td>
<td>Real-Time Zoom command</td>
</tr>
<tr>
<td>Ctrl + Shift + Hold and drag right mouse button</td>
<td>Real-Time Pan command</td>
</tr>
<tr>
<td>Ctrl + Shift + Hold and drag middle mouse button (wheel)</td>
<td>Free Orbit command</td>
</tr>
<tr>
<td>Alt + Shift + Hold and drag middle mouse button or Shift + Hold and drag middle mouse button</td>
<td>Constrained Orbit command</td>
</tr>
<tr>
<td>Shift + Left-click mouse</td>
<td>Deselect entities</td>
</tr>
<tr>
<td>Shift + Right-click mouse</td>
<td>Entity snap shortcut menu</td>
</tr>
<tr>
<td>Hold and drag left mouse button</td>
<td>Move selected entities</td>
</tr>
<tr>
<td>Right-click mouse</td>
<td>Display shortcut menu for the selected entity</td>
</tr>
<tr>
<td>Rotate mouse wheel</td>
<td>Zoom In and Zoom Out commands</td>
</tr>
<tr>
<td>Hold mouse wheel, and then move mouse</td>
<td>Pan command</td>
</tr>
<tr>
<td>Ctrl + Rotate mouse wheel when command bar is active</td>
<td>Zoom in and out of the command bar</td>
</tr>
</tbody>
</table>
### 2.5.11 Using keyboard shortcuts

The following keyboard shortcuts start commonly used CAD.direct Drafter commands. To customize function keys, choose Tools > Function Keys, or choose Tools > Customize and click the Keyboard tab.

#### Using keyboard shortcuts

The following keyboard shortcuts start commonly used CAD.direct Drafter commands. To customize function keys, choose Tools > Function Keys, or choose Tools > Customize and click the Keyboard tab.

<table>
<thead>
<tr>
<th>Command</th>
<th>Typed Entry</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinate</td>
<td>COORDINATE</td>
<td>F8, Ctrl+D, Ctrl+H</td>
<td>Switches coordinate display between On, Off, and Angle/Distance.</td>
</tr>
<tr>
<td>Copy to Clipboard</td>
<td>COPYCLIP</td>
<td>Ctrl+C, Ctrl+J, Ctrl+M</td>
<td>Copies selected entities to the Windows clipboard.</td>
</tr>
<tr>
<td>Copy with Base Point</td>
<td>COPYBASE</td>
<td>Ctrl+Shift+C</td>
<td>Copies selected entities to the Windows clipboard along with a base point.</td>
</tr>
<tr>
<td>Cut to Clipboard</td>
<td>CUTCLIP</td>
<td>Ctrl+X</td>
<td>Cuts selected entities from the active drawing and copies them into the Windows clipboard.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Command</th>
<th>Typed Entry</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete</td>
<td>DELETE</td>
<td>Del</td>
<td>Removes the selected entities.</td>
</tr>
<tr>
<td>Entity Snap</td>
<td>ESNAP</td>
<td>F3, Ctrl+F</td>
<td>Turns entity snaps on and off.</td>
</tr>
<tr>
<td>Entity Snap Tracking</td>
<td>ENTRACK</td>
<td>F11</td>
<td>Switches entity snap tracking on and off.</td>
</tr>
<tr>
<td>Exit</td>
<td>EXIT</td>
<td>Alt+F4, Ctrl+Q</td>
<td>Closes all drawings and exits CADconv.</td>
</tr>
<tr>
<td>Grid</td>
<td>GRID</td>
<td>F7, Ctrl+G</td>
<td>Turns the reference grid on and off. Starts online Help.</td>
</tr>
<tr>
<td>Help</td>
<td>HELP</td>
<td>F1</td>
<td>Closes all drawings and exits CADconv.</td>
</tr>
<tr>
<td>Hyperlink</td>
<td>HYPERLINK</td>
<td>Ctrl+K</td>
<td>Attaches hyperlinks to drawing entities.</td>
</tr>
<tr>
<td>Isometric Plane</td>
<td>ISOPLANE</td>
<td>F5, Ctrl+E</td>
<td>Switches the isometric plane between Top, Right, and Left.</td>
</tr>
<tr>
<td>New Drawing</td>
<td>NEW</td>
<td>Ctrl+N</td>
<td>Creates a new, blank drawing.</td>
</tr>
<tr>
<td>Open Drawing</td>
<td>OPEN</td>
<td>Ctrl+O</td>
<td>Displays the Open Drawing dialog box so you can open another drawing.</td>
</tr>
<tr>
<td>Orthogonal</td>
<td>ORTHOGONAL</td>
<td>F8, Ctrl+L</td>
<td>Switches the orthogonal mode on and off.</td>
</tr>
<tr>
<td>Pan</td>
<td>PAN down</td>
<td>Down Arrow</td>
<td>Pans the drawing window view down by one unit.</td>
</tr>
<tr>
<td></td>
<td>PAN left</td>
<td>Left Arrow</td>
<td>Pans the drawing window view left by one unit.</td>
</tr>
<tr>
<td>Command</td>
<td>Typed Entry</td>
<td>Shortcut</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-------------</td>
<td>----------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Print</td>
<td>PRINT</td>
<td>Ctrl+P</td>
<td>Prints the active drawing.</td>
</tr>
<tr>
<td>Quick Save</td>
<td>QSAVE</td>
<td>Ctrl+S</td>
<td>Saves the active drawing.</td>
</tr>
<tr>
<td>Redo</td>
<td>REDO</td>
<td>Ctrl+Y</td>
<td>Reverses the action of the last Undo.</td>
</tr>
<tr>
<td>Save As</td>
<td>SAVEAS</td>
<td>Ctrl+Shift+S</td>
<td>Saves the active drawing with the option to save it with a new name or file format.</td>
</tr>
<tr>
<td>Select All</td>
<td>SELGRIPS</td>
<td>Ctrl+A</td>
<td>Selects all entities in a drawing.</td>
</tr>
<tr>
<td>Snap</td>
<td>SNAP</td>
<td>F9, Ctrl+B</td>
<td>Turns snap settings on and off.</td>
</tr>
<tr>
<td>Undo</td>
<td>U</td>
<td>Ctrl+Z</td>
<td>Reverses the last command action.</td>
</tr>
<tr>
<td>VBA Editor</td>
<td>VBA</td>
<td>Alt+F11</td>
<td>Opens the Visual Basic for Applications editor so that you can create or modify a VBA macro.</td>
</tr>
<tr>
<td>Window Close</td>
<td>WCLOSE</td>
<td>Ctrl+F4</td>
<td>Closes the active drawing window.</td>
</tr>
</tbody>
</table>
2.5.12 Using scripts

The CAD.direct Drafter Script Recorder captures and saves many of your actions, so you can play them back. After you enable the Script Recorder, all commands and options that you type in the command bar are recorded until you type a command to stop recording. When you run the script, the program carries out the recorded commands in succession.

2.6 Correcting mistakes

CAD.direct Drafter tracks the commands you use and the changes you make. If you change your mind or make a mistake, you can undo, or reverse, the last action or several previous actions. You can also redo any actions that you reversed.

A. Click the Undo tool to reverse the last action.

B. Click the Redo tool to reverse the previous undos.

You can undo multiple actions by typing undo and specifying the number of actions to undo.

2.7 Customizing CAD.direct Drafter

You can tailor many aspects of CAD.direct Drafter to better suit your needs. For example, you can easily create and modify toolbars by simply dragging and dropping icons. If you want to restore any area of the user interface back to its default state, click Reset. CAD.direct Drafter stores your customized settings in the Windows registry; you can also store them in a separate file, called a profile.

CAD.direct Drafter supports the most important AutoCAD customization files, including linetypes, hatch patterns, text fonts, the unit conversion file, menus, toolbars, and aliases. In addition, CAD.direct Drafter unifies four AutoCAD customization functions with a single customize command: command aliases, keyboard shortcuts, menus, and toolbars.
You can also add custom programs written in any of several programming languages, including the following:

- IRX (similar to the Autodesk® ARX language)
- LISP (the program’s Autodesk® AutoLISP-compatible language)
- SDS (similar to the Autodesk® ADS language)
- DIESEL
- Microsoft® Visual Studio Tools for Applications (VSTA)
- Microsoft® Visual Basic for Applications (VBA)
- .NET

2.8 Getting online Help

CAD.direct Drafter includes online Help, which contains task-oriented topics, a command reference, a system variables reference, and a programming language reference.

You can display online Help in any of these ways:

- On the ribbon, choose Help, then choose a command.
- On the Standard toolbar, click Help.
- Press F1.
- Choose a command from the Help menu.
- Click the question mark in a dialog box.
- Type help in the command bar.
2.9 Saving a drawing

You can save your drawing at any time.

Use one of the following methods to choose Save:

• On the Quick Access toolbar of the ribbon, click Save.
• On the ribbon Application button, choose Save.
• On the Standard toolbar, click Save.
• On the menu, choose File > Save.
• Type save and then press Enter.

When you save a drawing the first time, the program displays the Save Drawing As dialog box so that you can choose a directory and type a name for the drawing. To save the drawing later using another name, do the following:

Choose File > Save As and type the new name.

2.10 Exiting CAD.direct Drafter

When you have finished working in CAD.direct Drafter:

• On the ribbon Application button, choose Exit.
• On the menu, choose File > Exit.
3. Working with drawings

CAD drawings help you organize information for greater efficiency. With CAD.direct Drafter, you can draw entities representing different types of information on various layers and use those layers to control color, line type, and visibility. CAD.direct Drafter also includes drawing aids that help you draw accurately.

This section explains setting up drawings and using built-in drawing aids, including how to:

- Create new drawings, open existing drawings, and save changes to drawings.
- Use aids such as the grid, snap, and orthogonal settings to draw accurately.

3.1 Creating a new drawing

When you start CAD.direct Drafter, the program automatically creates a new drawing based on a template drawing, icad.dwt. This template includes predefined settings such as drawing units, text size, print style table type, and drawing area. You can either use these settings or change them according to your needs. There is nothing unique about a template drawing. You can use any drawing as a template for future drawings.

You can save many steps by basing a new drawing on an existing template (.dwt file). By doing this, a new drawing will contain all the settings and entities you need. When you open a new drawing from your custom template, you can modify existing settings and delete any entities that you don’t need. When you save a drawing that was created using a template, you do not change the template.

To create a new drawing based on a template

1. Do one of the following:
   - On the ribbon toolbar, click the New tool.
   - Choose File > New.
   - Type newwiz and then press Enter.
2. Click Use A Template Drawing, and then click Next.
3. To display the Open Template dialog box, click Browse.
4. Select the template (.dwt) file that you want, and then click Open. You can also choose any drawing (.dwg) file to use as a template.
5. Click Finish.
3.2 Opening a drawing

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, Design Web Format (.dwf) files, and drawing template (.dwt) files.

3.2.1 Opening an existing drawing

You can open any of these drawing files:

Standard drawing files with a .dwg extension.

*In addition to your own drawing files, you can open and use one of the sample drawings that are included with CAD.direct Drafter.*


Drawing templates with a .dwt file extension.

Drawing files with a .dgn extension.

To open an existing drawing

1. Use one of the following methods to choose Open:
   - On the ribbon toolbar, click the Open tool.
   - On the menu, choose File > Open.
   - On the Standard toolbar, click the Open tool.
   - Type `open` and then press Enter.
2. In Files of Type, choose the type of file you want to open.
3. Choose the folder containing the desired file.
4. Do one of the following:
   - Choose the drawing you want to open, and then click Open.
   - Double-click the drawing you want to open.
   - If the drawing requires a password, enter the password, click OK to verify the password, and then click Open again.
You can also open drawings while browsing files on your computer.

*Simply double-click the file or drag it to the drawing area in CAD.direct Drafter. Using programs that came with your operating system, such as Windows File Explorer or My Computer, you can find the drawing you want by viewing thumbnail images of the drawing files as you browse them. If needed, choose Tools > Options and on the General tab, click Set Files Association to specify which filetypes are associated with CAD.direct Drafter.*

The most recently opened drawings are tracked on the File menu for easy opening. Choose File > file name to quickly open a drawing file that you recently used.
3.2.2 Opening a damaged drawing

Files can become damaged for many reasons. For example, if you are working on a drawing during a power outage, a system crash, or a hardware failure, your drawing file may become damaged. CAD.direct Drafter allows you to open and check damaged files to attempt file recovery.

- Recovering a file attempts to open one of the following file types:
  - Standard drawing files with a .dwg extension.
  - Drawing Exchange Format files with a .dxf file extension.
  - Design Web Format files with a .dwf file extension.
  - Drawing templates with a .dwt file extension.

You can also audit any open file to check it for errors. You specify whether you want CAD.direct Drafter to fix any errors that are found automatically. CAD.direct Drafter fixes as many errors as possible and any errors that cannot be fixed are reported as “Ignored” in the Prompt History window.

To open a damaged file

1. Use one of the following methods:
   - On the ribbon Application button, choose Drawing Utilities > Recover.
   - On the menu, choose File > Recover.
   - Type `recovery` and then press Enter.
2. In Files of Type, choose the type of file you want to recover.
3. Choose the directory containing the damaged file.
4. Choose the damaged file you want to recover.
5. Click Open.

If you want to check all drawings for errors automatically when you open them, choose Tools > Options > General tab and mark the check box for Open Drawings using Recover.

To check a drawing file for errors

1. With the drawing open that you want to check, do one of the following:
   - On the ribbon Application button, choose Drawing Utilities > Audit.
   - On the menu, choose File > Audit.
   - Type `audit` and then press Enter.
2. Choose whether you want CAD.direct Drafter to fix any found errors automatically, and then press Enter.

An ASCII file describes the audit.
If the AUDITCTL system variable is set to On and errors are found during a file recovery or audit, an ASCII file is created that describes the audit. The ASCII file is saved in the same folder as the audited drawing and has the same name as the drawing file, but with an .adt extension.

3.3 Setting up a drawing

You can specify individual settings when you create a new drawing or when you modify settings in a drawing created from a template.

3.3.1 Setting the current layer

Layers are like the overlays that you use in manual drafting. You use layers to organize different types of drawing information. Every drawing has at least one layer, the default layer, named “0.” Your drawing can also contain an unlimited number of additional layers. When you create an entity, it is created on the current layer.

To set the current layer

1. Do one of the following to choose Explore Layers:
   • On the ribbon, choose Home > Layers (in Layers).
   • On the menu, choose Format > Explore Layers.
   • On the Format toolbar, click the Explore Layers tool.
   • Type explayers and then press Enter.
   • Type la and then press Enter.
2. Double-click the layer name that you want to make current.
3. Close the CAD.direct Drafter Explorer window.
3.3.2 Setting the current entity color

An entity’s color determines how it is displayed and, if you are using a color printer, how it prints. Entities are created in the current color.

When you open a new drawing, entities are created in the color BYLAYER, which adopts the color of the current layer. Initially, layer 0 is both the only layer and the current layer. Its default color is white, so your entities appear as white.

There are index colors, which contain two additional color properties that are often referred to as colors, true colors, and color book colors. The two additional color properties are BYLAYER and BYBLOCK. These color properties cause an entity to adopt the color either of the layer or of the block in which it is a member.
To set the current entity color

1. Do one of the following to choose Drawing Settings:
   • On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   • On the menu, choose Tools > Drawing Settings.
   • On the Tools toolbar, click the Drawing Settings tool.
   • Type settings and then press Enter.

2. Click the Entity Creation tab.

3. Click Select Color.

4. In the Color dialog box, click one of the following tabs and select a color:
   • Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. You can also type the color number in the Index box.
   • TrueColor— Click a basic color, click a color in the color palette, enter the Hue, Saturation, and Luminance (HSL) values, or enter the Red, Green, Blue (RGB) values. There are more than 16 million true colors from which you can choose.
   • Color Books — Select a color book from the list, then click a color. You can select Show Only Color Book Colors Used in Drawing to limit the selection to only those color book colors that are used in the current drawing.

5. Click OK.

6. Click OK again.

3.3.3 Setting the current linetype

Linetypes help convey information. You use different linetypes to differentiate the purpose of one line from another. A linetype consists of a repeating pattern of dots, dashes, or blank spaces. Linetypes determine the appearance of entities both on the screen and when printed. By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and BYBLOCK. Your drawing may also contain an unlimited number of additional linetypes.

When you create an entity, it is created using the current linetype. By default, the current linetype is BYLAYER. CAD.direct Drafter indicates that the entity linetype is determined by the current layer’s linetype by assigning the BYLAYER property as the default linetype setting. When you assign BYLAYER, changing a layer’s linetype changes the linetype of all the entities assigned that layer (if they were created using the linetype BYLAYER).
You can also select a specific linetype as the current linetype, which overrides the layer’s linetype setting. Entities are then created using that linetype, and changing the layer linetype has no effect on them.

As a third option, you can use the linetype BYBLOCK property, in which case new entities are drawn using the CONTINUOUS linetype until you group them into a block. The entities then inherit the block’s linetype setting when you insert the block into a drawing.

**To set the current linetype**

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type `settings` and then press Enter.
2. Click the Entity Creation tab.
3. In the Entity Linetype list, choose the linetype that you want to make current.
4. Click OK.

Use the status bar shortcut.

*On the status bar, right-click the word BYLAYER for the current linetype, click Properties, and then choose the linetype that you want to make current.*

**3.3.4 Setting the linetype scale**

You can specify the linetype scale. The smaller the scale, the more repetitions of the linetype pattern are generated per drawing unit. For example, a linetype pattern is defined as a sequence of dashed lines and open spaces, each 0.25 units long. The line-type scale uses the drawing scale factor to determine the length. A scale factor of 0.5 would reduce the length of each line and space to 0.125 units; a scale factor of 2 would increase the length of each to 0.5 units.

Note that setting the linetype scale too large or too small may result in a line pattern looking like a solid line, depending on what the scale view is or at what scale the drawing is printed.

You can control a new entity’s individual linetype scale factor as well as the overall or global scale factor applied to all the entities in the drawing. If you use annotation scaling for entities such as text and dimensions, you can also set up linetype scaling to coordinate with various annotation scaling scenarios.
To set the current individual linetype scale

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.
2. Click the Entity Creation tab.
3. In the Linetype Scale field, type or choose the linetype scale that you want to make current.
4. Click OK.

To change the global linetype scale

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.
2. Click the Entity Creation tab.
3. In the Global Linetype Scale field, type or choose the global linetype scale that you want to change.
4. Click OK.

To set up linetype scaling to be the same in model space and paper space

1. Set the global linetype scale (mentioned previously) to the drawing scale. For example, enter .25 for the scale factor 1/4" - 1".
2. Type PSLTSCALE and press Enter, then enter 0 to turn this system variable off. Customized linetype scaling specific to paper space will be turned off.
3. Type MSLTSCALE and press Enter, then enter 0 to turn this system variable off. Customized linetype scaling specific to model space will be turned off.
To set up linetype scaling to be different in model space and paper space

1. Set the global linetype scale (mentioned previously) to 1. This sets the default linetype scale factor to be the same as the drawing scale.

2. Type PSLTSCALE and press Enter, then enter 1 to turn this system variable on. Customized linetype scaling specific to paper space will be turned off.

3. Type MSLTSCALE and press Enter, then enter 1 to turn this system variable on. Customized linetype scaling specific to model space will be turned off.

4. For drawings that also use annotation scaling, do the following:
   - On the status bar, right-click Annotations Scales List.
   - Choose the current annotation scale, for example 1/4” - 1”. This makes the linetype scale set to the annotation scale.

Linetypes will be the same for all viewports that have the same annotation scale. Setting up linetype scaling so it can be different in model space and paper space is the preferred method for drawings with details, profiles, or plan views that are not always the same scale. Paper space viewports will look and print as intended, and you can adjust the model space annotation scale for it to match the display in paper space. For more information about annotation scaling, see “Understanding scale factors” on page 56 in this chapter.

3.3.5 Setting the current lineweight

Lineweights help differentiate the purpose of one line from another. Lineweights determine how thick or thin entities appear both on the screen and when printed. Every drawing has these lineweights: DEFAULT, BYLAYER, BYBLOCK, and many additional lineweights in millimeters (or you can use inches).

When you create an entity, it is created using the current lineweight. By default, the current lineweight for a new entity is BYLAYER. This means that the entity line-weight is determined by the current layer. When you assign BYLAYER, changing a layer’s lineweight changes the lineweight of all the entities assigned that layer (if they were created using the lineweight BYLAYER).

You can also select a specific lineweight (or DEFAULT) as the current lineweight, which overrides the layer’s lineweight setting. Entities are then created using that lineweight (or the DEFAULT lineweight), and changing the layer lineweight has no effect on them.

As a third option, you can use the lineweight BYBLOCK property, in which case new entities are drawn using the DEFAULT lineweight until you group them into a block. The entities then inherit the block’s lineweight setting when you insert the block into a drawing.

If you choose a lineweight that is less than .025 millimeter, it displays as one pixel when you create your drawing. When you print your drawing, it prints at the thinnest lineweight that is available for your printer.
You cannot assign lineweights to planes, points, TrueType fonts, or raster images (if supported in your version of CAD.direct Drafter).

**To set the current lineweight**

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings or choose Tools > Lineweight.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.
2. Click the Entity Creation tab.
3. In the Lineweight list, choose the lineweight that you want to make current.
4. Click OK.

Use the status bar shortcut. On the status bar, right-click the word BYLAYER for the current lineweight, and then choose the current lineweight. You can also double-click the word LWT to toggle the display of lineweights on and off.

Lineweights need to be turned on to be visible. To see lineweights in your drawing, you may need to turn on their visibility. For details, see “Displaying lineweights” on page 179.

### 3.3.6 Setting the current print style

Print styles are used to change the appearance of an entity when it prints, without actually changing the entity in the drawing.

If your drawing uses named print style tables, you can specify a print style for any entity. Named print style tables contain print styles that you set up. If your drawing uses color-dependent print style tables, the print style is BYCOLOR, which cannot be changed. These types of print style tables determine printing requirements by the color assigned to an entity or layer. For details about converting a drawing that uses color-dependent print style tables to use named print style tables, see “Changing the print style table type of a drawing” on page 483.

When you create an entity in a drawing that uses named print style tables, the entity is created using the current print style. By default, the current print style is BYLAYER. When you assign BYLAYER, changing a layer's print style changes the print style of all the entities assigned that layer if they were created using the print style BYLAYER.
You can also select a specific print style as the current print style, which overrides the layer’s print style setting. Entities are then created using that print style, and changing the layer print style has no effect on them.

As a third option, you can use the print style BYBLOCK, in which case new entities use the Normal print style until you group them into a block. The entities then inherit the block’s print style setting when you insert the block into a drawing.

**To set the current print style in a drawing that uses named print style tables**

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type `settings` and then press Enter.

2. Click the Entity Creation tab.

3. In the Print Style list, choose the print style that you want to make current. If necessary, choose Other and then select a print style.

4 Click OK.

*Use the status bar or command bar shortcut.*

On the status bar, right-click the word BYLAYER for the current print style, click Other, and then choose the print style that you want to make current. Or, type `print style` to choose the current print style.

### 3.3.7 Setting drawing units

With CAD.direct Drafter, you typically draw at full-size (1:1 scale), and then set a scale factor when you print or plot your drawing. Before you begin drawing, however, you need to determine the relationship between drawing units and real-world units.

For example, you can decide whether one linear drawing unit represents an inch, a foot, a meter, or a mile. In addition, you can specify the way the program measures angles. For both linear and angular units, you can also set the degree of display precision, such as the number of decimal places or smallest denominator used when displaying fractions. The precision settings affect only the display of distances, angles, and coordinates. CAD.direct Drafter always stores distances, angles, and coordinates using floating-point accuracy.
To set the linear drawing units

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
     On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.

2. Click the Drawing Units tab.

3. Under Change Settings For, choose Linear Units.

4. Under Unit Types, select a unit type.

5. Under Display Precision, type the display precision according to the number of decimal places you want, or click the arrows to select it.

6. Click OK.

A Determines the type of units you are controlling.  
B Select the type of linear units.  
C Choose the display precision for linear units.
To set the angular drawing units

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.

2. Click the Drawing Units tab.

3. Under Change Settings For, choose Angular Units.

4. Under Unit Types, select a unit type.

5. Under Display Precision, type the display precision according to the number of decimal places you want, or click the arrows to select it.
   
   The field above this setting shows an example of the angular unit type at the current precision.

6. Under Angle Direction, select the direction in which angles increase when you specify a positive angle value.

7. Under Angle Base, specify the compass location for the zero angle.
   
   For example, by default, angle 0 is at the “three o’clock” or “east” position. The adjacent icon shows the current location of the angle base.

8. Click OK.
3.3.8 Understanding scale factors

Instead of drawing to a particular scale, you draw everything in the program full-size. Although it’s a good idea to keep your scale factor in mind when setting up a drawing, you don’t need to set the scale until you print it. For example, when you draw a mechanical part 40 inches in length with CAD.direct Drafter, you actually draw it as 40 inches, rather than applying a scale factor as you draw. When you print your drawing, you can assign the scale at which the drawing is to print.

Scale, however, does affect the way a few elements such as text, arrows, or linetypes print or plot and even display in your drawing. You can set up annotation scaling to control the scale of entities such as text, arrows, and linetypes, or you can make manual adjustments when you first set up your drawing so that annotations print and display at the correct size. For example, when you draw text, you need to determine the text size so that when you print it later at a particular scale, the text height is correct.
After you determine the eventual scale of your finished drawing, you can calculate the scale factor for the drawing as a ratio of one drawing unit to the actual scale unit represented by each drawing unit. For example, if you plan to print your drawing at $1/8'' = 1\text{-}0''$, your scale factor ratio is 1:96 ($1/8'' = 12''$ is the same as $1 = 96$). If you want your printed scale to be 1 inch = 100 feet, your scale factor ratio is 1:1200.

The following table shows some standard architectural and engineering scale ratios and equivalent text heights required to create text that measures 1/8-inch high when you print the drawing at the specified scale.

<table>
<thead>
<tr>
<th>Scale</th>
<th>Scale factor</th>
<th>Text height</th>
</tr>
</thead>
<tbody>
<tr>
<td>$1/16'' = 1\text{-}0''$</td>
<td>192</td>
<td>24''</td>
</tr>
<tr>
<td>$1/8'' = 1\text{-}0''$</td>
<td>96</td>
<td>12''</td>
</tr>
<tr>
<td>$3/16'' = 1\text{-}0''$</td>
<td>64</td>
<td>8''</td>
</tr>
<tr>
<td>$1/4'' = 1\text{-}0''$</td>
<td>48</td>
<td>6''</td>
</tr>
<tr>
<td>$3/8'' = 1\text{-}0''$</td>
<td>32</td>
<td>4''</td>
</tr>
<tr>
<td>$1/2'' = 1\text{-}0''$</td>
<td>24</td>
<td>3''</td>
</tr>
<tr>
<td>$3/4'' = 1\text{-}0''$</td>
<td>16</td>
<td>2''</td>
</tr>
<tr>
<td>$1'' = 1\text{-}0''$</td>
<td>12</td>
<td>1.5''</td>
</tr>
<tr>
<td>$1 1/2'' = 1\text{-}0''$</td>
<td>8</td>
<td>1''</td>
</tr>
<tr>
<td>$3'' = 1\text{-}0''$</td>
<td>4</td>
<td>0.5''</td>
</tr>
<tr>
<td>$1'' = 10'$</td>
<td>120</td>
<td>15''</td>
</tr>
<tr>
<td>$1'' = 20'$</td>
<td>240</td>
<td>30''</td>
</tr>
<tr>
<td>$1'' = 30'$</td>
<td>360</td>
<td>45''</td>
</tr>
<tr>
<td>$1'' = 40'$</td>
<td>480</td>
<td>60''</td>
</tr>
</tbody>
</table>
You can use these scale factors to predetermine the size of your drawing to make sure that it fits on a specific size paper when you print it. You control the size of your drawing by the drawing limits. To calculate the drawing limits to match the size of your paper, multiply the dimensions of your paper size by your scale factor.

For example, if the paper you use to print measures 36 inches x 24 inches and you print your drawing at 1/8" = 1'-0" (in other words, using a scale factor of 96), the size of your drawing measured in drawing units is 36 x 96 (or 3,456 units) wide and 24 x 96 (or 2,304 units) high.

Keep in mind that you can print the finished drawing at any scale, regardless of the scale factor you calculate. You can also print on paper of a different size and use the Layout tabs to create different views of your drawing and to position and scale those views differently. The scaling factor is not related to the size of the entities you draw; it simply provides a preliminary guide to help you establish the text height and drawing limits when you begin your drawing. You can change the text height and drawing limits at any time.

### 3.3.9 Setting up annotation scaling

Annotation scaling allows you to control individual entities, so their size will consistently display when a drawing is displayed or printed at different scales. You don’t have to use annotation scaling, but it is a convenient way to control the scaling of the following entities: text, tolerances, dimensions, leaders, multi-leaders, attributes, hatches, and blocks.

These individual entities can be annotative, and so can text styles, dimension styles, and multileader styles; text, dimensions, or multi-leaders assigned an annotative style will have annotation scaling turned on by default.

*CAD.direct Drafter comes ready to use annotation scaling, however, you may want to customize some of the settings according to your needs.*
3.3.10 Customizing the scales list

The scales list defines all of the scales that are available to assign to annotative entities. For example, to assign an annotation scale to a text entity, you choose it from the scales list. The scales list displays when you do any of the following:

- Set the current annotation scale — On the status bar, right-click Annotations Scales List.
- Assign an annotation scale to an entity — Select an entity and use the Properties or Entity Scale command.
- Print — Choose the Print command.

After you set up your scales list, you may want to create a drawing template with the default scales or export your scale list so you can easily import the list into other drawings.

To customize the scales list

1. Do one of the following to choose Scale List:
   - On the ribbon, choose Annotate > Scale List (in Annotation Scaling).
   - On the menu, choose Format > Scale List.
   - On the status bar, click Annotation Scales List.
   - Type scalelistedit and then press Enter.

2. To add a scale to the list, do the following:
   - Click Add.
   - Enter the name of the scale, which will appear in the list.
   - Enter the paper units to drawing units ratio.
   - Click OK.

3. Do any of the following to further customize the list:
   - Select a scale and click Modify to change a scale’s name or ratio.
   - Select a scale and click Delete to remove it from the list.
   - Select a scale and click Move Up or Move Down to reposition it in the list.

4. Optionally click Export to save your scales list to a file that you can easily import into other drawings.

5. Click OK.
Purging unused annotation scales can increase performance.

Older drawings from other CAD programs can sometimes have thousands of unused annotation scales. Click Purge in the Edit Drawing Scales dialog box to remove unused annotation scales and increase performance.
3.3.11 Customizing styles to be annotative

Text styles and dimension styles determine whether text and dimension entities that are assigned those styles are annotative by default. Multileader styles can also be annotative, but CAD.direct Drafter only supports the display of multi-leaders, not the creation of multi-leaders or multileader styles.

- For text styles, see “Working with text styles” on page 346.
- For dimension styles, see “Controlling dimension fit” on page 390.

Setting up automatic annotation scaling

Automatic annotation scaling automatically assigns the current annotation scale to annotation entities that have annotation scaling turned on.

To set automatic annotation scaling and the current annotation scale

1. On the status bar, click Automatic Annotation On/Off.
2. On the status bar, click Annotations Scales List.
3. Choose the current annotation scale.

3.3.12 Setting the text height

The text height setting controls the height of text, measured in drawing units. Set this value initially so that text used for your most common annotations, when scaled to the size at which you will print a drawing, measures 1/8-inch high on the printed drawing.

For example, if you plan to print your drawing at $1/8\text{"} = 1\cdot0\text{'}$ and you want your text to be 1/8-inch high in the final drawing, create that text 1 foot high (in your real-world drawing units) so that when you print it, it appears 1/8-inch high on the paper. You must create text 4 feet high that you want to print 1/2-inch high.

To set the text height

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type \textit{settings} and then press Enter.
2. Click the Entity Creation tab.
3. Under Change Settings For, choose Text.

4. In the Default Text Height field, select the text height or type the text height value that you want. If you have chosen an annotative text style, you enter the paper text height.

5. Click OK.

The default text height applies only if the current text style height is 0.0. Otherwise, the text height for the current style takes precedence.

3.3.13 Setting the drawing limits

You can specify the drawing limits that form an invisible boundary around your drawing. You can use the drawing limits to make sure that you do not create a drawing larger than can fit on a specific sheet of paper when printed at a specific scale.

For example, if you plan to print your drawing at 1/8" = 1'-0" (in other words, using a scale factor of 96) on a sheet of paper measuring 36 inches x 24 inches, you can set drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x 96), which allows a 1-inch margin around the edges of the printed image.
To set the drawing limits

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.

2. Click either the Coordinate Input tab or the Display tab.

3. Under Change Settings For, choose Limits.

4. Specify the x-coordinate and y-coordinate of the upper right drawing limit and the lower left drawing limit.

   You can also click Select to specify the drawing limits by selecting points in the drawing.

5. To constrain your drawing to these drawing limits, click the Disallow Input Beyond Limits check box.

6. Click OK.
3.4 Working with colors

An entity's color determines how it is displayed and, if you are using a color printer, how it prints. Entities are created in the current color specified for the drawing.

Layers can also control the color of entities. When you open a new drawing, entities are created in the color BYLAYER, which adopts the color of the current layer. Initially, layer 0 is both the only layer and the current layer. Its default color is white, so your entities appear as white.

For entities and layers in CAD.direct Drafter, there are three different types of colors:

- Index colors
- True colors
- Color book colors

True colors and color books are unavailable in some cases. For example, for dimension entities and cursor display.

You can choose colors by selecting them from the Color dialog box. In the command bar or in some dialog boxes, you specify a color either by name or by number.

3.4.1 Using index colors

There are 255 standard index colors and two additional color properties that are often referred to as colors (BYLAYER and BYBLOCK). You can use seven of the 255 standard index colors by name: red, yellow, green, cyan, blue, magenta, and white. (Numbers eight and nine are not named.) Each index color has a unique number from 1 to 255. The two additional color properties are BYLAYER and BYBLOCK. These color properties cause an entity to adopt the color either of the layer or of the block in which it is a member. BYLAYER is color number 256, and BYBLOCK is color number 0. In all commands for which you would use a color, you can indicate BYLAYER and BYBLOCK as well as by numbers 256 and 0, respectively.

To select an index color

1. Click Select Color in the desired dialog box, such as Layers, Drawing Settings, Properties, or Multiline Text. The Color dialog box opens.

2. Click the Index Color tab.
3. Do one of the following:
   - Click BYBLOCK.
   - Click BYLAYER.
   - Click the color of your choice, or type the color number in the Current box.
4 Click OK.

3.4.2 Using true colors

There are more than 16 million true colors from which you can choose. True colors are defined using 24-bit color.

Even with so many colors available, you can quickly choose a color from the display of basic colors or by clicking the color palette. Alternatively, if you know the values used to define the desired color, you can enter the Hue, Saturation, and Luminance (HSL) values, or you can enter the Red, Green, Blue (RGB) values.
To select a true color

1. Click Select Color in the desired dialog box, such as Layers, Drawing Settings, Properties, or Multiline Text.

The Color dialog box opens.

2. Click the True Color tab.

3. Do one of the following:
   - Click a basic true color.
   - Enter HSL values for the desired true color.
   - Enter RGB values for the desired true color.

4. Click OK.
3.4.3 Using color books

CAD.direct Drafter uses color books to store collections of colors. For example, you can store a unique color scheme for a client in a color book and then use colors only from that color book for the client’s drawings.

Selecting a color book color

To select a color book color

1. Click Select Color in the desired dialog box, such as Layers, Drawing Settings, Properties, or Multiline Text.

The Color dialog box opens.

2. Click the Color Books tab.

3. Select a color book from the list.

4. If you want to narrow your color search, do one of the following:

   • In the list of colors, select a color book page, if one is available. Pages are particularly helpful in large color books — they help group colors that you can find them quickly.
   
   • Select Show Only Color Book Colors Used in Drawing. Only those color book colors that are used in the current drawing will display in the list.

5. Select the desired color.

6. Click OK.
3.4.5 Creating color books

You may have a color book given to you by a client, developed by a third-party, or you can create your own. Each color book has an .acb extension and is saved automatically in Extensible Markup Language (XML) format.

To create a color book

1. Click Select Color in the desired dialog box, such as Layers, Drawing Settings, Properties, or Multiline Text.

The Color dialog box opens.

2. Click the Color Books tab.

3. Click Color Book Editor.

4. In the Color Book Editor dialog box, click the New tool.

5. In Color Book Name, enter the name of the color book. This name will appear in the list of color books on the Color Books tab in the Color dialog box.
6. Do the following to define organizational pages in the color book:
   • In the contents of the color book, click an existing page or color where you want to add a page.
   • Enter the name of the page, and then click Add Page.

7. Do the following to define colors in the color book:
   • In the contents of the color book, click an existing page or color where you want to add a color.
   • Define a color in the palette.
   • Enter the name of the color, and then click Add Color.

8. Do any of the following to change existing pages and colors in the color book:
   • Modify pages and colors — Select a page or color in the color book, define its new color settings in the palette, enter any changes to its name, and then click Modify.
   • Delete pages and colors — Select a page or color in the color book, and then click Delete.
   • Rearrange pages and colors — Select a page or color in the color book, and then click the up arrow or down arrow.

9. In the Color Book Editor dialog box, click the Save tool.

10. Enter a filename for the color book, and then click Save.

By default, the file is saved in the default folder where CAD.direct Drafter searches for color books.
A Select a color book.
B Click to select a color book color.
C Select to list only those color book colors that are used in the current drawing.
D Click to create and modify color books.
E Displays the selected color and its RGB values.
3.4.6 Modifying color books

You can modify your own color books and the color books that came with CAD.direct Drafter. If you modify a color book that came with CAD.direct Drafter, it is recommended that you save it with a new filename first so the original color book is not overwritten.

**To modify a color book**

1. Click Select Color in the desired dialog box, such as Layers, Drawing Settings, Properties, or Multiline Text.

The Color dialog box opens.

2. Click the Color Books tab.

3. Select the color book you want to modify.

4. Click Color Book Editor.

5. In Color Book Name, enter any changes to the color book name. This name appears in the list of color books on the Color Books tab in the Color dialog box.

6. Do any of the following to modify pages or colors in the color book:

   - Add pages — In the contents of the color book, click an existing page or color where you want to add a page. Define a color in the palette, enter the name of the page, and then click Add.
   - Add colors — In the contents of the color book, click an existing page or color where you want to add a color. Define a color in the palette, enter the name of the color, and then click Add.
   - Modify pages and colors — Select a page or color in the color book, define its new color settings in the palette, enter any changes to its name, and then click Modify.
   - Delete pages and colors — Select a page or color in the color book, and then click Delete.
   - Rearrange pages and colors — Select a page or color in the color book, and then click the up arrow or down arrow.

7 Do one of the following to save the color book:

   - To save the color book with the same filename, click the Save tool in the Color Book Editor.
   - To save the color book with a new filename or in a new location, click the Save As tool in the Color Book Editor.
3.4.7 Loading color books

If you have a color book given to you by a client or developed by a third-party, simply save it on your computer in a folder where CAD.direct Drafter can find it. By default, color books are stored in following folder: \Documents and Settings \YourName\My Documents\Color Books.

To load a color book

1. Save the color book in the folder where CAD.direct Drafter searches for color books.

To verify the folder location, choose Tools > Options, click the Paths/Files tab, and find the Color Book folder in the Paths list.

2. In a Color dialog box, click the Color Books tab.

The previously loaded color book displays in the list of color books.

3.5 Using the grid, snap alignment, and cursor restriction

Grid and snap settings are effective tools to use in your drawing to ensure accuracy. Although many users find it convenient to match grid points to snap settings, they are independent of each other and should not be confused. Grid points are for visual reference only; they do not affect your drawing and they do not print. Snap points are, by themselves, not visible; however, when set, they constrain the creation of new entities.

In addition, the cursor can be restricted to move orthogonally only or guides can display on the screen automatically at specified polar angle increments.

3.5.1 Setting a reference grid

A reference grid displays as a pattern of regularly spaced dots or lines. You can turn the grid on and off, and you can specify how far apart the dots or lines are spaced.

By default, the reference grid displays as lines, and it is adaptive (it proportionately scales according to the zoom ratio), helping you to align entities and visualize distances between entities. If desired, the grid can be constrained to only display within the limits of the drawing.
To turn the grid on or off and set the grid spacing

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.

2. Click the Coordinate Input tab.

3. Under Change Settings For, choose Snap and Grid.

4. Click the Grid On check box to turn the grid on or off.

5. Under Grid Spacing, in the X field, choose the horizontal grid spacing.

6. Under Grid Spacing, in the Y field, choose the vertical grid spacing.

7. Click OK.
Use the shortcuts for toggling the grid display on and off.

*Double-click the GRID setting on the status bar, click the Reference Grid tool on the Settings toolbar, or press F7.*

### 3.5.2 Setting snap spacing

Another way to ensure drawing accuracy is to turn on and set snap spacing. When snap is turned on, the program restricts the selection points to predetermined snap intervals. Although it is often helpful to match the snap spacing to some interval of the grid spacing or another related setting, the settings do not have to match.

**To turn snap settings on and set snap spacing**

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.
2. Click the Coordinate Input tab.
3. Under Change Settings For, choose Snap and Grid. 4 Click the Snap On check box to turn Snap on.
5. Under Snap Spacing, in the X field, choose the horizontal snap spacing.
6. Under Snap Spacing, in the Y field, choose the vertical snap spacing.
7. Click OK.

Use the shortcuts for toggling the snap settings on and off.

*Double-click the SNAP setting on the status bar or press F9.*

In addition to setting the snap spacing, you can change the snap and grid orientation. You can also rotate the alignment of the grid or set it to create isometric drawings.
3.5.3 Changing the snap and grid angle and base point

The snap and grid are both normally based on the drawing origin, the 0,0 coordinate in the World Coordinate System (WCS). You can relocate the snap and grid origin, however, to help you draw entities in relation to a different location. You can also rotate the grid to a different angle to realign the crosshairs to the new grid angle. If the grid is on, and the grid spacing is 0,0, then the grid defaults to the snap spacing.

To change the snap angle and base point

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.
2. Click the Coordinate Input tab.
3. Under Change Settings For, select Snap and Grid. 4 Click the Snap On check box to turn Snap on.
5. Click the Grid On check box to turn Grid on.
6. In Snap Basepoint, type the x-coordinate and y-coordinate of the new snap origin.
7. In Rotation, type the snap rotation angle, which also changes the display of the grid.
8. Click OK.
3.5.4 Using isometric snap and grid

You can use the Isometric Snap and Grid option to create two-dimensional isometric drawings. With the isometric option, you are simply drawing a simulated three-dimensional view on a two-dimensional plane, much the same as you might draw on a piece of paper. Do not confuse isometric drawings with three-dimensional drawings. You create three-dimensional drawings in three-dimensional space.

The isometric option always uses three preset planes, which are denoted as left, right, and top. You cannot alter the arrangement of these planes. If the snap angle is 0, the three isometric axes are 30 degrees, 90 degrees, and 150 degrees.

When you use the Isometric Snap option and select an isometric plane, the snap intervals, grid, and cross-hairs align with the current plane. The grid is always shown as isometric and uses y-coordinates to calculate the grid spacing. If you click the Draw Orthogonal check box, the program restricts the drawing of entities to the current isometric plane.

Use the shortcut to toggle between isometric planes. **Press F5.**
**To turn the Isometric Snap and Grid option on**

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.

2. Click the Coordinate Input tab.

3. Under Change Settings For, select Snap and Grid. 4 Click the Snap On check box to turn Snap on.

5. Click the Grid On check box to turn Grid on.

6. Under Snap Type, choose Isometric, then choose the option for the initial isometric plane you want (Top, Left, or Right).

7. Click OK.

---

![Isometric plane diagram](image)

*Isometric planes left (A), right (B), top (C).*

---

**3.5.5 Using orthogonal locking**

You can restrict cursor movement to the current horizontal and vertical axes so that you can draw at right angles, or orthogonally. For example, with the default 0-degree orientation (angle 0 at the “three o’clock” or
“east” position), when the Draw Orthogonal option is enabled, lines are restricted to 0 degrees, 90 degrees, 180 degrees, or 270 degrees. As you draw lines, the rubber-banding line follows either the horizontal or vertical axis, depending on which axis is farthest from the cursor. When you enable the isometric snap and grid, cursor movement is restricted to orthogonal equivalents within the current isometric plane.

Sometimes orthogonal locking is not used even when it is turned on. CAD.direct Drafter ignores orthogonal locking when you type coordinates in the command bar or when you use entity snaps. Additionally, orthogonal locking and polar tracking cannot be used at the same time — turning one option on turns the other option off.

To enable orthogonal locking

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.
2. Click the Coordinate Input tab.
3. Click the Draw Orthogonal check box.
4. Click OK.

Toggle orthogonal locking on and off.
Double-click the ORTHO setting on the status bar, click the Draw Orthogonal tool ( ) on the Settings toolbar, or press F8.

3.5.6 Using polar tracking

When polar tracking is turned on, guides display on the screen automatically at the polar angle increment that you specify. For example, if you draw a line with polar tracking turned on at 45 degrees, the rubber-banding line displays at 45 degree angle increments.

Polar tracking and orthogonal locking cannot be used at the same time — turning one option on turns the other option off.

To enable polar tracking and specify the polar angle increment

1. Do one of the following to choose Drawing Settings:
• On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
• On the menu, choose Tools > Drawing Settings.
• On the Tools toolbar, click the Drawing Settings tool.
• Type settings and then press Enter.

2. Click the Coordinate Input tab.

3. Under Change Settings For, select Polar Tracking.

4. Click the Polar Tracking check box.

5. Do one of the following to specify the polar angle increments:
   • In Increment, select an angle.
   • Mark the Additional Angles check box and click New to define a custom angle increment.

6. Click OK.

Toggle polar tracking on and off.
*Double-click the POLAR setting on the status bar,* type POLARTRACK in the command line, press F10, or press Ctrl+U.

### 3.6 Using entity snaps
Entity snaps enable you to quickly select exact geometric points on existing entities without having to know the exact coordinates of those points. With entity snaps, you can select the endpoint of a line or arc, the center point of a circle, the intersection of any two entities, or any other geometrically significant position. You can also use entity snaps to draw entities that are tangent or perpendicular to an existing entity.

You can use entity snaps any time the program prompts you to specify a point—for example, if you are drawing a line or other entity. You can work with entity snaps in one of two ways:

- Enable a running entity snap that remains in effect until you turn it off by choosing an entity snap when no other command is active.
- Enable a one-time entity snap for a single selection by choosing an entity snap when another command is active. You can also use a one-time entity snap to override a running entity snap.

If you type the name of entity snaps, you don’t need to type the whole name. **Type only the first three letters of the snap name.**

When using entity snaps, the program recognizes only visible entities or visible portions of entities. You cannot snap to entities on layers that have been turned off or to the blank portions of dashed lines.

When you specify one or more entity snaps, an entity snap target box is added to the crosshairs. In addition, an icon appears adjacent to the crosshairs indicating the active entity snap. When you select an entity, the program snaps to the snap point closest to the center of the target box.

### 3.6.1 Setting entity snaps

You can set entity snaps using any of the following methods:

- On the ribbon, choose Draw 2D and in Entity Snaps, choose the entity snap you want to set.
- Choose Tools > Entity Snap, and choose the entity snap you want to set.
- On the Entity Snaps toolbar, click one of the entity snap tools.
- In the command bar, type an entity snap command.
- In the status bar, double-click ESNAP.
- Press and hold down the Shift key while right-clicking anywhere within the drawing window to display the entity snap shortcut menu, and then choose the entity snap you want to set.

You can also set entity snaps using the Drawing Settings dialog box. To do this, choose Tools > Entity Snap > Entity Snap Settings. The Drawing Settings dialog box is displayed with the Coordinate Input tab active. In the Entity Snap Modes list, click the check box for each of the entity snaps that you want to set.

*There are several indicators if an entity snap is active.*

*If you select an entity snap, a check mark appears next to the entity snap in the menu, the associated tool if*
the Entity Snaps toolbar is active, and the corresponding box is checked in the Coordinate tab of the Drawing Settings dialog box.

To change the size of the entity snap target box

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.

2. Click the Coordinate Input tab.

3. Under Change Settings For, choose Entity Selection.

4. Under Entity Snap Aperture, change the value in the Aperture field.

5. Click OK.
3.6.2 Nearest Snap tool

Use the Nearest Snap tool to snap to the nearest point of another entity. You can snap to the nearest point on an arc, circle, ellipse, elliptical arc, line, point, polyline segment, ray, spline, infinite line, or hatch pattern that is visually closest to the cursor.

To set the Nearest Snap

- Do one of the following to choose Nearest Snap:
- On the ribbon, choose Draw > Nearest Snap (in Entity Snaps).
- On the menu, choose Tools > Entity Snap > Nearest Snap.
- On the Entity Snaps toolbar, click the Set Nearest Snap tool.
- Type nearest and then press Enter.

3.6.3 Endpoint Snap tool

Use the Endpoint Snap tool to snap to the endpoint of another entity. You can snap to the closest endpoint of an arc, line, polyline segment, ray, hatch pattern, plane, or three-dimensional face. If an entity has thickness, the Endpoint Snap also snaps to the endpoints of the edges of the entity.

To set the Endpoint Snap

Do one of the following to choose Endpoint Snap:

- On the ribbon, choose Draw > Endpoint Snap (in Entity Snaps).
- On the menu, choose Tools > Entity Snap > Endpoint Snap.
- On the Entity Snaps toolbar, click the Set Endpoint Snap tool.
- Type endpoint and then press Enter.

To snap to the endpoint, select anywhere on the entity near its endpoint (A).
3.6.4 Midpoint Snap tool

Use the Midpoint Snap tool to snap to the midpoint of another entity. You can snap to the midpoint of an arc, ellipse, line, polyline segment, plane, infinite line, spline, or hatch pattern. In the case of infinite lines, the midpoint snaps to the first defined point. If an entity has thickness, the midpoint entity snap also snaps to the midpoint of the edges of the entity.

Type m2p or mtp to enable a one-time snap to the midpoint of two points. 
*You specify the points, such as two points selected using entity snaps.*

**To set the Midpoint Snap**

Do one of the following to choose Midpoint Snap:

- On the ribbon, choose Draw > Midpoint Snap (in Entity Snaps).
- On the menu, choose Tools > Entity Snap > Midpoint Snap.
- On the Entity Snaps toolbar, click the Set Midpoint Snap tool.
- Type midpoint and then press Enter.

To snap to the midpoint, select anywhere on the entity near its midpoint (A).
3.6.5 Center Snap tool

Use the Center Snap tool to snap to the center point of another entity. You can snap to the center of an arc, circle, polygon, ellipse, or elliptical arc. To snap to the center, you must select a visible portion of the entity.

To set the Center Snap

Do one of the following to choose Center Snap:

- On the ribbon, choose Draw > Center Snap (in Entity Snaps).
- On the menu, choose Tools > Entity Snap > Center Snap.
- On the Entity Snaps toolbar, click the Set Center Snap tool.
- Type center and then press Enter.

To snap to the center, select anywhere on the visible portion of the entity (A).
3.6.6 Perpendicular Snap tool

Use the Perpendicular Snap tool to snap to the perpendicular point of another entity. You can snap to an arc, circle, ellipse, line, polyline, infinite line, ray, spline, hatch pattern, or edge of a plane to form a perpendicular alignment with that entity or with an imaginary extension of that entity.

To set the Perpendicular Snap

Do one of the following to choose Perpendicular Snap:

- On the ribbon, choose Draw > Perpendicular Snap (in Entity Snaps).
- On the menu, choose Tools > Entity Snap > Perpendicular Snap.
- On the Entity Snaps toolbar, click the Set Perpendicular Snap tool.
- Type perpendicular and then press Enter.

To form a perpendicular angle (A) to an entity (B), select anywhere on the entity.
3.6.7 Tangent Snap tool

Use the Tangent Snap tool to snap to the tangent point of another entity. You can snap to the point on an arc, ellipse, spline, or circle that, when connected to the previous point, forms a line tangent to that entity.

To set the Tangent Snap

Do one of the following to choose Tangent Snap:

- On the ribbon, choose Draw > Tangent Snap (in Entity Snaps).
- On the menu, choose Tools > Entity Snap > Tangent Snap.
- On the Entity Snaps toolbar, click the Set Tangent Snap tool.
- Type tangent and then press Enter.

To snap to a tangent, select the entity near the tangent point (A).
3.6.8 Quadrant Snap tool

Use the Quadrant Snap tool to snap to the quadrant point of another entity. You can snap to the closest quadrant of an arc, circle, ellipse, or elliptical arc.

To set the Quadrant Snap

- On the ribbon, choose Draw > Quadrant Snap (in Entity Snaps).
- On the menu, choose Tools > Entity Snap > Quadrant Snap.
- On the Entity Snaps toolbar, click the Set Quadrant Snap tool.
- Type quadrant and then press Enter.

To snap to a quadrant, select the entity near the quadrant point (A).
3.6.9 Insertion Point Snap tool

Use the Insertion Point Snap tool to snap to the insertion point of an attribute, block, or text entity.

**To set the Insertion Point Snap**

Do one of the following:

- On the ribbon, choose Draw > Insertion Point Snap (in Entity Snaps).
- On the menu, choose Tools > Entity Snap > Insertion Point Snap.
- On the Entity Snaps toolbar, click the Set Insertion Point Snap tool.
- Type insertion and then press Enter.

To snap to an insertion point, select anywhere on the entity (A).
3.6.10 Node Snap tool

Use the Node Snap tool to snap to a point entity.

To set the Node Snap

Do one of the following to choose Node Snap:

- On the ribbon, choose Draw > Node Snap (in Entity Snaps).
- On the menu, choose Tools > Entity Snap > Node Snap.
- On the Entity Snaps toolbar, click the Set Node Snap tool.
- Type node and then press Enter.

To snap to a point entity, select the entity (A).
3.6.11 Parallel Snap tool

Use the Parallel Snap tool to show parallel guides when picking second and subsequent points of new entities. Guides display parallel to points that you indicate on other lines, infinite lines, rays, or linear segments of polylines.

Turn ORTHO off before using parallel snapping
*If on, double-click ORTHO on the status bar to turn it off.*

To set the Parallel Snap

- On the ribbon, choose Draw > Parallel Snap (in Entity Snaps).
- On the menu, choose Tools > Entity Snap > Parallel Snap.
- On the Entity Snaps toolbar, click the Set Parallel Snap tool.
- Type parallel and then press Enter.

Select the first point of an entity (A), hover over the desired parallel entity (B), then move the cursor back to the new entity to view the guide.
To snap to a parallel point

1. Choose a command, for example, line.

2. Select the entity’s first point.

3. Type par and then press Enter.

4. Move the cursor over the desired parallel entity. A small “x” marks the position on the parallel entity.

5. Select additional parallel entities if necessary. You can also deselect a parallel entity by moving the cursor over its corresponding “x.”

6. Move the cursor back to the entity you are creating and use the parallel guide to select the next point of the entity.

3.6.12 Apparent Intersection Snap tool

The Apparent Intersection Snap tool snaps to the intersection of two entities that do not intersect in three-dimensional space but seem to intersect in the current view. You can snap to any two entities in the combination of an arc, circle, line, infinite line, polyline, ray, ellipse, elliptical arc, spline, hatch pattern, polygon mesh, or polyface mesh. You can also snap to an intersection point within a single entity, including a polyline or spline.

The Extended Apparent Intersection Snap option snaps to the logical location where two entities (lines, arcs, or elliptical segments) would intersect if they were of infinite length. CAD.direct Drafter automatically uses the extension option only when you type app in the command bar (not the full apparent command name) after selecting a command, such as Line or Circle. Dashed extension lines are drawn to help show the extended apparent intersection.

There are two types of intersection snaps.

You can set the Apparent Intersection Snap or Intersection Snap, but you cannot use both at the same time.

To set the Apparent Intersection Snap

- On the ribbon, choose Draw > Apparent Intersection Snap (in Entity Snaps).
- On the menu, choose Tools > Entity Snap > Apparent Intersection Snap.
- On the Entity Snaps toolbar, click the Apparent Intersection Snap tool.
- Type apparent and then press Enter.
To snap to an extended apparent intersection point

1. Choose a command, for example, line.
2. Type app and then press Enter.
3. Select an extended apparent intersection point.

The Extended Apparent Intersection Snap turns off automatically after you select a point.

3.6.13 Quick Snap command

Normally, an entity snap searches all the entities crossing the target and selects the one closest to the center of the target. Use the Quick Snap command to modify the current entity snap so that the program stops searching for the snap point as soon as it finds one entity with at least one point of the current entity type.

To set the Quick Snap

- Type quick and then press Enter.
3.6.14 Clear Entity Snaps tool

Use the Clear Entity Snaps tool to turn off all entity snap settings, regardless of how they were set: by menu, tool, command, or in the Drawing Settings dialog box.

To set Clear Entity Snaps

Do one of the following to choose Clear Entity Snaps:

- On the ribbon, choose Draw > Clear Entity Snaps (in Entity Snaps).
- On the Entity Snaps toolbar, click the Clear Entity Snaps tool.
- Type none and then press Enter.

3.6.15 From Point tool

Use the From Point tool to set a temporary base point from which to offset point selection. The From Point tool can be used only while another active command is requesting a point.

To set a temporary offset point

1. Choose a command, for example, line or move.

2. Do one of the following to choose From Point:

   - On the ribbon, choose Draw > From Point (in Entity Snaps).
   - On the menu, choose Tools > Entity Snap > From Point.
   - On the Entity Snaps toolbar, click the From Point tool.
   - Type from and then press Enter.

3. Select where to place the temporary base point.

4. Enter the offset distance from the base point, for example, (@8.5,0), where you want to locate the next point. Note that entering (8.5,0) places an absolute point from the UCS origin, not a relative point from the base point.

5. Continue with the original command.
3.6.16 Temporary Tracking Point tool

Use the Temporary Tracking Point tool to set a temporary tracking point while using a command. The Temporary Tracking Point tool can be used only while another active command is requesting a point.

To set a temporary tracking point

1. Choose a command, for example, line or move.

2. Do one of the following to choose Temporary Tracking Point:
   - On the ribbon, choose Draw > Temporary Tracking Point (in Entity Snaps).
   - On the menu, choose Tools > Entity Snap > Temporary Tracking Point.
   - On the Entity Snaps toolbar, click the Temporary Tracking Point tool.
   - Type TT and then press Enter.

3. Select a point to mark a temporary tracking point.

4. Continue with the original command.

3.6.17 Mid Between 2 Points tool

Use the Mid Between 2 Points tool to set a temporary midpoint snap between two points. The Mid Between 2 Points tool can be used only while another active command is requesting a point.

To set a temporary midpoint snap between two points

1. Choose a command, for example, line or move.

2. Do one of the following to choose Mid Between 2 Points:
   - On the ribbon, choose Draw > Mid Between 2 Points (in Entity Snaps).
   - On the menu, choose Tools > Entity Snap > Mid Between 2 Points.
   - On the Entity Snaps toolbar, click the Mid Between 2 Points tool.
   - Type m2p (or mtp) and then press Enter.

3. Select the first point.

4. Select the second point. The midpoint is calculated automatically.

5. Continue with the original command.
3.6.18 Using fly-over snapping

Fly-over snapping is a visual aid to help you see and use entity snaps more efficiently. When fly-over snapping is turned on, CAD.direct Drafter displays a colored marker at matching entity snap points as you move the crosshairs around the drawing.

Viewing fly-over snap markers.
Each entity snap has its own marker.

<table>
<thead>
<tr>
<th>Marker</th>
<th>Entity snap</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Endpoint Snap</td>
</tr>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Nearest Snap</td>
</tr>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Midpoint Snap</td>
</tr>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Center Snap</td>
</tr>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Perpendicular Snap</td>
</tr>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Tangent Snap</td>
</tr>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Quadrant Snap</td>
</tr>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Insertion Snap</td>
</tr>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Parallel Snap</td>
</tr>
</tbody>
</table>

Fly-over snap markers

<table>
<thead>
<tr>
<th>Marker</th>
<th>Entity snap</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Point Snap</td>
</tr>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Intersection Snap</td>
</tr>
<tr>
<td><img src="image" alt="Marker" /></td>
<td>Apparent Intersection Snap</td>
</tr>
</tbody>
</table>
3.6.19 Setting up fly-over snapping

When fly-over snapping is enabled, and multiple entity snaps are on, you can press Tab to cycle through the available entity snap points of the entities covered by the target box. For example, when the Endpoint and Midpoint Snaps are on and the aperture box is located on a line, press Tab to cycle between the line’s closest endpoint and midpoint.

To set the fly-over snapping options

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings or choose Tools > Entity Snap > Entity Snap Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.
2. Click the Coordinate Input tab.
3. Click Fly-Over. The Options dialog box opens to the Snapping tab. Mark Enable Fly-over Snapping to turn on fly-over snapping.
4. Set the fly-over options, including the color, size, and thickness of the snap marker.
6. Click OK.

7. Click OK again.

For details about the various fly-over snapping options, see “Changing the options on the Snapping tab” on page 607.

### 3.6.20 Using entity snap tracking

When entity snap tracking is turned on, guides display at specified angles outward from temporary tracking points. This can help you draw and modify entities using the relative position of existing entities, for example, inserting a block with the same y-coordinate of an existing line.

Temporary tracking points are marked with a red plus sign, and can be placed any-where in the drawing. To select where tracking points display, first activate a command that requests a point, then:

- Move the cursor and hover over an entity snap point to add a tracking point.
- Choose the Temporary Tracking Point command, then select anywhere in the drawing for the tracking point to reside.
- Move the cursor and hover over an existing tracking point to remove a tracking point.

You can set up entity snap tracking to display guides at 90-degree increments or additional increments that are defined for polar tracking. You can also set up entity snap tracking to display guides relative to the current UCS or relative to the last segment drawn.

To use entity snap tracking, at least one entity snap must be turned on and running snaps cannot be turned off. Polar tracking does not have to be turned on in order to use entity snap tracking.

**To turn entity snap tracking on or off**

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.

2. Click the Coordinate Input tab.

3. Under Change Settings For, select Entity Snaps. 4 Click the Entity Snap Tracking checkbox.
To specify settings for entity snap tracking

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.
2. Click the Coordinate Input tab.
3. Under Change Settings For, select Polar Tracking.
4. Select one of the following to specify entity tracking settings:
   - Orthogonal Only 90-degree angle increments are used for entity snap tracking, regardless of polar tracking settings.
   - Use all polar tracking angles All defined polar tracking angles, including those other than 90-degree angle increments, are used for entity snap tracking.
5. Select one of the following to specify how the angles of guides are calculated for entity snap tracking:
   - Absolute Guides display at angles relative to the current UCS.
   - Relative to last segment Guides display at angles relative to the last segment drawn, if creating entities with multiple segments (otherwise guides display at absolute angles).

6. Click OK.
3.4. Saving your drawing

When you save a drawing, your work is saved in a drawing (.dwg) file.

After you have saved your drawing for the first time, you can save it with a new name. In addition to drawing (.dwg) files, you can also save a drawing in a Drawing Exchange Format (.dxf) file or a drawing template (.dwt) file.

If you created your drawing using a template, saving the drawing does not alter the original template.

If you need an added level of security for your drawing files, you can save the drawing with a password so only you and those who know the password can open the drawing.

3.4.1 Saving a drawing

To save a drawing, choose any of the following methods to choose Save:

- On the ribbon Quick Access toolbar, click Save, or on the ribbon Application button, choose Save.
- On the menu, choose File > Save.
- On the Standard toolbar, click Save.
- Type save and then press Enter.
- Type qsave and then press Enter.

When you save a drawing the first time, the program displays the Save Drawing As dialog box so that you can choose a directory and type a name for the drawing. You can use any name when you first save the drawing.
A Displays a description of the file size, creation date, and other information about the drawing.
B Unavailable when saving drawings; available only when opening drawings.
C Turns the drawing preview on or off.
D Saves the drawing with a password.
E Displays an image of the drawing before you save it.
3.4.2 Saving a drawing with a new name or file format

You can save a drawing with a new name and in any of the following file formats:

Standard drawing files with a .dwg extension. You can choose a .dwg file format that is compatible with various versions of AutoCAD.

Drawing Exchange Format files with a .dxf file extension. You can choose a .dxf file format that is compatible with various versions of AutoCAD.

Drawing templates with a .dwt file extension. Drawing templates allow you to easily create new drawings that reuse your drawing settings and entities.

To save a drawing with a new name or file format

1. Do one of the following to choose Save As:
   - On the ribbon Quick Access toolbar, click Save As, or on the ribbon Application button, choose Save As.
   - On the menu, choose File > Save As.
   - Type save as and then press Enter.
2. In the Save Drawing As dialog box, under Save As Type, choose the file format.
3. Specify the name of the file you want to create.
4. Click Save.

Drawings can also be saved by exporting to various file formats. For more details, see “Exporting drawings” on page 566.
3.4.3 Saving a drawing with a password

Sometimes drawings may contain confidential information and you want to control who has access to that information. If you need an added level of security, you can save a drawing with a password so only you and those who know the password can open the drawing.

To save a drawing with a password, you must save it as a .dwg file for AutoCAD version 2004 or newer.

Record passwords or use familiar words. *If you forget a drawing’s password, the drawing cannot be opened or recovered. You may want to store all passwords in a safe place.*

To save a drawing with a password

1. Do one of the following to choose Save As:
   - On the ribbon Quick Access toolbar, click Save As, or on the ribbon Application button, choose Save As.
   - On the menu, choose File > Save As.
   - Type save as and then press Enter.
2. In the Save Drawing As dialog box, under Save As Type, choose a .dwg file for AutoCAD version 2004 or newer.
3. Click Password Protect.
4. Choose a folder where you want to save the drawing.
5. In File Name, specify the name of the file you want to create. 6 Click Save.
6. In the Password dialog box, enter a password.
7. If desired, record and store the password in a safe place. If you forget the drawing’s password, the drawing cannot be opened or recovered.
8. Click O.K
4. Creating simple entities

Simple entities include lines (both finite and infinite), circles, arcs, ellipses, elliptical arcs, points, and rays. In addition, CAD.direct Drafter includes a freehand sketch tool that can be used to create simple entities.

This section explains several methods for creating simple entities, including how to:

- Use menu commands on the Draw menu.
- Use the tools on the Draw toolbar.
- Type commands in the command bar.

In some cases, there are a number of different ways to create an entity. For the most part, one or two are given in this guide. Refer to the Command Reference in the online Help to learn how to create entities using other methods.

When you use a tool or a drawing command, the program prompts you to enter coordinate points, such as endpoints or insertion points. You can enter the points or distances either using a mouse or by typing coordinate values in the command bar. As you draw, CAD.direct Drafter also displays a context-sensitive prompt box with appropriate additional options for the type of entity you are drawing.

After you create entities, you can modify them using the entity modification tools.

4.1 Drawing lines

A line consists of two points: a start point and an endpoint. You can connect a series of lines, but each line segment is considered a separate line entity.

To draw a line

1. Do one of the following to choose Line:
   - On the ribbon, choose Home > Line or choose Draw > Line.
   - On the menu, choose Draw > Line.
   - On the Draw toolbar, click the Line tool.
   - Type line and then press Enter.
2. Specify the start point.
3. Specify the endpoint.
4. In the prompt box, choose Done to complete the command.
The prompt box provides several options as you draw. For example, when you draw the first line segment, you can specify its length or orientation angle. After you draw at least one line segment, you can click Undo to remove the previous line segment. You can click Done to end the line command. After you draw two or more line segments, you can click Close to complete the line command by drawing a line segment that connects to the start point of the first line segment you drew.

If the last entity you drew was an arc, you can also draw a line tangent to and starting from the endpoint of the arc.

**To draw a line as a continuation from the end of an arc**

1. Do one of the following to choose Line:
   - On the ribbon, choose Home > Line or choose Draw > Line.
   - On the menu, choose Draw > Line.
   - On the Draw toolbar, click the Line tool.
   - Type line and then press Enter.

2. In the prompt box, choose Follow.

3. Specify the length of the line.
4.2 Drawing circles

The default method for drawing a circle is to specify a center point and radius. You can draw circles using any of the following methods:

- Center-Radius
- Center-Diameter
- 2-Points
- 3-Points
- Radius-Tangents
- Convert Arc to Circle

To draw a circle by specifying its center and radius

1. Do one of the following to choose Circle Center-Radius:
   - On the ribbon, choose Home > Circle Center-Radius or choose Draw > Circle Center-Radius.
   - On the menu, choose Draw > Circle > Circle Center-Radius.
   - On the Draw toolbar, click the Circle Center-Radius tool.
   - Type circle and then press Enter.

2. Specify the center point.

3. Specify the radius of the circle.

Center point (A) and radius (B).
To draw a circle tangent to existing entities

1. Do one of the following to choose Circle Radius-Tangents:
   • On the ribbon, choose Home > Circle Radius-Tangents or choose Draw > Circle Radius-Tangents.
   • On the menu, choose Draw > Circle > Circle Radius-Tangents.
   • On the Draw toolbar, click the Circle Radius-Tangents tool. Go to step 3.
   • Type circle and then press Enter.

2. In the prompt box, choose Radius-Tangent-Tangent.

3. Specify the radius of the circle.

4. Select the first entity to which to draw the circle tangent.

5. Select the second entity to which to draw the circle tangent.

Radius of circle (A) and tangent lines (B) and (C).
To convert an arc to a circle

1. Do one of the following to choose Convert Arc to Circle:
   - On the ribbon, choose Home > Convert Arc to Circle or choose Draw > Convert Arc to Circle.
   - On the menu, choose Draw > Circle > Convert Arc to Circle.
   - On the Draw toolbar, click the Convert Arc to Circle tool. Go to step 3.
   - Type circle and then press Enter.

2. In the prompt box, choose Turn Arc Into Circle.

3. Select the arc you want to convert to a circle.
4.3 Drawing arcs

An arc is a portion of a circle. The default method for drawing an arc is to specify three points—the start point, a second point, and the endpoint. You can draw arcs using any of the following methods:

- Three points on an arc.
- Start point-center-endpoint, or Start point-endpoint-center, or Center-start point-endpoint.
- Start point-center-included angle, or Start point-included angle-center, or Center-start point-included angle.
- Start point-center-chord length, or Center-start point-chord length.
- Start point-endpoint-radius, or Start point-radius-endpoint.
- Start point-endpoint-included angle, or Start point-included angle-endpoint.
- Start point-endpoint-starting direction, or Start point-starting direction-end-point.
- Start point-radius-angle.
- As a tangent continuation of the previous arc or line.

To draw an arc by specifying three points

1. Do one of the following to choose 3-Point Arc:
   - On the ribbon, choose Home > 3-Point Arc or choose Draw > 3-Point Arc.
   - On the menu, choose Draw > Arc > 3-Point Arc.
   - On the Draw toolbar, click the 3-Point Arc tool.
   - Type arc and then press Enter.
2. Specify the start point.
3. Specify a second point.
4. Specify the endpoint.
The prompt box provides additional options for drawing arcs. For example, after you specify the start point of an arc, you can choose Angle, Center, Direction, Endpoint, or Radius. You can select the options in a different order as well. For instance, you can draw an arc by specifying its start point, endpoint, and radius, or you can specify the start point, radius, and then endpoint.

To draw an arc by specifying its start point, center point, and endpoint

1. Do one of the following to choose Arc Start-Center-End:
   • On the ribbon, choose Home > Arc Start-Center-End or choose Draw > Arc Start-Center-End.
   • On the menu, choose Draw > Arc > Arc Start-Center-End.
   • On the Draw toolbar, click the Arc Start-Center-End tool.
   • Type arc and then press Enter.
2. Specify the start point.
3. In the prompt box, choose Center.
4 Specify the center point.
5. Specify the endpoint.
To draw an arc by specifying two points and an included angle

1. Do one of the following to choose Arc Start-End-Angle:
   - On the ribbon, choose Home > Arc Start-End-Angle or choose Draw > Arc Start-End-Angle.
   - On the menu, choose Draw > Arc > Arc Start-End-Angle.
   - On the Draw toolbar, click the Arc Start-End-Angle tool.
   - Type arc and then press Enter.

2. Specify the start point.

3. In the prompt box, choose Angle or type angle.

4. To draw an arc in a counterclockwise direction, enter a positive value for the included angle. To draw an arc in a clockwise direction, enter a negative value for the included angle.

5. Specify the endpoint.

Start point (A), center point (B), and endpoint (C).

Start point (A), endpoint (B), and included angle (C).
If the last entity you drew was an arc or a line, you can also draw an arc tangent to and starting from the endpoint of the arc or line.

**To draw an arc tangent to an arc or line**

1. Do one of the following to choose Tangent Arc:
   - On the ribbon, choose Home > Tangent Arc or choose Draw > Tangent Arc.
   - On the menu, choose Draw > Arc > Tangent Arc.
   - On the Draw toolbar, click the Tangent Arc tool. Go to step 3.
   - Type arc and then press Enter.
2. In the prompt box, choose Follow.
3. Specify the endpoint.

Arcs can be converted to circles

*On the Draw toolbar, click the Convert Arc To Circle flyout tool.*
4.4 Drawing ellipses

The default method for drawing an ellipse is to specify the endpoints of one axis of the ellipse, and then specify a distance representing half the length of the second axis. The endpoints of the first axis determine the orientation of the ellipse. The longer axis of the ellipse is called the major axis, and the shorter one is the minor axis. The order in which you define the axes does not matter. The program determines the major and minor axes based on their relative lengths. You can draw ellipses using any of the following methods:

- Axis-Axis
- Axis-Rotation
- Center-Axes
- Center-Rotation

To draw an ellipse by specifying the axis endpoints

1. Do one of the following to choose Ellipse Axis-Axis:
   - On the ribbon, choose Home > Ellipse Axis-Axis or choose Draw > Ellipse Axis-Axis.
   - Type ellipse and then press Enter.

2. Specify the first endpoint.

3. Specify the second endpoint.

4. Specify the half-length of the other axis.
4.5 Drawing elliptical arcs

An elliptical arc is a portion of an ellipse. The default method for drawing an elliptical arc is to specify the endpoints of one axis of the ellipse, and then specify a distance representing half the length of the second axis. Then you specify the start and end angles for the arc, measured from the center of the ellipse in relation to its major axis. You can draw elliptical arcs using any of the following methods:

- Axis-Axis
- Axis-Rotation
- Center-Axes
- Center-Rotation

To draw an elliptical arc by specifying the axis endpoints

1. Do one of the following to choose Elliptical Arc Axis-Axis:
   - On the ribbon, choose Home > Elliptical Arc Axis-Axis or choose Draw > Elliptical Arc Axis-Axis.
   - On the Draw toolbar, click the Elliptical Arc Axis-Axis tool.
   - Type ellipse and then press Enter, and then type a (for Arc) and press Enter.
2. Specify the first endpoint.
3. Specify the second endpoint.
4. Specify the half-length of the other axis.
5. Specify the start angle of the arc.
6. Specify the end angle.

CAD.direct Drafter draws elliptical arcs in the direction you specify.

Go to Tools > Drawing Settings > Drawing Units tab.

Under Change Settings For, select Angular Units. The default setting is counterclockwise.
4.6 Drawing point entities

A point entity is a single x,y,z-coordinate location formatted as either a single dot or as one of 19 other possible display styles.

4.6.1 Drawing points

You can draw points one at a time or several at a time.

To draw a point

1. Do one of the following to choose Point:
   - On the ribbon, choose Draw > Point.
   - On the menu, choose Draw > Point.
   - On the Draw toolbar, click the Point tool.
   - Type point and then press Enter.
2. Specify the location of the point.

To draw several points

1. Do one of the following to choose Point:
   - On the ribbon, choose Draw > Point.
   - On the menu, choose Draw > Point.
   - On the Draw toolbar, click the Point tool.
   - Type point and then press Enter.
2. In the prompt box, choose Multiple Points.

3. Specify the location of each point.

4. In the prompt box, choose Done to complete the command.

4.6.2 Changing the size and appearance of point entities

Changing the size and appearance of point entities affects all point entities already in the drawing, as well as all points that you subsequently draw. Positive values represent the absolute size of the point entity measured in drawing units. Negative values represent a percentage relative to the drawing screen, so that points retain their visual size as you use the Zoom command to change the magnification of the drawing.

To change the size and appearance of point entities

1. Do one of the following:
   • Choose Format > Point Style.
   • Type ddpttype and then press Enter.
2. Under Point Display Type, select the style you want.
3. Under Point Size, select the point size, or choose one of the options.
4. Click OK.

When you regenerate the drawing, all point entities change to reflect the new size and appearance settings.
**A** To increase or decrease the point size, type or select a value.

**B** To use one of the preset point size options, click the one that you want.

**C** Select the button for the Point Display Type that you want.
4.7 Drawing rays

A ray is a line in three-dimensional space that starts at a point and extends to infinity. Because rays extend to infinity, they are not calculated as part of the drawing extents. The default method for drawing a ray is to select the start point of the ray and then specify its direction. You can draw a ray in any of the following ways:

- Horizontal draws the ray parallel to the x-axis of the current user coordinate system (UCS).
- Vertical draws the ray parallel to the y-axis of the current UCS.
- Angle draws the ray parallel to a specified angle.
- Bisect draws the ray perpendicular to an existing entity.
- Parallel draws the ray parallel to an existing entity.

To draw a ray

1. Do one of the following to choose Ray:
   - On the ribbon, choose Home > Ray or choose Draw > Ray.
   - On the menu, choose Draw > Ray.
   - On the Draw toolbar, click the Ray tool.
   - Type ray and then press Enter.
2. Specify the start point.
3. Specify the direction.
4. To complete the command, press Enter.

Start point (A) and direction (B).
4.8 Drawing infinite lines

Infinite lines are sometimes referred to as construction lines. An infinite line is a line through a given point, oriented at a specified angle in three-dimensional space and extending to infinity in both directions. Because infinite lines extend to infinity, they are not calculated as part of the drawing extents.

The default method for drawing an infinite line is to select a point along the line and then specify the direction of the line. You can draw an infinite line in any of the following ways:

- Horizontal draws the infinite line parallel to the x-axis of the current UCS.
- Vertical draws the infinite line parallel to the y-axis of the current UCS.
- Angle draws the infinite line parallel to a specified angle.
- Bisect draws the infinite line perpendicular to an existing entity.
- Parallel draws the infinite line parallel to an existing entity.

To draw an infinite line

1. Do one of the following to choose Infinite Line:
   - On the ribbon, choose Home > Infinite Line or choose Draw > Infinite Line.
   - On the menu, choose Draw > Infinite Line.
   - On the Draw toolbar, click the Infinite Line tool.
   - Type infline and then press Enter.
2. Specify a point along the line.
3. Specify the direction.
4. To complete the command, press Enter.

You can also draw infinite lines at a specific angle or at an angle relative to an existing entity.
To draw an infinite line at a specified angle relative to another entity

1. Do one of the following to choose Infinite Line:
   - On the ribbon, choose Home > Infinite Line or choose Draw > Infinite Line.
   - On the menu, choose Draw > Infinite Line.
   - On the Draw toolbar, click the Infinite Line tool.
   - Type infline and then press Enter.

2. In the prompt box, choose Angle.

3. In the prompt box, choose Reference.

4. Select the reference entity.

5. Specify the angle of the infinite line in relation to the selected entity.

6. Specify the location of the infinite line.

7. To complete the command, press Enter.

Reference entity (A) and angle in relation to entity (B).
4.9 Drawing freehand sketches

A freehand sketch consists of many straight line segments, created either as individual line entities or as a polyline.

4.9.1 Creating freehand sketches

Before you begin creating a freehand sketch, you must set the length, or increment, of each segment. The smaller the segments, the more accurate your sketch, but segments that are too small can greatly increase the file size.

After you specify the length of the sketch segments, the crosshairs change to a Pencil tool. Your freehand sketch is not added to the drawing until you “write” the sketch into your drawing. This means that you temporarily save the segment that you’ve drawn and the segment length, and you can continue sketching.

To create a freehand sketch

1. Do one of the following to choose Freehand:
   - On the ribbon, choose Draw > Freehand.
   - On the menu, choose Draw > Freehand.
   - On the Draw toolbar, click the Freehand tool.
   - Type freehand and then press Enter.
2. Specify the length of the sketch segments.
3. Click the mouse button to place the Pencil tool on the drawing to begin sketching.
4. Move the pencil image to draw a temporary freehand sketch.
5. Click the mouse button to lift the pencil up to stop sketching.
6. In the prompt box, choose Write, Then Resume to write the temporary freehand sketch into the drawing.
7. Click the mouse button to put the pencil down again and resume sketching.
8. Click the mouse button again to lift the pencil up to stop sketching.
9. In the prompt box, choose Done to write the temporary freehand sketch into the drawing and end the command.
4.9.2 Erasing freehand sketch lines

You can erase temporary freehand sketch lines that have not yet been written into the drawing by choosing the Delete On option in the prompt box. The pencil changes to an Eraser tool. You can erase portions of the line when you move the eraser over a temporary freehand line without clicking the mouse button.

To erase freehand sketch lines

1. Do one of the following to choose Freehand:
   - On the ribbon, choose Draw > Freehand.
   - On the menu, choose Draw > Freehand.
   - On the Draw toolbar, click the Freehand tool.
   - Type freehand and then press Enter.
2. Specify the length of the sketch segments.
3. Select a point on the drawing to display the Pencil tool and begin sketching.
4. Click the mouse button to lift the pencil up to stop sketching.
5. In the prompt box, choose Delete On.
6. Move the Eraser tool to the beginning or end of the freehand sketch line that you drew, and then move it as far along the line as you want to erase.
7. Click the mouse button to put the Pencil tool down to resume sketching.
4.9.3 Setting the sketch method and accuracy

Using polylines for freehand sketches makes it easier to go back and edit sketches. You control whether to create freehand sketches using line segments or polylines in the Drawing Settings dialog box. You can also control the length of sketch segments in this dialog box.

To specify lines or polylines when sketching

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.

2. Choose the Entity Creation tab.

3. Under Change Settings For, click Freehand Sketches.

4. Under Freehand Sketching Methods, click either Freehand Command Creates Lines or Freehand Command Creates A Polyline.

5. Click OK.
A Select the sketch method.  

B Specify the default length of sketch segments.
5. Creating complex entities

Complex entities include polylines (including rectangles, squares, and polygons), spline curves, donuts, and planes. In addition, CAD.direct Drafter includes tools for adding hatching to your drawings.

This section explains several methods for creating complex entities, including how to:

- Use menu commands on the Draw menu.
- Use the tools on the Draw toolbar.
- Type commands in the command bar.

In some cases, there are number of different ways to create an entity. For the most part, one or two are given in this guide. Refer to the Command Reference in the online Help to learn how to create entities using other methods.

When you type a drawing command or select a tool, the program prompts you to enter coordinate points, such as endpoints or insertion points. As you draw, the program displays a context-sensitive prompt box with appropriate additional options for the type of entity you are drawing.

After you create complex entities, you can modify them using the entity-modification tools. Several of these entity types require special editing commands.

5.1 Drawing rectangles and squares

Rectangles are closed polylines with four sides and a square is a rectangle with four equal sides.

You draw a rectangle by specifying its opposite corners. The rectangle is normally aligned parallel to the current snap and grid alignment, but you can use the Rotated option to align the rectangle to any angle.

You draw a square using the Square option of the Rectangle command. The square is normally aligned parallel to the current snap and grid alignment, but you can use the Rotated option to align the square to any angle.

To draw a rectangle

1. Do one of the following to choose Rectangle:
   - On the ribbon, choose Home > Rectangle or choose Draw > Rectangle.
   - On the menu, choose Draw > Rectangle.
   - On the Draw toolbar, click the Rectangle tool.
   - Type rectangle and then press Enter.
2. Specify one corner of the rectangle.

3. Specify the opposite corner of the rectangle.

Opposite corners (A and B) and resulting rectangle.

You can edit each side of a rectangle individually using the Edit Polyline tool on the Modify toolbar. You can convert the sides into individual line entities using the Explode tool on the Modify toolbar. You can control whether wide rectangle lines are shown filled or as outlines using the Fill tool on the Settings toolbar.

You can also use the Rectangle tool to draw a square. Instead of specifying the opposite corners, you specify the length of one side and the alignment of the square.

**To draw a square**

1. Do one of the following to choose Rectangle:
   - On the ribbon, choose Home > Rectangle or choose Draw > Rectangle.
   - On the menu, choose Draw > Rectangle.
   - On the Draw toolbar, click the Rectangle tool.
   - Type rectangle and then press Enter.
2. In the prompt box, choose Square.
3. Specify one corner of the square.
4. Specify the length of one side of the square by selecting its other end.
You can control the line width of rectangles. Choose the Width Of Line option in the prompt box. After you change the width of the line, the new width setting remains in effect for subsequent rectangles until you change it again.

5.2 Drawing polygons

Polygons are closed polylines composed of a minimum of three and a maximum of 1,024 equal-length sides. The default method for drawing a polygon is to specify the center of the polygon and the distance from the center to each vertex. You can draw a polygon using any of the following methods:

- Center-Vertex
- Center-Side
- Edge

5.2.1 Drawing polygons by vertex

You can create an equal-sided polygon defined by its center point and the distance to its vertices. First specify the number of sides, then the center point, and then the location of one vertex, which determines both the size and orientation of the polygon.

To draw a polygon by vertex

1. Do one of the following to choose Polygon Center-Vertex:
   - On the ribbon, choose Home > Polygon Center-Vertex or choose Draw > Polygon Center-Vertex.
   - On the menu, choose Draw > Polygon > Polygon Center-Vertex.
   - On the Draw toolbar, click the Polygon Center-Vertex tool.
   - Type polygon and then press Enter.
2. Type 5 to specify five sides for the polygon.
3. Specify the center of the polygon.
4. Specify the vertex of the polygon.

5.2.2 Drawing polygons by side

You can create a polygon with equal-length sides defined by its center point and the distance to the midpoint of a side. First specify the number of sides, then the center point, and then the location of the midpoint of one side, which determines both the size and orientation of the polygon.

To draw a polygon by side

1. Do one of the following to choose Polygon Center-Side:
   - On the ribbon, choose Home > Polygon Center-Side or choose Draw > Polygon Center-Side.
   - On the menu, choose Draw > Polygon > Polygon Center-Side.
   - On the Draw toolbar, click the Polygon Center-Side tool.
   - Type polygon and then press Enter.
2. Type 3 to specify three sides for the polygon.
3. Specify the center of the polygon.
4. Specify the midpoint of the side.
5.2.3 Drawing polygons by specifying the length of an edge

You can create a polygon with equal-length sides defined by the length of one of the polygon edges. First specify the number of sides, then the edge start point, and then the edge end point, which determines both the size and orientation of the polygon.

To draw a polygon by specifying the length of an edge

1. Do one of the following to choose Polygon Edge:
   - On the ribbon, choose Home > Polygon Edge or choose Draw > Polygon Edge. On the menu, choose Draw > Polygon > Polygon Edge.
   - On the Draw toolbar, click the Polygon Edge tool.
   - Type polygon and then press Enter.
2. Type 5 to specify three sides for the polygon.
3. Specify the first point of an edge on the polygon.
4. Specify the second point of the edge on the polygon.
You can edit each side of a polygon individually using the Edit Polyline tool on the Modify toolbar. You can convert the sides into individual line entities using the Explode tool on the Modify toolbar. You can control whether wide polygon lines are shown filled or as outlines using the Fill tool on the Settings toolbar.

### 5.3 Drawing polylines

A polyline is a connected sequence of arcs and lines that is treated as a single entity. You can draw a polyline with any line type and using a width that either remains constant or tapers over the length of any segment. When editing a polyline, you can modify the entire polyline or change individual segments.

To draw a polyline with straight segments

1. Do one of the following to choose Polyline:
   - On the ribbon, choose Home > Polyline or choose Draw > Polyline.
   - On the menu, choose Draw > Polyline.
• On the Draw toolbar, click the Polyline tool.
• Type polyline and then press Enter.

2. Specify the start point.

3. Specify the endpoint of each segment.

4. To complete the command, choose Close or Done.

5.3.2 Drawing a polyline with arc segments

With the Draw Arcs option, you can continually draw arc segments until you select the Draw Lines option to go back to drawing line segments. When you draw arc segments, the first point of the arc is the endpoint of the previous segment. By default, you draw arc segments by specifying the endpoint of each segment. Each successive arc segment is drawn tangent to the previous arc or line segment. If you choose Close while in the Draw Arcs option, the closing segment is created as an arc.

You can also specify the arc using any of the following methods:

• Start point, included angle, center point
• Start point, included angle, radius
• Start point, center point, endpoint
• Start point, included angle, endpoint
• Start point, center point, included angle
• Start point, center point, chord length
• Start point, direction, endpoint
• Start point, radius, included angle
• Start point, second point, endpoint

Polyline start point (A) and segment endpoints (B).
To draw a line segment followed by an arc polyline segment

1. Do one of the following to choose Polyline:
   - On the ribbon, choose Home > Polyline or choose Draw > Polyline.
   - On the menu, choose Draw > Polyline.
   - On the Draw toolbar, click the Polyline tool.
   - Type polyline and then press Enter.

2. Specify the start point.

3. Specify the endpoint.

4. In the prompt box, choose Draw Arcs.

5. Specify the endpoint of the arc segment.

6. To complete the command, choose Done.

Polyline start point (A), line endpoint/arc start point (B), and arc endpoint (C).
5.4 Drawing multilines

A multiline is made from multiple parallel lines (two lines by default), which consist of linear segments connected together. The end of the current segment is the start of the next segment. Ends of segments are the vertices of the multiline.

5.4.1 Drawing a multiline

To draw a multiline

1. Do one of the following to choose Multiline:
   - On the ribbon, choose Draw > Multiline.
   - On the menu, choose Draw > Multiline.
   - On the Draw toolbar, click the Multiline tool.
   - Type mline and then press Enter.

2. Specify the start point.

3. Specify additional vertices.

4. After specifying the last endpoint, choose Done or press Enter.

Multiline startpoint (A), vertices (B), and endpoint (C).
5.4.2 Specifying justification and scale

When you draw a multiline, you specify the vertices of one of the lines that makes up the multiline — the additional parallel lines are drawn in position according to the justification. Vertices can be specified on the top, middle, or bottom of a multiline, according to the selected justification.

You can also determine the overall width of the multiline, which affects the distance between parallel lines, by adjusting the multiline scale.

*NOTE:* If you change the multiline scale, you might need to make equivalent changes to the linetype scale to prevent dots or dashes from being disproportionately sized.

To draw a multiline with different justification or scale

1. Do one of the following to choose Multiline:
   - On the ribbon, choose Draw > Multiline.
   - On the menu, choose Draw > Multiline.
   - On the Draw toolbar, click the Multiline tool.
   - Type mline and then press Enter.
2. Select justification and choose one of the following options:
   - Top Specified vertices define the top line; additional parallel lines are drawn below the specified vertices.
   - Zero Specified vertices define the middle of the multiline.
   - Bottom Specified vertices define the bottom line; additional parallel lines are drawn above the specified vertices.
3. Select Scale and enter a new scale value according to the following:
   - Greater than 1 — Multilines are wider.
   - Less than 1 — Multilines are narrower.
   - Equal to 1 — Multilines collapse into a single line.
   - Negative value — Flips the justification when multilines are drawn and alters the scale according to the set value.
4. Specify the start point of the multiline.
5. Specify additional vertices.
6. After specifying the endpoint, choose Done or press Enter.
5.6 Drawing traces

With the Trace command, you can draw a two-dimensional solid line of specified width. The Trace command is not commonly used — most users use the Polyline command instead.

To draw a trace

1. Type trace and then press Enter. Or on the ribbon, choose Draw > Trace.
2. Specify the width of the trace.
3. Specify the start point.
4. Specify additional vertices.
5. After specifying the last endpoint, choose Done or press Enter.

Trace startpoint (A), vertices (B), and endpoint (C).
5.7 Drawing splines

A spline is a smooth curve defined by a set of points. You can use splines to create sculptured shapes such as the cross section of a turbine blade or an airplane wing.

To draw a spline

1. Do one of the following to choose Spline:
   - On the ribbon, choose Draw > Spline.
   - On the menu, choose Draw > Spline.
   - On the Draw toolbar, click the Spline tool.
   - Type spline and then press Enter.
2. Specify the first point of the spline.
3. Specify the second point of the spline.
4. Specify as many more points as you want.
5. When you have finished, press Enter.

You can add tangents to the spline, which are lines that give it shape.

To add tangents to a spline

1. Specify the starting tangent point.
2. Specify the ending tangent point.
5.7.1 Specifying fit tolerance

By default, a spline passes through all of the control points. When you draw a spline, you can change this by specifying the fit tolerance. The fit tolerance value determines how closely the spline fits the set of points you specify. For example, a spline fit tolerance value of 0 causes the spline to pass through the control points. A value of 0.01 creates a spline that passes through the start and endpoints and within 0.01 units of the intermediate control points.

To specify the fit tolerance

1. Do one of the following to choose Spline:
   - On the ribbon, choose Draw > Spline.
   - On the menu, choose Draw > Spline.
   - On the Draw toolbar, click the Spline tool.
   - Type spline and then press Enter.
2. Specify the first point of the spline.
3. Specify the second point of the spline.
4. In the prompt box, choose Fit Tolerance.
5. To accept the default of 0.0000, press Enter.

5.7.2 Drawing a closed spline

You can draw a closed spline, which is a spline for which the start point and endpoint are the same. Because the spline is closed, you specify only one tangent.

To draw a closed spline

1. Do one of the following to choose Spline:
   - On the ribbon, choose Draw > Spline.
   - On the menu, choose Draw > Spline.
   - On the Draw toolbar, click the Spline tool.
   - Type spline and then press Enter.
2. Specify the first point of the spline.
3. Specify the second point of the spline.
4. Specify as many more points as you want.
5. When you have finished, in the prompt box, choose Close.
6. To complete the command, specify the tangent point.

5.8 Drawing helices

A helix is a three-dimensional spiral that is open at both ends. The base and top can be equal values, similar to a coil or spring, or they can be different values, similar to a cone.

Helices are often used to create other entities.

In particular, the Sweep, Loft, and Revolve commands can all be used with helices in more complex drawings to create spiral stairs, spiral parts, and more.

To draw a helix

1. Do one of the following to choose Helix:
   - On the ribbon, choose Draw > Helix.
   - On the menu, choose Draw > Helix.
   - On the Draw toolbar, click the Helix tool.
   - Type helix and then press Enter.
2. Specify the center point of the helix.
3. Specify the radius (or diameter) of the bottom of the helix.
4. Specify the radius (or diameter) of the top of the helix.
5. Optionally set any of the following:

- **Turns** Specify the number of full turns. The default number of turns is three. The maximum is 500.
- **Turn height** Specify the height of one full turn, which updates the number of turns automatically. This option is available only if you have not specified a number of turns.
- **Twist** Specify the direction of helix turns: clockwise (CW) or counterclockwise (CCW).

6. Specify the height and position of the helix by choosing one of the following:

- **Choose Axis endpoint** and specify the endpoint of the helix, which determines the position and direction of the helix.
- **Specify the height of the helix.** If the height is zero, the helix will be a two-dimensional spiral, but if the start and end radius are the same it will look like a circle.

---

**Diagram:**

Helix center point (A), bottom radius (B), top radius (C), and height (D).
5.9 Drawing donuts

Donuts are solid, filled circles or rings created as closed, wide polylines. You can draw a donut using one of several methods. The default method is to specify the inside and outside diameters of the donut, and then specify its center. You can then create multiple copies of the same donut by specifying different center points until you press Enter to complete the command.

To draw a donut

1. Do one of the following to choose Donut:
   - On the ribbon, choose Draw > Donut.
   - On the menu, choose Draw > Donut.
   - On the Draw toolbar, click the Donut tool.
   - Type donut and then press Enter.
2. Specify the inside diameter of the donut.
3. Specify the outside diameter of the donut.
4. Specify the center of the donut.
5. Specify the center point to draw another donut, or choose Done to complete the command.

![Diagram of a donut with inside diameter (A) and outside diameter (B).]

The prompt box provides additional options for drawing donuts. For example, you can specify the width of the donut and two points on the diameter of the donut, or you can specify the width and three points on the donut. You can also draw a donut tangent to existing entities.

A donut can be a completely filled circle.
Donuts are completely filled if the inside diameter is zero.
To draw a donut tangent to existing entities

1. Do one of the following to choose Donut:
   - On the ribbon, choose Draw > Donut.
   - On the menu, choose Draw > Donut.
   - On the Draw toolbar, click the Donut tool.
   - Type donut and then press Enter.

2. In the prompt box, choose Radius Tangent Tangent.

3. Specify the width of the donut.

4. Specify the diameter of the donut.

5. Select the first tangent entity to which to draw the donut.

6. Select the second tangent entity to which to draw the donut.

You can edit donuts using the Edit Polyline tool on the Modify toolbar. You can convert donuts into arc entities using the Explode tool on the Modify toolbar. You can control whether donuts are shown filled or as outlines using the Fill tool on the Settings toolbar.

You can control the default outside and inside diameter of donuts.
Choose Tools > Drawing Settings, click the Entity Creation tab, and choose the options you want.
5.10 Creating planes

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a solid color. The default method is to specify the corners of the plane. After you specify the first two corners, the plane is displayed as you specify the remaining corners. Specify corner points in a triangular manner. The program prompts you for the third point and then the fourth point. If you continue specifying points, the third- and fourth-point prompts toggle until you press Enter to complete the command.

Creating planes in CAD.direct Drafter is similar to the Solid command in AutoCAD.

To draw a quadrilateral plane

1. Do one of the following to choose Plane:
   - On the ribbon, choose Draw > Plane.
   - On the menu, choose Draw > Plane.
   - On the Draw toolbar, click the Plane tool.
   - Type plane and then press Enter.
2. Specify the first point.
3. Specify the second point.
4. Specify the third point.
5. Specify the fourth point.
6. To complete the command, press Enter.

After you select the first two points (A) and (B), the sequence in which you select the third (C) and fourth (D) points determines the shape of the resulting quadrilateral plane.

The prompt box provides additional options for drawing planes. For example, you can draw rectangular, square, or triangular planes.
To draw a rectangular plane

1. Do one of the following to choose Plane:
   - On the ribbon, choose Draw > Plane.
   - On the menu, choose Draw > Plane.
   - On the Draw toolbar, click the Plane tool.
   - Type plane and then press Enter.

2. Choose Rectangle.

3. Specify the first point.

4. Specify the opposite corner.

5. Specify the rotation angle.

6. To complete the command, specify the opposite corner to draw another rectangle, or press Enter.

You can control whether planes are shown filled or as outlines using the Fill tool on the Settings toolbar. You can convert planes into individual line entities corresponding to the outline of the plane using the Explode tool on the Modify toolbar.
5.11 Drawing wipeouts

Wipeouts are unique entities that can help you hide areas of your drawing. They display with the current background color, so the details behind the wipeout do not display or print.

Wipeouts are similar to other entities — you can copy, mirror, array, erase, rotate, and scale them, and they can be used in both model space and paper space.

If you want to print the wipeout entities located in a drawing, you must print to a raster-capable printer. Note that in some cases you may have unexpected results when printing drawings that contain wipeout entities, for example, if printing on colored paper.

Wipeouts are created using existing polygons, closed zero-width polylines made up of only line segments, or new polylines that you draw while using the Wipeout command.

The display of wipeouts varies depending on your version of CAD.direct Drafter.

If your CAD.direct Drafter version does not include raster image capability, wipeout entities display, but the details behind the wipeouts also display.

5.11.1 Drawing a wipeout

To draw a wipeout

1. Do one of the following to choose Wipeout:
   - On the ribbon, choose Annotate > Wipeout (in Markup).
   - On the menu, choose Draw > Wipeout.
   - On the Draw toolbar, click the Wipeout tool.
   - Type wipeout and then press Enter.

2. Specify the start point.

3. Specify the endpoint of each segment.

4. After specifying the last endpoint, choose Done or press Enter.
5.11.2 Creating a wipeout using existing polygons and polylines

To create a wipeout using an existing polygon or polyline

1. Do one of the following to choose Wipeout:
   • On the ribbon, choose Annotate > Wipeout (in Markup).
   • On the menu, choose Draw > Wipeout.
   • On the Draw toolbar, click the Wipeout tool.
   • Type wipeout and then press Enter.

2. Choose Polyline.

3. Select the closed polyline to use for the wipeout.

4. Choose one of the following:
   • Yes — Creates the wipeout and deletes the polyline used to create the wipeout.
   • No — Creates the wipeout and keeps the polyline used to create the wipeout.

5.11.3 Turning wipeout frames on or off
Each wipeout has a frame along its boundary. Wipeout frames can be turned on or off for any drawing. When wipeout frames are on, you can select and modify wipeouts. You may want to turn off wipeout frames when it’s time to print.

**To turn wipeout frames on or off**

1. Do one of the following to choose Wipeout:
   - On the ribbon, choose Annotate > Wipeout (in Markup).
   - On the menu, choose Draw > Wipeout.
   - On the Draw toolbar, click the Wipeout tool.
   - Type wipeout and then press Enter.
2. Choose Frames.
3. Choose On or Off.

![Wipeout frames turned on and off](image.png)
5.12 Drawing revision clouds

Revision clouds are cloud shapes that mark areas of a drawing that require further attention. They are especially helpful when revising a drawing; add a revision cloud to each modified area so reviewers can find changes easily.

Revision clouds are polylines, so you can work with and modify them in the same way you would a polyline: move, copy, mirror, and scale the entire revision cloud or select and move individual vertices to adjust the arcs that make up the revision cloud.

5.12.1 Drawing a revision cloud

Drawing a revision cloud is easy: simply select a start point and move the mouse.

To draw a revision cloud

1. On the ribbon, choose Annotate > Revision Cloud (in Markup).
2. On the menu, choose Draw > Revision Cloud.
3. On the Draw toolbar, click the Revision Cloud tool.
4. Type revcloud and then press Enter.

2. Specify the start point.

3. Move the mouse, encircling the desired area.

When you return to the starting point, the revision cloud command finishes automatically.

Edit revision clouds just as you would a polyline.

Select the revision cloud and move its vertices or use the Edit Polyline tool on the Modify toolbar.
**5.12.2 Creating a revision cloud using existing entities**

In addition to drawing new revision clouds, you can also convert existing entities — lines, arcs, circles, 2D polylines, and splines — into revision clouds.

**To create a revision cloud using an existing entity**

1. Do one of the following to choose Revision Cloud:
   - On the ribbon, choose Annotate > Revision Cloud (in Markup).
   - On the menu, choose Draw > Revision Cloud.
   - On the Draw toolbar, click the Revision Cloud tool.
   - Type revcloud and then press Enter.
2. Choose Entity.
3. Select the existing line, arc, circle, 2D polyline, or spline to be converted.
4. Choose whether to reverse the direction of the individual arcs of the revision cloud. Choose No to keep the arcs pointing inward. Choose Yes to flip the arcs to point outward.

A revision cloud is created, and the selected entity remains or is deleted depending on the DELOBJ system variable setting.

**5.12.3 Customizing default revision cloud settings**

All revision clouds are drawn using default settings that can be customized:

- Minimum arc length — The individual arcs that make up a revision cloud can be made smaller or larger by setting the minimum arc length.
- Maximum arc length — The individual arcs that make up a revision cloud can be made smaller or larger by setting the maximum arc length.
- Style — Revision clouds can appear as if they had been drawn with a regular pen or a calligraphy pen.

Only new revision clouds will be drawn with the new settings. Existing revision clouds are not affected.
To customize revision cloud settings

1. Do one of the following to choose Revision Cloud:
   - On the ribbon, choose Annotate > Revision Cloud (in Markup).
   - On the menu, choose Draw > Revision Cloud.
   - On the Draw toolbar, click the Revision Cloud tool.
   - Type revcloud and then press Enter.

2. Choose Arc Length.

3. Enter the minimum length of the individual arcs that make up the revision cloud, then press Enter.

4. Enter the maximum length of the individual arcs that make up the revision cloud, then press Enter. The value cannot be set to more than three times the minimum arc length.

Arc lengths can also be scaled.
The setting of the DIMSCALE system variable also affects arc length.

5. Choose Style and select one of the following:
   - Normal — Draws new revision clouds as if they were drawn with a regular pen.
   - Calligraphy — Draws new revision clouds as if they were drawn with a calligraphy pen.

5.13 Creating boundary polylines

A bounded polyline is an area bound by a single closed entity or by multiple entities that intersect and is used for hatching or dimensioning.

5.13.1 Understanding boundary polylines

With the Boundary command, you can designate a specific area of a drawing for operations such as hatching and dimensioning. You create a boundary polyline by selecting an area inside a closed loop. The area you select can be bounded by a single closed entity or by multiple entities that intersect.

In cases where entities intersect, CAD.direct Drafter interprets the boundary as the closed loop closest to the point specifying the area. In the following figure, for example, the area point selected in the rectangle results in a boundary consisting of the closed loop nearest the point selection, as opposed to the closed loop formed by the rectangle itself.
To make boundaries more specific, you can create a boundary set. A boundary set specifies which entities are considered in determining the boundary path. This can make creating the boundary polyline faster if you are working with a complex drawing.

In the following figure, the circle and triangle are the selected entities. If you select an area anywhere inside the circle or the triangle, the result is a polyline that bounds the shaded area.
5.13.2 Using islands and island detection

Islands are closed loops that reside inside other closed loops. CAD.direct Drafter provides island-detection options so that you can specify which islands, if any, should be considered in the area selection for a boundary.

The following figure shows a rectangular polyline with two islands. The circle is referred to as the outer island, and the octagon is referred to as a nested island.

![Diagram of a rectangular polyline with two islands](image)

Rectangular polyline (A) with outer island (B), with point (C) specifying the area selection, and nested island (D).

You can choose from three island-detection methods.

- **Nested Islands** The outer entity and all its islands are considered for the polyline.
- **Outer** Only the outer entity and its outer island are considered for the polyline.
- **Ignore Islands** Only the outer entity is considered for the polyline.

![Examples of island detection](image)

Nested islands (A), with outer island (B), and with ignore islands (C).
5.13.3 Creating a boundary polyline

When you create a boundary polyline, you select an existing entity or multiple entities to define the boundary.

To draw a boundary polyline

1. Do one of the following to choose Boundary Polyline:
   • On the ribbon, choose Home > Boundary Polyline or choose Draw > Boundary Polyline.
   • On the menu, choose Draw > Boundary Polyline.
   • On the Draw toolbar, click the Boundary Polyline tool.
   • Type boundary and then press Enter.

2. Specify the entities that you want made available for the boundary polyline by doing one of the following:
   • All entities Select All Visible Entities to have all entities in the drawing considered when creating the boundary polyline.
   • Custom selection Define only specific areas to be considered when creating the boundary polyline, which can improve system performance if you are working with a complex drawing. Click Select Boundary Set. In the drawing, select the entities individually or by choosing a selection method from the prompt box, and then press Enter. The Current Selection Set option becomes selected automatically, which indicates that the entities you selected with the Select Boundary Set button will be considered when creating the boundary polyline.

   You don’t have to select entities again using the Select Boundary Set button.

   The Current Selection Set option uses the last set of entities you selected with the Select Boundary Set button.

3. Choose an island-detection option.

4. Click Select Area.

5. In the drawing, click inside the area whose closed perimeter forms the boundary, not on the polyline itself. If desired, continue clicking inside additional closed perimeters.

6. To complete the selection, press Enter.

7. In the Boundary dialog box, click OK.
5.14 Adding hatching

When you add hatching to a drawing, CAD.direct Drafter fills entities or enclosed areas with a pattern. You can choose a predefined hatch pattern, or you can create your own hatch pattern.

First you specify the hatch pattern and other options, and then you choose which entities or enclosed areas that you want to hatch.

Hatch patterns are memory intensive. *Because hatch patterns can take a considerable amount of time to draw and display, you may want to add hatching during the last steps of drawing creation or insert hatches on a separate layer that you can freeze as you continue to work on your drawing.*
5.14.1 Specifying a hatch pattern

A hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can select a hatch pattern from a set of predefined patterns, or you can define a pattern of your own. The hatch pattern you used most recently is the default pattern the next time you add hatching.

The program supplies predefined standard hatch patterns, which are stored in the following hatch pattern library files:

- icad.pat — American National Standards Institute (ANSI)-compliant patterns.

You can use other external hatch pattern libraries, such as an office standard library, customized patterns, and libraries available from vendors or standards organizations.

To specify a predefined hatch pattern

1. Do one of the following to choose Boundary Hatch:
   - On the ribbon, choose Draw > Boundary Hatch.
   - On the menu, choose Draw > Boundary Hatch.
   - On the Draw toolbar, click the Boundary Hatch tool.
   - Type bhatch and then press Enter.

2. From the Boundary Hatch dialog box, click the Pattern Properties tab.

3. In the Pattern Type list, click Predefined.

   With Predefined, you can apply a scale factor to make the pattern larger or smaller than the default size.

4. For Scale, enter the scale factor as a percentage of the default.

5. For Angle, enter the angle of the pattern in degrees (1-360).

   The default angle is clockwise; you can change the angle of any hatch pattern by entering a numerical value.

6. For ISO Pen Width, enter the pen width.

   If you choose a predefined, ISO standard pattern, you can scale the pattern based on the ISO pen width.

7. To copy the pattern properties from an existing hatch, choose Copy Hatch Properties and select the hatch.
8. To have the display and printing of the hatch pattern affected by annotation scaling, under Hatch Attributes, select the Annotative check box.

9. To associate the hatch pattern to its boundary entities, under Hatch Attributes, select the Associative check box. An associative hatch updates automatically if you move any of its boundaries.

10. To continue, add a hatch by doing one of the following:

   • Select the entities you want to add a hatch. For details, see “Selecting entities for hatching” on page 150 in this chapter. Begin with step 2.

   • Select an area or boundary you want to add a hatch. For details, see “Selecting areas for hatching” on page 151 in this chapter. Begin with step 2.

To specify a user-defined hatch pattern

1. Do one of the following to choose Boundary Hatch:

   • On the ribbon, choose Draw > Boundary Hatch.

   • On the menu, choose Draw > Boundary Hatch.

   • On the Draw toolbar, click the Boundary Hatch tool.

   • Type bhatch and then press Enter.

2. From the Boundary Hatch dialog box, click the Pattern Properties tab.

3. In the Pattern Type list, click User Defined.

4. For Spacing, enter the line spacing for the pattern.

5. To crosshatch the pattern, select the Cross-Hatched check box.

You can choose to crosshatch the pattern. Cross-hatching imposes a copy of the specified user-defined pattern at a 90-degree angle over the first pattern you defined.

6. To copy the pattern properties from an existing hatch, choose Copy Hatch Properties, and select a hatch pattern from a hatched entity in the drawing.

7. To have the display and printing of the hatch pattern affected by annotation scaling, under Hatch Attributes, select the Annotative check box.

8. To associate the hatch pattern to its boundary entities, under Hatch Attributes, select the Associative check box. An associative hatch updates automatically if you move any of its boundaries.
9. To continue, add a hatch by doing one of the following:

- Select the entities you want to add a hatch. For details, see “Selecting entities for hatching” on page 150 in this chapter. Begin with step 2.
- Select an area or boundary you want to add a hatch. For details, see “Selecting areas for hatching” on page 151 in this chapter. Begin with step 2.

To use a predefined library pattern

1. Do one of the following to choose Boundary Hatch:
   - On the ribbon, choose Draw > Boundary Hatch.
   - On the menu, choose Draw > Boundary Hatch.
• On the Draw toolbar, click the Boundary Hatch tool.
• Type bhatch and then press Enter.

2. From the Boundary Hatch dialog box, click the Pattern tab.

3. For Hatch File, select the icad.pat or icadiso.pat hatch pattern library file.

4. To select a predefined pattern, do one of the following:
   • In the Patterns list, click the pattern name.
   • Click the graphical representation of the hatch pattern.

5. To continue, add a hatch by doing one of the following:
   • Select the entities you want to add hatching. For details, see “Selecting entities for hatching” on page 150 in this chapter. Begin with step 2.
   • Select an area or boundary you want to add hatching. For details, see “Selecting areas for hatching” on page 151 in this chapter. Begin with step 2.
Specifying a custom library pattern:
You can use custom external hatch pattern libraries (.pat files), such as a standard library used in your office, customized patterns, and libraries available from vendors or standards organizations. The .pat file can be in any location.

To use a custom library pattern

1. Do one of the following:
   - Copy the custom pattern file (.pat file) to the Patterns folder where you installed CAD.direct Drafter. To check where CAD.direct Drafter searches for pattern files, choose Tools > Options, click Paths/Files, and check the folders listed for Hatch Patterns.
   - Choose Tools > Options, click Paths/Files, and add the location of the custom pattern file (.pat file) to the folders listed for Hatch Patterns.

2. Do one of the following to choose Boundary Hatch:
   - On the ribbon, choose Draw > Boundary Hatch.
   - On the menu, choose Draw > Boundary Hatch.
   - On the Draw toolbar, click the Boundary Hatch tool.
   - Type bhatch and then press Enter.

3. Click the Pattern Properties tab.

4. In Pattern Type, choose Custom. Custom is available only if a custom .pat file was loaded successfully in Step 1.

5. Click the Pattern tab.

6. In Hatch File, select the custom .pat file.

7. In the Patterns list, click a pattern name. Note that graphical representations are not available.

8. To continue, add a hatch by doing one of the following:
   - Select the entities you want to add hatching. For details, see “Selecting entities for hatching” on page 150 in this chapter. Begin with step 2.
   - Select an area or boundary you want to add hatching. For details, see “Selecting areas for hatching” on page 151 in this chapter. Begin with step 2.
15.4.2 Selecting entities for hatching

You can add hatching to any entity that forms a closed boundary, for example, a circle or rectangle. You can assign hatching to a single entity or several entities at the same time.

Existing hatches can be modified.
Type HATCHEDIT to modify existing hatches.

To select entities for hatching

1. Do one of the following to choose Boundary Hatch:
   - On the ribbon, choose Draw > Boundary Hatch.
   - On the menu, choose Draw > Boundary Hatch.
   - On the Draw toolbar, click the Boundary Hatch tool.
   - Type bhatch and then press Enter.

2. From the Boundary Hatch dialog box, click the Boundary tab.

3. Under Island Detection Options, choose one of the following:
   - Nested Islands The outer entity and all its islands are considered for hatching.
   - Outer Only Only the outer entity and its outer island are considered for hatching.
   - Ignore Islands Only the outer entity is considered for hatching.

Nested islands (A), with outer island (B), and with ignore islands (C).
4. To keep any new entities that are created for drawing the boundary hatch, select the Retain Boundaries check box. Existing entities are always retained.

5. Click Select Entities.

6. In the drawing, click the entities to be hatched individually or by choosing a selection method from the prompt box, and then press Enter when done.

7. In the Boundary Hatch dialog box, click OK.

Hatch patterns are memory intensive:

*Because hatch patterns can take a considerable amount of time to draw and display, you may want to add hatching during the last steps of drawing creation or insert hatches on a separate layer that you can freeze as you continue to work on your drawing.*
15.4.3 Selecting areas for hatching

You can add hatching to an area enclosed by selected entities to form the hatch boundary. The hatch is formed in the enclosed area, not the entities themselves.

After CAD.direct Drafter draws the hatch, the entire hatch is treated as a single entity and it is either associative or independent of the hatch boundary entities.

- Existing hatches can be modified.
- Type HATCHEDIT to modify existing hatches.

To select an area for hatching

1. Do one of the following to choose Boundary Hatch:
   - On the ribbon, choose Draw > Boundary Hatch.
   - On the menu, choose Draw > Boundary Hatch.
   - On the Draw toolbar, click the Boundary Hatch tool.
   - Type bhatch and then press Enter.

2. From the Boundary Hatch dialog box, click the Boundary tab.

3. Under Island Detection Options, choose one of the following:
   - Nested Islands The outer entity and all its islands are considered for hatching.
   - Outer Only Only the outer entity and its outer island are considered for hatching.
   - Ignore Islands Only the outer entity is considered for hatching.

![Diagram of hatching examples](nested islands (A), with outer island (B), and with ignore islands (C).)
4. To keep any new entities that are created for drawing the boundary hatch, select the Retain Boundaries check box. Existing entities are always retained.

5. Specify the entities that you want made available for boundary hatching by doing one of the following:

   - All entities Select All Visible Entities to have all entities in the drawing considered when creating the boundary hatch.
   - Custom selection Define only specific areas to be considered when creating the boundary hatch, which can improve system performance if you are working with a complex drawing. Click Select Boundary Set. In the drawing, select the entities individually or by choosing a selection method from the prompt box, and then press Enter. The Current Selection Set option becomes selected automatically, which indicates that the entities you selected with the Select Boundary Set button will be considered when creating the boundary hatch.

   You don’t have to select entities again using the Select Boundary Set button: The Current Selection Set option uses the last set of entities you selected with the Select Boundary Set button.

6. In the Boundary Hatch dialog box, click Select Area.

7. In the drawing, click inside the closed perimeter of a boundary, not on the boundary itself. If desired, continue clicking inside additional closed perimeters.

8. To complete the selection, press Enter.

9. In the Boundary Hatch dialog box, click OK.

   A warning message displays if the number of entities selected exceeds the HPOBJWARNING system variable value. If the warning displays, to improve performance before continuing with hatch creation, select fewer entities, or if Select All Visible Entities is chosen, zoom in to have fewer entities visible in the drawing. Hatch patterns are memory intensive and can take a considerable amount of time to draw.
A. Opens the drawing area for selection of entities to be considered when creating the boundary hatch.
B. Choose to consider all visible entities when creating the boundary hatch.
C. Choose to use the entities you selected for the boundary set. (Becomes available after you click the Select Boundary Set button.)
D. Mark the check box to keep any new entities that are created to draw the boundary hatch. Existing entities are always retained.
E. (Display only) Indicates the boundary is created as a polyline.
F. Determines how hatching interacts with islands.
G. Opens the drawing area for selection of enclosed areas to be hatched.
6 Viewing your drawing

CAD.direct Drafter provides many ways to display and view your drawing. You can also change various display settings to speed up the display or printing of a drawing. This section explains how to:

• Navigate within a drawing by scrolling, panning, and rotating the view.
• Change the magnification of a drawing by zooming in and out.
• View a drawing using annotation scales.
• Choose visual styles.
• Work with multiple windows or views of a drawing.
• Control the display of elements to optimize performance when working with large or complex drawings.

6.1 Redrawing and regenerating a drawing

As you work on a drawing, visual elements may remain after the completion of a command. You can remove these elements by refreshing, or redrawing, the display.

To redraw (refresh) the current window display

Do one of the following to choose Redraw:

• On the ribbon, choose View > Redraw (in Navigate 2D).
• On the menu, choose View > Redraw.
• On the Zoom toolbar, click the Redraw tool.
• Type redraw and then press Enter.

Information about drawing entities is stored in a database as floating point values, ensuring a high level of precision. Sometimes a drawing must be recalculated, or regenerated, from the floating-point database to convert those values to the appropriate screen coordinates. This occurs automatically. You can also manually initiate a regeneration. When the drawing is regenerated, it is also redrawn.

To regenerate the current window, type regen in the command bar. If more than one window is displayed, type regenall to regenerate all the windows.
6.2 Moving around within a drawing

You can move the view of a drawing displayed in the current viewport by scrolling, panning, or rotating the view. Doing this changes the portion of the drawing you are viewing without changing the current magnification. Scrolling lets you move around in the drawing horizontally and vertically. Panning lets you move the drawing in any direction. Rotating lets you view your drawing from any angle.

You can also move to a different view using the Model and Layout tabs. For more details, see “Viewing drawings in paper space and model space” on page 452. For more details, see Viewing drawings in paper space and model space.

6.2.1 Using scroll bars

To assist you in navigating within a drawing, horizontal and vertical scroll bars are available in each drawing window. The size of the scroll box in relation to the scroll bar indicates the current level of drawing magnification. The position of the scroll box in relation to the scroll bar indicates the location of the center of the drawing in relation to the extents of the drawing (the smallest rectangle containing all the entities in the drawing).

To turn scroll bars on or off

Do one of the following to choose Scroll Bars:

- On the ribbon, choose View > Scroll Bars (in Display).
- On the menu, choose View > Display > Scroll Bars.
- Choose Tools > Options > Display tab, and select Show Scroll Bars.
- Type scrollbar, press Enter, and then select On, Off, or Toggle.

6.2.2 Panning a drawing

You can move the drawing in any direction using the Pan tool on the View toolbar. Panning shifts or slides the view of the drawing horizontally, vertically, or diagonally. The magnification of the drawing remains the same, as does its orientation in space. The only change is the portion of the drawing displayed.

*If you often pan (and zoom) to a certain area of a drawing, you can create and re-use a view using the View Manager. For details, see “Using named views” on page 246.*

Panning by specifying two points.

For precise panning, specify two points defining the magnitude and direction of the pan. The first point, or base point, indicates the starting point of the pan. The second point indicates the amount of pan displacement relative to the first point.
To pan by specifying two points

1. Do one of the following to choose Pan:
   - On the ribbon, choose View > Pan (in Navigate 2D).
   - On the menu, choose View > Pan > Pan.
   - On the View toolbar, click the Pan tool.
   - Type pan and then press Enter.

2. Specify the pan base point either by typing the coordinates or by specifying a point in the drawing window.

3. Specify the pan displacement point either by typing the coordinates or by specifying a point in the drawing window.

Panning in real time

By panning in real time, you control the pan at the same time you move your mouse.

Using real-time pan in large drawing files can be memory intensive:

*It may be helpful to set the `ZOOMDETAIL` system variable to a higher number to reduce the number of entities that display. For example, if the value is set to 10, only the 10th entity will display when panning and zooming in real-time.*
To pan in real time

1. Do one of the following to choose Real-Time Pan:
   - On the ribbon, choose View > Real-Time Pan (in Navigate 2D).
   - Choose View > Pan > Real-Time Pan.
   - On the Zoom toolbar, click the Real-Time Pan tool.
   - Type rtpan and then press Enter.

2. Click and hold the left mouse button.

3. Move the cursor in the direction you want to pan.

4. To stop panning, release the mouse button.

Use the mouse and keyboard shortcut:

*Hold down the right mouse button while simultaneously pressing and holding Ctrl + Shift to pan in real-time.*

*Panning using a mouse with a wheel:*

You can use the wheel of your mouse to help zoom in and out of a drawing.

The MBUTTONPAN system variable controls this feature.

To pan using a mouse with a wheel

- Press and hold the wheel, and then move the mouse in the direction you want to pan.

*Panning using the arrow keys*

To pan in small increments, use the arrow keys.

You can pan using the arrow keys if Use Up/Down Arrows for Command History Navigation is not marked on the Display tab in Tools > Options.

To pan using the arrow keys

- Press the up, down, right, or left arrow keys.
6.2.3 Orbiting the drawing in real time

CAD.direct Drafter allows you to orbit the drawing, or rotate the view, in real time. This allows you to view your model from any angle while in model space. You cannot rotate the view while in paper space.

Using 3D Orbit commands in large drawing files can be memory intensive.

*It may be helpful to set the ZOOMDETAIL system variable to a higher number to reduce the number of entities that display. For example, if the value is set to 10, only the 10th entity will display when panning and zooming in real-time.*

**To orbit the drawing**

1. Do one of the following to choose Constrained Orbit:
   - On the ribbon, choose View > Constrained Orbit (in Navigate 2D).
   - On the menu, choose View > 3D Orbit > Constrained Orbit.
   - On the 3D Orbit toolbar, click the Constrained Orbit tool.
   - Type 3dorbit and then press Enter.

2. Do one of the following:
   - Click and drag the left mouse button to orbit the drawing.
   - Choose Set to pick a different point on which to orbit, then click and drag the mouse to orbit the drawing.

3. To stop orbiting, release the mouse button.

Use a shortcut.

*Press and hold Shift while viewing a drawing, then click and drag the middle mouse button (wheel) to orbit the drawing.*

**To orbit the drawing using continuous motion**

1. Do one of the following to choose Continuous Orbit:
   - On the ribbon, choose View > Continuous Orbit (in Navigate 2D).
   - On the menu, choose View > 3D Orbit > Continuous Orbit.
   - On the 3D Orbit toolbar, click the Continuous Orbit tool.
   - Type 3dcorbit and then press Enter.
2. Do one of the following:
   
   • Click and drag the left mouse button to orbit the drawing.
   • Choose Set to pick a different point on which to orbit, then click and drag the mouse to orbit the drawing.

3. Release the mouse button. The view continues to orbit.

4. When finished, press Enter or Esc, or right-click the drawing.

You can orbit without locking any axis or choose a different axis to lock.

*Use the Free Orbit command to orbit the drawing without any axis locked. Use the Constrained X Orbit, Constrained Y Orbit, and Constrained Z Orbit commands to orbit the drawing while maintaining the chosen axis. You can also press Ctrl and use the right mouse button to rotate the view about the z-axis.*

### 6.3 Changing the magnification of your drawing

You can change the magnification of your drawing at any time by zooming. The cursor changes to a magnifying glass when a zoom tool is active. Zoom out to reduce the magnification so you can see more of the drawing, or zoom in to increase the magnification so you can see a portion of the drawing in greater detail. Changing the magnification of the drawing affects only the way the drawing is displayed; it has no effect on the dimensions of the entities in your drawing.

If you often zoom (and pan) to a certain area of a drawing, you can create and re-use a view using the View Manager.

*For details, see “Using named views” on page 246.*

If you cannot zoom in a layout viewport, the layout viewport may be locked.

*The scale and view do not change in model space while panning or zooming in a locked layout viewport. For more details, see “Modifying layout viewports” on page 460. For more details, see Modifying layout viewports.*
6.3.1 Understanding zoom

One of the easiest ways to change the magnification of the drawing is to zoom in or out by a preset increment. On the Zoom toolbar, the Zoom In tool () doubles the current magnification of the drawing. The Zoom Out tool () reduces the magnification of the drawing by half. The portion of the drawing located at the center of the current viewport remains centered on the screen as you zoom in and out.

![Zoom in.](image1)

![Zoom out.](image2)

6.3.2 Zooming in to an area using a window

You can create a window that defines the portion of the drawing to which you want to zoom.

**To zoom in to an area using a window**

1. Do one of the following to choose Zoom Window:
   - On the ribbon, choose View > Zoom Window (in Navigate 2D). On the menu, choose View > Zoom > Window.
   - On the Zoom toolbar, click the Zoom Window tool.
   - Type zoom and then press Enter.
2. Select one corner of the window around the area you want to magnify.
3. Specify the opposite corner of the window around the area you want to magnify.
6.3.3 Zooming in to one or more entities

You can zoom in to specific entities that you select. The window fills with the entities that you select.

To zoom in to one or more entities

1. Select one or more entities.

2. Do one of the following to choose Zoom Entity:
   - On the ribbon, choose View > Zoom Entity (in Navigate 2D). On the menu, choose View > Zoom > Entity.
   - On the Zoom toolbar, click the Zoom Entity tool.

6.3.4 Zooming in real time

By zooming in real time, you control the zoom at the same time you move your mouse.

To zoom in real time

1. Do one of the following to choose Real-Time Zoom:
   - On the ribbon, choose View > Real-Time Zoom (in Navigate 2D).
• On the menu, choose View > Zoom > Real-Time Zoom.
• On the Zoom toolbar, click the Real-Time Zoom tool.
• Type rtzoom and then press Enter.
• Simultaneously press and hold Ctrl + Shift.

2. Click and hold the left mouse button.

3. To zoom in, move the cursor up the screen; to zoom out, move the cursor down the screen.

4. To stop zooming, release the mouse button.

### 6.3.5 Zooming using a mouse with a wheel

Each rotation of the wheel away from you zooms out .8 times; each rotation toward you zooms in 1.25 times.

**To zoom using a mouse with a wheel**

- Rotate the wheel away from you to zoom in or toward you to zoom out.

Customize the mouse wheel:

*Settings for the mouse wheel can be customized to accommodate your work style using the ZOOMWHEEL (wheel direction), ZOOMPERCENT (display accuracy for curved entities), and ZOOMFACTOR (zoom factor for the wheel) system variables.*

### 6.3.6 Displaying the previous view of a drawing

After you zoom in or pan to view a portion of your drawing in greater detail, you may want to restore the previous view to see the entire drawing.

**To display the previous view of a drawing**

Do one of the following to choose Zoom Previous:

- On the ribbon, choose View > Zoom Previous (in Navigate 2D).
- On the menu, choose View > Zoom > Previous.
- On the Zoom toolbar, click the Zoom Previous tool.

Selecting this tool repeatedly steps back through up to 25 successive zoomed or panned views.
6.3.7 Zooming to a specific scale

You can increase or decrease the magnification of your view by a precise scale factor measured relative to the overall size of the drawing or in relation to the current display. When you change the magnification factor, the portion of the drawing located at the center of the current viewport remains centered on the screen.

To change the magnification of the view relative to the overall size of the drawing, type a number representing the magnification scale factor. For example, if you type a scale factor of 2, the drawing appears at twice its original size. If you type a magnification factor of .5, the drawing appears at half its original size.

You can also change the magnification of the drawing relative to its current magnification by adding an x after the magnification scale factor. For example, if you type a scale factor of 2x, the drawing changes to twice its current size. If you type a magnification factor of .5x, the drawing changes to half its current size.

To zoom to a specific scale relative to the current display

1. Do one of the following to choose Zoom In:
   - On the ribbon, choose View > Zoom In (in Navigate 2D).
   - On the menu, choose View > Zoom > Zoom In.
   - On the Zoom toolbar, click the Zoom In tool.
   - Type zoom and then press Enter.
2. Type the scale factor, followed by an x (such as 2x).
3. Press Enter.

6.3.8 Combining zooming and panning

You can specify the point you want at the center of the view when you change the drawing magnification. You can specify the point you want at the lower left of the view when you change the magnification of the drawing with the Zoom Left tool ( ) on the Zoom toolbar. With the exception of the Zoom Window tool, the other zoom tools zoom in or out from the center of the current view.

To change the center of the current view

1. Do one of the following to choose Zoom Center:
   - On the ribbon, choose View > Zoom Center (in Navigate 2D). On the menu, choose View > Zoom > Center.
   - On the Zoom toolbar, click the Zoom Center tool.
   - Type zoom, press Enter, and then in the prompt box, choose Center.
2. Select the point you want located at the center of the new view.

3. Specify the zoom scale factor or the height of the drawing in drawing units.

6.3.9 Displaying the entire drawing

There are two main ways you can zoom to display the entire drawing:

- Zoom all — Displays the entire drawing. If you have drawn any entities outside the defined limits of the drawing, the extents of the drawing are displayed. If all entities are within the limits of the drawing, the drawing is displayed all the way to the drawing limits.

- Zoom extents — Displays the drawing to include all entities (to its extents), making the image fill the display to the greatest possible magnification.

To display the entire drawing

Do one of the following to choose Zoom All:

- On the ribbon, choose View > Zoom All (in Navigate 2D).
- On the menu, choose View > Zoom > All.
- On the Zoom toolbar, click the Zoom All tool.
- Or, to display the drawing to its extents, do one of the following to choose Zoom Extents:
  - On the ribbon, choose View > Zoom Extents (in Navigate 2D).
  - On the menu, choose View > Zoom > Extents.
  - On the Zoom toolbar, click the Zoom Extents tool.
6.4 Changing the view of annotative entities

If your drawing contains annotative entities, such as text and dimensions, you can change the scale, or size, of these entities by setting the annotation scale.

Entities that can be annotative include text, multiline text, tolerances, dimensions, leaders, multileaders, attributes, hatches, and blocks. If Annotative is set to Yes for one of these types of entities and you change the annotation scale, the entity will display at a different scale than other entities in the drawing. For example, if you set the annotation scale to 1:2, all annotative entities will display at that scale (if Automatic Annotation is turned on) or only those annotative entities that support the 1:2 scale will display at that scale (if Automatic Annotation is turned off).

Text styles, dimension styles, and multileader styles also can be annotative, so text, dimensions, or multileaders assigned an annotative style can also be affected.

6.4.1 Turning on scaling of annotative entities

Annotation scaling allows you to control certain entities, so their size will consistently display when a drawing is displayed or printed at different scales. You don’t have to use annotation scaling, but it is a convenient way to control the scaling of the following entities: text, tolerances, dimensions, leaders, multileaders, attributes, hatches, and blocks.

Text styles, dimension styles, and multileader styles can also use annotation scaling. Text, dimension, and multileader entities that are assigned an annotative style will have annotation scaling turned on by default. For details about text styles, see “Working with text styles” on page 346. For details about dimensions styles, see “Using dimension styles and variables” on page 382. CAD.direct Drafter supports the display of multileaders and their styles, but not editing.)
To turn annotation scaling on or off for one or more entities

1. Do one of the following to choose Properties:
   - On the ribbon, choose View > Properties (in Display).
   - On the menu, choose Modify > Properties.
   - On the Modify toolbar, click the Properties tool.
   - Type entprop and then press Enter.
   - Press Ctrl +1.

   The Properties pane displays.

2. Select the desired entities.

3. In Annotative, select one of the following:
   - Yes - Entities display according to the currently set annotation scale.
   - No - Entities are not affected by the currently set annotation scale.

To assign a scale to all annotative entities automatically

1. On the status bar, turn on automatic annotation by double-clicking Automatic Annotation On/Off.

2. On the status bar, click Annotations Scales List.

3. Choose the annotation scale.

   All annotative entities (all entities with Annotative set to Yes) will be assigned the selected annotation scale.

To add the current annotation scale to one more entities

1. Do one of the following to choose Add Current Scale:
   - On the ribbon, choose Annotate > Add Current Scale (in Annotation Scaling).
   - On the menu, choose Modify > Annotative Scale > Add Current Scale.
   - Type aiobjectscaleadd and then press Enter.

2. Select the desired entities.
To remove the current annotation scale from one more entities

Do one of the following to choose Delete Current Scale:

• On the ribbon, choose Annotate > Delete Current Scale (in Annotation Scaling).
• On the menu, choose Modify > Annotative Scale > Delete Current Scale.
• Type aiobjectscaleremove and then press Enter. 2 Select the desired entities.

To add or remove annotation scales for one or more entities

1. Do one of the following to choose Add/Delete Scales:

• On the ribbon, choose Annotate > Add/Delete Scales (in Annotation Scaling).
• On the menu, choose Modify > Annotative Scale > Add/Delete Scales.
• Type object scale and then press Enter.

2. Select the desired entities.

The Annotation Scales dialog box displays a list of annotation scales that are assigned to the entities.

3. Do one of the following:

• Click Add to select a scale and it to all selected entities.
• Select a scale and click Delete to remove it from all selected entities.

4. Click OK.
6.4.2 Changing the scale of annotative entities

The annotation scale of a drawing determines the size of annotative entities without changing the scale of other, non-annotative entities.

If automatic annotation is turned on, changing the annotation scale changes the scale, or size, of all entities that have annotation scaling turned on. If automatic annotation is turned off, the size is changed only for annotative entities that are assigned the selected annotation scale.

**To set the annotation scale**

1. On the status bar, click Annotations Scales List.
2. Choose the annotation scale.

All enabled annotative entities that have the selected scale assigned to them will display at the new scale.
To assign and set the scale automatically for all annotative entities

1. On the status bar, turn on automatic annotation by double-clicking Automatic Annotation On/Off.

2. On the status bar, click Annotations Scales List. Choose the annotation scale.

All enabled annotative entities (all entities with Annotative set to Yes) will be assigned the selected annotation scale and display at that scale.

*Use a system variable.*

*Automatic annotation can also be set using the ANNOAUTOSCALE system variable.*

6.4.3 Displaying and hiding certain annotative entities

An annotative entity can be assigned numerous scales that are used for viewing and printing. By default, if an annotative entity is not assigned the current annotation scale, it still displays but at the default scale. Alternately, you can hide annotative entities that are not assigned the current annotation scale.

You can set the display status for the Model tab and for each Layout tab.

**To display or hide annotative entities**

1. Click the desired Model tab or Layout tab.

2. On the status bar, double-click Annotation Visibility On/Off.

6.4.4 Returning scale views of annotative entities to their default positions

Each scale view of an enabled annotative entity can be moved to different locations using grip editing. If various scale views of an annotative entity have been repositioned, you can easily return those scale views to their original basepoint.

**To return scale views of annotative entities to their default positions**

1. Do one of the following to choose Synchronize Multiple-Scale Positions:
   - On the ribbon, choose Annotate > Sync Scale Positions (in Annotation Scaling).
   - On the menu, choose Modify > Annotative Scale > Synchronize Multiple-Scale Positions.
   - Type annoreset and then press Enter.

2. Select the desired entities.
6.5 Displaying a drawing with a visual style

Visual styles allow you to easily view your drawing using different methods according to your needs. For example, if you’re just starting a new drawing, you might want to view it using a wireframe mode, which looks similar to a model made out of wire and displays faster than more complex visual styles.

The following visual styles are available:

- 2D Wireframe — Drawing displays in two dimensions with all lines drawn at the edge of entities.
- 3D Wireframe — Drawing displays in three dimensions with all lines drawn at the edge of entities.
- 3D Hidden — Drawing displays in three dimensions with all lines drawn at the edge of entities except those behind surfaces.
- Realistic — Drawing displays in three dimensions with surfaces filled with assigned materials.
- Conceptual — Drawing displays in three dimensions with surfaces filled with assigned materials and more conceptual detail.

The more detail that displays on the screen, the greater the impact on performance.

To change the visual style

1. Do one of the following:
   - On the ribbon, choose View and in Visual Styles, make your selection.
   - Choose View > Visual Styles, then make your selection.
   - On the View toolbar, click the 2D Wireframe tool.
   - On the View toolbar, click the 3D Wireframe tool.
   - On the View toolbar, click the 3D Hidden tool.
   - On the View toolbar, click the Realistic tool.
   - On the View toolbar, click the Conceptual tool.
   - Type vscurrent, press Enter, then make your selection.
6.6 Displaying multiple views

When you begin a new drawing, it is displayed in a single window. You can view the drawing in a second window, or you can divide one window into multiple windows. You can also open and display multiple drawings.

6.6.1 Working with multiple views of a single drawing

You can open and work with several views of the same drawing simultaneously. There are two methods for dividing the current drawing into multiple views:

• Open a new window of the open drawing.
• Divide the current window into multiple views.

After you divide a single window into multiple windows, you can control each window separately. For example, you can zoom or pan in one window without affecting the display in any of the other windows. You can control the grid, snap, and view orientation separately for each window. You can restore named views in individual windows, draw from one window to another, and name window configurations individually so you can reuse them later.

As you draw, any changes you make in one window are immediately visible in the others. You can switch from one window to another at any time, even in the middle of a command, by clicking the window’s title bar.

6.6.2 Opening a new window of the same drawing

You can open additional windows to create more than one view of a drawing. To open a new window, choose Window > New Window. After you open a new window, you can change its display without affecting any of the other windows.

When you open more than one window for a single drawing, each window is assigned a unique number (for example, mydrawing:1, mydrawing:2, and so on). If your current window is maximized, you can switch to another open window by selecting its name from the bottom of the Window menu.

The names of other open drawings appear at the bottom of the Window menu. You can also use the Cascade, Tile Horizontally, and Tile Vertically commands to arrange all the open windows and drawings. To arrange all the windows and drawings into a stack of identically sized windows, choose Window > Cascade. Arranging windows and drawings in this way makes it easy to see the title bar for each window.

To arrange all the windows and drawings horizontally so they are placed in order from top to bottom, choose Window > Tile Horizontally. Arranging windows and drawings in this way displays each open window. The windows are resized to fit within the available space.
To arrange all the windows and drawings vertically so they are placed side by side, choose Window > Tile Vertically. Arranging windows and drawings in this way displays each open window. The windows are resized to fit within the available space.

To manage all the windows from one dialog box, choose Window > Windows to open the Windows dialog box. CAD.direct Drafter uses the commands in the following table to control its windows.

<table>
<thead>
<tr>
<th>Command</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>vports</td>
<td>Splits the current window into two, three, or four tiled windows.</td>
</tr>
<tr>
<td>wcascade</td>
<td>Cascades (overlaps) all open windows.</td>
</tr>
<tr>
<td>wclose</td>
<td>Closes the current window.</td>
</tr>
<tr>
<td>wclosel</td>
<td>Closes all windows; also closes all drawings.</td>
</tr>
<tr>
<td>wttile</td>
<td>Tiles all windows horizontally.</td>
</tr>
<tr>
<td>warrange</td>
<td>Arranges window icons.</td>
</tr>
<tr>
<td>wopen</td>
<td>Opens another window of the current drawing.</td>
</tr>
<tr>
<td>wvtile</td>
<td>Tiles all windows vertically.</td>
</tr>
</tbody>
</table>

### 6.6.3 Dividing the current window into multiple views

You can divide a single drawing window into multiple tiled windows (called view-ports) on the Model tab. You can control the number of windows created and the arrangement of the windows. You can also save and restore named window configurations and display a list of the current and saved window configurations.

While working in a viewport, use the Maximize Viewport command to enlarge the view to full size, allowing you to easily work on the geometry in that view. When done, use the Minimize Viewport command to switch back to the original scale and center point of the viewport.
To create multiple views

1. Do one of the following to choose Viewports:
   - On the ribbon, choose View > Viewports (in Model Viewports).
   - On the menu, choose View > Viewports.
   - On the View toolbar, click the Viewports tool.
   - Type viewports and then press Enter.

2. In the prompt box, choose Create 2 Viewports, Create 3 Viewports, or Create 4 Viewports.

3. In the prompt box, choose the viewport orientation.

You can divide a drawing window into two windows arranged vertically (A) or horizontally (B); three windows arranged left (C), right (D), above (E), below (F), vertically (G), or horizontally (H); or four tiled windows (I).
To join two views

1. Do one of the following to choose Viewports:
   - On the ribbon, choose View > Viewports (in Model Viewports).
   - On the menu, choose View > Viewports.
   - On the View toolbar, click the Viewports tool.
   - Type viewports and then press Enter.
2. In the prompt box, choose Join.
3. Click anywhere inside the window you want to keep.
4. Click anywhere inside the adjacent window you want to join to the first window.
5. Press Enter.

To maximize the current view

Do one of the following:
   - On the ribbon, choose View > Maximize Viewport (in Model Viewports).
   - On the menu, choose View > Viewports > Maximize Viewport.
   - On the status bar, click Maximize Viewport.
   - Type vpmax and then press Enter.

The viewport is enlarged.

To minimize the current view (if it is maximized)

Do one of the following:
   - On the ribbon, choose View > Minimize Viewport (in Model Viewports).
   - On the menu, choose View > Viewports > Minimize Viewport.
   - On the status bar, click Minimize Viewport.
   - Type vpmin and then press Enter.

The viewport returns to its original scale and center point.
6.6.4 Saving window configurations

If you have divided the drawing window into multiple views, you can save the current window arrangement so that you can recall it to the screen later. The number and placement of the windows are saved exactly as they are currently displayed. The settings for each window are also saved.

To name and save a window configuration

1. Do one of the following to choose Viewports:
   - On the ribbon, choose View > Viewports (in Model Viewports).
   - On the menu, choose View > Viewports.
   - On the View toolbar, click the Viewports tool.
   - Type viewports and then press Enter.
2. In the prompt box, choose Save.
3. Type a configuration name, and then press Enter.

The name can be up to 255 characters in length and can contain letters, numbers, the dollar sign ($), hyphen (-), and underscore (_), or any combination.

To restore a named window configuration

1. Do one of the following to choose Viewports:
   - On the ribbon, choose View > Viewports (in Model Viewports).
   - On the menu, choose View > Viewports.
   - On the View toolbar, click the Viewports tool.
   - Type viewports and then press Enter.
2. In the prompt box, choose Restore.
3. Type the name of the window configuration you want to restore.

6.6.5 Working with multiple drawings

With the multiple-document interface (MDI) feature, you can open more than one drawing inside of CAD.direct Drafter. Because you can open and work on several drawings at one time, you can copy, cut, or paste an entity from one drawing to another.
Each drawing appears in a drawing window, which has the following advantages:

- You can see two or more drawings side by side.
- You can easily copy entities from one drawing to another.
- Using the CAD.direct Drafter Explorer, you can copy such elements as layers, linetypes, and text styles from one drawing to another.
- Like viewports on the Model tab, you can tile or overlap drawing windows; unlike viewports on the Model tab, drawing windows maximize or reduce to an icon.

Each drawing window that you open and work on retains in the Prompt History log all the commands that you perform, but the command line does not indicate when you have switched windows.

When you work with more than one drawing open in its own window, you can easily move, cut, copy, and paste in between drawings. If you move an entity from one window to another and then want to undo this action, you must undo it in both drawings for it to take effect. If you copy an entity from one window to another and then want to undo that action, you must undo it from the drawing into which you copied the entity. If you cut and paste an entity and then want to undo that action, you must undo it in both drawings.
6.7 Controlling visual elements

The number of entities in your drawing and the complexity of the drawing affect how quickly CAD.direct Drafter can process commands and display your drawing. You can improve overall program performance by turning off the display of certain visual elements, such as solid fills and text, while you work on the drawing. When you are ready to print your drawing, turn on the display of these elements so your drawing prints the way you want.

You can also improve performance by turning off entity-selection highlighting, turning off the display of marker blips created when you select locations in the drawing, and by turning off the display of lineweights.

6.7.1 Displaying solid fills

You can reduce the time it takes to display or print a drawing by turning off the display of solid fill. When solid fills are turned off, all filled entities, such as wide polylines and planes, display and print as outlines. When you turn solid fills on or off, you must redraw the drawing before the change is displayed.

A check mark appears next to the Fill command on the Settings menu when it is turned on.

To turn the display of solid fills on or off

1. Do one of the following to choose Fill:
   • On the menu, choose View > Display > Fill.
   • On the Settings toolbar, click the Fill tool.
   • Type fill and then press Enter.
2. Choose View > Redraw.
6.7.2 Displaying quick text

Text entities require a considerable amount of time to display and print. You can reduce the time it takes to display or print a drawing by enabling quick text. For example, if you’re doing a preliminary check print of a drawing, you may want to turn quick text on to speed up printing. When quick text is enabled, text entities are replaced by rectangular boxes that indicate the outline of the area occupied by the text. When you turn quick text on or off, you must regenerate the drawing before the change is displayed.

To turn the display of quick text on and off

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type qtext, press Enter, and then in the prompt box, choose On or Off.
2. Click the Display tab.
3. Under Change Settings For, click Display.
4. Select or clear the Enable Quick Text check box.
5. Click OK.
6. To regenerate your drawing, do one of the following to choose Regen:
   - On the ribbon, choose View > Regen.
   - On the menu, choose View > Regen.
   - On the View toolbar, click the Regen tool.
   - Type regen and then press Enter.
6.7.3 Displaying highlighting

You can improve overall program performance by turning highlighting off. When you select entities to modify, the program highlights them using a dashed linetype. This highlight disappears when you finish modifying the entities or when the entities are cleared. Sometimes highlighting entities can take a considerable amount of time.

To turn highlighting on and off

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type highlight, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.

3 Under Change Settings For, click Display.

4 Select or clear the Highlight Item When Selected check box.

5 Click OK.
6.7.4 Displaying blips

You can turn blips off. They are the temporary markers that appear on the screen when you select an entity or location. Blips are visible only until you redraw the drawing. You cannot select blips; they are used only for reference and never print.

**To turn the display of blips on and off**

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - Type blipmode, press Enter, and then in the prompt box, choose On or Off.
2. Click the Display tab.
3. Under Change Settings For, click Display.
4. Select or clear the Show Marker Blips check box.
5. Click OK.

6.7.5 Displaying lineweights

You can reduce the time it takes to display a drawing by turning off the display of lineweights. When you turn off lineweights, all entities display as outlines.

You can also specify a lineweight scale. Specify a smaller scale to display thinner lines; specify a larger scale to display thicker lines. For example, a scale factor of 0.5 would display a .80 millimeter lineweight as .40 millimeter; a scale factor of 2 would increase the same lineweight to display at 1.6 millimeters. This can help you differentiate various lineweights that display in a drawing. Adjusting the lineweight display scale affects how
the lineweights appear on your screen, not how they appear when printed.

*Lineweight scale can affect performance.*

*Setting the lineweight scale too high may result in slower system performance.*

*You can also adjust the units for measuring lineweights, and the default lineweight.*

**To control the display of lineweights**

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.
   - Type lweight and then press Enter.
2. Click the Display tab.
3. Under Change Settings For, click Lineweights.
4. Select or clear Display Lineweights.
5. In Units for Listing, choose Millimeters or Inches.
6. In Default, select the lineweight assigned to layers and entities that use the Default lineweight.
7. In Adjust Display Scale, move the slider to the scale you want. By default, the slider begins at 1.00.
8. Click OK.

Use a shortcut.

*To turn the display of lineweights on or off, use the LWDISPLAY system variable or double-click the word LWT on the status bar.*

You can turn lineweights on or off when you print. For details, see “Specifying print options specifically for layouts” on page 470.
7. Working with coordinates

For accuracy in a drawing, you can locate specific points by entering coordinates as you draw or modify entities. When you create two-dimensional entities, you enter two-dimensional coordinates; for three-dimensional entities, you specify three-dimensional coordinates.

You can also specify coordinates in relation to other known locations or entities in a drawing. In particular, when you work in three-dimensional drawings, it is often easier to specify coordinates in relation to a two-dimensional working plane, called a user coordinate system (UCS).

This section explains how to work with coordinates, including how to:

- Use two-dimensional and three-dimensional coordinate systems.
- Specify absolute and relative coordinates.
- Specify polar, spherical, and cylindrical coordinates.
- Define and manipulate user coordinate systems.

7.1 Using Cartesian coordinates

Many commands in CAD.direct Drafter require that you specify points as you draw or modify entities. You can do so by selecting points with the mouse or by typing coordinate values in the command bar. The program locates points in a drawing using a Cartesian coordinate system.

7.1.1 Understanding how coordinate systems work

The Cartesian coordinate system uses three perpendicular axes — x, y, and z — to specify points in three-dimensional space. Every location in a drawing can be represented as a point relative to a 0,0,0 coordinate point, referred to as the origin. To draw a two-dimensional entity, you specify horizontal coordinate positions along the x-axis and vertical coordinate positions along the y-axis. Thus, every point on a plane can be represented as a coordinate pair composed of an x-coordinate and a y-coordinate. Positive coordinates are located above and to the right of the origin; negative coordinates are located to the left and below the origin.
When you work in two dimensions, your need to enter only the x- and y-coordinates; the program assumes that the z-axis value is always the current elevation. When you work in three dimensions, however, you must also specify the z-axis value. When you look at a plan view of your drawing (a view from above, looking down), the z-axis extends straight up out of the screen at a 90-degree angle to the xy plane. Positive coordinates are located above the xy plane, and negative coordinates are below the plane.

All CAD.direct Drafter drawings use a fixed coordinate system, called the World Coordinate System (WCS), and every point in a drawing has a specific x,y,z-coordinate in the WCS. You can also define arbitrary coordinate systems located anywhere in three-dimensional space. These are called user coordinate systems and can be located any-where in the WCS and oriented in any direction.

You can create as many user coordinate systems as you want, saving or redefining them to help you construct three-dimensional entities. By defining a UCS within the WCS, you can simplify the creation of most three-di-
mensional entities into combinations of two-dimensional entities.
To help you keep your bearings in the current coordinate system, the program displays a coordinate system icon. When you begin a new drawing, you are automatically in the WCS, indicated by the letter W in the icon. When you display a drawing in plain view, you see the coordinate system icon from the top, with the z-axis directed straight toward you. When you display a three-dimensional drawing in a view other than plan view, the coordinate system icon changes to reflect your new viewpoint.

The visible portions of the axes are the positive directions.

*The invisible portions are the negative directions.*

The CAD.direct Drafter UCS icon looks different from the UCS icon in AutoCAD, because it presents more information. Three colors represent the three axes, making it easier for you to recognize the orientation in three-dimensional space:

- x-axis: red
- y-axis: green
- z-axis: blue

If you prefer a single color for the cursor and UCS icon, you can make that change with the config or options command.
7.1.2 Understanding how coordinates display

The current position of the cursor is displayed as x,y,z-coordinates in the status bar and, by default, updates dynamically as you move the cursor. You can toggle the coordinate display to static mode by pressing F6, so that it updates only when you select a point in the drawing.

You can also change the coordinate display to a different dynamic mode that shows the distance and angle (rather than x,y,z-coordinates) when the program displays a rubber-band line. To do this, choose Tools > Drawing Settings and select the Display tab. Under Coordinate Display, select the option for Coordinates In Polar Form For Distance And Angle Selection.

You can control the coordinate display from the Drawing Settings dialog box.
7.1.3 Finding the coordinates of a point

To find the x,y,z-coordinates for a point on an entity, such as the endpoint of a line, select an appropriate entity snap (such as Endpoint) before selecting the entity. If you have no entity snaps set, the x,y-coordinates of the point you specified is displayed, with the z-coordinate equal to the current elevation.

To find the coordinate of a point in the drawing

1. Do one of the following to choose ID Coordinates:
   - On the ribbon, choose Tools > ID Coordinate (in Inquiry).
   - On the menu, choose Tools > Inquiry > ID Coordinates.
   - On the Inquiry toolbar, click the ID Coordinates tool.
   - Type idpoint and then press Enter.
2. Select the point for which you want to find the coordinates.

If the command bar is activated, the x,y,z-coordinates for the point you selected display in the command bar.

If the command bar is not activated, the Prompt History window displays, showing the x,y,z-coordinates for the point you selected.

7.2 Using two-dimensional coordinates

When working in two dimensions, you specify points on the xy plane. You can specify any point as an absolute coordinate (or Cartesian coordinate), using the exact x-coordinate and y-coordinate locations in relation to the origin (the 0,0 coordinate point at which the two axes intersect), or as a relative coordinate in relation to the previous point. You can also specify points using relative or absolute polar coordinates, which locate a point using a distance and an angle.

7.2.1 Entering absolute Cartesian coordinates

To enter absolute Cartesian coordinates, type the coordinate location of the point in the command bar. For example, to use absolute Cartesian coordinates to draw a line from the origin (0,0) to a point of 3 units to the right and 1 unit above the origin, start the Line command and respond to the prompts as follows:
When using absolute Cartesian coordinates, you need to know the exact point locations for anything you draw. For instance, to use absolute Cartesian coordinates to draw an 8.5-unit square with its lower left corner at 4,5, you must determine that the upper left corner is at coordinate 4,13.5, the upper right corner at 12.5,13.5, and the lower right corner at 12.5,5.

7.2.2 Entering relative Cartesian coordinates

Another, simpler method is to use relative Cartesian coordinates: you specify a location in the drawing by determining its position relative to the last coordinate you specified. To use relative Cartesian coordinates, type the coordinate values in the command bar, preceded by the at symbol (@). The coordinate pair following the @ symbol represents the distance along the x-axis and the y-axis to the next point. For example, to draw an 8.5-unit square with its lower left corner at 4,5 using relative Cartesian coordinates, start the Line command, and then respond to the prompts as follows:

Start of line: 4,5

Angle • Length • <Endpoint>: @8.5,0

Angle • Length • Follow • Undo • <Endpoint>: @0,8.5
The first relative coordinate (@8.5,0) locates the new point 8.5 units to the right (along the x-axis) from the previous point of 4,5; the second relative coordinate (@0,8.5) locates the next point 8.5 units above (along the y-axis) the previous point, and so on. Entering C (for Close) draws the final line segment back to the first point specified when you started the Line command.

7.2.3 Entering polar coordinates

Using relative polar coordinates makes drawing a square tilted at a 45-degree angle a simple task. Polar coordinates base the location of a point on a distance and angle from either the origin (absolute coordinate) or from the previous point (relative coordinate).

To specify polar coordinates, type a distance and an angle, separated by the open angle bracket (<). For example, to use relative polar coordinates to specify a point 1 unit away from the previous point and at an angle of 45 degrees, type @1<45.

To draw the square from the example in the previous section, “Entering relative Cartesian coordinates,” this time tilted at a 45-degree angle, start the Line command, and then respond to the prompts as follows:

Start of line: 4,5

Angle • Length • <Endpoint>: @8.5<45
Angle • Length • <Endpoint>: @8.5<45
Angle • Length • Follow • Close • Undo • <Endpoint>: @8.5<225
Angle • Length • Follow • Close • Undo • <Endpoint>: C

Drawing a tilted square using the relative polar coordinates method; enter C to close.

This example assumes the program’s default settings.

Like all examples in this guide, the example assumes default settings: Angles increase counterclockwise and decrease clockwise. An angle of 315 degrees is the same as -45 degrees.
7.3 Using three-dimensional coordinates

Specifying coordinates in three-dimensional space is similar to working in two dimensions, except that you also use the z-axis to locate coordinates. Three-dimensional coordinates are represented in the format x,y,z (for example, 2,3,6).

7.3.1 Using the right-hand rule

To visualize how CAD.direct Drafter works with three-dimensional space, use a technique known as the right-hand rule. Hold up your right hand in a loose fist with your palm facing you. Extend your thumb in the direction of the positive x-axis and your index finger upward in the direction of the positive y-axis. Then extend your middle finger straight toward you in the direction of the z-axis. These three fingers are now pointing in the positive x, y, and z directions, respectively.

You can also use the right-hand rule to determine the positive rotation direction. Point your thumb in the positive direction of the axis about which you want to rotate, and then curl the rest of your fingers toward your palm. These fingers are curling in the positive rotation direction.

The right-hand rule helps you determine the positive direction of the x-, y-, and z-axes and the positive rotation direction.
7.3.2 Entering x,y,z-coordinates

When working in three dimensions, you can specify x,y,z-coordinates as absolute distances in relation to the origin (the 0,0,0 coordinate point at which the three axes intersect) or as relative coordinates based on the last point selected. For example, to specify a point of 3 units along the positive x-axis, 4 units along the positive y-axis, and 2 units along the positive z-axis, specify the coordinate 3,4,2.

7.3.3 Entering spherical coordinates

When working in three-dimensional space, you can use spherical coordinates to specify a three-dimensional point by entering its distance from either the origin (absolute distance) or the last point (relative distance), along with its angle in the xy plane and its angle up from the xy plane. In spherical format, you separate each angle with the open angle bracket (<).

Thus, to draw a line from the origin to a point of 10.2500 drawing units away, at an angle of 45 degrees from the x-axis and 35 degrees from the xy plane, start the Line command, and then respond to the prompts as follows:

*Start of line: 0,0,0*

*Angle • Length • <Endpoint>: 10.2500<45<35*

When you draw a line from a start point (A) to an endpoint (B) using spherical coordinates, you specify its length (C, in this case 10.2500 units), the angle in the xy plane (D, in this case 45 degrees), and the angle from the xy plane (E, in this case 35 degrees).
7.3.4 Entering cylindrical coordinates

When working in three-dimensional space, you can also use cylindrical coordinates to specify a three-dimensional point. You specify a point by entering its distance from either the origin (absolute distance) or the last point (relative distance), its angle in the xy plane, and its z-coordinate value.

In cylindrical format, you separate the distance and angle with the open angle bracket (<) and separate the angle and z value with a comma. For example, to draw a line from the last point to a point of 7.4750 units away, at an angle of 27 degrees from the x-axis in the xy plane and 3 units up in the z direction, start the Line command, and then respond to the prompts as follows:

Start of line: (select point A)

Angle • Length • <Endpoint>: @7.4750<27,3

When you draw a line from a start point (A) to an endpoint (B) using cylindrical coordinates, you specify its length (C, in this case 7.4750), the angle in the xy plane (D, in this case 27 degrees), and the distance in the z direction (E, in this case 3 units).
7.4 Using xyz point filters

Point filters provide a method of locating a point in a drawing relative to another point without specifying the entire coordinate. Using a point filter, you can enter partial coordinates, and then the program prompts you for the remaining coordinate information. To use xyz point filters, respond to the prompt for a coordinate with a filter in the following form:

```
.coordinate
```

where *coordinate* is one or more of the letters x, y, and z. The program then prompts you for the filtered coordinate(s). For example, if you type .xy, the program prompts you to select a point whose xy-coordinate you want, and then prompts you for the z-coordinate. The filters .x, .y, .z, .xy, .xz, and .yz are all valid filters.

### 7.4.1 Using point filters in two dimensions

You can use point filters when you work in two dimensions to locate points in relation to existing entities. For example, to draw a circle centered in a rectangle, start the Circle command, and then respond to the prompts as follows:

```
2Point • 3Point • RadTanTan • Arc • Multiple • <Center of circle>: .y
Select Y of: mid
Snap to midpoint of: (select the left side of the rectangle)
Still need XZ of: mid
Snap to midpoint of: (select top of the rectangle)
Diameter • <Radius>: (specify radius of circle)
```

![Diagram of a circle centered in a rectangle with point filters used to locate the center](image)
7.4.2 Using point filters in three dimensions

You can use point filters when you work in three-dimensional space to locate points in two dimensions and then specify the z-coordinate as the elevation above the xy plane. For example, to begin drawing a line from a point with a z-coordinate of 3 units above the center of a circle, insert the circle, and then start the Line command and respond to the prompts as follows:

ENTER to use last point • Follow • <Start of line>: .xy

Select XY of: cen

Snap to centerpoint of: (select a point on the circle)

Still need Z of: 3 (locates the starting point 3 units above the center of the circle)

Length of line: (specify the length of the line)

You can use point filters to draw a line by first selecting a point in the xy plane (A), specifying the z-coordinate (B), and then specifying the length of the line (C).
7.5 Defining user coordinate systems

A user coordinate system (UCS) is a Cartesian coordinate system with origins and orientation defined by the user.

7.5.1 Understanding user coordinate systems

When working in three-dimensional space, you can define a UCS with its own 0,0,0 origin and orientation separate from the WCS. You can create as many user coordinate systems as you want, and then save and recall them as you need them to simplify construction of three-dimensional entities.

For example, you can create a separate UCS for each side of a building. Then, by switching to the UCS for the east side of the building, you can draw the windows on that side by specifying only their x- and y-coordinates. When you create one or more user coordinate systems, the coordinate entry is based on the current UCS.

UCS aligned with the front wall of the house.
7.5.2 Defining a user coordinate system

To define a UCS, you can use any of the following methods:

- Specify a new origin and points on the positive x- and y-axes.
- Specify a new origin and point on the positive z-axis.
- Align the UCS with an existing entity.
- Rotate the current UCS around any of its axes.
- Align the UCS with its z-axis parallel to the current viewing direction.
- Align the UCS xy plane perpendicular to the current view.

When you define a new UCS, the UCS icon changes to indicate the origin and orientation of the new UCS.

To define a UCS by specifying a new origin and points on the positive x- and y-axes

1. Do one of the following to choose User Coordinate Systems:
   - On the ribbon, choose Draw > User Coordinate Systems or choose View > User Coordinate Systems.
   - On the menu, choose Tools > User Coordinate Systems > Select a Predefined UCS.
   - On the UCS toolbar, click the Select a Predefined UCS tool.
   - Type setucs and then press Enter.
2. In the User Coordinate Systems dialog box, click Explore UCSs.
3. In CAD.direct Drafter Explorer, be sure that Coordinate Systems is selected, and click the New Item tool.
4. In the prompt box, choose 3 Point.
5. Select the new origin.
6. Select a point on the positive x-axis.
7. Select a point in the positive y direction.
8. In the CAD.direct Drafter Explorer - Coordinate Systems dialog box, type the name for the new UCS, and then close the dialog box.
Define the new UCS by selecting the origin (A), a point on the positive x-axis (B), and a point in the positive y direction (C).

7.5.3 Using a preset user coordinate system

CAD.direct Drafter lets you select a preset UCS. The six planes defined by looking along the x, y, z-axes align the UCS with the top, left, front, bottom, right, or back, based on either the WCS or the current UCS in effect when you select the tool. You can also select the previous UCS, align the UCS to the current view, or select the WCS.

When you select a UCS, the cursor orientation and UCS icon change to reflect the new UCS. The display does not change, however, unless you select the Change View To Plan View Of The Selected UCS check box.

After you align the UCS to a preset UCS, you can use the CAD.direct Drafter Explorer to save the UCS. To do this, in the CAD.direct Drafter Explorer window, choose Edit > New > UCS, and then select Current.
To select a preset UCS

1. Do one of the following to choose User Coordinate Systems:
   - On the ribbon, choose Draw > User Coordinate Systems or choose View > User Coordinate Systems.
   - On the menu, choose Tools > User Coordinate Systems > Select a Predefined UCS.
   - On the UCS toolbar, click the Select a Predefined UCS tool.
   - Type setucscs and then press Enter.
2. Under Set The Selected UCS Relative To, select either Current UCS to change to the new UCS by reorien
ting relative to the current UCS or World Coordinate System (WCS) to base the new UCS orientation on
the WCS.
3. Under Select UCS, click the button corresponding to the UCS you want as the new current UCS.

Preset UCSs are also available with a dialog box.

Choose Format > User Coordinate Systems, then select a predefined UCS from the list. The preset
UCSs are also available directly on the UCS toolbar.
8 Working with CAD.direct Drafter Explorer

CAD.direct Drafter Explorer provides a powerful and convenient way to maintain and manage many of the features and settings of your drawings. You can use CAD.direct Drafter Explorer to work with layers, linetypes, text styles, coordinate systems, named views, blocks, and dimension styles within the current drawing or to copy this information between drawings.

This section explains how to use CAD.direct Drafter Explorer to:

- Manage elements related to settings and entities in your drawings.
- Organize information on layers, manage layers, and work with layer states.
- Create and use linetypes.
- Load text fonts and create text styles.
- Select and control coordinate systems.
- Save and restore named views.
- Work with layouts.
- Save, insert, and manage blocks and external references.
- Work with groups.
- Copy, cut, and paste dimension styles between .dwg files.

8.1 Using CAD.direct Drafter Explorer

CAD.direct Drafter Explorer is a separate window that allows you to view, create, copy, and edit layers, layer states, linetypes, text styles, coordinate systems, blocks, dimension styles, and views within your drawings. You can also use CAD.direct Drafter Explorer to copy these elements from one open drawing to another. CAD.direct Drafter Explorer is a great way to manage and maintain your drawings.

8.1.1 Displaying CAD.direct Drafter Explorer

CAD.direct Drafter Explorer opens in its own, separate window, which you can move or resize. The CAD.direct Drafter Explorer window has its own menu and tools to display CAD.direct Drafter Explorer.

Do one of the following to choose CAD.direct Drafter Explorer:

- On the ribbon, choose Tools > CAD.direct Drafter Explorer (in Explorer).
- On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Layers (or any other item).
- On the Tools toolbar, click the CAD.direct Drafter Explorer tool.
- Type explayers and then press Enter.
- Type la and then press Enter.
- On the status bar, right-click the current layer, and from the list, select Properties.

CAD.direct Drafter Explorer displays elements, such as layers, layer states, linetypes, and more, on the left and corresponding drawing settings on the right.

Using CAD.direct Drafter Explorer, you can create, delete, or modify any of the settings for the currently selected element for a given drawing. You can also copy the contents of any element from one drawing to another. The tools and menu items in the CAD.direct Drafter Explorer window provide the following functions:
8.1.2 Copying settings

A particularly powerful feature of the CADconv Connect Explorer is its capability of copying many of the settings - layers, linetypes, text styles, coordinate systems, views, blocks, or dimension styles - from one drawing to another. If you have more than one drawing open, the CADconv Connect Explorer makes it easy to reuse information. For example, when you copy layers from one drawing to another, the layer names as well as their linetypes, colors, and other settings are also copied, but not the entities on those layers.
To copy layers from one open drawing to another open drawing

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CADconv Connect Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.

2. In the Elements pane, select the drawing from which you want to copy layers.

3. If necessary, click the plus (+) symbol to expand the Elements list for the drawing, and then click Layers.

4. In the Layers Settings In Drawing list (right pane), select the layers you want to copy.

5. Choose Edit > Copy, or click the Copy tool.

6. In the Elements pane, select the drawing to which you want to copy the layers.

7. If necessary, click the plus (+) symbol to expand the Elements list for the drawing, and then click Layers.

8. Choose Edit > Paste, or click the Paste tool.

8.1.3 Deleting settings

You can use the CAD.direct Drafter Explorer to delete many of the items that appear in the Elements list. You can delete a layer, linetype, text style, coordinate system, view, block, or dimension style.

Because you may have already created entities on a particular layer or using a particular linetype or text style, deleting one of these elements requires that you make certain choices from options the program presents. For example, if you attempt to delete a layer, the program prompts you to specify whether you want to move any entities from that layer to another layer. Every drawing has at least one layer, the default layer, named “0.” You cannot delete or rename this layer. Your drawing can also contain an unlimited number of additional layers, each of which you assign a unique name.

If you try to delete a linetype, the program prompts you to specify whether you want to convert all entities drawn using that linetype to a different linetype. If you attempt to delete a text style, the program prompts you to specify whether you want to convert all text entities created using that style to a different style.
To delete a layer and relocate its entities to another layer

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.

2. From the Layer Name list, select the layer that you want to delete.
   If that layer is the current layer, layer 0 automatically becomes the current layer.

3. Choose Edit > Delete, or click the Delete tool.

4. From the dialog box, click the Change option and then select the layer to which you want to relocate entities.

Delete a layer and its entities.

*In the command bar, type LAYDEL, then select an entity that is assigned the layer you want to delete. Using this method also deletes all entities assigned the layer.*

8.1.4 Purging elements

From within CAD.direct Drafter Explorer, you can eliminate unused blocks, layers, line-types, text styles, dimension styles, or annotation scales from your drawing file. Purging unused elements can significantly reduce the drawing file size.

To purge an element

1. Do one of the following to choose CAD.direct Drafter Explorer:
   - On the ribbon, choose Tools > CAD.direct Drafter Explorer (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer.
   - On the Tools toolbar, click the CAD.direct Drafter Explorer tool.

2. Select the element from which you want to purge unreferenced elements.

3. Choose Edit > Purge, or click the Purge tool.
8.2 Organizing information on layers

8.2.1 Understanding layers

Layers in CAD.direct Drafter are like the transparent overlays you use in manual drafting. You use layers to organize different types of drawing information. In CAD.direct Drafter, each entity in a drawing exists on a layer. When you draw an entity, it is created on the current layer.

You can control the visibility of layers in individual viewports. When you turn a layer off, entities drawn on that layer are no longer visible, and they do not print. Although a layer may be invisible, you can still select it as the current layer, in which case new entities are also invisible until you turn the layer back on. Entities on invisible layers can also affect the display and printing of entities on other layers. For example, entities on invisible layers can hide other entities when you use the Hide command to remove hidden lines.

You can also freeze and thaw layers. Entities drawn on frozen layers do not display, do not print, and do not regenerate. When you freeze a layer, its entities do not affect the display or printing of other entities. For example, entities on frozen layers do not hide other entities when you use the Hide command to remove hidden lines. In addition, you cannot draw on a frozen layer until you thaw it, and you cannot make a frozen layer current.

You cannot freeze the current layer. If you attempt to freeze the current layer, a dialog box appears prompting you to specify a different layer. You also cannot freeze or thaw a viewport layer unless you are working in a Layout tab.

You can lock or unlock layers. The entities on a locked layer are still visible and will print, but you cannot edit them. Locking a layer prevents you from accidentally modifying entities.

Each layer has its own properties, such as color, linetype, lineweight, transparency, print visibility, and more. For drawings that use named print styles, layers can also have their own print style. Entities you draw on a particular layer are displayed in the color, linetype, and lineweight associated with that layer unless you override these settings. You control all of the associated settings for layers using the Layers element in the CAD.direct Drafter Explorer. You can also access layer settings for entities using the Entity Properties toolbar.

Some drawings contain large lists of layers, in which case you can search for layers by name, or you can organize layers into subsets using layer filters. Layer states are also useful for drawings that contain many layers. With layer states, you can assign properties to individual layers and save them in a layer state, then apply those settings at any time.
8.2.2 Displaying layer information in CAD.direct Drafter Explorer

To display layer information

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Tools toolbar, click the CAD.direct Drafter Explorer tool.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.

2. If desired, view information for only certain layers by doing one of the following:
   - On the toolbar, type the name of the desired layers, including wildcards, and press Enter.
   - In the list of layer filters, select All Used Layers to display only those layers that are used in the drawing.
   - In the list of layer filters, select an existing group filter or properties filter. For details about filtering and searching layers, see “Filtering and finding layers” on page 207 in this chapter.
8.2.3 Creating and naming layers

You can create an unlimited number of layers in every drawing and use those layers for organizing information. When you create a new layer, it is initially assigned the color white (or black, depending on your system settings) and the linetype CONTINUOUS. By default, a new layer is also visible. After you create and name a layer, you can change its color, linetype, visibility, and other properties.
To create a new layer

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.

2. Do one of the following:
   - Choose Edit > New > Layer.
   - Click the New Item tool.

A new layer is added to the Layer Name list, with the default name NewLayer1.

3. Type a name for the new layer over the highlighted default name, and then press Enter.

4. To complete the command and return to your drawing, close the window.

To change a layer name in the current drawing

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.

2. In the Layer Name list, select the layer you want to rename.

3. Do one of the following:
   - Choose Edit > Rename, type a new name, and then press Enter.
   - Right-click the layer name you want to change, and from the shortcut menu, select Rename, type a new name, and then press Enter.

4. To complete the command and return to your drawing, close the window.

The layer named “0” is reserved.

You cannot rename it.
8.2.4 Filtering and finding layers

Some drawings contain large lists of layers. To limit the layers that appear in the list, you can search layers by name (including wildcards) and you can also create layer filters.

By default, there are two predefined filters. One displays all layers and the other displays all layers that are used in the drawing.

There are two types of layer filters that you can create:

- Properties filter — Includes layers according to properties that you specify.
- Group filter — Includes layers that you include in the group.

After you create a layer filter, you can turn all the layers on or off, thaw or freeze the layers, and lock or unlock the layers. Layer filters can also be inverted, imported, and exported.
8.2.5 Searching layers by name

To search for layers by name

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.

2. In the CAD.direct Drafter Explorer toolbar, type the search name, including the following wildcards:
   - * Matches any character or series of characters.
   - ? Matches a single character.
   - # Matches any numerical character.
   - @ Matches any alphabetic character.
   - . Matches any character that is not alphabetic or numeric. [ ] Matches any of the characters inside the brackets.
   - ~ Matches any characters except for those after the tilde.
   - [~,] Matches any of the characters except for those inside the brackets.
   - [-] Matches a range of characters inside the brackets.
   - ‘Matches the exact characters located after the quote mark. This is most often used when searching for layer names that include wildcards, for example, @Floor or Field#.

3. To view all layers again in the list, delete the search term.

4. Click OK.
8.2.6 Filtering layers by property

Layer property filters include layers according to properties that you specify. For example, a property filter can display all layers with a dashed linetype, then you can easily turn those layers on or off.

To create a properties filter

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.
2. Click the Properties Filter tool.

Filters can be nested.

To create a sub-filter of an existing filter, right-click the existing filter and choose New Properties Filter or New Group Filter.

3. Type a name for the filter.

4. Do any of the following in Filter Definition:
   - Click the column of an empty row to specify the property to match. All layers that match the specified properties of any row will be included.
   - Click the column of an existing row to specify an additional property that a layer must match to be included in the filter. All layer properties in a single row must be matched for the layer to be included.
   - Right-click a row and choose Delete Row to delete a row you no longer need.
   - Right-click a row and choose Duplicate Row to make a copy of an existing row. The filter preview displays the layers that will be included in the filter.
5. Click OK.

6. To complete the command and return to your drawing, close the window.
To modify a properties filter

1. In CAD.direct Drafter Explorer, select Layers, then do one of the following:
   
   - To rename a properties filter, select it and type a new name.
   - To delete a properties filter, select it and press Delete.
   - To change the definition of a properties filter, double-click it.

Use a shortcut.

*Right-click a properties filter to modify it.*

To modify the layers in a properties filter

1. In CAD.direct Drafter Explorer, select Layers.

2. To change the visibility of all layers in a properties filter, right-click the properties filter, choose Visibility, then choose one of the following:
   
   - On
   - Off
• Thaw
• Freeze

3. To change the accessibility of all layers in a properties filter, right-click the properties filter, choose Lock, then choose one of the following:

• Lock
• Unlock

8.2.7 Filtering layers by group

Layer group filters include any layer that you select for the group. For example, a group filter can display all layers that contain text entities, then you can freeze or thaw those layers as needed.

To create a group filter

1. Do one of the following to choose Explore Layers:

   • On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   • On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   • On the Explorer toolbar, click the Explore Layers tool.
   • Type explayers and then press Enter.
2. Click the Group Filter tool.

Filters can be nested.

To create a sub-filter of an existing filter, right-click the existing filter and choose New Properties Filter or New Group Filter.

3. Type a name for the new group filter, then press Enter.

4. To choose layers for the group filter, do one of the following:

   • Right-click the group filter, choose Select Layers > Add, then select entities in your drawing that reside on layers to include in the group. Press Enter when done. Choose Select Layers > Replace if the group filter has existing layers that you want to remove before adding new layers.
   • Double-click the group filter, then mark and unmark the desired layers.
5. Click OK.

6. To complete the command and return to your drawing, close the window
Create a group filter by converting an existing property filter.

*In CAD.direct Drafter Explorer, view layer filters, right-click a property filter, and choose Convert to Group Filter.*

To modify a group filter

1. In CAD.direct Drafter Explorer, select Layers, then do one of the following:
   - To rename a group filter, select it and type a new name.
   - To delete a group filter, select it and press Delete.
   - To change the layers included in a group filter, double-click it.
   - To select new layers for the group filter directly in the drawing, right-click the group filter. Choose Select Layers > Add if you want to keep all existing layers in the group filter and select new ones to add directly in the drawing. Choose SelectLayers > Replace if you want to remove all existing layers from the group filter and select new ones directly in the drawing.

Use a shortcut.

*Right-click a group filter to modify it.*
To modify the layers in a group filter

1. In CAD.direct Drafter Explorer, select Layers.

2. To change the visibility of all layers in a group filter, right-click the group filter, choose Visibility, then choose one of the following:
   - On
   - Off
   - Thaw
   - Freeze

3. To change the accessibility of all layers in a group filter, right-click the group filter, choose Lock, then choose one of the following:
   - Lock
   - Unlock

8.2.8 Inverting layer filters

Layer filters can be inverted, for example, you can invert the All Used Layers filter to display a list of all layers that are unused in the drawing.

To invert a layer filter

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.

2. Select a layer filter.

3. Click the Invert Filter tool.

4. To complete the command and return to your drawing, close the window.

   The filter stays inverted until it’s turned off.

If the contents of a filter look incorrect, it could be because it is inverted.
8.2.9 Importing and exporting layer properties filters

Layer properties filters can be imported and exported as .lst files.

To import layer properties filters

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.
2. Click the Import Layer Filter tool.
3. Navigate to where you want to save the layer filter, type a name, then click Save.
4. To complete the command and return to your drawing, close the window.

To export layer properties filters

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.
2. Select the layer filter you want to export.
3. Click the Export Layer Filter tool.
4. Locate the layer filter (.lft file) and select it.
5. Click Open.
6. To complete the command and return to your drawing, close the window.
8.2.10 Setting the current layer

When you create new entities, they are drawn on the current layer. To draw new entities on a different layer, you must first make that layer the current layer.

To make a layer current

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.
2. In the Layer Name list, select the layer you want to make current.
3. Do one of the following:
   - Choose Edit > Current.
   - In the Layer Name list, select the name you want to make current, and then click the Current tool.
   - Double-click the layer name in the Layer Name list.
   - Right-click the layer name you want to change, and from the shortcut menu select Current.
4. To complete the command and return to your drawing, close the window.

Use the command bar.

*In the command bar, type LAYBYENT and choose Set or type LAYMCUR, then select an entity that is assigned the layer you want to be current.*

8.2.11 Controlling layer visibility

A layer can be visible or invisible. Entities on invisible layers are not displayed and do not print. By controlling layer visibility, you can turn off unnecessary information, such as construction lines or notes. By changing layer visibility, you can put the same drawing to multiple uses.

For example, if you are drawing a floor plan, you can draw the layout of light fixtures on one layer and the location of plumbing lines on another. By selectively turning layers on and off, you can print the electrical engineering drawings and the plumbing drawings from the same drawing file. For even more convenience, you can control the visibility of layers within individual viewports, so that layers that display in one viewport are invisible in other viewports in the same drawing.
When you turn a layer off, entities drawn on that layer are no longer visible. When you turn the layer back on, the entities on that layer are redisplayed.

To turn layers on or off

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.

2. Click in the On/Off column for the layer you want to turn on or off.

3. To complete the command and return to your drawing, close the window.

You can also freeze layers to improve the performance of operations such as zooming and panning or producing hidden lines or shaded images. When a layer is frozen, entities drawn on that layer are no longer visible.

Select an entity that is assigned to the layer you want to turn off.

In the command bar, type LAYBYENT and choose Off or type LAYOFF, then select an entity that is assigned the layer you want to turn off.

Use a shortcut to turn on all layers.

Choose Format > Layer Tools > Turn All Layers On or type LAYON in the command bar to turn on all layers in a drawing.

To control the visibility of external reference layers and save any changes made to them in the current drawing, turn on Xref Visibility.

To turn on Xref Layer visibility

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter
2. Choose View > Records from Xref Visibility.

Use the system variable.

_You can also turn on xref layer visibility by typing visretain to access the system variable._

**To freeze or thaw layers**

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.

2. Click in the All Viewports column for the layer you want to freeze or thaw.

3. To complete the command and return to your drawing, close the window.

Select an entity that is assigned to the layer you want to freeze.

_In the command bar, type LAYBYENT and choose Freeze or type LAYFRZ, and select an entity that is assigned the layer you want to freeze._

Use a shortcut to thaw all layers.

_ChOOSE FORMAT > LAYER TOOLS > THAW ALL LAYERS OR TYPE LAYTHW IN THE COMMAND BAR TO THAW ALL LAYERS IN A DRAWING._

**8.2.12 Locking and unlocking layers**

Locking a layer makes it easy to refer to information contained on the layer, but prevents you from accidentally modifying its entities. When a layer is locked (but visible and thawed), its entities remain visible, but you cannot edit them. If you lock the current layer, you can still add new entities to it. Unlocking a layer restores full editing capabilities.
To lock or unlock layers

1. Do one of the following to choose Explore Layers:
   • On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   • On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   • On the Explorer toolbar, click the Explore Layers tool.
   • Type explayers and then press Enter.

2. Click in the Locked column for the layer you want to lock or unlock.

3. To complete the command and return to your drawing, close the window.

Select an entity that is assigned to the layer you want to lock or unlock.

In the command bar, type LÁBYENT and choose Lock or Unlock or type LÁYLCK or LÁYULK, then select an entity that is assigned the layer you want to lock or unlock.

8.2.13 Controlling layer printing

Controlling layer printing is another way you can specify which entities print in your drawing.

By controlling layer printing, you can turn off unnecessary information during printing. For example, if you are drawing a floor plan, you can draw the layout of light fixtures on one layer and the location of plumbing lines on another. By selectively turning layers on and off when you print, you can print the electrical engineering drawings and the plumbing drawings from the same drawing file. By changing layer printing, you can put the same drawing to multiple uses.

When you turn off printing for a layer, entities drawn on that layer are still visible, but they do not print. If you turn off a layer’s visibility, entities drawn on that layer do not display or print. Controlling layer printing can be especially helpful if you want layer visibility on, but do not want to print entities on that layer.

Layer visibility must be turned on to print entities drawn on that layer.

To turn layer printing on or off

1. Do one of the following to choose Explore Layers:
   • On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   • On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
• On the Explorer toolbar, click the Explore Layers tool.
• Type explayers and then press Enter.

2. Click in the Print column for the layer you want to turn printing on or off for.

8.2.14 Setting the layer color

Each layer in a drawing is assigned a color. CAD.direct Drafter uses the BYLAYER color as the default color setting for entity creation so that new entities are drawn in the color of the layer on which they are inserted (set in the Drawing Settings dialog box).

Using the CAD.direct Drafter Explorer, you can set or change the color assigned to a layer. With the direct-editing feature, you can click on the color you want to change, and then select a new color from the dialog box that appears. Changing a layer’s color automatically changes the color of all entities on that layer with the BYLAYER color.

To change the layer color

1. Do one of the following to choose Explore Layers:
   • On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   • On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   • On the Explorer toolbar, click the Explore Layers tool.
   • Type explayers and then press Enter.

2. Click in the Color column for the layer you want to change.

3. In the Color dialog box, select a color on one of the following tabs:
   • Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. You can also type the color number in the Index box.
   • TrueColor— Click a basic color, click a color in the color palette, enter the Hue, Saturation, and Luminance (HSL) values, or enter the Red, Green, Blue (RGB) values. There are more than 16 million true colors from which you can choose.
   • Color Books — Select a color book from the list, then click a color. You can select Show Only Color Book Colors Used in Drawing to limit the selection to only those color book colors that are used in the current drawing. If necessary, create or edit color books by clicking Color Book Editor. For more details, see “Using color books” on page 66.

4. Click OK.
Entities don’t have to use the layer’s color.

You can assign a specific color to an entity, which overrides the layer’s color setting. When you create a new entity, use the Format > Colors > Select Color command to change the current color. For an existing entity, select the entity, right-click for the shortcut menu, and choose Properties to change the entity’s color using the Properties pane.

For more details about using color in the many aspects of your drawing, see “Working with colors” on page 63.

8.2.15 Setting the layer linetype

Each layer uses a default linetype (a repeating pattern of dashes, dots, or blank spaces). Linetype determines the appearance of entities both on the screen and when printed.

It’s a good idea to assign the BYLAYER linetype to any entities that you draw on that layer. CAD.direct Drafter uses the BYLAYER linetype as the default linetype setting for Entity Creation (in the Drawing Settings dialog box).

Using the CAD.direct Drafter Explorer, you can set or change the linetype assigned to a layer. With the direct-editing feature, you can click on the linetype you want to change, and then select a new linetype from the dialog box that appears. Changing the linetype assigned to a layer changes the linetype of all entities drawn on that layer with the BYLAYER linetype.

Only those linetypes already set in the drawing can be assigned to layers. For more information about setting additional linetypes, see “Working with linetypes” on page 229 in this chapter.

To change the linetype assigned to one or more layers

1. Do one of the following to choose Explore Layers:
   • On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   • On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   • On the Explorer toolbar, click the Explore Layers tool.
   • Type explayers and then press Enter.
2. Click in the Linetype column for the layer you want to change.
3. In the Linetype dialog box, select a new linetype for the layer, or click Browse to select your linetype file.
Entities don’t have to use the layer’s linetype.

You can also assign a specific linetype to an entity, which overrides the layer’s line-type setting. When you create a new entity, use the Tools > CAD.direct Drafter Explorer > Explore Linetypes command to change the current linetype through the CAD.direct Drafter Explorer. For an existing entity, select the entity, right-click for the shortcut menu, and choose Properties. You can then modify the entity’s linetype using the Properties pane.

8.2.16 Setting the layer lineweight

Each layer uses a default lineweight. Lineweights determine the thickness of entities both on the screen and when printed.

All new layers are assigned the DEFAULT lineweight, which is .25 millimeters or .01 inches. If you want a different lineweight assigned to a layer, you can easily change it using CAD.direct Drafter Explorer. For example, you may want different line-weights on each layer of your drawing to show separate elements, such as walls, dimensions, structural steel, and electrical plans. Changing the lineweight assigned to a layer changes the lineweight of all entities drawn on that layer with the BYLAYER lineweight.

When you create new entities, it’s a good idea to assign the BYLAYER lineweight to any entities that you draw on that layer, unless you want to override the layer line-weight. CAD.direct Drafter uses the BYLAYER lineweight as the default lineweight setting when you create entities (in the Drawing Settings dialog box).

You can change the default lineweight.

To change the DEFAULT lineweight, choose Tools > Drawing Settings, click the Display tab, select Lineweights in Change Settings For, and then select a new default.

To change the lineweight assigned to one or more layers

1. Do one of the following to choose Explore Layers:
   • On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   • On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   • On the Explorer toolbar, click the Explore Layers tool.
   • Type explayers and then press Enter.
2. Click in the Lineweight column for the layer you want to change.
3. In the Lineweight list, select a new lineweight for the layer, then click OK.
Entities don’t have to use the layer’s lineweight.

You can assign a specific lineweight to an entity, which overrides the layer’s line-weight setting. When you create a new entity, use the Tools > Drawing Settings > Entity Creation tab to change the current lineweight. For an existing entity, select the entity, right-click for the shortcut menu, and choose Properties. You can then modify the entity’s lineweight using the Properties pane.

8.2.17 Setting the layer transparency

Each layer uses a transparency value from 0 to 90, where zero is no transparency (regular visibility) and 90 is the most transparency (almost invisible).

By default, each layer is assigned zero transparency. If you want a different transparency assigned to a layer, you can easily change it using CAD.direct Drafter Explorer.

To change the transparency assigned to one or more layers

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.
2. Click in the Transparency column for the layer you want to change.
3. Enter a new value for the transparency, then press Enter.

8.2.18 Setting the layer print style

If your drawing uses named print style tables, you can specify a print style for each layer. Named print style tables contain print styles that you set up to control what entities look like when they print, without actually changing the entities in the drawing.

If your drawing uses color-dependent print style tables, you cannot specify a print style for a layer. These types of print style tables automatically determine printing requirements by the color assigned to a layer or an entity. For details about converting a drawing that uses color-dependent print style table to use named print style tables, see “Changing the print style table type of a drawing” on page 483.
In drawings that use named print style tables, the default print style is Normal for all new layers. If desired, you can assign a print style using CAD.direct Drafter Explorer. Changing the print style assigned to a layer changes the print style of all entities drawn on that layer with the BYLAYER print style.

When you create new entities, it’s a good idea to assign the BYLAYER print style to any entities that you draw on that layer, unless you want to override the layer print style. CAD.direct Drafter uses the BYLAYER print style as the default print style setting when you create entities (in the Drawing Settings dialog box).

**To change the print style assigned to one or more layers (only in a drawing that uses named print style tables)**

1. Do one of the following to choose Explore Layers:
   - On the ribbon, choose Home > Layers or choose Tools > Layers (in Explorer).
   - On the menu, choose Format > Explore Layers or choose Tools > CAD.direct Drafter Explorer > Explore Layers.
   - On the Explorer toolbar, click the Explore Layers tool.
   - Type explayers and then press Enter.
2. Click in the Print Style column for the layer you want to change.
3. If necessary, select a different print style table in the Active Print Style Table list.
4. In Print Styles, select a print style.
5. Click OK.

Entities don’t have to use layer’s print style.

*For drawings that use named print style tables, you can also assign a specific print style to an entity, which overrides the layer’s print style setting. When you create a new entity, use the Tools > Drawing Settings > Entity Creation tab to change the current print style. For an existing entity, select the entity, right-click for the shortcut menu, and choose Properties. You can then modify the entity’s print style using the Properties pane.*
8.2.19 Working with layer states

Layer states are collections of individual layers and their properties. You can restore layer states at any time, which makes it easy to switch between layer configurations according to your tasks.

Layer states can also be imported and exported. For example, to quickly create all the layers you need in a new drawing, create and export a layer state from an existing drawing that has the layers you need, and then import the layer state to the new drawing.

Layer states are saved in the drawing, including drawing templates and exported or imported drawings.

For each layer included in a layer state, you can set the following properties:

- Color
- Linetype
- On/Off
- Lock/Unlock
- Freeze/Thaw
- Lineweight
- Transparency
- Print
- New Viewports

8.2.20 Displaying layer states in the Layer States Manager

To display the Layer States Manager

1. Do one of the following to choose Layer State Manager:
   - On the ribbon, choose Home > Layer States Manager (in Layers).
   - On the menu, choose Format > Layer State Manager or choose Format > Explore Layers, then click the Layer States Manager tool.
   - On the Format toolbar, click the Layer States Manager tool.
   - Type layerstate and then press Enter.
8.2.21 Creating layer states

In addition to loading predefined linetypes from a linetype library file, you can create new linetypes. You can save new linetypes you create to a linetype library file for use in other drawings.

To create a layer state

1. Create all the layers that you want to be in the layer state.

Although you can modify the layer state layer, first you should set up your drawing with its layers and properties so when you create the layer state, it captures all

2. Do one of the following to choose Layer States Manager:

   - On the ribbon, choose Home > Layer States Manager (in Layers).
   - On the menu, choose Format > Layer State Manager or choose Format > Explore Layers, then click the Layer States Manager tool.
   - On the Format toolbar, click the Layer States Manager tool.
   - Type layerstate and then press Enter.
3. Click New.

4. Enter a name and description, then click OK.

5. Click Edit and do any of the following:
   - Click any column for any layer to change its setting. The new setting applies only when this layer state is applied (restored).
   - Click the Add Layer tool and select a layer to add to the layer state.
   - Select a layer and click the Delete Layer tool to remove a layer from the layer state.

6. Click OK.

7. Click Close.
8.2.22 Applying a layer state

To apply the settings of a layer state

1. Do one of the following to choose Layer State Manager:
   - On the ribbon, choose Home > Layer States Manager (in Layers).
   - On the menu, choose Format > Layer State Manager or choose Format > Explore Layers, then click the Layer States Manager tool.
   - On the Format toolbar, click the Layer States Manager tool.
   - Type layerstate and then press Enter.

2. Select the layer state to apply.

3. Layer states by design don’t always contain all layers of a drawing. Make selections for the following:
   - Layers not found in state are turned off — After the layer state is applied, the only layers that will be turned on are those that are included in the layer state. If unmarked, the on/off status of unmatched layers is not changed.
   - Layers not found in state are frozen in current viewport — After the layer state is applied, the only layers that will be thawed in the current viewport are those that are included in the layer state. If unmarked, the freeze/thaw statuses of unmatched layers are not changed.

4. In Layer Properties to Restore, mark which properties of all layers included in the layer state to apply. If a property is not marked, that property will not be applied for matching layers.

5. Click Restore.

8.2.23 Displaying layer states in CAD.direct Drafter Explorer

To display layer states

- Do one of the following or choose Explore Layer States:
  - On the ribbon, choose Tools > Layer States (in Explorer).
  - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Layer States.
  - On the Explorer toolbar, click the Explore Layer States tool.
  - Type explayerstates and then press Enter.
  - Choose Tools > CAD.direct Drafter Explorer, and then click the Layer States element.
8.2.24 Importing and exporting layer states from files

Layer states can be imported and exported as .las files. Exporting layer states from one drawing and importing them in a new drawing is a quick way to create all the new layers you need for the new drawing.

To import a layer state from a file

1. Do one of the following to choose Layer States Manager:
   - On the ribbon, choose Home > Layer States Manager (in Layers).
   - On the menu, choose Format > Layer State Manager or choose Format > Explore Layers, then click the Layer States Manager tool.
   - On the Format toolbar, click the Layer States Manager tool.
   - Type layerstate and then press Enter.
2. Click Open.
3. Select the .las file to import.
4. Click Import.

To export a layer state to a file

1. Do one of the following to choose Layer State Manager:
   - On the ribbon, choose Home > Layer States Manager (in Layers).
   - On the menu, choose Format > Layer State Manager or choose Format > Explore Layers, then click the Layer States Manager tool.
   - On the Format toolbar, click the Layer States Manager tool.
   - Type layerstate and then press Enter.
2. Select the layer state to export.
3. Click Export.
4. Enter a name for the .las file.
5. Click OK.
8.3 Working with linetypes

Linetypes are sequences of alternating line segments, dots, and blank spaces that affect the appearance of a line.

8.3.1 Understanding linetypes

CADconv Connect provides simple and complex linetypes:

- A simple linetype consists of a repeating pattern of dots, dashes, or blank spaces.
- A complex linetype contains embedded shape and text entities along with dots, dashes, and spaces.

You can use different linetypes to represent specific kinds of information. For example, if you are drawing a site plan, you can draw roads using a continuous linetype, a fence using a using a linetype of dashes with square posts, or a gas line using a complex linetype showing the text “GAS”.

By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and BYBLOCK. You cannot rename or delete these linetypes. Your drawing may also contain an unlimited number of additional linetypes. You can load more line-types into the program from a linetype library file or create and save linetypes you define.
8.3.2 Displaying linetype information in CAD.direct Drafter Explorer

To display the CAD.direct Drafter Explorer Linetypes element

Do one of the following to choose Explore Linetypes:

- On the ribbon, choose Tools > Linetypes (in Explorer).
- On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Linetypes.
- On the Explorer toolbar, click the Explore Linetypes tool. Type expltypes and then press Enter.
8.3.3 Setting the current linetype

You normally draw an entity using the linetype assigned to the current layer, indicated as BYLAYER. You can also assign linetypes on a per-entity basis, which over-rides the layer’s linetype setting. A third option is to assign the BYBLOCK linetype, whereby you draw new entities using the default linetype until you group them into a block. The entities inherit the current linetype setting when you insert the block into the drawing.

To make the linetype current

1. Do one of the following to choose Explore Linetypes
   - On the ribbon, choose Tools > Linetypes (in Explorer):
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Linetypes.
   - On the Explorer toolbar, click the Explore Linetypes tool.
   - Type expltypes and then press Enter.
2. In the Linetype Name list, select the linetype you want to make current.
3. Do one of the following:
   - Choose Edit > Current.
   - Select it in the Linetype Name list and click the Current tool.
   - Double-click the linetype name.
4. To complete the command and return to your drawing, close the window.

Use the status bar.

*On the status bar, right-click on the word BYLAYER for the current linetype, click Properties, and then choose the linetype that you want to make current.*
8.3.4 Loading additional linetypes

Before you can select a new linetype to use in a drawing, you must either create the linetype definition or load a predefined linetype from a linetype library file (*.lin). CAD.direct Drafter includes a linetype library file, icad.lin, which contains more than 100 predefined linetypes.

To load a new linetype from a linetype library

1. Do one of the following to choose Explore Linetypes:
   - On the ribbon, choose Tools > Linetypes (in Explore
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Linetypes.
   - On the Explorer toolbar, click the Explore Linetypes tool. Type expltypes and then press Enter.

2. Using one of the following methods, open the New Linetype dialog box:
   - Choose Edit > New > Linetype.
   - Click the New Item tool.
   - With the cursor in the right side of the window, right-click to display the shortcut menu, and then choose New > Linetype.

3. Select the linetype to load.

4. If necessary, click Browse to choose a different linetype library file that contains the linetype definitions you want to load.

5. Click OK.
A Displays the name of the current linetype library file that contains the linetype definitions from which you can choose.

B Click to select and load a linetype.

C Click to create a new linetype definition for the current linetype library file.

D Click a column title to sort by category.

E Click to open a different linetype library file that contains the linetypes you want to choose.
8.3.5 Creating and naming linetypes

In addition to loading predefined linetypes from a linetype library file, you can create new linetypes. You can save new linetypes you create to a linetype library file for use in other drawings.

8.3.6 Creating a new simple linetype

To create a new simple linetype

1. Do one of the following to choose Explore Linetypes:
   - On the ribbon, choose Tools > Linetypes (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Linetypes.
   - On the Explorer toolbar, click the Explore Linetypes tool. Type expltypes and then press Enter.

2. Using one of the following methods, open the New Linetype dialog box:
   - Choose Edit > New > Linetype.
   - Click the New Item tool.
   - With your cursor in the right side of the window, right-click to display the shortcut menu, and choose New > Linetype.

3. Click New.

4. Type the name of the line linetype. Do not use spaces between words in the new linetype name.

5. If necessary, in Linetype File Name, specify a different linetype library file to which you want to add the new linetype.

6. In Linetype Description, type the linetype description.

   You can type anything in this field that will help you remember the purpose or appearance of this linetype. For example, it is helpful to type text or symbols such as ___.__.__. that approximate the appearance of the linetype.

7. In Linetype Definition, type the linetype definition.

   The definition consists of positive and negative numbers separated by commas. A positive number draws a solid line segment for the specified number of drawing units; a negative number creates a gap for the specified number of units; a zero creates a dot.

8. Click OK.
8.3.7 Creating a new complex linetype

To create a new complex linetype

A complex linetype can denote utilities, boundaries, contours, and so on. As with simple linetypes, complex lines are dynamically drawn as the user specifies vertices. Shapes and text entities embedded in lines are always displayed completely; they are never trimmed.

1. Do one of the following to choose Explore Linetypes:
   - On the ribbon, choose Tools > Linetypes (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Linetypes.
   - On the Explorer toolbar, click the Explore Linetypes tool.
   - Type expltypes and then press Enter.
2. Using one of the following methods, open the New Linetype dialog box:
   - Choose Edit > New > Linetype.
   - Click the New Item tool.
   - With your cursor in the right side of the window, right-click to display the shortcut menu, and choose New > Linetype.

3. Click New.

4. Type the name of the line linetype. Do not use spaces between words in the new linetype name.

5. In Linetype Description, type the linetype description.
   You can type anything in this field that will help you remember the purpose or appearance of this linetype. For complex linetypes, it is helpful to type a text description of the linetype.

6. In Linetype Definition, type the linetype definition.
   As for the simple linetypes, the syntax for a complex linetype is a comma delimited list of pattern descriptors. For more details, see “Syntax for a complex line-type definition” on page 235 in this chapter.

7. Click OK.

### 8.3.8 Syntax for a complex linetype definition

Complex linetypes can include shape and text entities as pattern descriptors, as well as the dash and dot descriptors of simple linetypes.

**The shape descriptor syntax**

You can add a shape entity to a complex linetype using the following syntax:

```
[shape_name, shape_filename] or [shape_name, shape_filename, transform]
```

The definitions of the fields in the syntax are as follows.

- **shape_name**
  The name of the shape to add to the linetype. The shape name must exist in the specified shape file (shape_filename).

- **shape_filename**
  The name of a compiled shape definition file (extension *.shx). If no path is defined for the shape file name, the library path is searched for the file.
TRANSFORM

The transform argument is optional and can be any series of the following (each preceded by a comma):

\[ R=value \hspace{1cm} \text{Relative rotation} \]
\[ A=value \hspace{1cm} \text{Absolute rotation} \]
\[ S=value \hspace{1cm} \text{Scale} \]
\[ X=value \hspace{1cm} \text{X offset} \]
\[ Y=value \hspace{1cm} \text{Y offset} \]

In this syntax, value represents a signed decimal number. The rotation is expressed in degrees while the other options are in linetype scaled drawing units.

ROTATION

\[ R=value \text{ or } A=value \]

R= determines a relative or tangential rotation with respect to the line’s elaboration.

A= determines an absolute rotation of the shape with respect to the origin. All shapes have the same rotation regardless of their relative position to the line. The value can be appended with a d for degrees (default), r for radians, or g for grads. If rotation is omitted, 0 relative rotation is used.

SCALE

\[ S=value \]

Determines a factor by which the shape’s internal scale is multiplied. If the shape’s internal scale is 0, the scale value is used as the scale.

X offset

\[ X=value \]

Determines a shift of the shape along the X axis of the linetype computed from the end of the linetype definition vertex. If X offset is omitted or is 0, the shape is elaborated with no offset. Include this field if you want a continuous line with shapes. This value is not scaled by the scale factor defined by S.

Y offset

\[ Y=value \]
Determines a shift of the shape along the Y axis of the linetype computed from the end of the linetype definition vertex. If Y offset is omitted or 0, the shape is elaborated with no offset. This value is not scaled by the scale factor defined by S.

The text descriptor syntax

You can add a text entity to a complex linetype using the following syntax:

[“string”, style_name] or [“string”, style_name, transform]

The definitions of the fields in the syntax are as follows.

**STRING**

The text to be used in the complex linetype. You cannot use the ` or the “ characters in the text string. To use these characters, enter a control code (%%) with the ASCII value for the character instead.

**STYLE_NAME**

The name of the text style to be elaborated. The specified text style must be included. If it is omitted, use the currently defined style.

**TRANSFORM**

The transform argument is optional and can be any series of the following (each preceded by a comma):

- **R=value**  
  Relative rotation
- **A=value**  
  Absolute rotation
- **S=value**  
  Scale
- **X=value**  
  X offset
- **Y=value**  
  Y offset

In this syntax, value represents a signed decimal number. The rotation is expressed in degrees while the other options are in linetype scaled drawing units.

**ROTATION**

**R=value** or **A=value**

R= determines a relative or tangential rotation with respect to the line's elaboration.

A= determines an absolute rotation of the shape with respect to the origin. All shapes have the same rotation regardless of their relative position to the line. The value can be appended with a d for degrees (default), r for radians, or g for grads. If rotation is omitted, 0 relative rotation is used.
**SCALE**

*S=value*

Determines a factor by which the shape's internal scale is multiplied. If the shape's internal scale is 0, the scale value is used as the scale.

**X offset**

*X=value*

Determines a shift of the shape along the X axis of the linetype computed from the end of the linetype definition vertex. If X offset is omitted or is 0, the shape is elaborated with no offset. Include this field if you want a continuous line with shapes. This value is not scaled by the scale factor defined by S.

**Y offset**

*Y=value*

Determines a shift of the shape along the Y axis of the linetype computed from the end of the linetype definition vertex. If Y offset is omitted or 0, the shape is elaborated with no offset. This value is not scaled by the scale factor defined by S.

### 8.3.9 Modifying linetypes

**To change a linetype name**

1. Do one of the following to choose Explore Linetypes:
   - On the ribbon, choose Tools > Linetypes (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Linetypes.
   - On the Explorer toolbar, click the Explore Linetypes tool. Type expltypes and then press Enter.
2. Do one of the following:
   - Select the linetype, and then choose Edit > Rename.
   - Click the linetype name you want to change, and then type the new name.
   - Right-click the linetype name you want to change, and from the shortcut menu, select Rename.
3. To complete the command and return to your drawing, close the window.

The linetypes named CONTINUOUS, BYBLOCK, and BYLAYER are reserved. You cannot rename them.
8.4 Working with text styles

A text style is a named, saved collection of format settings that determines the appearance of text.

8.4.1 Understanding text styles

When you add text to a drawing, it is created using the current text style. The text style determines the font, size, angle, orientation, if the text is annotative by default, and other text characteristics.

Every drawing has at least one text style, named Standard, which initially uses the Arial font. You cannot delete the Standard style, but you can rename it or modify it. For example, you can change the font, or the oblique angle applied to the font. You also can use an unlimited number of additional text styles in your drawing.

From the CAD.direct Drafter Explorer, you can directly edit any setting associated with a text style by using the single-click editing method to change the setting.

8.4.2 Displaying text style information in CAD.direct Drafter Explorer

To display the CAD.direct Drafter Explorer Text Styles element

Do one of the following to choose Explore Text Styles:

- On the ribbon, choose Tools > Text Styles (in Explorer).
- On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Text Styles.
- On the Explorer toolbar, click the Explore Text Styles tool.
- Type expstyles and then press Enter.
8.4.2 Creating and naming text styles

Fonts are character sets that consist of letters, numbers, punctuation marks, and symbols. Each font is stored in its own font file. Text styles apply additional formatting to fonts. You can create multiple text styles based on the same font, changing the various characteristics to alter the appearance of the font. To create a new text style, you assign formatting characteristics to a font.

CAD.direct Drafter uses *.shx font files and provides a selection of fonts. These fonts are located in the CAD.direct Drafter/Fonts directory. You can also use any font designed to work with AutoCAD as well as Windows system fonts. Many fonts are available from third-party vendors.
To create a new text style

1. Do one of the following to choose Explore Text Styles:
   - On the ribbon, choose Tools > Text Styles (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Text Styles.
   - On the Explorer toolbar, click the Explore Text Styles tool.
   - Type expfontsl and then press Enter.

2. Do one of the following:
   - Choose Edit > New > Text Style.
   - Click the New Item tool.

A new style is added to the text styles list with the default name, NewStyle1.

3. Type the name for the new style by typing over the highlighted default text, and then press Enter.

4. Click the columns for the items you want to change and make your selections for the new text style.

5. To complete the command, close the window.

To change a text style name in the current drawing

1. Do one of the following to choose Explore Text Styles:
   - On the ribbon, choose Tools > Text Styles (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Text Styles.
   - On the Explorer toolbar, click the Explore Text Styles tool.
   - Type expfonts and then press Enter.

2. Do one of the following:
   - Select the text style, choose Edit > Rename, type a new name, and then press Enter.
   - Click the text style name you want to change, type a new name, and then press Enter.
   - Right-click the text style name you want to change, and from the shortcut menu, select Rename, type a new name, and then press Enter.

3. To complete the command and return to your drawing, close the window.
8.4.3 Modifying text styles

A new text style is initially assigned default values for height, width factor, oblique angle, and other characteristics. You can change these values for both new and existing text styles. You can also change the font assigned to the text style. If you change the font or orientation properties of a text style assigned to text previously inserted in the drawing, all text using that style is regenerated to reflect the changes. Oblique angle and height, if specified, are given by the style definition when text is created, but are not updated for existing text when the style is changed.

A fixed text height value of 0 allows you to specify the text height at the time you insert text into the drawing. Any other value sets height of the text to that value; the program does not prompt for the text height when you insert text into the drawing. The width factor determines the horizontal scaling of text. A value less than 1 compresses the text (for example, 0.75 compresses the text 25 percent); a value greater than 1 expands the text (for example, 1.50 expands the text 50 percent). The oblique angle determines the forward or backward slant of text as an angle offset from 90 degrees. Negative values slant text to the left; positive values slant text to the right.

To modify a text style

1. Do one of the following to choose Explore Text Styles:
   - On the ribbon, choose Tools > Text Styles (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Text Styles.
   - On the Explorer toolbar, click the Explore Text Styles tool.
   - Type expfonts and then press Enter.
2. Click in the desired column for the text style you want to change, then make the desired changes.
3. To complete the command, close the CAD.direct Drafter Explorer window.

8.4.4 Setting the current text style

When you insert text in a drawing, the text is created using the current text style. You can also select a different text style when you create text.

To make the text style current

1. Do one of the following to choose Explore Text Styles:
   - On the ribbon, choose Tools > Text Styles (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Text Styles.
• On the Explorer toolbar, click the Explore Text Styles tool.
• Type expfonts and then press Enter.

2. In the Text Style Name list, click the style you want to make current.

3. Use one of the following methods to make the style the current style:
   • Choose Edit > Current.
   • Click the Current tool.
   • With the cursor in the right side of the window, right-click to display the shortcut menu, and choose Current.

4. To complete the command and return to your drawing, close the CAD.direct Drafter Explorer window.

Use a shortcut.

*You can also make a text style current by selecting it in the Text Style Name list and clicking the Current tool or by double-clicking the text style name in the Text Style Name list.*

### 8.5 Working with coordinate systems

A coordinate system is a system of points that represents the drawing space in relation to an origin (0,0,0) and a set of axes that intersect at the origin.

#### 8.5.1 Understanding coordinate systems

When you create entities in a drawing, they are located in relation to the drawing’s underlying Cartesian coordinate system. Every drawing has a fixed coordinate system called the World Coordinate System (WCS). You cannot delete or modify the WCS.

Your drawing may contain additional coordinate systems, however, each with its own 0,0,0 origin and orientation. You can create as many user coordinate systems as you want, and then save and recall them as you need them. You can edit the origin of a coordinate system from within the CAD.direct Drafter Explorer by single-clicking the origin coordinates and then typing new coordinates.

For example, you can create a separate user coordinate system (UCS) for each side of a building. Then, by switching to the UCS for the east side of the building, you can draw the windows on that side by specifying only their x- and y-coordinates.
You can create and then switch between various user coordinate systems by selecting Coordinate Systems in the CAD.direct Drafter Explorer.

8.5.2 Displaying coordinate system information in CADconv Connect Explorer

To display the Coordinate Systems element

Do one of the following to choose Explore Coordinate Systems:

- On the ribbon, choose Tools > Coordinate Systems (in Explorer).
- On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Coordinate Systems.
- Choose Tools > User Coordinate Systems > Explore Coordinate Systems.
- On the Explorer toolbar, click the Explore Coordinate Systems tool.
- Type `expucs` and then press Enter.
8.5.3 Defining and naming user coordinate systems

A drawing can contain as many coordinate systems as you want and can be named appropriate names, so you can remember how they are used in your drawing for recalling them later.

To define new user coordinate systems in the CAD.direct Drafter Explorer

1. Do one of the following to choose Explore Coordinate Systems.
   - On the ribbon, choose Tools > Coordinate Systems (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Coordinate Systems.
   - On the Explorer toolbar, click the Explore Coordinate Systems tool.
   - Type expucs and then press Enter.
2. Do one of the following:
   - Choose Edit > New > UCS.
   - Click the New Item tool.
   - With your cursor in the right side of the window, right-click to display the shortcut menu, and choose New > UCS.
3. Select a method from the prompt box or command bar by which to define the UCS in the drawing window.
   For example, select 3 Point and then specify three points in the drawing window to define the x, y, and z axes for your coordinate system.
4. Type the name for the new user coordinate system by typing over the highlighted default text, and then press Enter.
5. To complete the command, close the window.

8.5.4 Setting the current user coordinate system

When you draw new entities, they are created in relation to the current coordinate system. You can set the current UCS from the CAD.direct Drafter Explorer.

To set the current UCS from the CAD.direct Drafter Explorer

Do one of the following:
   - Double-click the UCS name in the UCS Name list.
   - Select the UCS in the UCS Name list, and then choose Edit > Current.
   - Select the UCS in the UCS Name list, and then click the Current tool.
8.6 Using named views

As you work on a drawing, you may find that you frequently switch among different portions of it. For example, if you are drawing the floor plan of a house, you may zoom in to particular rooms of the house and then zoom out to display the entire house. Although you can repeat the Pan and Zoom commands to do this, it is much easier to save various views of the drawing as named views. You can then quickly switch among these views. You can save and later restore named views using either the View command or the Views element in the CAD direct Drafter Explorer.

8.6.1 Displaying views in the CAD.direct Drafter Explorer

To display views in the CAD.direct Drafter Explorer

Do one of the following to choose Explore Views:

- On the ribbon, choose Tools > Views (in Explorer).
- Choose Tools > Explore Views.
- On the Explorer toolbar, click the Explore Views tool.
- Type expviews and then press Enter.
8.6.2 Saving and naming views

You can save the view displayed in the current window as a named view. After you save a named view, you can restore that view in the current window at any time.

To save the current view as a named view

1. Do one of the following to choose View Manager:
   - On the ribbon, choose View > View Manager (in Views).
   - Choose View > View Manager.
   - On the View toolbar, click the View Manager tool.
   - Type view and then press Enter.
2. Click New.
3. In Name, type a name for the view, and then click OK.
4. To complete the command and return to your drawing, close the window.

To save a portion of the current view as a named view

1. Do one of the following to choose Explore Views
   - On the ribbon, choose Tools > Views (in Explorer): 
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Views.
   - On the Explorer toolbar, click the Explore Views tool.
   - Type expviews and then press Enter.
2. Do one of the following:
   - Choose Edit > New > View.
   - On the CAD.direct Drafter Explorer toolbar, click the New Item tool.
3. In the prompt box, choose Window.
4. Specify the first corner of the view window.
5. Specify the opposite corner of the view window.
6. Rename the new view, and then press Enter.

Do not use spaces between words in the new view name.
7. To complete the command and return to your drawing, close the window.
To change a saved view name in the current drawing

1. Do one of the following to choose Explore Views:
   - On the ribbon, choose Tools > Views (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Views.
   - On the Explorer toolbar, click the Explore Views tool.
   - Type expviews and then press Enter.

2. Do one of the following
   - Select the view, choose Edit > Rename, type a new name, and then press Enter.
   - Click the view name you want to change, type a new name, and then press Enter.
   - Right-click the view name you want to change, and from the shortcut menu, select Rename, type a new name, and then press Enter.

8.6.3 Restoring named views

After you save one or more named views, you can restore any of those views in the current window using either the View command or the CAD.direct Drafter Explorer.

To restore a named view using the View command

1. Do one of the following to choose View Manager:
   - On the ribbon, choose View > View Manager (in Views).
   - On the menu, choose View > View Manager.
   - On the View toolbar, click the View Manager tool.
   - Type view and then press Enter.

2. Select the view you want to restore.

3. Click Set Current.

To restore a named view from the CAD.direct Drafter Explorer

Do one of the following:
   - Select the view name in the list of View settings, and then choose Edit > Current.
   - Select the view name in the list of View settings, and then click the Current tool().
   - Double-click the view name in the View list.
8.6.4 Changing named view properties

Once you create a named view you can modify its properties, such as the target direction and twist angle. This gives you access to many of the view settings after a view has been defined. Some properties are available directly in CAD.direct Drafter Explorer, while others are available in the Views Manager.

To change the view options

1. Do one of the following to choose Explore Views:
   
   - On the ribbon, choose Tools > Views (in Explorer).
   - On the menu, choose Tools > Explore Views.
   - On the Explorer toolbar, click the Explore Views tool.
   - Type expviews and then press Enter.

2. Click in the Height, Width, or Target Direction column for the view you want to change, and then make the changes.

3. To make additional changes, click the View Manager tool, change the desired settings, and then close the dialog box.

4. To complete the command and return to your drawing, close the window.

8.7 Working with layouts

Each drawing that you create contains the area where you do most of your work on the Model tab and can also contain numerous layouts on Layout tabs that simulate the paper on which you will print a copy of the drawing.

Using CAD.direct Drafter Explorer, you can manage the layouts in a drawing, assign a page setup, and you can also easily copy layouts to be reused in other drawings.

Making a layout active in CAD.direct Drafter Explorer is the equivalent of clicking its corresponding tab in the drawing window.
8.7.1 Displaying layouts in the CAD.direct Drafter Explorer

To display layouts in the CADconv Connect Explorer

Do one of the following to choose Explore Layouts:

- On the ribbon, choose Tools > Layouts (in Explorer).
- On the menu, choose Tools > Explore Layouts.
- On the Explorer toolbar, click the Explore Layouts tool.
- Type explayouts and then press Enter.
- Choose Tools > CAD.direct Drafter Explorer, and then click the Views element.
8.7.2 Creating and naming layouts

To display layouts in the CADconv Connect Explorer

Do one of the following to choose Explore Layouts: On the ribbon, choose Tools > Layouts (in Explorer).

- On the menu, choose Tools > Explore Layouts.
- On the Explorer toolbar, click the Explore Layouts tool.
- Type explayouts and then press Enter.
- Choose Tools > CAD.direct Drafter Explorer, and then click the Views element.

8.7.3 Creating and naming layouts

Each drawing can contain one layout for the model and up to 255 other layouts.

To create a new layout

1. Do one of the following to choose Explore Layouts:
   - On the ribbon, choose Tools > Layouts (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Layouts.
   - On the Explorer toolbar, click the Explore Layouts tool.
   - Type explayouts and then press Enter.

2. Do one of the following:
   - Choose Edit > New > Layout.
   - Click the New Item tool.

A new layout is added to the layouts list with a default name

3. Type the name for the new layout by typing over the highlighted default text, and then press Enter.

4. To complete the command, close the window.

To change a layout name using CAD.direct Drafter Explorer

1. Do one of the following to choose Explore Layouts:
   - On the ribbon, choose Tools > Layouts (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Layouts.
• On the Explorer toolbar, click the Explore Layouts tool.
• Type explayouts and then press Enter.

2. Do one of the following:
• Select the layout, choose Edit > Rename, type a new name, and then press Enter.
• Click the layout name you want to change, type a new name, and then press Enter.
• Right-click the layout name you want to change, and from the shortcut menu, select Rename, type a new name, and then press Enter.

3. To complete the command and return to your drawing, close the window.

8.7.4 Specifying page setup options for a layout

Each layout can have its own page setup assigned to it. This enables you to accommodate unique print settings for each layout. If some layouts use the same print settings, those layouts can be assigned the same page setup.

Assigning a page setup to a model or layout doesn’t mean it will always print with the specified settings. All of the print settings specified for a page setup can be overridden at print time.

For more details about page setups, see “Working with page setups” on page 462.

To assign a page setup to a layout

1. Do one of the following to choose Explore Layouts:
   • On the ribbon, choose Tools > Layouts (in Explorer).
   • On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Layouts.
   • On the Explorer toolbar, click the Explore Layouts tool.
   • Type explayouts and then press Enter.

2. Click in the Page Setup column for the desired layout.

3. Select the desired page setup, click Set Current, then click Close.

4. To complete the command, close the CAD.direct Drafter Explorer window.
To modify the settings of an assigned page setup

1. Do one of the following to choose Explore Layouts:
   - On the ribbon, choose Tools > Layouts (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Layouts.
   - On the Explorer toolbar, click the Explore Layouts tool.

2. Click in the Page Setup column for the desired layout.

3. Select the page setup that requires changes, then click Modify.

4. Select the new options, then click OK.

5. If necessary, select the page setup that you want to assign to the layout, then click Set Current.

6. Click Close.

7. To complete the command, close the CAD.direct Drafter Explorer window.

8.8 Working with blocks

Blocks represent a special type of entity that, once saved, can be inserted and manipulated in the drawing as a single entity.

8.8.1 Understanding blocks

A block can consist of visible entities such as lines, arcs, and circles as well as visible or invisible data called attributes. You can use attributes to track things such as part numbers and prices and to export attribute information to an external database. You can also track the number of parts by counting the number of times a block has been inserted into the drawing. Blocks are stored as part of the drawing file.

External references have similar uses to blocks. Using external references, you can attach entire drawings to your current drawing. Unlike a block, however, an external reference does not become part of the current drawing.

You can save blocks in the CAD.direct Drafter Explorer. You can also use the CAD.direct Drafter Explorer to manage and insert copies of blocks. The CADconv Connect Explorer lists the names of all blocks contained in the current drawing, along with other information about each block or external reference.

You can also rename a block, modify its insertion point, and change the path of an externally referenced drawing by single-clicking on the property and making your edits within the CAD.direct Drafter Explorer.
8.8.2 Displaying block information in CAD.direct Drafter Explorer

To display blocks in the CAD.direct Drafter Explorer

Do one of the following to choose Explore Blocks:

- On the ribbon, choose Tools > Blocks (in Explorer).
- On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Blocks.
- On the Explorer toolbar, click the Explore Blocks tool.

Type `expblocks` and then press Enter.

The Blocks element in the CAD.direct Drafter Explorer defaults with icons on. The Icons view shows you a small image of each block.

![IntelliCAD Explorer - Blocks](image)

The Images view shows an image of each block in the selected drawing. Click an image to select it.

When blocks are displayed, additional tools on the Block toolbar provide the functions described in the following table:
### Additional tools on the Block toolbar

<table>
<thead>
<tr>
<th>Tool</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icons" /> <a href="image">Icons</a></td>
<td>Displays an image of each block.</td>
</tr>
<tr>
<td><img src="image" alt="Details" /> <a href="image">Details</a></td>
<td>Displays information about each block.</td>
</tr>
<tr>
<td><img src="image" alt="Insert" /> <a href="image">Insert</a></td>
<td>Inserts a block.</td>
</tr>
</tbody>
</table>

### Additional tools on the Block toolbar

<table>
<thead>
<tr>
<th>Tool</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Insert External File Block" /></td>
<td>Inserts a drawing available from disk as a block.</td>
</tr>
<tr>
<td><img src="image" alt="Save Block" /> <a href="image">Save Block</a></td>
<td>Saves the selected block as an independent.dwg file.</td>
</tr>
<tr>
<td><img src="image" alt="Edit Block Reference" /></td>
<td>Redefines the definition of a block.</td>
</tr>
</tbody>
</table>

To see more information about each block, click the Details tool. In the Details view, you can edit the path and the insertion point by clicking the setting and typing your changes.
8.8.3 Creating and naming blocks

You can combine any number of entities into a single block. After you create a block, you can insert copies of it into a drawing. Each block insertion is treated as a single entity; for example, you can rotate or scale each block when you insert it. The program adds the name of the new block you insert to the Block Name list in the CAD.direct Drafter Explorer.

To create a block

1. Do one of the following to choose Explore Blocks:
   - On the ribbon, choose Tools > Blocks (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Blocks.
   - On the Explorer toolbar, click the Explore Blocks tool.
   - Type `expblocks` and then press Enter.
2. Do one of the following:
   - Choose Edit > New > Block.
   - On the CAD.direct Drafter Explorer toolbar, click the New Item tool.

3. In the Block definition dialog box, enter a name and description for the new block.

4. Specify the insertion point for the block by doing one of the following:
   - Specify on Screen Mark this check box to select the base point in the drawing after you click OK.
   - Pick Base Point Click to temporarily close the dialog box immediately, select the base point in the drawing, then return to the dialog box. This option is available only if Specify on Screen is not marked.
   - X, Y, and Z Enter the x-, y-, and z- coordinates of the base point. This option is available only if Specify on Screen is not marked.

5. Select the entities to be combined into the block by doing one of the following:
   - Specify on Screen Mark this check box to select the entities in the drawing after you click OK.
   - Select entities Click to temporarily close the dialog box immediately, select the entities in the drawing, then return to the dialog box. Or you can click to select entities by type or value. This option is available only if Specify on Screen is not marked.

6. Select what to do with the entities after the block is created:
   - Retain entities Entities selected for the block remain in the drawing.
   - Convert to block Entities selected for the block are converted to the block, which remains in the drawing.
   - Delete entities Entities selected for the block are removed from the drawing.

7. Select any of the following options for the block:
   - Annotative Determines whether the block is annotative by default. The display and printing of annotative blocks is affected by annotation scaling. If annotative by default, you can determine whether the block, when located in paper space, is oriented automatically according to the layout viewport.
   - Scale uniformly Mark this check box to retain the aspect ratio if the block is scaled. Annotative blocks must be scaled proportionately.
   - Allow exploding Mark this check box to allow the block to be exploded into separate entities.
   - Unit Defines the unit of the block, for example inches or millimeters.

8. Click OK.

The program adds a new block to the blocks list, with the name you entered for it.
To change a block name in the current drawing

1. Do one of the following to choose Explore Blocks:
   - On the ribbon, choose Tools > Blocks (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Blocks.
   - On the Explorer toolbar, click the Explore Blocks tool.
   - Type expblocks and then press Enter.

2. Do one of the following
   - Select the block, choose Edit > Rename, type a new name, and then press Enter.
   - Click the block name you want to change, type a new name, and then press Enter.
   - Right-click the block name you want to change, and from the shortcut menu, select Rename, type a new name, and then press Enter.

3. To complete the command and return to your drawing, close the window.
8.8.4 Inserting a block

You can insert into a drawing any block listed in the Block Name list in the CAD.direct Drafter Explorer. This includes blocks contained within any open drawing.

To insert a block

1. Do one of the following to choose Explore Blocks:
   - On the ribbon, choose Tools > Blocks (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Blocks.
   - On the Explorer toolbar, click the Explore Blocks tool.
2. If you want to insert a block from another open drawing, select the drawing in the left side of the CAD.direct Drafter Explorer window. (If the block is contained within the same drawing, you can skip this step.)
3. Select the block to be inserted.
4. On the CAD.direct Drafter Explorer toolbar, click the Insert tool. 5 In the drawing, specify the insertion point.
5. Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, select Done.
6. To complete the command and return to your drawing, close the window.

Use a shortcut. You can insert a block by choosing Tools > CAD.direct Drafter Explorer, and then double-clicking the name of the block you want to insert in the Block Name list. And, you can also insert a block from the Insert menu, see Chapter 13, “Working with other files in your drawings.”

8.8.5 Inserting a drawing as a block

You can insert another drawing as a block into the current drawing. After you do this, the block name is added to the Block Name list in the CAD.direct Drafter Explorer. Changes made later to the inserted drawing will not be reflected in this drawing.

To insert a drawing as a block

1. Do one of the following to choose Explore Blocks:
   - On the ribbon, choose Tools > Blocks (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Blocks.
   - On the Explorer toolbar, click the Explore Blocks tool.
   - Type `expblocks` and then press Enter.
2. On the CADconv Connect Explorer toolbar, click the Insert External File Block tool.
3. In the Insert Block dialog box, select the drawing you want to insert, and then click Open.
4. In the drawing, specify the insertion point.
5. Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, select Done.
6. To complete the command and return to your drawing, close the window.

8.8.6 Saving a block as a separate drawing

You can save a block as a separate drawing, and then you can open and modify that drawing as you would any other drawing.

To save a block as a separate drawing file

1. Do one of the following to choose Explore Blocks:
   - On the ribbon, choose Tools > Blocks (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Blocks.
   - On the Explorer toolbar, click the Explore Blocks tool.
   - Type `expblocks` and then press Enter.
2. Select the block you want to save.
3. On the CADconv Connect Explorer toolbar, click the Save Block too.
4. In the Save Block dialog box, select the folder in which you want to save the block.
5. In the File Name field, type a name for the new drawing file (or accept the default, in which case the new drawing name is the same as the name of the block), and then click Save.

8.9 Working with references to external files

In CAD.direct Drafter Explorer, you can work with any file that is referenced from an open drawing. In addition to commonly used xrefs, or externally referenced drawing files, you can also manage raster images, .dwf files, .dgn files, .pdf files, and point clouds directly from CAD.direct Drafter Explorer.

When you reference an external file from a drawing, the contents of referenced file appear in the current drawing, but the contents themselves are not added to the drawing.
8.9.1 Displaying information about referenced files in CAD.direct Drafter Explorer

To display information about referenced files

1. Do one of the following to choose Explore External References:
   - On the ribbon, choose Tools > External References (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore External References.
   - On the Explorer toolbar, click the Explore External References tool.
   - Type `exprefs` and then press Enter.

2. Do one of the following:
   - Click the Icons tool ( ) to see a small image of each referenced file,
   - Click the Details tool ( ) to see more detailed information about each block.

---

**Diagram Description:**
- **A**: Click to display the externally referenced file settings.
- **B**: Lists names of files referenced from the current drawing.
- **C**: Displays the load status of the file in the current drawing.
- **D**: Displays the number of times the file is referenced from the current drawing.
- **E**: Displays the size of the file.
- **F**: Displays the type of file.
- **G**: Displays the date of the file.
- **H**: Displays the location of the file.
- **I**: Click a column title to sort by category.
8.9.2 Attaching referenced files

To attach an externally referenced file
1. Do one of the following to choose Explore External References:
   - On the ribbon, choose Tools > External References (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > External References.
   - On the Explorer toolbar, click the Explore External Reference tool.
   - Type `exprefs` and then press Enter.
2. Do one of the following:
   - Choose Edit > New > External Reference.
   - On the CAD.direct Drafter Explorer toolbar, click the New Item tool.
3. In Files of type, select the type of file to attach, then click Open.
4. Specify the insertion point for the file and complete the additional prompts.
5. To complete the command and return to your drawing, close the window.

8.9.3 Modifying the settings for referenced files

Any referenced file can be modified from the CAD.direct Drafter Explorer, including renaming, linking to a new location, clipping, and more.

To change the name of a referenced file in the current drawing
1. Do one of the following to choose Explore External References:
   - On the ribbon, choose Tools > External References (in Explorer).
   - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore External References.
   - On the Explorer toolbar, click the Explore External Reference tool.
Type `exprefs` and then press Enter.
2. Do one of the following:
   • Select the file, choose Edit > Rename, type a new name, and then press Enter.
   • Click the file name you want to change, type a new name, and then press Enter.
   • Right-click the file name you want to change, and from the shortcut menu, select Rename, type a new name, and then press Enter.

3. To complete the command and return to your drawing, close the window.

To change the name of a referenced file in the current drawing

1. Do one of the following to choose Explore External References:
   • On the ribbon, choose Tools > External References (in Explorer).
   • On the menu, choose Tools > CAD.direct Drafter Explorer > Explore External References.
   • On the Explorer toolbar, click the Explore External Reference tool.
   • Type exprefs and then press Enter.

2. Do one of the following:
   • Select a file in the list, choose Edit, then the desired option
   • Right-click the desired file, and from the shortcut menu, select the desired option.
   • Click either the Image Manager tool or the Xref Manager tool.

3. To complete the command and return to your drawing, close the window.

For more details about working with external references, see “Working with external references” on page 421.
8.10 Working with dimension styles

From CAD.direct Drafter Explorer, you can use the Dimension Styles element to cut, copy, and paste dimension styles from one drawing to another.

A dimension style contains the settings that control the appearance of a dimension. Although you cannot control these settings from within the CAD.direct Drafter Explorer, you can use the Dimension Styles dialog box to control settings related to the appearance of arrows, lines, text, units, and other formatting characteristics.

8.10.1 Displaying dimension style information in CAD.direct Drafter Explorer

To display the CAD.direct Drafter Explorer Dimension Styles element

- Do one of the following to choose Explore Dimension Styles:
  - On the ribbon, choose Tools > Dimension Styles (in Explorer).
  - On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Dimension Styles.
  - On the Explorer toolbar, click the Dimension Styles tool.
  - Type setdim and then press Enter.
8.10.2 Creating and naming dimension styles

By using the Dimension Styles element in combination with the Dimension Styles dialog box, you can create new dimension styles, modify them, and copy them into a different drawing.

To create a dimension style

1. Do one of the following to choose Explore Dimension Styles:
   • On the ribbon, choose Tools > Dimension Styles (in Explorer).
   • On the menu, choose Tools > CAD.direct DrafterExplorer > Explore Dimension Styles.
   • On the Explorer toolbar, click the Explore Dimension Styles tool.
   • Type expdimstyles and then press Enter

2. In the Dimension Styles Manager dialog box, click New.

3. Type the name of the new dimension style.

4. Click the Edit icon for the new dimension style.

5. In the Modify Dimension Styles dialog box, select the desired options.

6. Click OK.

To change a dimension style name in the current drawing

1. Do one of the following to choose Explore Dimension Styles:
   • On the ribbon, choose Tools > Dimension Styles (in Explorer).
   • On the menu, choose Tools > CAD.direct DrafterExplorer > Explore Dimension Styles.
   • On the Explorer toolbar, click the Explore Dimension Styles tool.
   • Type expdimstyles and then press Enter.

2. Do one of the following
   • Select the dimension style, choose Edit > Rename, type a new name, and then press Enter.
   • Click the dimension style name you want to change, type a new name, and then press Enter.
   • Right-click the dimension style name you want to change, and from the shortcut menu, select Rename, type a new name, and then press Enter.

3. To complete the command and return to your drawing, close the window.
8.10.3 Copying dimension styles

You can copy and paste dimension styles between drawings. In addition to the steps below, you can also select a dimension style and use the Windows shortcut keys (Ctrl+A to select all, Ctrl+X to cut, Ctrl+C to copy, Ctrl+V to paste) to copy it in CADconv Connect Explorer. You can use these shortcut keys with all other CAD.direct Drafter Explorer elements as well.

To copy a dimension style from one drawing to another

1. Do one of the following to choose Explore Dimension Styles:
   - On the ribbon, choose Tools > Dimension Styles (in Explorer).
   - On the menu, choose Tools > CAD.direct DrafterExplorer > Explore Dimension Styles.
   - On the Explorer toolbar, click the Explore Dimension Styles tool.
   - Type `expdimstyles` and then press Enter.
2. Right-click the dimension style name you want to copy.
3. From the shortcut menu, select Copy.
4. In the left pane, select the drawing to which you want to copy the dimension style.
5. Click the Dimension Styles element for that drawing.
6. In the right pane, right-click, and then from the shortcut menu, select Paste.

Each drawing contains a dimension style named Standard.

You cannot delete this dimension style, but you can rename it from within the CAD.direct Drafter Explorer or modify its properties in the Dimension Styles dialog box.
8.11 Working with groups

In CAD.direct Drafter Explorer, you can manage groups — collections of entities saved together as one unit — that exist in an open drawing, create new groups, manage the entities contained in a group, and change the settings of groups.

8.11.1 Displaying information about groups in d Explorer

To display groups in CAD.direct Drafter Explorer

Do one of the following to choose Explore Groups:

- On the ribbon, choose Tools > Groups (in Explorer).
- On the menu, choose Tools > CAD.direct Drafter Explorer > Explore Groups.
- On the Format toolbar, click the Explore Groups tool.
- Type expgroups and then press Enter.

8.11.2 Creating a new group using CAD.direct Drafter Explorer

To create a new group using CAD.conv Connect Explorer

1. Do one of the following:
   - Choose Edit > New > Group.
   - On the CAD.direct Drafter Explorer toolbar, click the New Item tool. A new group is added as Anonym-
   
mous.

2. Type the name for the new group by typing over the highlighted default text, and then press Enter.

3. Click the [+] tool to select the entities to be included in the group; click the [-] tool to select the entities to remove from the group.

   You can also click the Number of Entities column and choose Add Entities or Remove Entities.

4. Press Enter when done selecting entities.

5. To complete the command, close the window.
8.11.3 Modifying groups

To modify a group using CAD.direct Drafter Explorer

1. In Explorer, select Groups.

2. To rename a group, do one of the following:
   - Select the group, choose Edit > Rename, type a new name, and then press Enter.
   - Right-click the group name you want to change, and from the shortcut menu, select Rename, type a new name, and then press Enter.

3. To add entities to a group, select the group and click the [+] tool, select the entities in the drawing to be included in the group, then press Enter when done selecting entities.

4. To remove entities from a group, select the group and click the [-] tool, select the entities in the drawing to remove from the group, then press Enter when done selecting entities.

5. To make a group selectable or unselectable in the drawing, click Selectable for it.

6. To reorder the entities in a group, select the group and click the Reorder tool, make you selections, then click OK.

7. To select a group in the drawing and have that group highlighted in the list of groups, click the Highlight tool, select the desired group, then press Enter. The appropriate group will be highlighted in the list.

8. To complete the command, close the window.

For more details about working with groups, see “Grouping entities” on page 324.
9. Getting drawing information

CAD.direct Drafter stores accurate, detailed information about all the entities in a drawing. You can get details about an existing drawing and its entities using the tools for measuring distances and calculating areas. You can also track the amount of time you spend editing a drawing. This section explains how to:

- Measure distances along an entity.
- Measure distances and angles.
- Divide an entity into several equal segments.
- Calculate areas.
- Display information about entities in a drawing.
- Track the amount of time spent editing a drawing.

Many of the functions described in this section require that you set CAD.direct Drafter to the Advanced experience level.

9.1 Specifying measurements and divisions

You can divide a line, arc, circle, polyline, ellipse, or spline into a number of equal segments or mark off intervals of a specific length along an entity. (Note that divide is not the same as break.) For example, you may want to place station-point markers every 50 feet along the centerline of a roadway or divide the plan view of a window into three equal-width sections of glass, placing a mullion at each division point.

9.1.1 Understanding measurements and divisions

To specify measurements and divisions, use these commands:

- For the length of the segments, use the Measure command.
- For the number of equal-length segments, use the Divide command.

You can measure or divide arcs, circles, lines, polylines, ellipses, and splines. With either command, you can identify the segments by placing either a block or point entity at the end of each interval. If you use points, you can snap to the ends of intervals using the point entity snap. The appearance of the point entities is determined by the current point display type, which you control in the Drawing Settings dialog box.

To use a block as the marker, the block must already be defined in the current drawing. You can further indicate whether to rotate the block to align perpendicularly to the entity you are measuring or dividing.
CAD.direct Drafter begins measuring or dividing based on the point at which you select the entity and the type of entity with which you are working. For most entities, measuring starts from the endpoint closest to the point you used to select the entity. If you select the entity to be measured or divided using a method other than pointing (for example, using a window or fence selection), the program prompts you to specify the end from which you want to begin measuring.

9.1.2 Measuring intervals on entities

You can mark specified length increments along a selected entity using either a point entity or a block.

To measure intervals along an entity and mark them using point entities
Advanced experience level

1. Do one of the following to choose Measure:
   • On the ribbon, choose Edit > Measure (in Modify).
   • On the menu, choose Modify > Measure.
   • On the Modify toolbar, click the Measure tool.
   • Type measure and then press Enter.

2. Select the entity.

3. Specify the segment length, and then press Enter.
To measure intervals along an entity and mark them using blocks

Advanced experience level

1. Do one of the following to choose Measure:
   • On the ribbon, choose Edit > Measure (in Modify).
   • On the menu, choose Modify > Measure.
   • On the Modify toolbar, click the Measure tool.
   • Type measure and then press Enter.

2. Select the entity.

3. In the prompt box, choose Insert Blocks.

4. Type the name of the block you want to insert as the marker.

5. In the prompt box, choose either Yes-Align Blocks to rotate each insertion of the block so that its vertical alignment is always perpendicular to the entity or No-Do Not Align to insert each copy of the block with a zero-rotation angle.

6. Specify the segment length, and then press Enter.
9.1.3 Dividing entities into segments

You can place markers along a selected entity, dividing that entity into a specified number of equal-length segments. You can use either a point entity or a block to mark the segments.

**To divide an entity into segments and mark them using point entities**

Advanced experience level

1. Do one of the following to choose Divide:
   - On the ribbon, choose Edit > Measure (in Modify).
   - On the menu, choose Modify > Divide.
   - On the Modify toolbar, click the Divide tool.
   - Type divide and then press Enter.

2. Select the entity.

3. Specify the number of segments, and then press Enter.

![Diagram of dividing an entity into segments with point entities](image)

When you select the entity by pointing, divisions are marked beginning from the end closest to the point at which you select the entity (A). Blocks or point entities (B) are placed along the entity to mark it in equal intervals.

**To divide an entity into segments and mark them using blocks**

Advanced experience level

1. Do one of the following to choose Measure:
   - On the ribbon, choose Edit > Measure (in Modify).
   - On the menu, choose Modify > Divide.
   - On the Modify toolbar, click the Divide tool.
   - Type divide and then press Enter.
2. Select the entity.

3. In the prompt box, choose Insert Blocks.

4. Type the name of the block you want to insert as the marker.

5. In the prompt box, choose either Yes-Align Blocks to rotate each insertion of the block so that its vertical alignment is always perpendicular to the entity or No-Do Not Align to insert each copy of the block with a zero-rotation angle.

6. Specify the number of segments, and then press Enter.

9.2 Calculating areas

You can calculate the area and perimeter of a polygon based on a series of points you specify or enclose with a circle or closed polyline. You can also determine the area of several combined entities and add or subtract the area of one or more entities from a total combined area.

9.2.1 Calculating areas defined by points

You can find the area and perimeter of any closed region by specifying a series of points. The program calculates the area and perimeter of the space that is enclosed by an imaginary polygon consisting of straight-line segments connecting each point.

To calculate the area defined by points you specify

1. Do one of the following to choose Area:
   - On the ribbon, choose Tools > Area (in Inquiry).
   - On the menu, choose Tools > Inquiry > Area.
   - On the Inquiry toolbar, click the Area tool.
   - Type area and then press Enter.

2. Specify the first point.

3. Specify the second point.

4. Continue specifying points in sequence to define the perimeter of the area you want to measure.

As you select each successive point, the resulting polygon is displayed on the screen.
To complete the calculation, press Enter.

The area and perimeter of the region you defined are displayed. For example, the following type of information is displayed:

Area = 11.0583, Perimeter = 15.3092

9.2.3 Calculating areas of closed entities

You can find the area of any closed entity. In addition, the program calculates either the circumference or the perimeter of the entity, depending on the type of entity you select.

To calculate the area of a closed entity

1. Do one of the following to choose Area:
   - On the ribbon, choose Tools > Area (in Inquiry).
   - On the menu, choose Tools > Inquiry > Area.
   - On the Inquiry toolbar, click the Area tool.
   - Type area and then press Enter.
2. In the prompt box, choose Find Area Of One Entity.

3. Select the entity.

The following type of information is displayed:

\[ \text{Area} = 62.3837, \text{Circumference} = 27.9989 \]

### 9.2.4 Calculating combined areas

You can find the total area of several combined regions by specifying points or by selecting entities. You can also subtract the areas of entities or polygons from a running total.

**To add areas to calculate a combined area**

1. Do one of the following to choose Area:
   - On the ribbon, choose Tools > Area (in Inquiry).
   - On the menu, choose Tools > Inquiry > Area.
   - On the Inquiry toolbar, click the Area tool.
   - Type area and then press Enter.

2. In the prompt box, choose Add Areas Together.

3. Using one of the following methods, identify the first area:
   - Specify points defining a polygon, and then in the prompt box, choose Done Specifying Area.
   - In the prompt box, choose Add Entities To Area, select the entities you want to add, and then press Enter to complete the calculations.

4. To complete the command, choose Done in the prompt box.

**To subtract areas when calculating a combined area**

1. Do one of the following to choose Area:
   - On the ribbon, choose Tools > Area (in Inquiry).
   - On the menu, choose Tools > Inquiry > Area.
   - On the Inquiry toolbar, click the Area tool.
   - Type area and then press Enter.

2. In the prompt box, choose Add Areas Together.
3. Using one of the following methods, identify the first area:
   - Specify points defining a polygon, and then in the prompt box, choose Done Specifying Area.
   - In the prompt box, choose Add Entities To Area, select the entities you want to add, and then press Enter to complete the calculations.

4. In the prompt box, choose Subtract Areas.

5. Using one of the following methods, identify the area to be subtracted:
   - Specify points defining a polygon, and then in the prompt box, choose Done Specifying Area.
   - In the prompt box, choose Subtract Entities From Area, select the entities you want to subtract, and then press Enter to complete the calculations.

6. To complete the command, choose Done in the prompt box.

To calculate the area of the gasket using the Area command, first add the area of the entire gasket (A), and then subtract the areas of the two circles (B and C).
9.2.5 Viewing calculated area details

As you select entities, the program displays the calculations. If the command bar is displayed, the information appears there. If the command bar is not displayed, the program opens the Prompt History window and displays the calculations. The following type of information is an example of what is displayed:

*Entity • Add • Subtract • <First point>: Choose Add Areas Together*
*Adding: Entity • Subtract • <First point>: Choose Add Entities to Area*
*Adding area: <Select entities>: Select the first entity*
*Area = 64.6259, Perimeter = 33.3049*
*Total length = 33.3049*
*Total area = 64.6259*
*Adding area: <Select entities>: press Enter*
*Adding: Entity • Subtract • <First point>: Choose Subtract Areas*
*Subtracting: Entity • Add • <First point>: Choose Subtract Entities from Area*
*Subtracting area: <Select entities>: Select the first entity to subtract*
*Area = 3.1597, Circumference = 6.3012*
*Total length = 27.0036*
*Total area = 61.4662*
*Subtracting area: <Select entities>: Select the second entity to subtract*
*Area = 3.1597, Circumference = 6.3012*
*Total length = 20.7024*
*Total area = 58.3066*
*Subtracting area: <Select entities>: Press Enter*
*Subtracting: Entity • Add • <First point>: Choose Done*

9.3 Calculating distances and angles

You can calculate the distance between any two points you select to determine the following information:

- The distance between the points, measured in drawing units.
- Their angle in the xy plane.
- Their angle measured from the xy plane.

The change (delta) in the x, y, and z distances between the two points.
9.3.1 Calculating the distance between two points and their angle

When calculating the distance between points, it is often helpful to use entity snaps to specify precise points.

To calculate the distance between two points and their angle

1. Do one of the following to choose Distance:
   - On the ribbon, choose Tools > Distance (in Inquiry).
   - On the menu, choose Tools > Inquiry > Distance.
   - On the Inquiry toolbar, click the Distance tool.
   - Type distance and then press Enter.

2. Specify the first point.

3. Specify the second point.

Use the Distance command to calculate the distance (A) between two points (B and C), the angle in the xy plane (D), the angle from the xy plane, and the delta x (E), delta y (F), and delta z distances between the two points.
9.3.2 Viewing calculated distance details

As you select entities, the program displays the calculations. If the command bar is displayed, the information appears there. If the command bar is not displayed, the program opens the Prompt History window and displays the calculations. The following type of information is an example of what is displayed:

\[ \text{Distance} = 13.2850, \text{Angle in XY Plane} = 31^\circ, \text{Angle from XY Plane} = 0^\circ \]
\[ \text{Delta X} = 11.3878, \text{Delta Y} = 6.8418, \text{Delta Z} = 0.0000 \]

9.4 Displaying information about your drawing

You can display a variety of information about a drawing and the entities it contains, including:

- Information in the drawing database about selected entities.
- The current drawing status.
- The time spent working on the drawing.

This information is displayed in the Prompt History window and in the command bar.

9.4.1 Displaying information about entities

You can display information about the selected entities. The information varies, depending on the type of entities you select. All the listings display the following information:

- Entity type.
- Layer.
- Color.
- Linetype.
- The location of the entity (its xyz-coordinates relative to the current user coordinate system [UCS]).
- The current space (model space on the Model tab or paper space on a Layout tab).
- The size of the entity (the information varies, depending on the entity type).

To display information about an entity

Advanced experience level

1. Do one of the following to choose List Entity Info:
   - On the ribbon, choose Tools > List Entity Info (in Inquiry).
• On the menu, choose Tools > Inquiry > List Entity Info.
• On the Inquiry toolbar, click the List Entity Info tool.
• Type list and then press Enter.

2. Select one or more entities.

3. Press Enter.

Use a shortcut.

To return to the drawing window, press F2.

The following type of information is displayed:

------ Circle ---------------------------------------------------
Handle: 2C
Current space: Model
Layer: 0
Color: BYLAYER
Linetype: CONTINUOUS
Handle: 4C
Current space: Model
Center point: X= -5.8583 Y= 7.2752 Z= 0.0000
Radius: 4.4562
Circumference: 27.9989
Area: 62.3837

9.4.2 Displaying the drawing status

You can display information about the status of a drawing, including:

• Drawing name.
• Limits.
• Insertion base point.
• Snap and grid settings.
• Current layer, color, and linetype.
• Current settings for various modes (fill, grid, orthogonal, snap, blips, and so on).
To display the drawing status
Advanced experience level

Do one of the following to choose Drawing Status:

- On the Inquiry toolbar, click the Drawing Status tool.
- Type status and then press Enter.

The following type of information is displayed:

Current drawing name: Site Plan

*Drawing limits are:* X=0.0000 Y=0.0000 Z=0.0000
X=12.0000 Y=9.0000 Z=0.0000
*Paper space limits are:* X=0.0000 Y=0.0000 Z=0.0000
X=12.0000 Y=9.0000 Z=0.0000
*Screen width (pixels):* 971
*Screen height (pixels):* 569
*Insertion base is:* X=0.0000 Y=0.0000 Z=0.0000
*Snap resolution is:* X=0.5000 Y=0.5000 Z=0.0000
*Grid spacing is:* X:0.5000 Y:0.5000 Z=0.0000
*Current layer:* 0
*Current color:* BYLAYER
*Current linetype:* BYLAYER
*Current elevation:* 0.0000
*Current thickness:* 0.0000
*Fill:* on
*Grid:* off
*Ortho:* off
*Snap:* off
*Blips:* off
*Drag:* on
*Command echo:* on
*Positive angle direction:* Counterclockwise
*Angular units:* Decimal degrees
*Dimension units:* Decimal
*Pick box height:* 3
*Entities in drawing:* 288
9.4.3 Tracking time spent working on a drawing

You can display information about the amount of time you have spent working on a drawing, including:

- The date and time the drawing was created.
- The date and time the drawing was most recently saved.
- The total amount of time spent working on the drawing.
- The time spent working on the drawing during the current editing session.

You can turn the elapsed-time timer on and off or reset it to zero.

**To display the timer information**

Advanced experience level

1. Do one of the following to choose Time Variables:
   - On the Inquiry toolbar, click the Time Variables tool.
   - Type time and then press Enter.

2. Select any of the prompt box options:
   - Choose Timer On to turn the elapsed time on.
   - Choose Timer Off to turn the elapsed time off.
   - Choose Display Timer to redisplay the timer information.
   - Choose Reset Timer to reset the elapsed time to zero.

3. In the prompt box, choose Cancel to exit the command.

Each time you display the timer information, the following type of information is displayed:

*The current time is Fri Dec 19 09:58:43 1997*
*Drawing was created on: Wed 17 Dec 1997 at 16:17:59.8090*
*Drawing was last updated on: Thur 18 Dec 1997 at 09:58:43.3040*
*Total editing time: 1 2: 35:4.2345*
*Elapsed timer (on): 0 1: 21:5.6324*
10. Modifying entities

CAD.direct Drafter provides many editing tools for modifying a drawing. You can easily move, rotate, or stretch drawing entities, or change their scale. When you want to remove an entity, you can delete it with a few clicks of the mouse. You can also make multiple copies of any entity and copy entities from one drawing to another.

You can modify most entities using general-purpose editing commands. Some complex entities require special commands. This section explains how to:

- Select entities using entity-selection methods and grips.
- Change the properties of entities.
- Rearrange entities by moving, rotating, or changing the display order.
- Resize entities by stretching, scaling, extending, trimming, or editing their lengths. Split and combine entities by breaking, joining, exploding, and grouping them.
- Edit polylines.
- Create chamfers and fillets.

10.1 Selecting entities

You can create a selection set that consists of one or more entities for modification. Use any of the following methods to create a selection set:

- Choose a command or tool first, and then select entities.
- Select entities first, and then choose a command or tool (most entities).
- Select entities by pointing, and then use grips to modify them.
10.1.1 Understanding when to select entities

You can select entities before or after you choose a command.

Selecting entities first

When you select entities and then issue a command, the program immediately acts on the entities you’ve selected. In many cases, a command-specific prompt box provides additional options for that editing operation. If you want to modify the selection set at that point, right-click to display the prompt box with the selection options and choose the option you want. To redisplay the command-specific prompt box, right-click again.

After you select one or more entities, you can choose an entity-modification command, such as the Copy or Move command. You can also click the right mouse button to display a shortcut menu containing the entity-modification commands appropriate for the selected entities, and then choose the command from the menu.

Choosing a command first

When you choose an entity-modification tool or command first, the program prompts you to select entities and displays a prompt box from which you can choose a selection method. You can select individual entities or use other techniques such as selection windows to select multiple entities.

When you select entities, you add them to the selection set. After you select at least one entity, you can remove entities from the selection set. To finish adding entities to the selection set, press Enter. Most entity-modification commands then act on the entire selection set.

10.1.2 Understanding entity-selection methods

When you choose a command that requires you to select entities (when you’re deleting or changing entity properties, for example), you can use any of the following selection methods by choosing them in the prompt box or entering them in the command bar:
<table>
<thead>
<tr>
<th>Selection method</th>
<th>Command bar</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select all entities</td>
<td>ALL</td>
<td>Selects all entities in the current drawing.</td>
</tr>
<tr>
<td>Add to set</td>
<td>+ or A</td>
<td>Adds one or more entities to the selection set.</td>
</tr>
<tr>
<td>Subtract from set</td>
<td>- or R</td>
<td>Removes one or more entities from the selection set.</td>
</tr>
<tr>
<td>Previous selection</td>
<td>P</td>
<td>Selects entities included in the previous selection set.</td>
</tr>
<tr>
<td>Last entity in drawing</td>
<td>L</td>
<td>Selects the entity most recently added to the drawing.</td>
</tr>
<tr>
<td>Window-Inside</td>
<td>W</td>
<td>Selects entities contained entirely within a rectangular selection window.</td>
</tr>
<tr>
<td>Crossing window</td>
<td>C</td>
<td>Selects entities contained within or crossing the boundary of a rectangular selection window.</td>
</tr>
<tr>
<td>Outside window</td>
<td>O</td>
<td>Selects entities falling completely outside a rectangular selection window.</td>
</tr>
<tr>
<td>Window polygon</td>
<td>WP</td>
<td>Selects entities contained entirely within a polygon selection window.</td>
</tr>
<tr>
<td>Crossing polygon</td>
<td>CP</td>
<td>Selects entities contained within or crossing the boundary of a polygon selection window.</td>
</tr>
<tr>
<td>Outside polygon</td>
<td>OP</td>
<td>Selects entities falling completely outside a polygon selection window.</td>
</tr>
<tr>
<td>Window circle</td>
<td>WC</td>
<td>Selects entities contained entirely within a circular selection window.</td>
</tr>
<tr>
<td>Crossing circle</td>
<td>CC</td>
<td>Selects entities contained within or crossing the boundary of a circular selection window.</td>
</tr>
<tr>
<td>Outside circle</td>
<td>OC</td>
<td>Selects entities falling completely outside a circular selection window.</td>
</tr>
<tr>
<td>Point</td>
<td>PO</td>
<td>Selects any closed entities that surround the selected point.</td>
</tr>
<tr>
<td>Fence</td>
<td>F</td>
<td>Selects entities crossing a line or line segments.</td>
</tr>
<tr>
<td>Quick Select</td>
<td>QSELECT</td>
<td>Selects entities by type according to a specified value or range of values.</td>
</tr>
<tr>
<td>Select by Properties</td>
<td>PRO</td>
<td>Selects entities that match a particular set of properties—for example, all entities on a particular layer or drawn in a certain color.</td>
</tr>
</tbody>
</table>
You can also use a few selection methods automatically, without displaying the prompt box:

- Click one or more entities to select them.
- Click an entity to select it, then Ctrl + click to cycle through the entities below the cursor, selecting one at a time.
- Click two opposite corners of a rectangular selection window. The direction in which you define the points of the rectangle (left-to-right or right-to-left) determines which type of window you create.

### 10.1.3 Selecting entities by clicking them

You can click entities to select them.

**To select entities by clicking them.**

Click an entity.

### 10.1.4 Selecting entities by drawing a selection window

You can draw a selection window to include the entities contained within the window.

**To create a selection window from left to right**

1. Click to select a point in the drawing.

2. Click to the right of the first point to select a second point in the drawing.
To create a selection window from right to left

1. Click to select a point in the drawing.
2. Click to the left of the first point to select a second point in the drawing.

In addition to a rectangular window, you can define a selection window using other shapes such as a polygon or circle.

To select entities using a polygon selection window

1. Activate an entity-modification command.
2. In the prompt box, choose Window Polygon.
3. Specify the vertices of the polygon.
4. To complete the selection polygon, press Enter.
10.1.5 Selecting entities using a fence

A selection fence is a multisegmented line that selects entities it crosses.

**To select entities using a fence**

1. Activate an entity-modification command.
2. In the prompt box, choose Fence.
3. Specify the endpoints of the Fence segments.
4. To complete the Fence, press Enter.
10.1.6 Filtering entity selection

Filtering a selection is an efficient way to select a set of entities that have something in common. For example, you can select all entities with the same property such as color, all entities that are proxies, or all entities with the same value, block name, or type. You can even add or remove more filters to a set of entities to further customize the selection.

10.1.7 Selecting entities by property

CAD.direct Drafter makes it easy to select entities according to their common properties, allowing you to modify large sets of entities quickly and efficiently. When selecting entities, simply use a filter to add or remove entities according to these common properties: color, layer, linetype scale, linetype, lineweight, thickness, and width.

Use the List command to get more information for filtering. If you are unsure what properties are available for filtering, type list to select an area of the drawing and list the selected entities and their properties.

To select entities by property using a properties filter

1. Activate an entity-modification command, or type select.

2. Choose Filter.

3. Choose a filter option:
   - Color — Enter the color of entities you want to select.
   - Layer — Enter the layer name of entities you want to select.
   - LinetypeScale — Enter the linetype scale of entities you want to select.
   - Linetype — Enter the linetype of entities you want to select.
   - Lineweight — Enter the lineweight of entities you want to select.
   - Thickness — Enter the thickness of entities you want to select. Note that some entities have thickness, however, lines, circles, arcs, and polylines all have thickness.
   - Width — Enter the width of entities you want to select. Note that only polylines have width.
Names of properties are case sensitive. For example, a drawing with layers SAMPLE Layer 1, sample Layer 2, and SAM-PLE Layer 3 will return no selection if you specify “SAMPLE” for the layer name. Specifying “SAMPLE*” returns two layers, “*Layer*” returns all layers, and “sample**” returns one layer.

4. If desired, add or remove more entities using a filter:
   - Choose any other filter option to add more entities to the selection set.
   - Choose Remove to remove entities from the selection set according to the filter you choose next.
   - A prompt displays the total number of entities in the selection set.

5. To complete the selection, press Enter.

![Selection by specifying the smaller of two lineweight properties. Resulting selection.]

### 10.1.8 Selecting proxy entities using a filter

Proxy entities are entities or custom objects that CAD.direct Drafter does not support. When a drawing containing proxy entities is loaded into CAD.direct Drafter, a message displays indicating that some entities will not display, however, the entities reappear when you open the drawing later in a CAD application that supports those entities.

Proxy entities can be selected using typical selection methods, but they can also be selected using a filter, for example, you might want to select all proxies and place them on a hidden layer or delete them if you know they won’t be needed in the future.
To select proxy entities using a filter

1. Activate an entity-modification command, or type select.
2. Choose Filter.
3. Choose Proxy.
4. If desired, add or remove more entities using a filter:
   • Choose any other filter option to add more entities to the selection set.
   • Choose Remove to remove entities from the selection set according to the filter you choose next.
5. To complete the selection, press Enter.

10.1.9 Selecting blocks of the same name

Some drawings contain many of the same blocks, which are easy to select as a set using a filter.

Use the List command to get block names. If you are unsure what blocks are available for filtering, type list to select an area of the drawing and list the selected entities and their block names.

To select entities by block name

1. Activate an entity-modification command, or type select.
2. Choose Filter.
3. Choose Block.
4. Enter the block name of the entities you want to select.
5. If desired, add or remove more entities using a filter:
   • Choose any other filter option to add more entities to the selection set.
   • Choose Remove to remove entities from the selection set according to the filter you choose next.
   • A prompt displays the total number of entities in the selection set.
6. To complete the selection, press Enter.
10.1.10 Selecting entities by type

You can filter entities in a selection set according to their type, for example, a circle, line, text, attribute, or block type.

Use the List command to get type names. If you are unsure what entity types are available for filtering, type list to select an area of the drawing and list the selected entities and their types.

**To select entities by type using the filter option**

1. Activate an entity-modification command, or type select.

2. Choose Filter.

3. Choose Type.

4. Enter the type name (a string value) of the entities you want to select.

5. If desired, add or remove more entities using a filter:
   - Choose any other filter option to add more entities to the selection set.
   - Choose Remove to remove entities from the selection set according to the filter you choose next.
   - A prompt displays the total number of entities in the selection set.

6. To complete the selection, press Enter.

Use the Quick Select command to select entities by type.

_You can also type qselect to select entities by type._
10.1.11 Selecting entities by value

You can filter entities in a selection set according to common properties and their values. For example, you can filter a selection set to include all the entities that are the color red and use the Dashed2 linetype, and then change the value of the linetype.

To select entities by value using Quick Select

1. Do one of the following to choose Quick Select:
   - On the menu, choose Home > Quick Select (in Utilities).
   - On the menu, choose Tools > Quick Select.
   - On the Properties pane or Save Block to Disk dialog box, click the Quick Select tool.
   - Type qselect.

2. In Apply To, specify which entities to consider for selection. For example, select Entire Drawing to consider all entities in the drawing. To specify a portion of the drawing to consider for selection, click and make your selection directly in the drawing.

3. In Entity Type, specify the type of entity you want to select.

4. Specify the property to filter for selection, its operator, and value. The options vary by entity type.

5. Select one of the following:
   - Include in New Selection Set Creates a new selection that includes only those entities that meet the selected options.
   - Exclude from New Selection Set Creates a new selection set that includes all of the entities except those that meet the selected options.

6. To add the newly selected entities to a current selection set (available if entities were selected before using the Quick Select command), mark Append to Current Selection Set.

7. Click OK.
To select entities by value using the filter option

1. Activate an entity-modification command, or type select.

2. Choose Filter.

3. Choose Value.

4. Enter the value (a string) of the entities you want to select.
5. If desired, add or remove more entities using a filter:
   - Choose any other filter option to add more entities to the selection set.
   - Choose Remove to remove entities from the selection set according to the filter you choose next.
   - A prompt displays the total number of entities in the selection set.

6. To complete the selection, press Enter.

*Use the List command to get values.*

*If you are unsure what values are available for filtering, type list to select an area of the drawing and list the selected entities and their values.*

10.1.12 Deselecting entities

If an entity is no longer needed in a selection set, you can deselected it to remove it from the selection set.

**To remove an entity from the selection set**

Press Shift, and then select the entity again.

*Use a shortcut.*

*Pressing Shift while selecting entities using a crossing window removes all entities from the specified selection set.*

**To remove all entities from the selection set**

Press Escape.

10.1.13 Using grips

To use grips for editing, you select an entity to display the grips, and then click a grip to make it active. The grip you select depends on the type of entity you’re modifying and the editing operation you’re performing. For example, to move a line entity, drag it by its midpoint grip. To stretch the line, drag one of the endpoint grips. You do not need to enter a command when using grips.

10.1.14 Selecting grips for editing
You can select entities first and then choose how to modify them. As you select each entity, it is highlighted with small squares called grips, which appear at strategic points on the entity.

The locations of the grips depend on the type of entity selected. For example, grips appear at the endpoints and midpoint of a line, at the quadrant points and center point of a circle, and at the endpoints, midpoint, and center of an arc.

![Examples of grip locations.](image)

**To select grips for editing**

1. Click an entity to select it and display grips.

2. Click a grip to make it active.

3. Do any of the following:
   - Drag the grip to move it.
   - Choose a command, such as Copy or Move.
   - Press the Spacebar to cycle through available commands, such as Copy, Move, Rotate, and more, depending on the entity and the selected grip.

**10.1.15 Turning grips on and off**

You can turn the use of grips on and off and control the size and color of grips.

**To change grip settings**

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
• On the menu, choose Tools > Drawing Settings.
• On the Tools toolbar, click the Drawing Settings tool.
• Type ddgrips and then press Enter.

2. In the Drawing Settings dialog box, click the Display tab.

3. In the Change Settings For list, click Grips and choose from the following:
   • Enable grips — Click to activate grips for all selected entities.
   • Grip size — Specify the grip size.
   • Grip color — Click to assign the color for grips.

4. Click OK.

10.1.16 Displaying selected entities highlighted

You can specify whether to display selected entities highlighted, which makes the selection set easier to see. By default, the highlighting feature is turned on.

To turn the highlighting feature on or off

1. Do one of the following to choose Drawing Settings:
   • On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   • On the menu, choose Tools > Drawing Settings.
   • On the Tools toolbar, click the Drawing Settings tool.
   • Type settings and then press Enter.

2. Click the Display tab.

3. In the Change Settings For box, select Display.

4. Select or clear the Highlight Item When Selected check box.

5. Click OK.

10.2 Modifying the properties of entities
You can change the layer, thickness, linetype, color, and linetype scale of one or more entities. Depending on the type of entity or entities you select, you can also change other properties, such as the start point and endpoint of lines, the center point and radius of circles, and the vertices of polylines.

10.2.1 Modifying entity properties

To modify properties of entities

1. Do one of the following to choose Properties:
   • On the ribbon, choose View > Properties (in Display).
   • On the menu, choose Modify > Properties.
   • On the Modify toolbar, click the Properties tool.
   • Type entprop and then press Enter.
   • Press Ctrl +1. The Properties pane displays.

2. Select the desired entities.

3. Make changes to the properties.
You can also use the Entity Properties toolbar. Click a tool on the Entity Properties toolbar to change the properties of selected entities. Note that the Entity Properties toolbar settings that display when no entities are selected determine the properties of new entities when you draw them.

### 10.2.2 Modifying the properties of multiple entities

You can modify all the properties of all selected entities simultaneously. For example, using the entprop command, select all entities on a particular layer, and then move the entities to another layer by simply selecting a name from the Layer text box. Additionally, using the select command and the Select by Properties option, select all blue entities and change their color to green.

In the Properties pane, changes that you make in the Layer, Color, Thickness, Line-weight, Linetype, Linetype Scale, and Print Style (if using named print style tables) fields affect all selected entities. To change the properties of a single entity in the selection set, choose the entity from the list at the top of the Properties pane.

You can select the entities to be changed using any entity-selection method.
10.2.3 Changing multiple properties to ByLayer

The Set to ByLayer command sets properties of selected entities to ByLayer. Properties that can be changed using the Set to ByLayer command include: color, linetype, lineweight, material, print style, and transparency.

To modify properties of entities

1. Do one of the following to choose Set to ByLayer:
   - On the ribbon, choose Home > Set to ByLayer (in Layers).
   - On the menu, choose Format > Layer Tools > Set to ByLayer.
   - On the Layer Tools toolbar, click the Set to ByLayer tool.
   - Type setbylayer and then press Enter.

2. Press Enter.

3. In the SetByLayer Settings dialog box, make your selections for the properties you want to change:
   - Color — Resulting entities will have a Color property set to ByLayer.
   - Linetype — Resulting entities will have a Linetype property set to ByLayer.
   - Lineweight — Resulting entities will have a Lineweight property set to ByLayer.
   - Material — Resulting entities will have a Material property set to ByLayer.
   - Print Style — Resulting entities will have a Print Style property set to ByLayer.
   - Transparency — Resulting entities will have a Transparency property set to ByLayer.

4. Click OK.

5. At the prompt, select the desired entities.

6. Choose Yes to change any found ByBlock properties to ByLayer. Otherwise, choose No.

7. Choose Yes to change the properties of blocks that are selected. Blocks must be on unlocked layers. Otherwise, choose No.
10.3 Deleting entities

You can remove entities from a drawing. You can delete entities using any of the entity-selection methods.

To delete a selection set

1. Do one of the following to choose Delete:
   • On the ribbon, choose Home > Delete (in Modify) or choose Edit > Delete (in Modify).
   • On the menu, choose Edit > Delete.
   • On the Standard toolbar, click the Delete tool.
   • Type delete and then press Enter.

2. Select the entities, and then press Enter.

Typing the Undelete command restores the most recently deleted selection set. If you have made additional modifications since deleting the entities, use Undelete rather than Undo to restore those entities without reversing those modifications.

10.4 Copying entities

You can copy one or more entities, making one copy or multiple copies within the current drawing. You can also copy entities between drawings.

Use any of the following methods to copy entities within the current drawing:
   • Create a copy at a location referenced from the original.
   • Create a copy aligned parallel to the original.
   • Create a copy as a mirror image of the original.
   • Create several copies in a rectangular or circular pattern.
10.4.1 Copying entities within a drawing

You can duplicate entities within the current drawing. The default method is to create a selection set and then specify a starting point, or base point, and an endpoint, or displacement point, for the copy. You can also make multiple copies or copy the selection set to a location you specify, using a direction vector.

To copy a selection set

1. Do one of the following to choose Copy:
   - On the ribbon, choose Edit > Copy (in Modify).
   - On the menu, choose Modify > Copy.
   - On the Modify toolbar, click the Copy tool.
   - Type copy and then press Enter.

2. Select the entities, and then press Enter. 3 Specify the base point.

4. Specify the insertion point.

5. Continue specifying insertion points to place additional copies.

6. To complete the command, press Enter.
Use a shortcut.  
Press and hold Ctrl, then click and drag the left mouse button to copy an entity.

Use a system variable.  
The COPYMODE system variable controls whether you are prompted for multiple copies.

10.4.2 Copying between drawings

You can use the Clipboard to cut or copy entities from one drawing to another. Cutting removes the selected entities from a drawing and stores them on the Clipboard. Copying duplicates the selected entities from a drawing and places them on the Clipboard.

To cut entities to the Clipboard

1. Select the entities you want to cut.

2. Do one of the following to choose Cut:
   - On the ribbon, choose Edit > Cut (in Modify).
   - On the menu, choose Edit > Cut.
   - On the Standard toolbar, click the Cut tool.
   - Type cutclip and then press Enter.

To copy entities to the Clipboard
1. Select the entities you want to copy.

2. Do one of the following to choose Copy:
   - On the ribbon, choose Home > Copy (in Clipboard).
   - On the menu, choose Edit > Copy.
   - On the Standard toolbar, click the Copy tool.
   - Type copyclip and then press Enter.

Anything that you can copy to the Clipboard can be pasted into a drawing. The format in which the program adds the Clipboard contents to the drawing depends on the type of information in the Clipboard. For example, if you copy CAD.direct Drafter drawing entities to the Clipboard, the program pastes them into the drawing as CAD.direct Drafter entities. If you copy items to the Clipboard from other programs, they are pasted into the current drawing as embedded ActiveX® objects.

Sometimes the format you want to paste is not available on the Clipboard. This is mostly likely due to the settings on the Clipboard tab in Tools > Options. For details, see “Changing the options on the Clipboard tab” on page 609.

**To paste entities from the Clipboard**

1. Do one of the following to choose Paste:
   - On the ribbon, choose Home > Paste (in Clipboard) or choose Edit > Paste (in Modify).
   - On the menu, choose Edit > Paste.
   - On the Standard toolbar, click the Paste tool.
   - Type pasteclip and then press Enter.

2. Specify the insertion point.

Clipboard contents can also be inserted as a block. Type pasteblock to convert Clipboard contents into a block upon insertion

**10.4.3 Copying between spaces**
You can copy entities from model space to paper space or from paper space to model space. You must be viewing a Layout tab that has at least one layout viewport in order to copy entities between spaces. You can also move entities between spaces using the same ChaFor more details about model space and paper space, see “Understanding paper space and model space” on page 450.nge Space command.

For more details about model space and paper space, see “Understanding paper space and model space” on page 450.

**To copy entities between spaces**

1. Click a Layout tab.

2. Select the entities you want to copy.

3. Do one of the following to choose Change Space:
   - On the ribbon, choose Edit > Change Space (in Modify).
   - On the menu, choose Modify > Change Space.
   - On the Modify toolbar, click the Change Space tool.
   - Type chspace and then press Enter.

4. Choose Copy.

If using the command bar, the Copy option can get confused with crossing selections. To use the Crossing selection method, type the full keyword “crossing”. Typing “c” calls the Copy option.

**10.4.4 Making parallel copies**

You can use the offset feature to copy selected entities and align them parallel to the original entities at a specified distance. You can make parallel, offset entities using arcs, circles, ellipses, elliptical arcs, lines, two-dimensional polylines, rays, and infinite lines.

Making parallel, offset copies of curved entities creates larger or smaller curves, depending on which side of the original entity you place the copy. For example, placing a parallel copy of a circle outside the circle creates a larger concentric circle; positioning the copy inside the circle creates a smaller concentric circle.

**To make a parallel copy by specifying the distance**
1. Do one of the following to choose Offset:
   • On the ribbon, choose Edit > Offset (in Modify).
   • On the menu, choose Modify > Basic Editing > Offset.
   • On the Modify toolbar, click the Offset tool.
   • Type offset and then press Enter.

2. Specify the distance by selecting two points or by entering a distance.

3. Select the entity to copy.

4. Specify on which side of the entity to place the parallel copy.

5. Select another entity to copy, or press Enter to complete the command.

To make a parallel copy passing through a point

1. Do one of the following to choose Offset:
   • On the ribbon, choose Edit > Offset (in Modify).
   • On the menu, choose Modify > Basic Editing > Offset.
   • On the Modify toolbar, click the Offset tool.
   • Type offset and then press Enter.

2. In the prompt box, choose Through Point.

3 Select the entity to copy.
4. Specify the point for the entity to pass through.

5. Repeat steps 3 and 4, or press Enter to complete the command.

10.4.5 Mirroring entities

You can create a mirror image of an entity. You mirror the entity about a mirror line, which you define by specifying two points in a drawing. You can delete or retain the original entities.

To mirror entities

1. Do one of the following to choose Mirror:
   - On the ribbon, choose Edit > Offset (in Modify).
   - On the menu, choose Modify > Mirror.
   - On the Modify toolbar, click the Mirror tool.
   - Type mirror and then press Enter.

2. Select the entity, and then press Enter.

3. Specify the first point of the mirror line.

4. Specify the second point of the mirror line.

5. In the prompt box, choose one of the following:
   - Yes, Delete Entities – deletes the original entities.
   - No, Keep Entities – retains the original entities.
10.4.6 Arraying entities

You can copy an entity in a rectangular or polar (circular) pattern, creating an array. For a rectangular array, you control the number of copies in the array by specifying the number of rows and columns. You also specify the distance between each row and column. For a polar array, you control the number of copies that compose the array and whether to rotate the copies.

**To create a polar array**

1. Do one of the following to choose Array:
   - On the ribbon, Edit > Array (in Modify).
   - On the menu, choose Modify > Array.
   - On the Modify toolbar, click the Array tool.
   - Type array and then press Enter.

2. Select the entities, and then press Enter.

3. In the Array dialog box, choose Polar Array.

4. Specify the center point of the array, or click to select the center point in the drawing.
5. Select the method, which determines the two variables that are used to create the array, then specify the two variables:

- Total number of items — Enter the number of items to create in the array, including one for the original selection set.
- Angle to fill — Enter the angle to fill: 0 to 360 degrees. The default setting for the angle is 360 degrees. Positive values create the array in a counterclockwise direction; negative values create the array in a clockwise direction. You can also click to select the angle in the drawing.
- Angle between items — Enter the angle between lines. The default setting is 90 degrees. You can also click to select the angle in the drawing.

6. In Rotate Entities as Copied, mark the checkbox to rotate entities as they are arrayed or unmark it to retain the original orientation of each copy as it is arrayed.

7. To specify a new base point for the array, do the following:

- Click More.
- Unmark Set to Entity’s Default.
- In Base Point, enter a new entity base point to use for the array, or click to select the base point in the drawing.

To create a polar array, select the entity to copy (A), specify the center point of the array (B), and then specify other options.
A Select Polar to create a circular array.
B Click to specify the center point directly in the drawing.
C Enter the X and Y coordinates for the center point around which you want the entities arrayed.
D Select to create an array using a combination of two of the following: total number of items to array, angle the array will fill, and the angle between items.
E Enter the number of items to create in the array.
F Enter the angle the array will fill.
G Enter the degree of the angle between the items arrayed.
H Click to specify the angle between items directly in the drawing.
I Click to specify the angle to fill directly in the drawing.
J Select to automatically rotate items as they are arrayed.
K Select to use the entity's default base point for the array.
L Enter a new entity base point to use for the array.
M Click to preview the array in the drawing (only available after entities are selected for the array).
N Click to specify the base point directly in the drawing.
O Click to display or hide more options.
P Displays the number of entities that are selected in the drawing for the array.
Q Click to switch temporarily to the drawing to select entities to include in the array.
To create a rectangular array

1. Do one of the following to choose Array:
   - On the ribbon, Edit > Array (in Modify).
   - On the menu, choose Modify > Array.
   - On the Modify toolbar, click the Array tool.
   - Type array and then press Enter.

2. Select the entities, and then press Enter.

3. In the Array dialog box, choose Rectangular Array.

4. Enter the number of rows and the number of columns. A rectangular array must have at least two rows or two columns.

5. In Row Offset, specify the distance between the rows. You can also click ( ) to specify the row and column offset at the same time in the drawing, or you can click ( ) to select only the row offset.

6. In Column Offset, specify the distance between the columns. You can also click ( ) to specify the row and column offset at the same time in the drawing, or you can click ( ) to select only the column offset.

7. In Angle of Array, enter the angle at which to rotate the array, or click ( ) to select the angle directly in the drawing.
10.5 Rearranging entities

You can move one or more entities, and you can also rotate entities about a specified point. If you have entities that overlap, you can also change the display order.

10.5.1 Moving entities

You can move entities around within the current drawing or from one drawing to another. The default method is to create a selection set and then specify a starting point, or base point, and an endpoint, or displacement point, to define the relocation of the entities. You can also relocate the entities using a direction vector.
To move a selection set

1. Do one of the following to choose Move:
   - On the ribbon, choose Edit > Move (in Modify).
   - On the menu, choose Modify > Move.
   - On the Modify toolbar, click the Move tool.
   - Type move and then press Enter.

2. Select the entities, and then press Enter.

3. Specify the base point.

4. Specify the displacement point.

You can also move entities using grips. To move an entity using grips, select the entity to display its grips, and then click a grip and drag it. The grip you select depends on the type of entity you’re modifying. For example, to move a line entity, select the midpoint grip. To move a curved entity, such as an arc, circle, or ellipse, select the center point grip. Not all entities can be moved using grips.

To move an entity using grips

1. Select the entity.

2. Click a grip to select it.

3. Drag the entity to where you want to relocate it.

4. Click to release.
10.5.2 Moving entities between spaces

You can move entities from model space to paper space or from paper space to model space. You must be viewing a Layout tab that has at least one layout viewport in order to move entities between spaces. You can also copy entities between spaces using the same Change Space command.

For more details about model space and paper space, see “Understanding paper space and model space” on page 450.

To move entities between spaces

1. Click a Layout tab.
2. Select the entities you want to move.
3. Do one of the following to choose:
   • On the ribbon, choose Edit > Change Space (in Modify).
   • On the menu, choose Modify > Change Space.
   • On the Modify toolbar, click the Change Space tool.
   • Type chspace and then press Enter.
4. Choose Move.

10.5.3 Rotating entities

You can rotate entities about a specified point at a specified rotation angle or by an angle referenced to a base angle. The default method rotates the entities using a relative rotation angle from their current orientation.

To rotate a selection set

1. Do one of the following to choose Rotate:
   • On the ribbon, choose Edit > Rotate (in Modify).
   • On the menu, choose Modify > Rotate.
   • On the Modify toolbar, click the Rotate tool.
   • Type rotate and then press Enter.
2. Select the entities, and then press Enter.

3. Specify the rotation point.

4. If desired, choose Copy to rotate a copy of selected entities.

5. Specify the rotation angle.

To rotate a selection set in reference to a base angle

1. Do one of the following to choose Rotate:
   - On the ribbon, choose Edit > Rotate (in Modify).
   - On the menu, choose Modify > Rotate.
   - On the Modify toolbar, click the Rotate tool.
   - Type rotate and then press Enter.

2. Select the entities, and then press Enter.

3. Specify the rotation point.

4. If desired, choose Copy to rotate a copy of selected entities.

5. In the prompt box, choose Base Angle.

6. Specify the base angle, then specify the new angle.
10.5.4 Reordering entities

When multiple entities overlap, you can change the order in which they are displayed and printed. You can move entities to the front, back, or on top or below of another entity.

To reorder entities:

1. Do one of the following to choose Draw Order:
   - On the ribbon, choose View > Draw Order (in Draworder).
   - On the menu, choose Tools > Draw Order.
   - On the Tools toolbar, click the Draw Order tool or use the Draworder toolbar.
   - Type draworder and then press Enter.

2. Select the entity you want to reorder, and then press Enter.

3. In the prompt box, specify the new drawing order, and then press Enter.

4. If you are reordering above or under, select the entity you want the first entity to be above or below, and then press Enter.

*Use a system variable.*

The SORTENTS system variable automatically turns on, which may affect system performance.
10.6 Resizing entities

You can change the size of an entity or set of entities by stretching, scaling, extending, trimming, or editing their lengths.

10.6.1 Stretching entities

You can change the size of entities by stretching them. When you stretch entities, you must select the entities using either a crossing window or a crossing polygon. You then specify a displacement distance or select a base point and a displacement point. Entities that cross the window or polygon boundary are stretched; those completely within the crossing window or crossing polygon are simply moved.

To stretch an entity

1. Do one of the following to choose Stretch
   • On the ribbon, choose Home > Stretch (in Edit).
   • On the menu, choose Modify > Stretch.
   • On the Modify toolbar, click the Stretch tool.
   • Type stretch and then press Enter.

2. In the prompt box, choose Crossing Window or Crossing Polygon.

3. Select the entities, and then press Enter.

4. Specify the base point.

5. Specify the second point of displacement.
To stretch an entity using grips, you select it to display its grips and then select a grip to make it the active grip. This becomes the base point. Then you move the active grip to a new location. The grip you select depends on the type of entity you’re modifying. For example, to stretch one corner of a rectangle, select the corner point grip. To stretch a line, select an endpoint grip. Not all entities can be stretched using grips.

**To stretch an entity using grips**

1. Select the entity.
2. Click a grip to activate it.
3. Drag the grip.
4. Click to release.
10.6.2 Scaling entities

You can change the size of a selected entity by scaling it in relation to a base point. You can change the size of an entity by specifying a base point and a length, which is used as a scale factor based on the current drawing units, or by specifying a scale factor. You can also use a scale factor referenced to a base scale factor, for example, by specifying the current length and a new length for the entity.

To scale a selection set by a scale factor

1. Do one of the following to choose Scale:
   - On the ribbon, choose Edit > Scale (in Modify).
   - On the menu, choose Modify > Scale.
   - On the Modify toolbar, click the Scale tool.
   - Type scale and then press Enter.

2. Select the entities, and then press Enter.

3. Specify the base point.

4. Specify the scale factor.

You can also scale some entities using grips. To scale an entity, you select the entity, and then click a grip. You then change the size of the entity by moving the grip. The grip you select depends on the type of entity you’re modifying. For example, to scale a circle, select a quadrant point grip.
To scale an entity using grips

1. Select the entity.
2. Click a grip to select it.
3. Drag the grip.
4. Click to release.

10.6.3 Extending entities

You can extend entities so that they end at a boundary defined by other entities. You can also extend entities to the point at which they would intersect an implied boundary edge. When extending entities, you first select the boundary edges, and then specify the entities to extend, selecting them either one at a time, using the fence selection method, or the projection selection method.

You can extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, ellipses, lines, splines, polylines, rays, infinite lines, and viewports on a Layout tab can act as boundary edges.

To extend an entity

1. Do one of the following to choose Extend:
   - On the ribbon, choose Edit > Extend (in Modify).
   - On the menu, choose Modify > Extend.
To extend an entity to an implied boundary

1. Do one of the following to choose Extend:
   • On the ribbon, choose Edit > Extend (in Modify).
   • On the menu, choose Modify > Extend.
   • On the Modify toolbar, click the Extend tool.
   • Type extend and then press Enter.

2. Select one or more boundary edges, and then press Enter.

3. In the prompt box, choose Edge Mode.

4. In the prompt box, choose Extend.

5. Select the entity to extend.

6. Select another entity to extend, or press Enter to complete the command.
To extend several entities using the fence selection method

1. Do one of the following to choose Extend:
   - On the ribbon, choose Edit > Extend (in Modify).
   - On the menu, choose Modify > Extend.
   - On the Modify toolbar, click the Extend tool.
   - Type extend and then press Enter.

2. Select one or more boundary edges, and then press Enter.

3. In the prompt box, choose Fence.

4. Specify the first point of the fence.

5. Specify the second point of the fence.

6. Specify the next fence point, or press Enter to complete the command.
When you extend a wide polyline, its centerline intersects the boundary edge. Because the end of the polyline is always cut at a 90-degree angle, part of the polyline may extend past the boundary edge. A tapered polyline continues to taper until it intersects the boundary edge. If this would result in a negative polyline width, the ending width changes to 0.

10.6.4 Trimming entities

You can clip, or trim, entities so they end at one or more implied cutting edges defined by other entities. You can also trim entities to the point at which they would intersect an implied cutting edge. When trimming entities, you first select the cutting edges and then specify the entities to trim, selecting them either one at a time or using the fence selection method.

You can trim arcs, circles, lines, open two-dimensional and three-dimensional polylines, and rays. Arcs, circles, lines, polylines, rays, infinite lines, and viewports on a Layout tab can act as cutting edges. An entity can be both a cutting edge and one of the entities being trimmed.
To trim an entity

1. Do one of the following to choose Trim:
   • On the ribbon, choose Edit > Trim (in Modify).
   • On the menu, choose Modify > Trim.
   • On the Modify toolbar, click the Trim tool.
   • Type trim and then press Enter.

2. Select one or more cutting edges, and then press Enter.

3. Select the entity to trim.

4. Select another entity to trim, or press Enter to complete the command.

To trim an entity to an implied boundary

1. Do one of the following to choose Trim:
   • On the ribbon, choose Edit > Trim (in Modify).
   • On the menu, choose Modify > Trim.
   • On the Modify toolbar, click the Trim tool.
   • Type trim and then press Enter.

2. Select one or more cutting edges, and then press Enter.

3. In the prompt box, choose Edge Mode.
4. In the prompt box, choose Extend.

5. Select the entity to trim.

6. Select another entity to trim, or press Enter to complete the command.

To trim several entities using the fence selection method

1. Do one of the following to choose Trim:
   • On the ribbon, choose Edit > Trim (in Modify).
   • On the menu, choose Modify > Trim.
   • On the Modify toolbar, click the Trim tool.
   • Type trim and then press Enter.

2. Select one or more cutting edges, and then press Enter.

3. In the prompt box, choose Fence.

4. Specify the first point of the fence.

5. Specify the second point of the fence.

6. Specify the next fence point, or press Enter to complete the command.
10.6.5 Editing the length of entities

You can change the length of entities or the included angle of arcs. Use any of the following methods to change the length of an entity:

- Dynamically drag the endpoint or angle.
- Specify an incremental length or angle measured from an endpoint.
- Specify the new length as a percentage of the total length or angle.
- Specify a new length or included angle.

You can change the length of arcs, lines, and open polylines.

To change the length of an entity by dragging

1. Do one of the following to choose Edit Length:
   - On the ribbon, choose Edit > Edit Length (in Modify).
   - On the menu, choose Modify > Edit Length.
   - On the Modify toolbar, click the Edit Length tool.
   - Type editlen and then press Enter.

2. In the prompt box, choose Dynamic.

3. Select the entity you want to change.

4. Specify the new endpoint or included angle.
10.7 Splitting and combining entities

You can break and combine entities using the following methods:

- **Break** — Separate a single entity into two parts, removing a portion of the entity in the process.
- **Join** — Combine two entities into a single entity.
- **Explode** — Separate a complex entity, such as a block or polyline, into its various component parts.
- **Group** — Combine multiples entities to behave as a single unit.

10.7.1 Breaking entities

You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When breaking entities, you must specify two points for the break. By default, the point you use to select the entity becomes the first break point; however, you can use the First option to select a break point different from the one that selects the entity.

To break an entity

1. Do one of the following to choose Break:
   - On the ribbon, choose Edit > Break (in Modify).
   - On the menu, choose Modify > Break.
   - On the Modify toolbar, click the Break tool.
   - Type break and then press Enter.
2 Select the entity.

3 Specify the second break point.

To select an entity and then specify the two break points

1. Do one of the following to choose Break:
   - On the ribbon, choose Edit > Break (in Modify).
   - On the menu, choose Modify > Break.
   - On the Modify toolbar, click the Break tool.
   - Type break and then press Enter.

2. Select the entity.

3. In the prompt box, choose First.

4. Specify the first break point.

5. Specify the second break point.
You can break an entity in two without removing a portion of the entity. Specify the same point for the first and second break points by typing the at sign (@) and pressing Enter instead of specifying the second break point.

10.7.2 Joining entities

You can join two entities into a single entity. You can join either two lines or two arcs. The two lines must be parallel; the two arcs must share the same center point and radius.

When you join two lines, the farthest endpoints remain at their existing locations; the program draws a new line between these points. Arcs are joined counterclockwise, from the first arc you select to the second.

To join two entities

1. Do one of the following to choose Join:
   • On the ribbon, choose Edit > Join (in Modify).
   • On the menu, choose Modify > Join.
   • On the Modify toolbar, click the Join tool.
   • Type join and then press Enter.

2. Select the first arc or line.

3. Select the second arc or line.
10.7.3 Exploding entities

You can convert a complex entity, such as a block or polyline, from a single entity into its component parts. Exploding a polyline, rectangle, donut, polygon, dimension, or leader reduces it to a collection of individual line and arc entities that you can then modify individually. Blocks are converted to the individual entities, possibly including other, nested blocks that composed the original entity.

With the following exceptions, exploding an entity usually has no visible effect on a drawing:

- If the original polyline had a width, the width information is lost when you explode it. The resulting lines and arcs follow the centerline of the original polyline.
- If you explode a block containing attributes, the attributes are lost, but the original attribute definitions remain.
- Colors, linetypes, lineweights, and print styles assigned BYBLOCK may be different after exploding an entity, because they will adopt the default color, linetype, lineweight, and print style until inserted into another block.

To explode an entity

1. Do one of the following to choose Explode:
   - On the ribbon, choose Home > Explode (in Modify) or choose Edit > Explode (in Modify).
   - On the menu, choose Modify > Explode.
   - On the Modify toolbar, click the Explode tool.
   - Type explode and then press Enter.

2. Select the entities to explode.

3. Press Enter.

To explode an entity and specify properties of the resulting entities

1. Do one of the following to choose Xplode:
   - On the ribbon, choose Edit > Xplode (in Modify).
   - On the menu, choose Modify > Xplode.
   - On the Modify toolbar, click the Xplode tool.
   - Type xplode and then press Enter.
2. Select the entities to explode.

3. Choose an option:

   • All — Displays prompts for specifying all available properties: color, layer, linetype, and lineweight.
   • Color — Enter a color. You can enter an index color, true color, or color from a colorbook.
   • Layer — Enter a layer for the resulting entities.
   • LType — Enter a linetype for the resulting entities.
   • LWeight — Enter a lineweight for the resulting entities.
   • Inherit — Explodes selected entities and assigns the same color, layer, linetype, and lineweight properties to sub-entities as the parent entity if the sub-entity layer is 0 and other properties are BY-BLOCK.
   • Explode — Explodes selected entities in the same way as the Explode command.
10.7.4 Grouping entities

A group is a collection of entities saved together as one unit. After you select the entities that belong in the group, you can later add more entities, remove entities, and reorder the entities. If necessary, you can also ungroup the entities at any time to work with the entities separately.

10.7.5 Creating groups

When you create a group, you enter a group name and description, and then select the entities for the group.

To create a group

1. Do one of the following to choose Group:
   - On the ribbon, choose Home > Group (in Utilities) or Tools > Group (in Manage).
   - On the menu, choose Tools > Group.
   - On the Tools toolbar, click the Group tool.
   - Type group and then press Enter.

2. Under Create New Group, enter the name and description of the group.

3. Click Selectable if you want all entities in the group to be selected when you select one entity of the group in the drawing.

4. Click Select Entities and Create Group.

5. Select the entities for the group, and then press Enter.

6. In the Group dialog box, click OK.

You can select entities using groups.

Enter the name of a group in the command bar when selecting entities.
10.7.6 Modifying groups

To modify a group and its entities

1. Do one of the following to choose Group:
   - On the ribbon, choose Home > Group (in Utilities).
   - On the menu, choose Tools > Group.
   - On the Tools toolbar, click the Group tool.
   - Type group and then press Enter.

2. Select the group you want to modify.
3. Under Modify Selected Group, do one or more of the following:
   • Enter a new name, and then click Rename Group.
   • Enter a new description, and then click Change Group Description.
   • Select whether you want the group to be selectable in the drawing.
   • Click Add Entities to Group, select the entities to add to the group, and then press Enter.
   • Click Remove Entities from Group, select the entities to remove from the group, and then press Enter.

4. In the Group dialog box, click OK.

To change the order of entities in a group

1. Do one of the following to choose Group:
   • On the ribbon, choose Home > Group (in Utilities).
   • On the menu, choose Tools > Group.
   • On the Tools toolbar, click the Group tool.
   • Type group and then press Enter.

2. Under Modify Selected Group, click Reorder Entities.

3. In the Reorder Grouped Entities dialog box, select the group you want to reorder.

4. To see the order of entities in the group, click Highlight. Follow the prompts that display to view the entities one by one.

5. To reverse the order of all entities in the group, click Reverse Order. 6. To change the order of specific entities or a range of entities:
   • In Remove from Position, enter the current position of the entity.
   • In Place to Position, enter the new position of the entity.
   • In Number of Entities, enter the number of entities or range of entities to reorder. For example, if you are changing the order of only one entity, enter 1.
   • Click Reorder.
The entities in a group are numbered 0, 1, 2, 3, and so on.

7. Click OK, and then click OK again.

10.7.7 Ungrouping entities

When you ungroup entities, the entities remain in the drawing, but the group is deleted from the drawing.

To ungroup entities

1. Do one of the following to choose Group:
   - On the ribbon, choose Home > Group (in Utilities).
   - On the menu, choose Tools > Group.
   - On the Tools toolbar, click the Group tool.
   - Type group and then press Enter.

2. Select the group to delete.

3. Under Modify Selected Group, click Ungroup Entities.

4. Click OK.

10.8 Editing polylines

You can modify any type of two-dimensional or three-dimensional polyline. Entities such as rectangles, polygons, and donuts, as well as three-dimensional entities such as pyramids, cylinders, and spheres, are all variations of polylines that you can edit.

You can edit a polyline by opening or closing it, by changing its overall width or the widths of individual segments, and by converting a polyline with straight line segments into a flowing curve or an approximation of a spline. In addition, you can use the Edit Polyline tool to edit individual vertices, adding, removing, or moving vertices. You can also add new segments to an existing polyline, change the linetypes of a polyline, and reverse the direction or order of the vertices.
10.8.1 Converting an entity to a polyline

To modify a polyline, you first select the polyline, and then select a polyline editing option. The available options vary depending on whether the selected polyline is a two-dimensional or three-dimensional entity. If the selected entity is not a polyline, the Edit Polyline tool provides the option of turning it into one. You can convert only arcs and lines into polylines. If several arcs or lines are joined endpoint to endpoint, they can all be selected and turned into one polyline.

To convert an entity into a polyline

1. Do one of the following to choose Edit Polyline:
   • On the ribbon, choose Edit > Edit Polyline (in Modify).
   • On the menu, choose Modify > Edit Polyline.
   • On the Modify toolbar, click the Edit Polyline tool.
   • Type editpline and then press Enter.

2. Select the entity.

3. In the prompt box, choose Yes-Turn Into Polyline.

4. In the prompt box, choose another option, or choose Done to complete the command.

10.8.2 Opening and closing polylines

When you close a polyline, the program draws a straight polyline segment from the last vertex of the polyline to the first vertex. Opening a polyline removes the closing segment. When you select a polyline for editing, the prompt box displays either the Open or Close option, depending on whether the polyline you select is closed or open.

To close an open polyline

1. Do one of the following to choose Edit Polyline:
   • On the ribbon, choose Edit > Edit Polyline (in Modify).
   • On the menu, choose Modify > Edit Polyline.
   • On the Modify toolbar, click the Edit Polyline tool.
   • Type editpline and then press Enter.
2. Select the polyline.

3. In the prompt box, choose Close.

4. In the prompt box, choose another option, or choose Done to complete the command.

10.8.3 Curving and recurving polylines

You can convert a multi-segment polyline into a smooth curve using either the Fit or Spline option. The Fit option creates a smooth curve connecting all the vertices. The Spline option computes a smooth curve that is pulled toward the vertices but passes through only the first and last vertices. The Decurve option removes Fit or Spline curves and arcs, leaving straight segments between the vertices.

To fit a curve to a polyline

1. Do one of the following to choose Edit Polyline:
   - On the ribbon, choose Edit > Edit Polyline (in Modify).
   - On the menu, choose Modify > Edit Polyline.
   - On the Modify toolbar, click the Edit Polyline tool.
   - Type editpline and then press Enter.

2. Select the polyline.
3. In the prompt box, choose Fit.

4. In the prompt box, choose another option, or choose Done to complete the command.

10.8.4 Joining polylines

You can add an arc, line, or polyline entity to an existing open polyline, forming one continuous polyline entity. To join an entity to a polyline, that entity must already share an endpoint with an end vertex of the selected polyline.

When you join an entity to a polyline, the width of the new polyline segment depends on the width of the original polyline and the type of entity you are joining to it:

- A line or an arc assumes the same width as the polyline segment for the end vertex to which it is joined.
- A polyline joined to a tapered polyline retains its own width values.
- A polyline joined to a uniform-width polyline assumes the width of the polyline to which it is joined.

To join an arc, line, or polyline to an existing polyline

1. Do one of the following to choose Edit Polyline:
   - On the ribbon, choose Edit > Edit Polyline (in Modify).
   - On the menu, choose Modify > Edit Polyline.
• On the Modify toolbar, click the Edit Polyline tool.
• Type editpline and then press Enter.

2. Select the polyline.

3. In the prompt box, choose Join.

4. Select the arc, line, or polyline to join.

5. In the prompt box, choose another option, or choose Done to complete the command.

10.8.5 Changing the polyline width

You can change the width of an entire polyline, applying a uniform width to the entire entity or tapering the polyline uniformly along its entire length.

To apply a uniform width to an entire polyline

1. Do one of the following to choose Edit Polyline:
   • On the ribbon, choose Edit > Edit Polyline (in Modify).
   • On the menu, choose Modify > Edit Polyline.
   • On the Modify toolbar, click the Edit Polyline tool.
   • Type editpline and then press Enter.

2. Select the polyline.

3. In the prompt box, choose Width.

4. Specify the new polyline width.

5. In the prompt box, choose another option, or choose Done to complete the command.

To taper a polyline uniformly along its length

1. Do one of the following to choose Edit Polyline:
   • On the ribbon, choose Edit > Edit Polyline (in Modify).
   • On the menu, choose Modify > Edit Polyline.
• On the Modify toolbar, click the Edit Polyline tool.
• Type editpline and then press Enter.

2. Select the polyline.

3. In the prompt box, choose Taper.

4. Specify the starting width.

5. Specify the ending width.

6. In the prompt box, choose another option, or choose Done to complete the command.

10.8.6 Editing polyline vertices

You can use the Edit Vertices option to modify individual polyline vertices. When you select this option, the program switches into a special vertex editing mode and places an x on the first vertex. The x indicates the vertex you are editing. The Next and Previous options move the x to the next or previous vertex. You can edit only one vertex at a time.

When editing vertices, you can modify the polyline in the following ways:

• Convert a polyline segment into a curve by specifying a new tangent angle.
• Break a polyline into two separate polylines.
• Insert a new vertex after the current vertex.
• Move the current vertex.
• Straighten the polyline segment between two vertices.
• Change the width of the polyline segment between two vertices.

To move a polyline vertex

1. Do one of the following to choose Edit Polyline:
• On the ribbon, choose Edit > Edit Polyline (in Modify).
• On the menu, choose Modify > Edit Polyline.
• On the Modify toolbar, click the Edit Polyline tool.
• Type editpline and then press Enter.
2. Select the polyline.

3. In the prompt box, choose Edit Vertices.

4. In the prompt box, choose Next Vertex.

Repeat until the x reaches the vertex you want to move.

5. In the prompt box, choose Move.

6. Specify the new location for the vertex.

7. In the prompt box, choose another option, or choose Exit to stop editing vertices.

8. In the prompt box, choose another option, or choose Done to complete the command.

To taper the width of an individual polyline segment

1. Do one of the following to choose Edit Polyline:
   • On the ribbon, choose Edit > Edit Polyline (in Modify).
   • On the menu, choose Modify > Edit Polyline.
   • On the Modify toolbar, click the Edit Polyline tool.
   • Type editpline and then press Enter.

2. Select the polyline.

3. In the prompt box, choose Edit Vertices.
4. In the prompt box, choose Next Vertex.

Repeat until the x reaches the first vertex of the segment you want to taper.

5. In the prompt box, choose Width.

6. Specify the starting width.

7. Specify the ending width.

8. In the prompt box, choose another option, or choose Exit to stop editing vertices and update the display.

9. In the prompt box, choose another option, or choose Done to complete the command.

10.9 Chamfering and filleting entities

You can chamfer or fillet entities. A chamfer connects two nonparallel entities with a line to create a beveled edge. A fillet connects two entities with an arc of a specified radius to create a rounded edge. If both entities you are working with are on the same layer, the chamfer or fillet is drawn on that layer. If they are on different layers, the chamfer or fillet is drawn on the current layer.

10.9.1 Modifying the chamfer and fillet settings

The Chamfer/Fillet settings in the Drawing Settings dialog box control the chamfer and fillet settings. The portions of the entities that extend beyond the chamfer or fillet are normally deleted when you create the chamfer or fillet. You can retain these original entities, however, by changing the settings in the dialog box.
To modify the chamfer and fillet settings

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.

2. In the Drawing Settings dialog box, click the Entity Modification tab.

3. In the Change Settings For list, click Chamfer/Fillet and choose from the following:
   - Corners — Select to remove or retain portions of entities that extend beyond the chamfer or fillet.
   - Fillet radius — Specify the fillet radius or click Select to specify it by selecting two points in the drawing.
   - Chamfer Distances and Angles — Choose to use the distance-distance method or distance-angle method when creating chamfers. The distance-distance method creates a chamfer using two chamfer distances that you specify. The distance-angle method creates a chamfer using a chamfer length and angle that you specify.

4. Click OK.

10.9.2 Chamfering entities

You can connect two nonparallel entities by extending or trimming them and then joining them with a line to create a beveled edge. You can chamfer lines, polylines, rays, and infinite lines. When creating a chamfer, you can specify how far to trim the entities back from their intersection (distance-distance method), or you can specify the length of the chamfer and the angle it forms along the first entity (distance-angle method).

When chamfering a polyline, you can chamfer multiple segments between two selected polyline segments, or you can chamfer the entire polyline.
10.9.3 Chamfering two entities using the distance-distance method

To chamfer two entities using the distance-distance method

1. Do one of the following to choose Chamfer:
   - On the ribbon, choose Modify > Chamfer (in Modify).
   - On the menu, choose Modify > Chamfer.
   - On the Modify toolbar, click the Chamfer tool.
   - Type chamfer and then press Enter.

2. In the prompt box, choose Chamfer Settings.

3. In the Drawing Settings dialog box, click the Entity Modification tab. Under Chamfer Distances And Angles, click Distance-Distance.

4. Under Chamfer Distances And Angles, specify the first and second chamfer distances.

5. Click OK.

6. Select the first entity.

7. Select the second entity.
10.9.4 Chamfering two entities using the distance-angle method

To chamfer two entities using the distance-angle method

1. Do one of the following to choose Chamfer:
   • On the ribbon, choose Modify > Chamfer (in Modify).
   • On the menu, choose Modify > Chamfer.
   • On the Modify toolbar, click the Chamfer tool.
   • Type chamfer and then press Enter.

2. In the prompt box, choose Chamfer Settings.

3. In the Drawing Settings dialog box, click the Entity Modification tab.

4. Under Chamfer Distances And Angles, click Distance-Angle.

5. Under Chamfer Distances And Angles, specify the chamfer distance and angle. Click OK.

6. Select the first entity.

7. Select the second entity.
10.9.5 Chamfering all vertices in a polyline

To chamfer all vertices in a polyline

1. Do one of the following to choose Chamfer:
   - On the ribbon, choose Modify > Chamfer (in Modify).
   - On the menu, choose Modify > Chamfer.
   - On the Modify toolbar, click the Chamfer tool.
   - Type chamfer and then press Enter.

2. In the prompt box, choose Polyline.

3. Select the polyline.

10.9.6 Chamfering selected vertices in a polyline

To chamfer selected vertices in a polyline

1. Do one of the following to choose Chamfer:
   - On the ribbon, choose Modify > Chamfer (in Modify).
   - On the menu, choose Modify > Chamfer.
   - On the Modify toolbar, click the Chamfer tool.
   - Type chamfer and then press Enter.
2. Select the polyline along the segment where you want to begin the chamfer.

3. Select the polyline along the segment where you want to end the chamfer.

10.9.7 Filleting entities

You can connect two entities with an arc of a specified radius to create a rounded edge. You can fillet pairs of line segments, straight polyline segments, arcs, circles, rays, and infinite lines. You can also fillet parallel lines, rays, and infinite lines. When filleting a polyline, you can fillet multiple segments between two selected segments, or you can fillet the entire polyline.

10.9.8 Filleting two entities

To fillet two entities

1. Do one of the following to choose Fillet:
   - On the ribbon, choose Modify > Fillet (in Modify).
   - On the menu, choose Modify > Fillet.
   - On the Modify toolbar, click the Fillet tool.
   - Type fillet and then press Enter.

2. In the prompt box, choose Fillet Settings.

3. In the Drawing Settings dialog box, specify the fillet radius.

4. Click OK.

5. Select the first entity.

6. Select the second entity.
10.9.9 Filleting an entire polyline

To fillet an entire polyline

1. Do one of the following to choose Fillet:
   • On the ribbon, choose Modify > Fillet (in Modify).
   • On the menu, choose Modify > Fillet.
   • On the Modify toolbar, click the Fillet tool.
   • Type fillet and then press Enter.

2. In the prompt box, choose Polyline.

3. Select the polyline.
10.9.10 Filleting selected vertices in a polyline

To fillet selected vertices in a polyline

1. Do one of the following to choose Fillet:
   - On the ribbon, choose Modify > Fillet (in Modify).
   - On the menu, choose Modify > Fillet.
   - On the Modify toolbar, click the Fillet tool.
   - Type fillet and then press Enter.

2. Select the polyline along the segment where you want to begin the fillet.

3. Select the polyline along the segment where you want to end the fillet.

When you fillet circles and arcs, more than one fillet can exist between the entities. The point at which you select the entities determines the fillet.
You can fillet parallel lines, rays, and infinite lines. The first entity must be a line or ray; the second entity can be a line, ray, or infinite line. The diameter of the fillet arc is always equal to the distance between the parallel entities. The current fillet radius is ignored.
11 Working with text

You can insert text into your drawing and control its appearance, allowing you to provide additional information for your CAD.direct Drafter drawings. This section explains how to:

- Create line text.
- Create paragraphs.
- Create text styles.
- Format text.
- Change line text and paragraph text.
- Convert line text to paragraph text.
- Check the spelling of text.
- Use an alternate text editor.
- Working with text written in different languages.

11.1 Creating line text

When you create text, you end each line of text by pressing Enter. Each line of text is created as a separate entity that you can modify.

To create text

1. Do one of the following to choose Text:
   - On the ribbon, choose Home > Text (in Annotation) or choose Annotate > Text (in Text).
   - On the menu, choose Draw > Text.
   - On the Draw toolbar, click the Text tool.
   - Type text and then press Enter.
2. Specify the insertion point for the first character.
3. Specify the height of the text.
4. Specify the text rotation angle.
5. Type the text, and then press Enter at the end of each new line.
6. To complete the command, press Enter again.
If you’ve already created text, new text can appear immediately below the previous text.

Choose Insert > Text. When prompted for an insertion point, press Enter. The new text will keep the same height and rotation angle as the previous text.

11.2 Creating paragraph text

Paragraph text consists of one or more lines of text or paragraphs that fit within a boundary width that you specify. Each paragraph text entity you create is treated as a single entity regardless of the number of individual paragraphs or lines of text it contains.

When you create paragraph text, you first determine the paragraph’s boundary width by specifying the opposite corners of a rectangle. The paragraph text automatically wraps so that it fits within this rectangle. The first corner of the rectangle determines the default attachment point of the paragraph text. You can determine the direction in which text flows within the rectangle, and you can also select the text and paragraph format, text style, text height, and the rotation angle of the entire paragraph text entity.

To create paragraph text

1. Do one of the following to choose Multiline Text:
   - On the ribbon, choose Home > Multiline Text (in Annotate).
   - On the menu, choose Draw > Multiline Text.
   - On the Draw toolbar, click the Multiline Text tool.
   - Type mtext and then press Enter.
2. Select the first corner of the text area.
3. In the MTEXT prompt box, choose the properties you want to set, or proceed directly to the next step. You can also choose these properties later for the resulting multiline text entity using the Properties pane.
4. Select the second corner of the text area.
5. Type the text you want.
6. To create paragraphs, press Enter and continue typing.
7. On the ribbon (or floating toolbar if not viewing the ribbon), use the Text Editor tools to make your selections for highlighted text, or if no text is highlighted, the changes affect new text when you type it.
8. Click Close Editor to accept your changes and close the editor.
<table>
<thead>
<tr>
<th>Tool</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Standard</td>
<td>Select a text style.</td>
</tr>
<tr>
<td></td>
<td>Text Height</td>
<td>Select or type the text font height.</td>
</tr>
<tr>
<td></td>
<td>Bold and Italic</td>
<td>Click to bold and/or italicize text.</td>
</tr>
<tr>
<td></td>
<td>Underline and</td>
<td>Click to underline and/or overline text.</td>
</tr>
<tr>
<td></td>
<td>Overline</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Uppercase and</td>
<td>Click to make text uppercase or lowercase.</td>
</tr>
<tr>
<td></td>
<td>Lowercase</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Text Font</td>
<td>Select the text font.</td>
</tr>
<tr>
<td></td>
<td>Text Color</td>
<td>Select BYBLOCK, BYLAYER, the color of your choice, or choose Select Color to select from additional colors.</td>
</tr>
<tr>
<td></td>
<td>Background Mask</td>
<td>Click to set the background settings for text. For more details, click Help in the dialog box that displays.</td>
</tr>
<tr>
<td></td>
<td>Oblique Angle</td>
<td>Select or type the angle of text.</td>
</tr>
<tr>
<td></td>
<td>Tracking</td>
<td>Select or type the factor representing spacing between letters.</td>
</tr>
<tr>
<td></td>
<td>Width Factor</td>
<td>Select or type the font width factor.</td>
</tr>
<tr>
<td></td>
<td>Undo and Redo</td>
<td>Click to redo or undo the previous action.</td>
</tr>
<tr>
<td></td>
<td>Justification</td>
<td>Select the text box justification.</td>
</tr>
<tr>
<td></td>
<td>Symbol</td>
<td>Click to Insert a symbol where the cursor is located in the text editor.</td>
</tr>
<tr>
<td></td>
<td>Insert Field</td>
<td>Click to Insert a field where the cursor is located in the text editor. For more details, click Help in the dialog box that displays.</td>
</tr>
<tr>
<td></td>
<td>Find and Replace</td>
<td>Click to find and replace text in the text editor.</td>
</tr>
<tr>
<td></td>
<td>Import Text</td>
<td>Click to select a file that contains text to import.</td>
</tr>
<tr>
<td></td>
<td>AutoCAPS</td>
<td>Click to turn on or off capitalizing text automatically as you type.</td>
</tr>
<tr>
<td></td>
<td>Ruler</td>
<td>Click to show or hide the ruler in the text editor.</td>
</tr>
<tr>
<td></td>
<td>Stacked Text</td>
<td>Click to stack or unstack selected text, for example, fractions can display as stacked text.</td>
</tr>
<tr>
<td></td>
<td>More</td>
<td>Click to display a menu of additional options, including the character set, settings for the text editor, and online help.</td>
</tr>
<tr>
<td></td>
<td>Close Editor</td>
<td>Accepts your changes and close the editor.</td>
</tr>
</tbody>
</table>
Access more options by right-clicking the text editor.

*Right-click the text editor to access additional options, including Select All, Cut, Copy, and Paste. You can also use typical shortcuts such as Ctrl + V to paste text from the clipboard.*

There are two multiline text editors.

*The in-place text editor, described previously, has some missing features when compared with the older dialog box version. To switch to the dialog box version of the multiline text editor, set the MTEXTED system variable to “old editor”.*

### 11.3 Working with text styles

When you add text to a drawing, it uses the current text style. Text style determines the font, size, angle, orientation, whether the text is annotative by default, and other characteristics.

Every drawing has a default text style, named Standard, which initially uses the Arial font. You cannot delete the Standard style, but you can rename it or modify it. You can change the font, the size of the font, and the obliquing angle applied to it. If you change the font or orientation of an existing style, all existing text entities created using that style are automatically updated to reflect the new font or orientation. Changing any other characteristic has no effect on existing text. You also can create and use an unlimited number of additional text styles.

The text style determines the characteristics shown in the following table.
To create a text style

1. Do one of the following to choose Text Styles Manager:
   - On the ribbon, choose Annotate > Text Styles Manager (in Text).
   - On the menu, choose Format > Text Styles Manager.
   - On the Format toolbar, click the Text Styles Manager tool.
   - Type style and then press Enter.
2. Click New.
3. Type a new text style name, then click OK.
4. Under Text Font, select the name, style, and language of the font you want to use.
5. Under Text Measurements, select the check boxes if you want annotative text; you can also enter a Fixed Text Height (Paper Text Height if annotative), Width Factor, or Oblique Angle measurement.
6. Under Text Generation, select the check boxes you want to indicate the direction for printed text to appear.
7. Click OK.
8. To begin using the new style, choose Draw > Text.
9. In the prompt box, select Use Defined Style.
11.4 Formatting text

When you create text, you choose the text style and set the alignment. The style determines the font characteristics for the text. For single-line text, the alignment point determines how the text aligns with the text insertion point. For paragraph text, the alignment point determines the location of the attachment point in relation to the paragraph text boundary and the direction in which text flows within the boundary.

11.4.1 Setting the line text style

You can set the text style before you specify the insertion point. You select the text style by typing the name of a previously defined style.

To specify a line text style

1. Do one of the following to choose Text:
   - On the ribbon, choose Home > Text (in Annotation) or choose Annotate > Text (in Text).
   - On the menu, choose Draw > Text.
   - On the Draw toolbar, click the Text tool.
   - Type dtext and then press Enter.
2. In the prompt box, choose Use Defined Style.
3. Type the name of a previously defined text style, and then press Enter.

To display a list of available text styles, type a question mark (?), and then press Enter.

4. Specify the text insertion point.
5. Specify the text height.
6. Specify the rotation angle.
7. Type the text line, and then press Enter.
8. To complete the command, press Enter again.

11.4.2 Setting the paragraph text style

You can set the paragraph text style before you specify the insertion point. You select the text style by typing the name of a previously defined style.
To specify a paragraph text style

1. Do one of the following to choose Multiline Text:
   • On the ribbon, choose Home > Multiline Text (in Annotate).
   • On the menu, choose Draw > Multiline Text.
   • On the Draw toolbar, click the Multiline Text tool.
   • Type mtext and then press Enter.

2. Specify the first point of the text box.

3. In the prompt box, choose Text Style.

4. Type the name of a previously defined text style, and then press Enter.

5. Specify the text height.

6. Specify the rotation angle.

7. Specify the opposite corner of the text box.

8. Type the text.

9. To complete the command, click Close Editor.

11.4.3 Setting the line text alignment

When you create text, you can set the text alignment before you specify the insertion point. You set the alignment by choosing it in the prompt box. By default, text is left justified. You can align text at the left, center, or right and at the top, middle, or base-line of the text or at the bottom of descending letters.
You can also align text so that it fits or aligns between two points. The Align option creates text that scales up or down while maintaining a constant height/width ratio; the Fit option expands or compresses the text to fit between the two points.

To specify the line text alignment

1. Do one of the following to choose Text:
   - On the ribbon, choose Home > Text (in Annotation) or choose Annotate > Text (in Text).
   - On the menu, choose Draw > Text.
   - On the Draw toolbar, click the Text tool.
   - Type dtext and then press Enter.
2. In the prompt box, choose an alignment option, or choose Justification Options to display all the justification options.
3. Specify the text insertion point, and then continue creating the line text.

11.4.4 Setting the paragraph text alignment

When you create paragraph text, you can set the text alignment by specifying the direction in which text flows within the boundary. You can set the paragraph text alignment either in the prompt box displayed after you specify the first corner of the paragraph text boundary or from the Properties pane. You can specify the attachment point at the top left, top center, top right, middle left, middle center, middle right, bottom left, bottom center, or bottom right. The paragraph text can flow left to right, right to left, top to bottom, or bottom to top.
11.4.5 Including special text characters

You can use control codes to over score or underscore text or to include special characters. Both over score and underscore can be active at the same time. To include control codes, as you type text, type two percent symbols (%%) followed by the special control code or character. A single percent sign is treated as a normal text character. A triple-percent control code is provided for those instances where a control-code sequence must follow a percent sign in the text.

<table>
<thead>
<tr>
<th>Style characteristic</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Style name</td>
<td>Standard</td>
<td>The name of the style, up to 255 characters.</td>
</tr>
<tr>
<td>Font file</td>
<td>Arial</td>
<td>The font file on which the style is base, and whether Asian language big font files are used (for .SHX file fonts only).</td>
</tr>
<tr>
<td>Language</td>
<td>Western</td>
<td>The character height. A value of 0 prompts for text height upon insertion.</td>
</tr>
<tr>
<td>Annotative</td>
<td>No</td>
<td>Determines whether text is annotative by default and therefore its display and print is affected by annotation scaling. If annotative by default, also determines whether the text, when displayed in paper space, is oriented automatically according to the layout viewport.</td>
</tr>
<tr>
<td>Text height</td>
<td>0</td>
<td>The character height. A value of 0 prompts for text height upon insertion. The text height is the paper text height if the text style is annotative.</td>
</tr>
<tr>
<td>Width factor</td>
<td>1</td>
<td>The horizontal expansion or compression of the text. Values less than 1 compress the text; values greater than 1 expand the text.</td>
</tr>
<tr>
<td>Obliquing angle</td>
<td>0</td>
<td>The slant of the text, in degrees. Negative values slant the text to the left; positive values slant the text to the right.</td>
</tr>
<tr>
<td>Backward</td>
<td>No</td>
<td>Determines whether text appears backward.</td>
</tr>
<tr>
<td>Upside down</td>
<td>No</td>
<td>Determines whether text appears upside down.</td>
</tr>
<tr>
<td>Vertical</td>
<td>No</td>
<td>Determines whether text has a vertical orientation.</td>
</tr>
</tbody>
</table>
11.5 Changing text

You can change line and paragraph text in your drawing.

11.5.1 Changing line text

You can edit and modify the text as you would any other drawing entity. That is, you can delete, move, rotate, and scale text.

To edit text and its properties

1. Do one of the following to choose Edit Text:
   - On the ribbon, choose Annotate > Edit Text (in Text).
   - On the menu, choose Modify > Entities > Text.
   - On the Modify toolbar, click the Edit Text tool.
   - Type ddedit and then press Enter.
2. Select the text entity.
3. In the Text dialog box, edit the text.
4. Change the text properties you want.

The Text dialog box displays when EDITTEXTMODE is set to 3 (the default).

If the TEXTEDITMODE system variable is set to 1 or 2, line text is edited in the command bar or Properties pane respectively instead of the Text dialog box.

11.5.2 Changing paragraph text

You can modify the text as you would any other drawing entity. That is, you can delete, move, rotate, and scale text.

To edit paragraph text and its properties

1. Do one of the following to choose Edit Text:
   - On the ribbon, choose Annotate > Edit Text (in Text).
   - On the menu, choose Modify > Entities > Text.
   - On the Modify toolbar, click the Edit Text tool.
   - Type ddedit and then press Enter.
2. Select the text entity.
3. In the text editor, edit the text.
4. Change the text properties you want.
5. Click Close Editor.

**11.5.3 Finding and replacing text**

You can search and optionally replace text throughout a drawing, within a layout, or within selected entities.

CAD.direct Drafter searches and displays a list of matching text. Each found text item has an associated entity type to help you identify its location in the drawing. Entity types can include single-line text, multiline text, dimension leaders, hyperlinks, alternate text, paperspace and modelspace. Note that some types of dimension leaders are listed as multiline text because of the way dimensions are created.

Any replacements made to the text are visible in the drawing after you click Done.

**To find an optionally replace text**

1. Do one of the following to choose Find and Replace:
   - Choose Edit > Find and Replace.
   - On the Standard toolbar, click the Find and Replace tool.
   - Type find and then press Enter.
2. In Find What, type the text you want to search for, or select previously entered text from the list.
3. In Find Where, select the location where you want to search:
   - Entire drawing Searches the entire drawing.
   - Current layout Searches the current layout only.
   - Selected entities Searches selected entities only. You can click to switch to the drawing temporarily and select entities.
4. In Text Types, select the text types you want to include in the search.
5. In Search Options, select the desired search options.
6. Click Find to displays a list of all matching text.
7. To replace text, do the following:
   • In Replace With, enter or select the new text.
   • In the list of found text, select the text to replace.
   • Click Replace.

   Use a shortcut for replacing text.

   **Click Replace All to replace all matching text without finding it first.**

8. Click Done to view text changes (if any) in the drawing.
11.5.4 Converting line text to paragraph text

When converting line text to paragraph text, one or more text entities created with the Text command are combined into one multiline text entity. During the conversion, the selected text entities are removed from the drawing and a multiline text entity is created.

To convert line text to paragraph text

1. Do one of the following to choose Text to Multiline Text:
   - On the ribbon, choose Home > Text to Multiline Text (in Annotation) or Annotate > Text to Multiline Text (in Text).
   - On the menu, choose Draw > Text to Multiline Text.
   - On the Text toolbar, click the Text to Multiline Text tool.
   - Type `txt2mtxt` and then press Enter.
2. Select one or more text entities.
3. When finished with selection, press Enter.

To customize options while converting line text to paragraph text

1. Do one of the following to choose Text to Multiline Text:
   - On the ribbon, choose Home > Text to Multiline Text (in Annotation) or Annotate > Text to Multiline Text (in Text).
   - On the Text toolbar, click the Text to Multiline Text tool.
   - Type `txt2mtxt` and then press Enter.
2. Press Enter.
3. Select one of the following:
   - Selection set order Select to add single-line text to multiline text in the order that you select.
   - Top-down order Select to add single-line text to multiline text in the order that they appear in the drawing, from the top downwards.
4. Mark Create Word-Wrap MText to add spaces within individual lines of text, which helps balance multiple lines of text.
5. Click OK.
6. Select one or more text entities.

All text entities are combined into a single multiline text entity.

11.6 Checking the spelling

You can check the spelling of text in your drawing, customize the dictionary to recognize new words, and use a different spelling dictionary that supports another language.

11.6.1 Checking the spelling of text

You can use the Check Spelling command to check the spelling of single-line text, multiline text, paragraph text, attributes, attribute definitions, and dimension text.

To check the spelling of text

1. Do one of the following to choose Check Spelling:
   - On the ribbon, choose Annotate > Check Spelling (in Text).
   - On the menu, choose Tools > Check Spelling.
   - On the Standard toolbar, click the Check Spelling tool.
   - Type spell and then press Enter.

2. Select one or more text entities.
3. In the Check Spelling dialog box, misspelled words display one at a time. Do one of the following for each found word:

- Keep text unchanged — Click Ignore to keep the found word unchanged in the drawing, or click Ignore All to keep all instances of the found word unchanged in the drawing.
- Change text — Select or type a word in the Suggestions box, then click Change to change the found word in the drawing to the new text, or click Change All to change all instances of the found word in the drawing.

4. Click Add if you want to add the currently found word to a list of custom spelling words. The Check Spelling dialog will recognize the added word as spelled correctly the next time the word is checked for spelling.
11.6.2 Customizing the spelling words

Most drawings contain text that is not recognized as spelled correctly, even though it is spelled correctly. For example, if your company name Zaffer, Inc. appears in all of your drawings, the company name will appear as misspelled every time you check the spelling of drawing text. You can easily add words to a custom dictionary so that any word in the custom dictionary is recognized as spelled correctly.

The custom dictionary is independent of any spelling dictionary you have chosen to use. You can check the spelling of text using one dictionary, check the spelling of the same or other text using a different dictionary, and in both cases your custom dictionary is used.

To create and manage a custom dictionary

1. Do one of the following to choose Check Spelling:
   • On the ribbon, choose Annotate > Check Spelling (in Text).
   • On the menu, choose Tools > Check Spelling.
   • On the Standard toolbar, click the Check Spelling tool.
   • Type spell and then press Enter.
2. Select one or more text entities.
3. In the Check Spelling dialog box, click Change Dictionaries.
4. To add a custom word, type a word in Custom Dictionary Words, then click Add.
5. To delete a custom word, select a word in Custom Dictionary Words, then click Delete.
6. Click OK.
You can also add custom words to the custom dictionary during spell checking of text.

_in the Check Spelling dialog box, click Add to add the currently found word to the custom dictionary._

### 11.6.3 Changing the dictionary

The Check Spelling command compares text found in the drawing with correctly spelled words in an installed dictionary (.dic file). There are many different dictionaries that can be used with CAD.direct Drafter, including dictionaries in different languages. You can download and install a new dictionary or use a dictionary already installed on your computer.

**To download and install a new dictionary**

1. Do one of the following to choose Check Spelling:
   - On the ribbon, choose Annotate > Check Spelling (in Text).
   - On the menu, choose Tools > Check Spelling.
   - On the Standard toolbar, click the Check Spelling tool.
• Type spell and then press Enter.
• On the ribbon, choose Annotate > Check Spelling (in Text).

2. Select one or more text entities, then in the Check Spelling dialog box, click Change Dictionaries.
3. Click Download.
4. From the web page that displays (or from a different web page), download the desired dictionary.
5. Unzip the contents of the downloaded file to \MyDocuments\Spelling, or the location where you installed spelling dictionaries for CAD.direct Drafter.
6. Click Change Dictionaries again, which will load the newly installed dictionary.
7. In Main Dictionary, select the desired dictionary.
8. Click OK.
To use a dictionary already installed on your computer

1. Do one of the following:

   • Copy the existing dictionary (.dic file) to \MyDocuments\Spelling, or to the location where you install spelling dictionaries for CAD.direct Drafter.
   
   • Add the folder of the existing dictionary to the list of folders where CAD.direct Drafter searches for dictionaries. Choose Tools > Options, click Paths/Files and add the folder location to the Dictionary paths. For more details, see

2. Choose Tools > Check Spelling, select one or more text entities, then in the Check Spelling dialog box, click Change Dictionaries.

3. In Main Dictionary, select the desired dictionary.

4. Click OK.

11.7 Using an alternate text editor

CAD.direct Drafter includes a built-in text editor for creating paragraph text using the Multi-line Text command. You can also specify an alternate text editor for the Multiline Text command.

11.7.1 Selecting an alternate text editor

Before you can use an alternate text editor, you must specify the editor by setting the MTEXTED system variable.

To select an alternate text editor

1. Type mtexted and then press Enter.

2. Enter the path and name of the executable file for the text editor you want to use to create or edit multiline text. For example, to use Microsoft® Wordpad, you would type something similar to the following (adjusting the path name as necessary):

   C:\Program Files\Windows\Accessories\Wordpad.exe
11.7.2 Creating paragraph text in an alternate text editor

After you set up CAD.direct Drafter to use an alternate text editor, you can start using it to include text in your drawings.

To use an alternate text editor

1. Do one of the following to choose Multiline Text:
   - On the ribbon, choose Home > Multiline Text (in Annotate).
   - On the menu, choose Draw > Multiline Text.
   - On the Draw toolbar, click the Multiline Text tool.
   - Type mtext and then press Enter.

2. Select the first and second corners of the text area.

3. In the text editor, type the text you want, using the special characters from the table shown next to achieve special formatting. Enter \P to end a paragraph and start a new paragraph on the next line. For example, to use an alignment value of 1 and stack two numbers to display them as a fraction:

4. When your text is complete, save the changes and exit the text editor.

<table>
<thead>
<tr>
<th>Special format character</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>\0...\0</td>
<td>Toggles overscore mode on and off.</td>
</tr>
<tr>
<td>\1...\1</td>
<td>Toggles underscore mode on and off.</td>
</tr>
<tr>
<td>~</td>
<td>Inserts a nonbreaking space.</td>
</tr>
<tr>
<td>\</td>
<td>Inserts a backslash.</td>
</tr>
<tr>
<td>{...}</td>
<td>Inserts an opening and closing brace.</td>
</tr>
<tr>
<td>\Value;</td>
<td>Sets the color to a specified value.</td>
</tr>
<tr>
<td>\FileName;</td>
<td>Sets the font based on a specified font file name.</td>
</tr>
<tr>
<td>\Value;</td>
<td>Sets the text height to a specified value.</td>
</tr>
<tr>
<td>\ValueX;</td>
<td>Sets the text height to a multiple of the current text height.</td>
</tr>
<tr>
<td>\S...\A...</td>
<td>Stacks the subsequent text at the /, #, or ^ symbol.</td>
</tr>
<tr>
<td>\Value;</td>
<td>Adjusts the space between characters, from 0.75 to 4 times.</td>
</tr>
<tr>
<td>\Angle;</td>
<td>Changes obliquing angle.</td>
</tr>
<tr>
<td>\WValue;</td>
<td>Changes width factor to produce wide text.</td>
</tr>
<tr>
<td>\A</td>
<td>Sets the alignment value.</td>
</tr>
<tr>
<td>\P</td>
<td>Ends paragraph.</td>
</tr>
<tr>
<td>([i].),([x1,x2,...,x32])</td>
<td>Formats paragraph: i = first line indent; l = paragraph offset; t = tab positions.</td>
</tr>
</tbody>
</table>
11.8 Working with text written in different languages

You can include text in your drawings that is written in different languages.

11.8.1 Using Unicode characters

CAD.direct Drafter supports the Unicode character encoding standard, which enables you to display and write text in different languages using different letters. Unicode fonts contain many more characters than typically defined in a system. The following table describes only a small set that is available.

<table>
<thead>
<tr>
<th>Unicode control code</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>\U+00B0</td>
<td>Draws a degree symbol (°).</td>
</tr>
<tr>
<td>\U+00B1</td>
<td>Draws the plus-or-minus symbol (±).</td>
</tr>
<tr>
<td>\U+0394</td>
<td>Draws the delta symbol (Δ).</td>
</tr>
<tr>
<td>\U+2205</td>
<td>Draws the circle diameter symbol (Ø).</td>
</tr>
<tr>
<td>\U+03A9</td>
<td>Draws the omega symbol (Ω).</td>
</tr>
<tr>
<td>\U+2260</td>
<td>Draws the not equal symbol (≠).</td>
</tr>
</tbody>
</table>

For details about using other special characters, see “Including special text characters” on page 350 in this chapter. You can also use a different text editor; see “Using an alternate text editor” on page 360 in this chapter.

11.8.2 Specifying character sets for drawings

The character set used to display text in drawings typically depends on the character set specified by your operating system, for example, ANSI_1252 is Latin 1, ANSI_1253 is Greek, and ANSI_1254 is Turkish. This is also called the code page.

CAD.direct Drafter allows you to manage which code page is assigned to a drawing. This unique feature is usually not necessary if you distribute drawings within the same geographic region, but it can be very helpful when sharing or distributing drawings between different geographic regions. Changing the code page is highly desirable especially in geographic regions where several languages are used that require different character sets to display text properly.

Setting the code page doesn’t change the language of your text; instead it specifies the character set in which the text displays. Some fonts can display its characters several different ways depending on the code page setting.
There are two system variables that relate to the code page of a drawing:

- SYSCODEPAGE — Character set defined for your operating system.
- DWGCODEPAGE — Character set defined for an individual drawing that over-rides the operating system code page.

**To select a code page for the current drawing**

1. Type `codepage` and then press Enter.

   The Code Page Manager dialog box opens.

2. If you want to convert the drawing to use a code page that is different from the operating system code page, in Drawing Code Page, select the new code page for the drawing.

3. Click OK.
12. Dimensioning your drawing

The CAD.direct Drafter dimensioning tools let you add measurements to a drawing. You can quickly add dimensions by simply pointing to entities. You can also add tolerance symbols to your drawings.

The program’s many dimensioning variables let you control the appearance of the dimensions. With dimension styles, you can save dimension variable settings so you can reuse them without having to re-create them.

This section explains how to:

- Create dimensions as linear, angular, arcs, diametral, radial, and ordinate.
- Create leaders and annotations.
- Edit dimensions.
- Use dimension styles and variables.
- Add geometric tolerances.
- Control alternate dimension units.

12.1 Understanding dimensioning concepts

You can create five basic types of dimensions: linear, angular, radial, diametral, and ordinate. You can create dimensions for existing entities by selecting them, or you can create dimensions by selecting points within a drawing. For example, you can create a linear dimension either by selecting the entity to be dimensioned or by specifying the first and second extension line origins.
When you create a dimension, the program draws it on the current layer, using the current dimension style. Each dimension has a corresponding dimension style, which controls the appearance of the dimension, such as the types of arrowheads, text style, and colors of various components. You can modify existing dimension styles by changing one of the dimension variable settings and then updating the dimension style to reflect the new settings.

Each dimension you create consists of several parts. A dimension line shows where a dimension begins and ends. When you create an angular dimension, the dimension line is a dimension line arc that subtends the measured angle.

Extension lines, also called projection lines, are lines that extend away from the entity for which you are creating a dimension, so that you can place the dimension line away from the entity. Arrowheads form the termination at each end of the dimension line.

Dimension text contains the measured dimension and can also include prefixes, suffixes, tolerances, and other optional text. As you insert dimensions, you can control the dimension text and specify its position and orientation.

Dimensions can also contain other optional components. A leader is a line leading from a feature of the drawing to an annotation. Leaders begin with an arrowhead, and you can use them to place a dimension away from the dimension line or to add notes. When you create a radial dimension, you can add a center mark, which is a small cross that marks the center of a circle or an arc, or you can add centerlines, which are crossing lines that extend out from the center of a circle or an arc.
Dimensions can be one of three types:

- **Associative** — A dimension is linked with the entities it measures. If the entities being measured by the dimension are modified, the dimension is updated automatically. Newly created dimensions are associative when DIMASSOC is set to 2 (default) and created using entity snaps.
- **Non-associative** — A dimension is not linked with the entities it measures. If the entities being measured by the dimension are modified, the dimension is not updated automatically. Newly created dimensions are non-associative when DIMASSOC is set to 1.
- **Exploded** — Dimensions are created as separate entities, not a single dimension entity. Newly created dimensions are exploded when DIMASSOC is set to 0.

### 12.2 Creating dimensions

You can create dimensions by:

- Selecting the entity to dimension and specifying the dimension line location.
- Specifying the extension line origins and the dimension line location.

When you create dimensions by selecting an entity, the program automatically places the extension line origins at the appropriate definition points based on the type of entity you select. For example, the definition points are located at the endpoints of arcs, lines, and polyline segments. When you create dimensions by specifying the extension line origins, the points you specify determine the definition points. To establish these points precisely, use entity snaps.

You can create dimensions in model space or paper space.

#### 12.2.1 Creating linear dimensions

Linear dimensions annotate linear distances or lengths and can be oriented horizontally, vertically, or aligned parallel to an existing entity or to the selected extension origin points. After you create a linear dimension, you can add a baseline dimension or a continued dimension. A linear baseline dimension inserts an additional dimension from a common first extension line origin of a previous linear dimension. A linear continued dimension continues a linear dimension from the second extension line of a previous linear dimension.

Selecting exact points is important when creating dimensions.

Use entity snaps to select precise ordinate points.
To create a horizontal or vertical dimension

1. Do one of the following to choose Linear:
   - On the ribbon, choose Annotate > Linear (in Dimensions).
   - On the menu, choose Dimensions > Linear.
   - On the Dimensioning toolbar, click the Linear tool.
   - Type dimaligned and then press Enter.

2. Press Enter, and then select the entity to dimension.

3. Specify the dimension line location.

To create an aligned dimension

1. Do one of the following to choose Aligned:
   - On the ribbon, choose Annotate > Aligned (in Dimensions).
   - On the menu, choose Dimensions > Aligned.
   - On the Dimensioning toolbar, click the Aligned tool.
   - Type dimaligned and then press Enter.
2. Press Enter, and then select the entity to dimension.

Or you can insert the dimension by specifying the first and second extension line origins.

3. Specify the dimension line location.

To create a linear baseline dimension

1. Create a dimension.

2. Do one of the following to choose Baseline

On the ribbon, choose Annotate > Baseline (in Dimensions).

- On the menu, choose Dimensions > Baseline.
- On the Dimensioning toolbar, click the Baseline tool.
- Type dimbaseline and then press Enter.

3. To select a starting dimension, press Enter.

4. Select the next extension line origin, and then press Enter.

Or press Enter, and then select an existing dimension for the baseline. Select the origin of the next extension line, and then press Enter.
The program automatically places the new baseline dimension above or below the previous dimension line. The distance between the two dimension lines is determined by the Baseline Offset value in the Dimension Styles dialog box.

To create a linear continued dimension

1. Create a dimension.
2. Do one of the following to choose Continue:
   - On the ribbon, choose Annotate > Continue (in Dimensions).
   - On the menu, choose Dimensions > Continue.
   - On the Dimensioning toolbar, click the Continue tool.
   - Type dimcontinue and then press Enter.
3. To select a starting dimension, press Enter.
4. Select the next extension line origin, and then press Enter.
Or press Enter, and then select an existing dimension to continue.

5. To add continued dimensions, continue selecting extension line origins. 6 To end the command, press Enter twice.

6. To end the command, press Enter twice.

12.2.2 Creating angular dimensions

Angular dimensions annotate the angle measured between two lines. You can also dimension an angle by selecting an angle vertex and two endpoints. After you create an angular dimension, you can add a baseline dimension or a continued dimension. An angular baseline dimension inserts an additional dimension from a common first extension line origin of a previous angular dimension. An angular continued dimension continues an angular dimension from the second extension line of a previous angular dimension.

To dimension an angle encompassed by an arc

1. Do one of the following to choose Angular:
   - On the ribbon, choose Annotate > Angular (in Dimensions).
   - On the menu, choose Dimensions > Angular.
On the Dimensioning toolbar, click the Angular tool.
Type dimangular and then press Enter.

2. Select the arc.
3. Specify the dimension arc location.

To dimension an angle between two lines

1. Do one of the following to choose Angular:
   - On the ribbon, choose Annotate > Angular (in Dimensions).
   - On the menu, choose Dimensions > Angular.
   - On the Dimensioning toolbar, click the Angular tool.
   - Type dimangular and then press Enter.
2. Select one line.
3. Select the other line.
4. Specify the dimension line location.
Or press Enter, and then select an existing dimension for the baseline. Select the origin of the next extension line, and then press Enter.

The program automatically places the new baseline dimension above or below the previous dimension line. The distance between the two dimension lines is determined by the Baseline Offset value in the Dimension Styles dialog box.

**12.2.3 Creating arc dimensions**

Arc dimensions annotate the length of an arc or arc segment. You can also dimension a portion of an arc by selecting two points. After you create an arc dimension, you can change its text to the arc angle or to any other text.

**To dimension an arc length**

1. Do one of the following to choose Arc:
   - On the ribbon, choose Annotate > Arc (in Dimensions).
   - On the menu, choose Dimensions > Arc.
   - On the Dimensioning toolbar, click the Arc tool.
   - Type dimarc and then press Enter.
2. Select the arc or arc segment.
3. Specify the dimension arc location.
To dimension part of an arc length

1. Do one of the following to choose Arc:
   - On the ribbon, choose Annotate > Arc (in Dimensions).
   - On the menu, choose Dimensions > Arc.
   - On the Dimensioning toolbar, click the Arc tool.
   - Type dimarc and then press Enter.

2. Choose Partial.

3. Select the start point of the arc length you want to measure.

4. Select the end point.

12.2.5 Creating diametral and radial dimensions

Diameter and radius dimensions annotate the radii and diameters of arcs and circles. You can optionally include centerlines or center marks.

To create a diametral dimension

1. Do one of the following to choose Diameter:
   - On the ribbon, choose Annotate > Diameter (in Dimensions).
   - On the menu, choose Dimensions > Diameter.
• On the Dimensioning toolbar, click the Diameter tool.
• Type dimdiameter and then press Enter.

2. Select the arc or circle.

3. Specify the dimension line location.

To create a radial dimension
1. Do one of the following to choose Radius:
   • On the ribbon, choose Annotate > Radius (in Dimensions).
   • On the menu, choose Dimensions > Radius.
   • On the Dimensioning toolbar, click the Radius tool.
   • Type dimradius and then press Enter.

2. Select the arc or circle.

3. Specify the dimension line location.
### 12.2.6 Creating ordinate dimensions

An ordinate dimension annotates the perpendicular distance from an origin or base point (the origin of the current user coordinate system [UCS]). Ordinate dimensions consist of an x- or y-coordinate and a leader. An x-ordinate dimension measures distances along the x-axis; a y-ordinate dimension measures distances along the y-axis.

As you select ordinate points, the program automatically determines whether the point is an x- or y-ordinate based on which direction you drag the second point. You can also specify whether the ordinate represents an x- or y-ordinate. Ordinate dimension text is always aligned with the ordinate leader lines, regardless of the text orientation specified by the current dimension style.

**To create an ordinate dimension**

1. Do one of the following to choose Ordinate:
   - On the ribbon, choose Annotate > Ordinate (in Dimensions).
   - On the menu, choose Dimensions > Ordinate.
   - On the Dimensioning toolbar, click the Ordinate tool.
   - Type `dimordinate` and then press Enter.

2. Select the point for ordinate dimension.

3. Specify the ordinate leader endpoint.

Selecting exact points is important when creating dimensions. Use entity snaps to select precise ordinate points.
12.2.7 Creating leaders and annotations

Leaders consist of a line or series of lines that connects a feature in a drawing to an annotation. Generally, you place an arrowhead at the first point. An annotation, created as dimension text, is placed immediately adjacent to the last point. By default, the text placed at the end of the leader line consists of the most recent dimension. You can also type an annotation as a single line of text.

To create a leader and an annotation

1. Do one of the following to choose Leader:
   - On the ribbon, choose Annotate > Leader (in Dimensions).
   - On the menu, choose Dimensions > Leader.
   - On the Dimensioning toolbar, click the Leader tool.
   - Type dimleader and then press Enter.
2. Specify the starting point of the leader.
3. Specify the endpoint of the leader line segment.
4. Specify additional leader line segment endpoints.
5. After you specify the last endpoint, press Enter.
6. Type the annotation, or press Enter to accept the most recent dimension as the default annotation.
12.2.8 Dimensioning model space entities in paper space

To increase efficiency, you can separate your drawing model from annotations using the Model and Layout tabs.

It takes time to display dimensions, title blocks, keynotes, and other annotations. If you draw these on a Layout tab, display-time and visual clutter are reduced when you work on your model (on the Model tab). CADdirect Drafter allows you to dimension model space entities on either the Model tab or a Layout tab — you can make the choice depending on the method that works best for your needs.

To dimension model space entities in paper space

1. Click a Layout tab.

2. Create at least one layout viewport. For details, see “Creating layout viewports” on page 457.

3. Lock the desired layout viewport by doing the following:
   - Right-click the edge of the layout viewport that you want to use for creating dimensions.
   - Choose Properties.
   - Mark Lock Viewport, and then click OK.

Locking the viewport is not required, but it is extremely helpful when you zoom or pan in the layout viewport; it prevents the viewport scale and view center from changing.
You can work in a layout viewport without having it clutter your display or selections.

*Place layout viewports on their own layer, and after locking the layout viewports, hide the layer that contains them.*

4. Make sure you are working in paper space by verifying that the Model/Paper Space toggle in the status bar begins with “P.” If necessary, switch to paper space by double-clicking the Model/Paper Space toggle in the status bar.

5. Create a dimension. You can select the model space entities directly, specify definition points, or use entities snaps to help accurately select the definition points.

The dimension is created in paper space.

For more details about using paper space and model space, see “Understanding paper space and model space” on page 450.

### 12.3 Editing dimensions

You can use grips to edit entity dimensions. You can also edit the dimension text. You can rotate dimension lines and dimension text at any angle, and you can reposition the dimension text anywhere along the dimension line.

#### 12.3.1 Making dimensions oblique

Extension lines are normally created at a perpendicular angle to the dimension line. You can change the angle of the extension lines, however, so that they tilt relative to the dimension line.

**To make oblique extension lines**

1. Do one of the following to choose Make Oblique:
   - On the ribbon, choose Annotate > Make Oblique (in Dimensions).
   - On the menu, choose Dimensions > Make Oblique.
   - On the Dimensioning toolbar, click the Make Oblique tool.
   - Type `dimedit`, press Enter, and then in the prompt box, choose Oblique Lines. 2 Select the linear dimension, and then press Enter.
2. Type the obliquing angle, and then press Enter.
You can align the oblique angle if you don’t know the exact measurement.

Use entity snaps to pick two points on the entity.

**12.3.2 Editing dimension text**

You can rotate the text of an existing dimension, move the dimension text to a new position, or replace selected dimension text with new text. You can also restore dimension text to its original position as defined by the current dimension style.

When you rotate or replace selected text, you specify the change first, and then select one or more dimensions to which to apply the change. All the selected dimensions are updated simultaneously.

**To rotate dimension text**

Advanced experience level

1. Do one of the following to choose Rotate Dimension Text:
   - On the ribbon, choose Annotate > Rotate Dimension Text (in Dimensions).
   - On the menu, choose Dimensions > Rotate Dimension Text.
   - On the Dimensioning toolbar, click the Rotate Dimension Text tool.
   - Type `dimedit`, press Enter, and then in the prompt box, choose Rotate Text.
2. Type the new dimension text angle, and then press Enter.
3. Select the dimension to be rotated, and then press Enter.
The dimension text angle is relative to the dimension line.

If the dimension text rotation is set to zero, the text angle is defined by the dimension type and the dimension style.

**To move dimension text**

Advanced experience level

1. Do one of the following to choose Reposition Dimension Text:
   - On the ribbon, choose Annotate > Reposition Dimension Text (in Dimensions).
   - On the menu, choose Dimensions > Reposition Dimension Text.
   - On the Dimensioning toolbar, click the Reposition Dimension Text tool.
   - Type `dimtedit` and then press Enter.
2. Select the dimension to reposition text.
3. Select the new text position.
To restore dimension text to its home position

Advanced experience level

1. Do one of the following to choose Restore Text Position:
   - On the ribbon, choose Annotate > Restore Text Position (in Dimensions).
   - On the menu, choose Dimensions > Restore Text Position.
   - On the Dimensioning toolbar, click the Restore Text Position tool.
   - Type dimedit, press Enter, and then in the prompt box, choose Restore Text.

2. Select the dimension text to restore, and then press Enter.

To replace existing dimension text with new text

Advanced experience level

1. Do one of the following to choose Edit Dimension Text
   - On the ribbon, choose Annotate > Edit Dimension Text (in Dimensions).
   - On the menu, choose Dimensions > Edit Dimension Text.
   - On the Dimensioning toolbar, click the Edit Dimension Text tool.
   - Type dimedit and then in the prompt box, choose Edit Text.

2. Type the new dimension text, and then press Enter.

3. Select the dimension to be replaced, and then press Enter.

12.4 Using dimension styles and variables

Dimensions that you insert are created using the current dimension style. You can create, save, restore, and delete named dimension styles. To display information about the current dimension style and compare it with other style names, you can use the dimstyle command.

12.4.1 Creating a dimension style

Dimension styles provide a way for you to change various settings that control the appearance of dimensions. You can then save those settings for reuse. If you don’t define a dimension style before creating dimensions, the program uses the Standard dimension style, which stores the default dimension variable settings. Each option in the Dimension Styles dialog box relates to a variable that you can set manually. See the online Command Reference for more information.
To create a dimension style

1. Do one of the following to choose Dimension Styles Manager:
   - On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).
   - On the menu, choose Dimensions > Dimension Styles Manager or choose Format > Dimension Styles Manager.
   - On the Dimensioning toolbar, click the Dimension Styles tool.
   - Type setdim and then press Enter.

2. In the Dimension Styles Manager dialog box, click New. 3 Type the name of the new dimension style.

4. Click Continue.

5. In the Dimension Styles dialog box, make your selections for the dimension style as necessary.

6. When finished, click OK.

12.4.2 Selecting a dimension style

To select a dimension style

1. Do one of the following to choose Dimension Styles Manager:
   - On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).
   - On the menu, choose Dimensions > Dimension Styles Manager or choose Format > Dimension Styles Manager.
   - On the Dimensioning toolbar, click the Dimension Styles tool.
   - Type setdim and then press Enter.

2. In the Dimension Styles Manager dialog box, select a dimension style from the list.

3. Click Set Current.

4. Click Close.
12.4.3 Renaming a dimension style

To rename a dimension style

1. Do one of the following to choose Dimension Styles Manager:
   - On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).
   - On the menu, choose Dimensions > Dimension Styles Manager or choose Format > Dimension Styles Manager.
   - On the Dimensioning toolbar, click the Dimension Styles Manager tool.
   - Type setdim and then press Enter.
2. In the Dimension Styles Manager dialog box, click Rename.
3. In the Rename list, select the dimension style you want to rename.
4. Type the new dimension style name.
5. Click Rename.
6. Click OK.

12.4.4 Deleting a dimension style

To delete a named dimension style

1. Do one of the following to choose Dimension Styles Manager:
   - On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).
   - On the menu, choose Dimensions > Dimension Styles Manager or choose Format > Dimension Styles Manager.
   - On the Dimensioning toolbar, click the Dimension Styles Manager tool.
   - Type setdim and then press Enter.
2. In the Dimension Styles dialog box, select the dimension style to delete.
3. Click Delete.
4. To confirm the deletion, click OK.
5. Click OK.
To display information about the current style

1. Type `dimstyle` and then press Enter.
2. Type `v` and then press Enter to display information about the variables.
3. Type the dimension style name, and press Enter.

12.4.5 Controlling line settings

You can control settings affecting dimension lines, extension lines, and center marks. Any changes you make affect the current dimension style. The image tile on the right side of the Dimension Styles dialog box shows the appearance of the dimensions based on the current dimension style settings.

To set the color for dimension lines

1. Do one of the following to choose Dimension Styles Manager:
   - On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).
   - On the menu, choose Dimensions > Dimension Styles Manager or choose Format > Dimension Styles Manager.
   - On the Dimensioning toolbar, click the Dimension Styles Manager tool.
   - Type `setdim` and then press Enter.
2. Click the Lines tab.
3. Make your selections.
4. Click OK.
12.4.6 Controlling dimension arrows

You can control the appearance and size of arrowheads or tick marks placed at the ends of dimension lines. Any changes you make affect the current dimension style. The arrowheads you choose display in the image tile on the right side of the Dimension Styles dialog box.

You can choose from a number of arrowhead types. You can specify different arrowheads for each end of a dimension line and for leader lines. The Starting arrow corresponds to the first extension line; the Ending arrow corresponds to the second extension line. Blocks defined in the drawing also display in the three Arrowhead lists as user-defined arrows. You can use these blocks to create and assign your own arrowheads.

The Arrow Size value determines the size of the arrowhead, measured in drawing units. You can also use tick marks instead of arrowheads.

To choose an arrowhead

1. Do one of the following to choose Dimension Styles Manager:
   - On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).
   - On the menu, choose Dimensions > Dimension Styles Manager or choose Format > Dimension Styles Manager.
   - On the Dimensioning toolbar, click the Dimension Styles Manager tool.
   - Type setdim and then press Enter.
2. Click the Symbols and Arrows tab.
3. In the Starting Arrowhead or Ending Arrowhead list, click to select the starting or ending arrowhead, respectively. If necessary, mark Allow Separate Arrowheads if you want to use different starting and ending arrowheads.
4. In the Leader Arrowhead list, click to select a leader arrowhead for leader lines.
5. Click OK.

Use the system variable.

The DIMLDRBLK system variable also specifies leader arrow types
12.4.7 Controlling dimension text

You can control the settings affecting the appearance of dimension text. Any changes you make affect the current dimension style. The image tile on the right side of the Dimension Styles dialog box shows the appearance of the dimensions based on the current dimension style settings.
To align dimension text with the dimension line

1. Do one of the following to choose Dimension Styles Manager:
   - On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).
   - On the menu, choose Dimensions > Dimension Styles Manager or choose Format > Dimension Styles Manager.
   - On the Dimensioning toolbar, click the Dimension Styles Manager tool.
   - Type setdim and then press Enter.

2. Click the Text tab.

3. Make your selections.

4. Click OK.
12.4.8 Controlling dimension fit

You can control the way dimension text and arrowheads are placed in relation to the dimension lines. You can also control how the dimension scales by choosing whether it is annotative by default or whether it scales according to a specific scale or according to the layout. Any changes you make affect the current dimension style. The image tile on the right side of the Dimension Styles dialog box shows the appearance of dimensions based on the current dimension style settings.

The program determines whether both dimension text and arrowheads will fit between the extension lines by comparing the distance between the extension lines to the size of the dimension text, the size of the arrowheads, and the amount of space required around dimension text. The program applies the best fit method based on the available space. If possible, both the dimension text and arrowheads are placed between the extension lines. If both will not fit between the extension lines, you can determine how text and arrowheads are placed using the Fit Method settings on the Dimension Styles dialog box.

To format the fit of dimensions

1. Do one of the following to choose Dimension Styles Manager:
   - On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).
   - On the menu, choose Dimensions > Dimension Styles Manager or choose Format > Dimension Styles Manager.
   - On the Dimensioning toolbar, click the Dimension Styles Manager tool.
   - Type setdim and then press Enter.

2. Click the Fit tab.

3. Click the options that you want.

4. Click OK.
Use the system variables.

The DIMATFIT system variable specifies how dimension text and arrows are arranged. The DIMTMOVE system variable specifies how dimension text is moved.

A. Select how to fit text and arrows if they both do not fit inside extension lines.
B. Select to always place text inside extension lines.
C. Select to prevent the creation of arrows if they don't fit inside extension lines.
D. Select to draw dimension lines between extension lines when text and arrows are placed outside extension lines.
E. Select how to position text relative to dimension lines and whether to include a leader.
F. Select to be prompted for text placement when creating dimensions.
G. Select to scale the dimension according to the layout or enter a specific scale to apply to all dimension style settings (available only if Annotative is not selected).
H. Select to make the dimension support annotative scaling by default.
12.4.9 Controlling primary dimension units

You can determine the appearance and format of the primary dimension units. The image tile on the right side of the Dimension Styles dialog box shows the appearance of the dimensions based on the current dimension style settings.

To set the primary units of dimensions

1. Do one of the following to choose Dimension Styles Manager:
   - On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).
   - On the menu, choose Dimensions > Dimension Styles Manager or choose Format > Dimension Styles Manager.
   - On the Dimensioning toolbar, click the Dimension Styles Manager tool.
   - Type setdim and then press Enter.
2. Click the Primary Units tab.
3. Make your selections.
4. Click OK.

Use the system variables.

*The DIMLUNIT system variable specifies units for linear dimensions. The DIMFRAC system variable specifies fraction formats.*
A. Select the linear dimension unit format.
B. Type or select the number of decimal places for text of linear dimensions.
C. Select the format for text fractions of linear dimensions.
D. Enter the marker symbol used for decimals.
E. Type or select the nearest value to round to for linear distances.
F. Type a prefix to be appended to linear dimension text.
G. Type a suffix to be appended to linear dimension text.
H. Select to prevent the inclusion of trailing zeros for linear dimension text.
I. Select to prevent the inclusion of leading zeros for linear dimension text.
J. Select to prevent the inclusion of inches or feet in dimension text when the corresponding number of inches or feet is zero.
K. Select to prevent the inclusion of leading zeros for angular dimensions.
L. Select the angular dimension unit format.
M. Type or select the number of decimal places for angular dimensions.
N. Select to prevent the inclusion of trailing zeros for angular dimensions.
O. Type or select the linear scale factor applied to all lengths measured by dimensioning commands.
P. Type or select the scale factor applied to all dimensions.
12.4.10 Controlling alternate dimension units

You can include alternate dimensions in addition to the primary dimension text. You can also determine the appearance and format of the alternate dimensions, including the scale factor applied to generate alternate dimensions. The image tile on the right side of the Dimension Styles dialog box shows the appearance of the dimensions based on the current dimension style settings.

To control alternate dimension units

1. Do one of the following to choose Dimension Styles Manager:
   - On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).
   - On the menu, choose Dimensions > Dimension Styles Manager or choose Format > Dimension Styles Manager.
   - On the Dimensioning toolbar, click the Dimension Styles Manager tool.
   - Type setdim and then press Enter.
2. Click the Alternate Units tab.
3. Select Display Alternate Units.
4. Make your selections.
5. Click OK.
A. Select to include alternate units with dimension text.
B. Click to select the format for alternate dimension text.
C. Type or select the number of decimal places displayed in alternate dimension text.
D. Type or select the scale factor applied to measured dimensions to generate the alternate dimension text.
E. Type or select any rounding for alternate dimension text.
F. Type a prefix to be appended to alternate dimension text.
G. Type a suffix to be appended to alternate dimension text.
H. Select the placement of alternate dimension text.
I. Select to prevent the inclusion of trailing zeros for alternate dimension text.
J. Select to prevent the inclusion of leading zeros for alternate dimension text.
K. Select to prevent the inclusion of inches or feet in alternate dimension text when the corresponding number of inches or feet is zero.
L. Select to prevent the inclusion of leading zeros for tolerances included as part of alternate dimensions.
M. Select to prevent the inclusion of trailing zeros for tolerances included as part of alternate dimensions.
N. Select to prevent the inclusion of inches or feet for tolerances included as part of alternate dimensions when the corresponding number of inches or feet is zero.
O. Type or select the number of decimal places displayed in limits or tolerances included as part of alternate dimensions.
12.5 Adding geometric tolerances

Geometric tolerances indicate the maximum allowable variations in the geometry defined by a drawing. CAD direct Drafter draws geometric tolerances using a feature control frame, which is a rectangle divided into compartments.

12.5.1 Understanding geometric tolerances

Each feature control frame consists of at least two compartments. The first compartment contains a geometric tolerance symbol that indicates the geometric characteristic to which the tolerance is applied, such as location, orientation, or form. For example, a form tolerance may indicate the flatness or roundness of a surface. The geometric tolerance symbols and their characteristics are shown in the following table.
The second compartment contains the tolerance value. When appropriate, the tolerance value is preceded by a diameter symbol and followed by a material condition symbol. The material conditions apply to features that can vary in size. The material condition symbols and their meanings are shown in the following table.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>M</td>
<td>At maximum material condition (MMC), a feature contains the maximum amount of material stated in the limits.</td>
</tr>
<tr>
<td>L</td>
<td>At least material condition (LMC), a feature contains the minimum amount of material stated in the limits.</td>
</tr>
<tr>
<td>S</td>
<td>Regardless of feature size (RFS) indicates that the feature can be any size within the stated limits.</td>
</tr>
</tbody>
</table>

The tolerance value can then be followed by primary, secondary, and tertiary datum reference letters, along with the material conditions of each datum. Datum reference letters are generally used as reference tolerances to one of up to three perpendicular planes from which a measurement is made, although datum reference letters can also indicate an exact point or axis.

When two tolerances apply to the same geometry, you can also add a composite tolerance consisting of a primary tolerance value followed by a secondary tolerance value. To make a tolerance even more specific, it can also contain a projected tolerance consisting of a height value followed by a projected tolerance symbol. For example, you can use a projected tolerance to indicate the perpendicularity of an embedded part.
12.5.2 Adding a geometric tolerance

To add a geometric tolerance

1. Do one of the following to choose Tolerance:
   • On the ribbon, choose Annotate > Tolerance (in Dimensions).
   • On the menu, choose Dimensions > Tolerance.
   • On the Dimensioning toolbar, click the Tolerance tool.
   • Type tolerance and then press Enter.

2. To display the geometric tolerance symbols, on the first line, click the Sym box.

3. Click to select a geometric tolerance symbol.

4. Under Tolerance 1, click the Dia box to add a diameter symbol.

5. In the field, type the first tolerance value.

6. To display the material condition symbols, click the M.C. box.

7. Click to select a material condition.

8. Under Tolerance 2, repeat steps 4 through 7 to add a secondary tolerance value, if appropriate.

9. Under Datum 1, type the primary datum reference letter.

10. To display the material condition symbols, click the M.C. box.

11. Click to select a material condition.

12. Repeat steps 9 through 11 to add secondary and tertiary datum, if appropriate.

13. In the second row, repeat steps 2 through 12 to add composite tolerances, if appropriate.

14. In the Height box, type a projected tolerance zone height value, if appropriate.

15. To insert a projected tolerance zone symbol, click the Projected Tolerance Zone box, if appropriate.

16. Click OK.

17. In the drawing, specify the location of the feature frame.
A  Use this row to include composite tolerances.
B  Type a projected tolerance height value.
C  Type a datum identifier.
D  Click to include a projected tolerance symbol.
E  Click to select the material condition symbol for tertiary data.
F  Type the tertiary datum reference letter.
G  Click to select the material condition symbol for secondary datum.
H  Type the secondary datum reference letter.
I  Click to select the material condition symbol for primary datum.
J  Type the primary datum reference letter.
K  Click to select the material condition symbol for the second tolerance value.
L  Type the second tolerance value.
M  Click to include a diameter symbol for the second tolerance value.
N  Click to select the material condition symbol for the first tolerance value.
O  Type the first tolerance value.
P  Click to include a diameter symbol for the first tolerance value.
Q  Click to select a geometric tolerance symbol.
12.5.3 Controlling dimension tolerances

You can create dimensions as either tolerance or limits dimensions. When creating a tolerance dimension, you can control the upper and lower tolerance limits as well as the number of decimal places of the dimension text. The image tile on the right side of the Dimension Styles dialog box shows the appearance of tolerance and limits dimensions based on the current dimension style settings.

![Image showing tolerance and limits dimensions](image)

**To control dimension tolerances**

1. Do one of the following to choose Dimension Styles Manager:
   - On the ribbon, choose Annotate > Dimension Styles Manager (in Dimensions).
   - On the menu, choose Dimensions > Dimension Styles Manager or choose Format > Dimension Styles Manager.
   - On the Dimensioning toolbar, click the Dimension Styles Manager tool.
   - Type setdim and then press Enter.

2. Click the Tolerance tab.

3. Make your selections.

4. Click OK.
A Select to insert a plus and minus tolerance value with dimension text.
B Select to insert upper and lower tolerance limits with dimension text.
C Type or select the number of decimal places displayed in limits or tolerance dimension text.
D Type or select the minimum tolerance or lower limit value.
E Type or select the maximum tolerance or upper limit value.
F Type or select the scale factor applied to the height of limits or tolerance dimension text.
G Select the vertical justification of limits or tolerance dimension text.
H Select to prevent the inclusion of trailing zeros in limits or tolerances dimension text.
I Select to prevent the inclusion of leading zeros limits or tolerances dimension text.
J Select to prevent the inclusion of inches or feet in limits or tolerance dimension text when the corresponding number of inches or feet is zero.
13 Working with other files in your drawings

Blocks, attributes, and external references provide mechanisms for managing entities in your drawings and for including additional information with the standard drawing entities. With blocks, you can combine numerous entities into a single entity, and then reuse it, inserting multiple copies. With attributes, you can associate text, such as part numbers or prices, with blocks, and then extract the text-attribute information to a separate file, such as a database, for further analysis. With external references, you can link separate reference drawing files to a drawing to combine information without adding the contents of the reference drawings to the current drawing. If you make changes to the referenced file, all references are updated automatically.

This section explains how to:

- Create, insert, and redefine blocks.
- Create, edit, and insert attributes.
- Extract attribute data to a separate file.
- Attach and work with external references and underlays.
- Use images in your drawings.

13.1 Working with blocks

Usually, blocks are several entities combined into one that you can insert into a drawing and manipulate as a single entity. A block can consist of visible entities such as lines, arcs, and circles, as well as visible or invisible data called attributes. Blocks are stored as part of the drawing file.

13.1.1 Understanding blocks

Blocks can help you better organize your work, quickly create and revise drawings, and reduce drawing file size. Using blocks, you can create a library of frequently used symbols. Then you can insert a symbol as a block rather than redraw the symbol from scratch.

After you create a block from multiple entities, you save it once, which also saves disk space. You insert only multiple references to a single block definition. You can change the block definition to quickly revise a drawing, and then update all instances of the block.

If you insert a block that contains entities originally drawn on layer 0 and assigned color and linetype BYLAYER, it is placed on the current layer and assumes the color and linetype of that layer. If you insert a block that contains entities originally drawn on other layers or with explicitly specified colors or linetypes, the block retains the original settings.
If you insert a block that contains entities originally assigned color and linetype BYBLOCK, and the block itself has the color and linetype BYLAYER, those entities adopt the color and linetype of the layer onto which they are inserted. If the block is assigned an explicit color or linetype, such as red or dashed, those entities adopt those qualities.

A procedure called nesting occurs when you include other blocks in a new block that you are creating. Nesting is useful when you want to combine and include small components, such as nuts and bolts, into a larger assembly and you need to insert multiple instances of that assembly into an even larger drawing.

### 13.1.2 Creating blocks

You can create blocks in two ways:

- By saving a block for use within the current drawing only.
- By saving the block as a separate drawing file that you can insert into other drawings.

When you create a block, you specify its name, its insertion point, and the entities that compose the block. The insertion point is the base point for the block and serves as the reference point when you later insert the block into a drawing.

The new block you create exists only in the current drawing.

Blocks can also be created using CAD.direct Drafter Explorer. For details, see “Working with blocks” on page 253.

**To create a block for use within a current drawing**

Advanced experience level

1. Do one of the following to choose Create Block:
   - On the ribbon, choose Home>Create Block (in Block) or choose Insert > Create Block (in Block Definition).
   - On the menu, choose Draw > Block > Create Block.
   - On the Tools toolbar, click the Create Block tool.

2. In the Block definition dialog box, enter a name and description for the new block.
3. Specify the insertion point for the block by doing one of the following:
   - Specify on Screen Mark this check box to select the base point in the drawing after you click OK.
   - Pick Base Point Click to temporarily close the dialog box immediately, select the base point in the drawing, then return to the dialog box. This option is available only if Specify on Screen is not marked.
   - X, Y, and Z Enter the x-, y-, and z-coordinates of the base point. This option is available only if Specify on Screen is not marked.

4. Select the entities to be combined into the block by doing one of the following:
   - Specify on Screen Mark this check box to select the entities in the drawing after you click OK.
   - Select entities Click to temporarily close the dialog box immediately, select the entities in the drawing, then return to the dialog box. Or you can click to select entities by type or value. This option is available only if Specify on Screen is not marked.

5. Select what to do with the entities after the block is created:
   - Retain entities Entities selected for the block remain in the drawing.
   - Convert to block Entities selected for the block are converted to the block, which remains in the drawing.
   - Delete entities Entities selected for the block are removed from the drawing.

6. Select any of the following options for the block:
   - Annotative Determines whether the block is annotative by default. The display and printing of annotative blocks is affected by annotation scaling. If annotative by default, you can determine whether the block, when located in paper space, is oriented automatically according to the layout viewport.
   - Scale uniformly Mark this check box to retain the aspect ratio if the block is scaled. Annotative blocks must be scaled proportionately.
   - Allow exploding Mark this check box to allow the block to be exploded into separate entities.
   - Unit Defines the unit of the block, for example inches or millimeters.

7. Click OK.

The program adds a new block to the blocks list, with the name you entered for it.
Some users frequently restore original entities after defining a block.

To restore the original entities to the drawing while retaining the new block, type undelete or oops. You might also want to add the Undelete command to a menu or toolbar by choosing Tools > Customize.

13.1.3 Saving blocks

You can create a block as a separate drawing file that you can insert into other drawings.

To save a block as a separate drawing file

Advanced experience level
1. Do one of the following to choose Save Block To Disk:
   - On the ribbon, choose Insert > Save Block to Disk (in Block Definition).
   - On the menu, choose Tools > Save Block To Disk.
   - On the Tools toolbar, click the Save Block To Disk tool.
   - Type wblock and then press Enter.

2. In Source, choose Block, then select the desired block from the list.

3. In File Name and Path, type the name and path of the destination drawing file you want to create, or click [...]
   to browse for it.

4. In Insert Units, select the units used for inserting the separate drawing file.

5. Click OK.

The program assigns the 0,0,0 coordinate as the insertion base point.

*You can change the base point by opening the drawing and redefining the block.*

**To save the current drawing as a separate drawing file**

Advanced experience level

1. Do one of the following to choose Save Block to Disk:
   - On the ribbon, choose Insert > Save Block to Disk (in Block Definition).
   - On the menu, choose Tools > Save Block To Disk.
   - On the Tools toolbar, click the Save Block To Disk tool.
   - Type wblock and then press Enter.

2. In Source, choose Entire Drawing.

3. In File Name and Path, type the name and path of the destination drawing file you want to create, or click [...]
   to browse for it.

4. In Insert Units, select the units used for inserting the separate drawing file.

5. Click OK.

The program assigns the 0,0,0 coordinate as the insertion base point.

*You can change the base point by opening the drawing and redefining the block.*
To select entities and save them a separate drawing file

Advanced experience level

1. Do one of the following to choose Save Block to Disk:
   • On the ribbon, choose Insert > Save Block to Disk (in Block Definition).
   • On the menu, choose Tools > Save Block To Disk.
   • On the Tools toolbar, click the Save Block To Disk tool.
   • Type wblock and then press Enter.

2. In Source, choose Entities.

3. In File Name and Path, type the name and path of the destination drawing file you want to create, or click [...] to browse for it.

4. In Insert Units, select the units used for inserting the separate drawing file.

5. Click OK.

The program assigns the 0,0,0 coordinate as the insertion base point.

You can change the base point by opening the drawing and redefining the block.

To select entities and save them a separate drawing file

Advanced experience level

1. Do one of the following to choose Save Block to Disk:
   • On the ribbon, choose Insert > Save Block to Disk (in Block Definition).
   • On the menu, choose Tools > Save Block To Disk.
   • On the Tools toolbar, click the Save Block To Disk tool.
   • Type wblock and then press Enter.

2. In Source, choose Entities.

3. In Base Point, enter the x,y,z coordinates of the base point to save with the separate drawing file, or click to select it directly in the current drawing.

4. Click and then select the source entities directly in the current drawing. Or you can click to select entities by type or value.
5. Choose what action to take with selected entities in the current drawing after the separate drawing file is created:
   • Retain Keeps the selected source entities in the current drawing.
   • Convert to block Converts the selected source entities to a block in the current drawing.
   • Delete from drawing Deletes the selected source entities from the current drawing.
   • If no entities are selected, a separate drawing file is not created.

6. In File Name and Path, type the name and path of the destination drawing file you want to create, or click [...] to browse for it.

7. In Insert Units, select the units used for inserting the separate drawing file.

8. Click OK.
13.1.4 Inserting blocks

You can insert blocks and other drawings into the current drawing. When you insert a block, it is treated as a single entity. When you insert a drawing, it is added to the current drawing as a block. You can then insert multiple instances of the block without reloading the original drawing file. If you change the original drawing file, those changes have no effect on the current drawing unless you redefine the block by reinserting the changed drawing.

You can also insert blocks from another drawing into the current drawing, using the CAD.direct Drafter Explorer. Both drawings must be open at the same time to do this.
When you insert a block or drawing, you must specify the insertion point, scale, and rotation angle. The block's insertion point is the reference point specified when you created the block. When you insert a drawing as a block, the program takes the specified insertion point as the block insertion point. You can change the insertion point, however, by first opening the original drawing and redefining the block.

Block settings can also be set before block insertion.

You can specify the insertion point, scale factors, and rotation angle in the Insert Block dialog box before inserting the block. You can also control whether the block is exploded back into its original component entities after insertion. Under Positioning, clear the Position Block When Inserting check box, and specify the appropriate coordinates. If you want to explode the block immediately, select the Explode Upon Insertion check box.

**To insert a block**

1. Do one of the following to choose Block:
   - On the ribbon, choose Home > Insert Block (in Block) or choose Insert > Insert Block (in Block).
   - On the menu, choose Insert > Block.
   - On the Draw toolbar, click the Block tool.
   - Type `ddinsert` and then press Enter.
2. In the Insert Block dialog box, under Insert, click Block Name.
3. In the Block Name box, select the name of the block you want to insert.
4. Click Insert.
5. Specify the insertion point for the block.
6. Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept the default values.

**To insert an entire drawing into the current drawing**

1. Do one of the following to choose Block:
   - On the ribbon, choose Home > Insert Block (in Block) or choose Insert > Insert Block (in Block).
   - On the menu, choose Insert > Block.
   - On the Draw toolbar, click the Block tool.
   - Type `ddinsert` and then press Enter.
2. In the Insert Block dialog box, under Insert, click From File.
3. Type the path and the drawing file name, or click Browse to specify the file from the Insert Drawing dialog box, and click Open.
4. Click Insert.

5. Specify the insertion point for the block.

6. Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept the default values.

You can also insert drawings while browsing files on your computer.

If the DRAGOPEN system variable is set to 0, you can drag a .dwg file to the drawing area in CAD.direct Drafter to insert it as a block. If DRAGOPEN is set to 1 (the default), the drawing opens in CAD.direct Drafter.

13.1.5 Redefining blocks

You can redefine all instances of a block within the current drawing. To redefine a block that was created in the current drawing, you create a new block using the same name. You can update all the blocks in the current drawing by redefining the block. If the block was inserted from a separate drawing file that was subsequently updated, reinsert that block to update all other instances in the current drawing.
To redefine a block in the current drawing

Advanced experience level

1. Do one of the following to choose Create Block:
   - On the ribbon, choose Home>Create Block (in Block) or choose Insert > Create Block (in Block Definition).
   - On the menu, choose Draw > Block > Create Block. On the Tools toolbar, click the Create Block tool.
   - Type block and then press Enter.
2. In Name, select the name of the block you want to redefine from the list.
3. Specify the insertion point for the block.
4. Select the entities for the block.
5. Make selections about the behavior.
6. Click OK.
7. When prompted, choose Yes to redefine the block. The block is redefined, and all instances of the block in the drawing are updated.
8. To restore the original entities to the drawing while retaining the new block, type undelete or oops.

You can update all instances of a block inserted from a separate drawing by reinserting the drawing.

13.1.6 Editing blocks in-place

After a block is inserted in a drawing, it can be edited directly in CAD.direct Drafter, and the source block and all references to the block are updated automatically. Editing in-place is an easy way to make changes to a block without having to locate and load it.

To edit blocks in-place

1. Do one of the following:
   - On the ribbon, choose Insert > Edit Reference in Place (in Reference).
   - On the menu, choose Tools > Edit Block or X-Ref In-Place > Edit In-Place.
   - Type refedit and then press Enter.
2. At the prompt, select the block you want to edit. The Reference Edit dialog box displays.
3. In Reference Name, select the block you want to edit.
4. Select the Settings tab and select from the following options:

- Create Unique Layer, Style and Block Names Select to create unique names for layers, styles, and blocks that you change. A prefix is added to the original name of a changed layer, style, or block. Names of unchanged layers, styles, and blocks do not change.
- Display Attribute Definitions for Editing Select to hide attributes and display attribute definitions while editing. After saving, changed attribute definitions affect new block insertions only. Existing blocks are not affected.

5. Click OK.

6. Make changes to the contents of the block.

7. To add an entity from the drawing to the block, select the entity and do one of the following:

- Choose Tools > Edit Block or X-Ref In-Place > Add to Working Set.
- Type refset, press Enter, then choose Add.

8. To remove an entity from the block, select the entity and do one of the following:

- Choose Tools > Edit Block or X-Ref In-Place > Remove from Working Set.
- Type refset, press Enter, then choose Remove.

9. When you’re finished editing the block, do one of the following:

- Choose Tools > Edit Block or X-Ref In-Place > Close Reference.
- Type refclose and then press Enter.

10. Choose Save to save changes or Discard to cancel changes.

If changes are saved, all instances of the block are updated in the current drawing.

13.1.7 Exploding blocks

You can explode an inserted block to its original component entities. When you explode a block, only that single instance of the block is affected. The original block definition remains in the drawing, and you can still insert additional copies of the original block. If you explode a block that contains attributes, the attributes are lost, but the original attribute definitions remain.

Exploding dissociates component entities to their next simplest level of complexity; blocks or polylines in a block become blocks or polylines again.
### To explode a block

1. Do one of the following to choose Explode:
   - On the ribbon, choose Home > Explode (in Modify) or choose Edit > Explode (in Modify).
   - On the menu, choose Modify > Explode.
   - On the Modify toolbar, click the Explode tool.
   - Type explode and then press Enter.

2. Select the block.

3. Press Enter.

### 13.2 Working with attributes

An attribute is a particular entity that you can save as part of a block definition. Attributes consist of text-based data. You can use attributes to track such things as part numbers and prices. Attributes have either fixed or variable values. When you insert a block containing attributes, the program adds the fixed values to the drawing along with the block, and you are prompted to supply any variable values.

After you insert blocks containing attributes, you can extract the attribute information to a separate file and then use that information in a spreadsheet or database to produce a parts list or bill of materials. You can also use attribute information to track the number of times a particular block is inserted into a drawing.

Attributes can be visible or hidden. Hidden attributes are neither displayed nor printed, but the information is still stored in the drawing and written to a file when you extract it.

#### 13.2.1 Defining Attributes

You add an attribute to a drawing by first defining it and then saving it as part of a block definition. To define an attribute, you specify the characteristics of the attribute, including its name, prompt, and default value; the location and text formatting; and optional modes (hidden, fixed, validate, predefined, and locked).

### To define an attribute Advanced experience level

1. Do one of the following to choose Define Attributes:
   - On the ribbon, choose Insert > Define Attributes (in Block Definition).
   - On the menu, choose Draw > Block > Define Attributes.
   - On the Tools toolbar, click the Define Attributes tool.
   - Type ddattddef and then press Enter.
2. In the Define Attribute dialog box, type the name, prompt, and default value.

3. Under Insert Coordinates, specify the location of the attribute, or click Select to select a point in the drawing.

4. Under Attribute Flags, select the optional attribute modes.

5. Under Text, specify the text characteristics.

6. To add the attribute to the drawing, do one of the following:
   - Click Define to add the attribute and keep the dialog box active so you can define another attribute.
   - Click Define And Exit to add the attribute and end the command.
A  Type the name you want to assign to the attribute.
B  Enter the identifying prompt information displayed when you insert a block containing the attribute.
C  Enter the default or constant value. For variable attributes, the default value is replaced by the actual value when you later insert a block containing the attribute.
D  Specify the x-, y-, and z-coordinates for the attribute insertion point.
E  Select to create a hidden attribute.
F  Select to create a fixed-value attribute.
G  Select to create an attribute whose value must be validated when you later insert a block containing the attribute.
H  Select to create an attribute whose value is defined and not requested when you later insert a block containing the attribute, but that you can edit after the block is inserted.
I  Select to create an attribute whose position is locked.
J  Select to create an attribute whose default text contains multiple lines of text.
K  Click to add the attribute and keep the dialog box active so you can define another attribute.
L  Click to add the attribute and end the command.
M  Specify the text rotation angle, or click to specify the rotation angle by selecting two points in the drawing.
N  Specify the text height, or click to specify the height by selecting two points in the drawing.
O  Choose the text justification.
P  Choose the text style from those styles already defined in the drawing.
Q  Select to create an attribute that is annotative by default.
R  Click to specify the attribute insertion point by selecting a point in the drawing.
S  Click to enter multiple lines of default text. Available only if Multiple line is selected.
13.2.2 Editing attribute definitions

You can edit an attribute definition before you associate it with a block and before it is saved as part of a block definition.

To edit an attribute definition

Advanced experience level

1. Select the attribute definition text to edit.

2. Do one of the following to choose Properties:
   - On the ribbon, choose View > Properties (in Display)
   - On the menu, choose Modify > Properties.
   - Right-click the attribute definition text, then choose Properties.
   - Type entprop and then press Enter.

3. Modify the properties, including name, prompt, default value, and other attribute-specific properties.

13.2.3 Attaching attributes to blocks

You can attach attributes to a block after you define it and select it as one of the entities to include. Include the attributes when the program prompts you for the entities to include in the selection set for a block. After the attribute is incorporated into a block, the program prompts you each time you insert the block, so you can specify different values for the attributes each time you insert it into a new drawing.

13.2.4 Editing attributes attached to blocks

You can edit the attribute values of a block that has been inserted into a drawing.

To edit an attribute attached to a block

Advanced experience level

1. Do one of the following to choose Edit Block Attributes:
   - On the ribbon, choose Insert > Edit Block Attributes (in Block Definition).
   - On the menu, choose Tools > Edit Block Attributes.
   - On the Tools toolbar, click the Edit Block Attributes tool.
   - Type ddatte and then press Enter.

2. Select the block to edit.

The Edit Block Attributes dialog box displays all the attributes attached to the block you select.
3. Edit the attribute values as necessary.

4. Click OK.

13.2.5 Extracting attribute information

You can extract attribute information from a drawing and save it to a separate text file for use with a database program. You can save the file in any of the following formats:

- Comma Delimited Format (CDF) Contains one line for each instance of a block, with individual attribute fields separated by commas. Character string fields are enclosed with single quotation marks. You must specify a template file when extracting to a CDF file.

- Space Delimited Format (SDF) Contains one line for each instance of a block. Each attribute field has a fixed length; there are no separators or character string delimiters. You must specify a template file when extracting to a SDF file.

- Drawing Exchange Format (DXF) Creates a subset of a standard DXF file (a *.dxx file) containing all the information about each block, including the insertion points, rotation angles, and attribute values. No template file is required.

Before extracting attributes to a CDF or SDF file, you must create a template file. The template file is an ASCII text file that specifies the attribute data fields to be written in the extract file. Each line of the template file
specifies one attribute field. CAD.direct Drafter recognizes 15 different fields, which contain elements such as the block name, the x-, y-, and z-coordinates of its insertion point, the layer on which it is inserted, and so on. You can include any of these fields. The template file must include at least one attribute name.

Each line in the template file must start with the field name. Block name and insertion-point values must begin with BL:. The next nonblank character must be either a C (indicating a character string field) or an N (indicating a numeric field). This character is then followed by three digits indicating the width of the field (in characters). The final three digits indicate the number of decimal places (for numeric fields). In the case of character fields, the last three digits must be zeros (000). A typical template file is similar to the one shown here:

![Diagram](image)

**A. Field name.**
**B. Block name.** Block names must begin with **BL:.**
**C. Insertion point.** Insertion-point values must begin with **BL:.**
**D. Attribute tags.**
**E. Number of decimal places for numeric fields or 000 for character fields.**
**F. Field width for character or numeric fields.**
**G. C for character fields; N for numeric fields.**

**To create a template file**

1. Create a template file using any ASCII text editor (such as Microsoft® Notepad or Microsoft® WordPad) or a word-processing program such as Microsoft® Word.

2. Include the necessary fields in the template file.

3. Save the template file in ASCII text format.
To extract attribute information

1. Do one of the following to choose Extract Attributes:
   - On the ribbon, choose Insert > Extract Attributes (in Block Definition).
   - On the menu, choose Tools > Extract Attributes.
   - On the Tools toolbar, click the Extract Attributes tool.
   - Type ddattext and then press Enter.

2. Click Select, specify the entities from which to extract attributes, and then press Enter.

3. Specify the format of the extracted file.

4. For CDF and SDF formats, specify the template file.

5. Specify the extract output file.

6. Click Extract.
13.3 Working with external references

You can link entire drawings to the current drawing as external references. Unlike inserting a drawing as a block, in which you add all the entities from the separate drawing into the current drawing, external references attach a pointer to the external file. The entities in the external reference appear in the current drawing, but the entities themselves are not added to the drawing. Thus, attaching an external reference does not significantly increase the size of the current drawing file.

13.3.1 Understanding external references

External references provide additional capabilities not available when you insert a drawing as a block. When you insert a drawing as a block, the entities are stored in the drawing. Any changes you make to the original drawing are not reflected in the drawing in which you inserted it. When you attach an external reference, however, any changes you make to the original drawing file are reflected in the drawings that reference it. These changes appear automatically each time you open the drawing containing the external reference. If you know that the original drawing was modified, you can reload the external reference anytime you're working on the drawing.

External references are useful for assembling master drawings from component drawings. Use external references to coordinate your work with others in a group. External references help reduce drawing file size and ensure that you are always working with the most recent version of a drawing. However, if you send or receive drawings that contain external references, it is important to include with the master drawing all of the external references attached to it. When you open a drawing that contains external references, the source external reference files must be accessible for the external references to display in the drawing.

The Xref Manager helps you easily attach and work with external references.
13.3.2 Attaching external references

Attaching a separate drawing to the current one creates an external reference. The external reference appears in the drawing as a block definition, but the drawing entities are linked rather than added to the current drawing. If you modify the linked drawing, the current drawing that contains the external reference is updated automatically when you open it, or you can reload the external reference manually, so it reflects the latest version of the external reference.

When you attach an external reference, its layers, linetypes, text styles, and other elements are not added to the current drawing. Rather, these elements are also linked from the referenced file.
There are two ways you can attach an external reference:

- An attachment is an inserted drawing that contains a link to the original file. Attachments can themselves contain other, nested reference files. When you attach an external reference, any nested references contained in the file also appear in the current drawing.
- An overlay is an inserted drawing that contains a link to the original file. Overlays allow you to lay a drawing on top of another drawing, similar to the way you work manually with transparencies. When a drawing that contains overlaid external references is itself attached or overlaid as an external reference in another drawing, the overlays do not appear as part of the external reference. Use overlaying when you want to see reference geometry in a drawing, but you do not need to include that geometry in drawings that will be used by others (nested external references).

You can attach as many copies of an external reference file as you want. Each copy can have a different position, scale, and rotation angle.

**To attach an external reference**

1. Do one of the following to choose Xref Manager
   - On the ribbon, choose Insert > Xref Manager (in Reference).
   - On the menu, choose Insert > Xref Manager.
   - On the Tools toolbar, click the Xref Manager tool.
   - Type xrm and then press Enter.
2. Click Attach.
3. Specify the drawing file to attach as an external reference, and then click Open.
4. In Reference Type, choose how you want to insert the drawing:
   - Attachment – inserts a copy of the drawing and includes any other drawings that are externally referenced within the referenced drawing.
   - Overlay – lays a copy of a drawing over your original drawing; it does not include any nested external references from the externally referenced drawing.
5. Make any additional selections.
6. Click OK.
7. If you marked Specify On-Screen for any items, follow the prompts to attach the external reference.
13.3.3 Viewing the list of external references

You can view a list of the external references that are linked to the current drawing two different ways using the Xref Manager:

- List View displays the external references in a list, which allows you to sort the list of references by name, status, size, type, date, or saved path.
- Tree View displays a hierarchical representation of the external references and the relationships between them. The tree view shows the level of nesting relationships of the attached external references.
To view a list of external references

1. Do one of the following to choose Xref Manager:
   • On the ribbon, choose Insert > Xref Manager (in Reference).
   • On the menu, choose Insert > Xref Manager.
   • On the Tools toolbar, click the Xref Manager tool.
   • Type xrm and then press Enter.
2. Click List View or Tree View.

13.3.4 Opening external references

From the Xref Manager you can quickly open the source drawing for any external reference. This is especially helpful if you are working with nested external references, which you cannot bind or detach. From the Xref Manager, open the source drawing, make changes, and then save and close the source drawing. When the Xref Manager displays again, simply reload the external reference.

To open an external reference

1. Do one of the following to choose Xref Manager:
   • On the ribbon, choose Insert > Xref Manager (in Reference).
   • On the menu, choose Insert > Xref Manager.
   • On the Tools toolbar, click the Xref Manager tool.
   • Type xrm and then press Enter.
2. Select the external reference to open.
3. Click Open.

Use a shortcut.

Type xopen to open an external reference without using the Xref Manager. To see any changes that you make to the external reference while it is open, reload it.
13.3.5 Removing external references

Removing external references from the current drawing is easy with the Xref Manager. You can unload an external reference, which keeps some information about the external reference in the current drawing for easy reloading later, or you can detach the external reference entirely.

When you unload an external reference, you remove it from the current drawing. However, its elements, such as layers and linetypes, remain in the drawing and it is still listed in the Xref Manager. By detaching an external reference, you can remove it and all of its elements from the current drawing, and it is no longer listed in the Xref Manager.

To unload an external reference

1. Do one of the following to choose Xref Manager:
   - On the ribbon, choose Insert > Xref Manager (in Reference).
   - On the menu, choose Insert > Xref Manager.
   - On the Tools toolbar, click the Xref Manager tool.
   - Type xrm and then press Enter.
2. Select the external reference to unload.
3. Click Unload.

To detach an external reference

1. Do one of the following to choose Xref Manager:
   - On the ribbon, choose Insert > Xref Manager (in Reference).
   - On the menu, choose Insert > Xref Manager.
   - On the Tools toolbar, click the Xref Manager tool.
   - Type xrm and then press Enter.
2. Select the external reference to detach.
3. Click Detach.

Nested external references cannot be detached.

Only the external references that are attached directly to the current drawing can be detached.
13.3.6 Reloading external references

When you open or print a drawing, any external references in the drawing are updated automatically. If a drawing is already open and a referenced drawing is modified, you can update the current drawing manually to display the latest version of the referenced drawing.

You may also want to reload an external reference that has been unloaded temporarily.

To reload an external reference

1. Do one of the following to choose Xref Manager:
   - On the ribbon, choose Insert > Xref Manager (in Reference).
   - On the menu, choose Insert > Xref Manager.
   - On the Tools toolbar, click the Xref Manager tool.
   - Type xrm and then press Enter.
2. Select the external reference to reload.
3. Click Reload.

13.3.7 Changing the path for external references

If the file associated with an external reference is moved to a different directory or renamed, the program displays a message indicating that it cannot load the external reference. You can re-establish the link to the file by doing any of the following:

   - Change the path for the external reference.
   - Specify additional directories for CAD.direct Drafter to search. This is especially helpful if you have several external references that have moved to a new directory.

To change the path for a single external reference

1. Do one of the following to choose Xref Manager:
   - On the ribbon, choose Insert > Xref Manager (in Reference).
   - On the menu, choose Insert > Xref Manager.
   - On the Tools toolbar, click the Xref Manager tool.
   - Type xrm and then press Enter.
2. Select the external reference whose path you want to change.
3. In Xref Path, do one of the following:
   - Enter a new filename or location.
   - Click Browse to locate and select the referenced drawing. CAD.direct Drafter reloads the specified external reference automatically.

External references cannot be recursive.

*You cannot recursively reference a drawing from the same original drawing.*

**To change the search paths for all external references in the drawing**

1. Do one of the following to choose Xref Manager:
   - On the ribbon, choose Insert > Xref Manager (in Reference).
   - On the menu, choose Insert > Xref Manager.
   - On the Tools toolbar, click the Xref Manager tool.
   - Type `xrm` and then press Enter.

2. In Additional Xref Search Paths, do one of the following:
   - Enter a new directory and its path. Separate multiple paths with a semicolon, for example, `c:\My Drawings;d:\My Drawings\Backup`.
   - Click Browse to locate and select a directory. CAD.direct Drafter searches the specified directories; any found external references are reloaded automatically.

**13.3.8 Binding external references to drawings**

External references are not part of the drawing. Rather, they are links to an externally referenced file. To provide a copy of a drawing containing external references to someone else, you must also provide all the external reference files. In addition, the person receiving the drawings must either re-create the same paths you used when linking the external references or change the paths for the external references.

To provide a copy of a drawing that contains external references, it is often easier to first bind the external references to the drawing. Binding the external references makes them a permanent part of the drawing, which is similar to inserting a separate drawing as a block.

You can bind external references that are attached directly to the current drawing; you cannot bind nested external references.
To bind an existing external reference to a drawing

1. Do one of the following to choose Xref Manager:
   - On the ribbon, choose Insert > Xref Manager (in Reference).
   - On the menu, choose Insert > Xref Manager.
   - On the Tools toolbar, click the Xref Manager tool.
   - Type xrm and then press Enter.

2. Select the external reference to bind.

3. Click Bind.

4. Choose one of the following:
   - **Bind** Binds the external reference and creates a unique name for each named entity, such as a layer or block, that is located in the external reference. For example, a layer named Electric in the external reference will be named Xref$0$Electric in the current drawing. If the current drawing already has a layer or block with the same name, the name is changed incrementally, for example, Xref$1$Electric.
   - **Insert** Binds the external reference, but does not change the names of any named entities in the external reference. For example, a layer named Electric in the external reference will have the same name, Electric, in the current drawing. If the current drawing has a layer or block with the same name, the named entity in the external reference takes on the properties of the named entity in the current drawing.

5. Click OK.

### 13.3.9 Clipping external references

When you attach a drawing as an external reference, all of the referenced drawing displays in the current drawing. However, after you attach an external reference, you can define a clipping boundary that determines which portion of the referenced drawing is visible or hidden.

You can edit, move, or copy clipped external references the same way you modify unclipped external references. The boundary moves with the reference. If an external reference contains nested clipped external references, they also appear clipped in the drawing.

In addition to clipping external references, you can also partially hide blocks using clipping boundaries.
13.3.10 Adding clipping boundaries

When you create a clipping boundary, it affects only the display of the referenced drawing; it does not affect the original referenced drawing or any referenced geometry. The portion of the external reference within the clipping boundary is visible and the remainder of the external reference becomes hidden.

To define a rectangular clipping boundary

1. Do one of the following:
   - On the ribbon, choose Insert > Clip Xref (in Reference).
   - On the menu, choose Modify > Xref Clip.
   - Type xclip and then press Enter.
2. Select the external references to clip. If desired, you can also select blocks.
3. Press Enter.
4. Press Enter to create a new clipping boundary.
5. If prompted, press Enter to delete any existing boundaries.

6. Choose Rectangular.

7. Define the first corner of the clipping rectangle.

8. Define the second corner of the clipping rectangle.

The selected external references are clipped by the rectangle.

Use the shortcut.

You can first select all external references, right-click the selection, and then select Xref Clip from the shortcut menu.

To define a clipping boundary using a polyline

1. Draw a polyline where you want to clip external references.

2. Do one of the following:
   - On the ribbon, choose Insert > Clip Xref (in Reference).
   - On the menu, choose Modify > Xref Clip.
   - Type xclip and then press Enter.

3. Select the external references to clip. If desired, you can also select blocks.

4. Press Enter.

5. Press Enter to create a new clipping boundary.

6. If prompted, press Enter to delete any existing boundaries.

7. Choose Select Polyline.

8. Select the polyline to use as clipping boundary.
13.3.11 Turning clipping boundaries on and off

You can turn xref clipping on or off. When a clipping boundary is turned off, the boundary does not display and the entire external reference is visible, provided that the geometry is on a layer that is on and thawed. When a clipping boundary is turned off, it still exists and can be turned on. However, deleting a clipping boundary is permanent.

To turn clipping boundaries on and off

1. Do one of the following:
   - On the ribbon, choose Insert > Clip Xref (in Reference).
   - On the menu, choose Modify > Xref Clip.
   - Type xclip and then press Enter.
2. Select the desired external references.
3. Press Enter.
4. To turn off clipping boundaries, choose Off. To turn on existing clipping boundaries, choose On.
5. Press Enter.

If you are turning off a clipping boundary, click the clipped portion of the external reference to view the previously hidden portion of the referenced drawing.

Use the XCLIPFRAME system variable.

*When the XCLIPFRAME system variable is on (set to 1), you can select and print the clipping boundary frame.*

13.3.12 Deleting clipping boundaries

If you no longer need a clipping boundary for an external reference, you can delete it.

To delete a clipping boundary

1. Do one of the following:
   - On the ribbon, choose Insert > Clip Xref (in Reference).
   - On the menu, choose Modify > Xref Clip.
   - Type xclip and then press Enter.
2. Select the desired external references.

3. Press Enter.

4. Choose Delete, and then press Enter.

5. Click the clipped portion of the external reference.

The previously hidden portion of the referenced drawing displays.

13.3.13 Editing external references in-place

After an external reference is inserted in a drawing, it can be edited directly in CAD.direct Drafter, and the source drawing file is updated automatically. Editing in-place is an easy way to make changes to the source file without having to locate the file and load it.

To edit an external reference in-place

1. Do one of the following:
   - On the ribbon, choose Insert > Edit Reference in Place (in Reference)
   - On the menu, choose Tools > Edit Block or choose X-Ref In-Place > Edit In-Place.
   - Type refedit and then press Enter.

2. At the prompt, select the external reference you want to edit. The Reference Edit dialog box displays.

3. In Reference Name, select the external reference you want to edit.

4. Select the Settings tab and select from the following options:
   - Create Unique Layer, Style and Block Names Select to create unique names for layers, styles, and blocks that you change. A prefix is added to the original name of a changed layer, style, or block. Names of unchanged layers, styles, and blocks do not change.
   - Display Attribute Definitions for Editing Select to hide attributes and display attribute definitions while editing. After saving, changed attribute definitions affect new insertions only.

5. Click OK.

6. Make changes to the contents of the external reference. Any new entities created during edit in-place are automatically added when the external reference is closed and saved.
7. To add an existing entity from the drawing to the external reference, select the entity and do one of the following:
   - Choose Tools > Edit Block or X-Ref In-Place > Add to Working Set.
   - Type refset, press Enter, then choose Add.

8. To remove an entity from the external reference, select the entity and do one of the following:
   - Choose Tools > Edit Block or X-Ref In-Place > Remove from Working Set.
   - Type refset, press Enter, then choose Remove.

9. When you’re finished editing the external reference, do one of the following:
   - Choose Tools > Edit Block or X-Ref In-Place > Close Reference.
   - Type refclose and then press Enter.

10. Choose Save to save changes or Discard to cancel changes.

11. The external reference is updated and the current drawing displays the changes.

You can also type xopen to open an external reference directly.

*To see any changes that you make to the external reference while it is open, reload it.*

### 13.4 Attaching underlays created in other file formats

When you attach an underlay, a picture representation of the file’s contents is inserted into the drawing. An underlay is similar to an image and different from an external reference in that it cannot be linked and automatically updated.

You can attach underlays using files that have the following formats:

- **PDF format** — Portable document format viewable using Adobe® Acrobat® Reader® and Adobe® Acrobat. The PDF format uses the .pdf file extension.
- **Autodesk® DWF format** — Autodesk Design Web Format(used with .dwf files) is used to distribute a drawing for others to view in a Web browser, review, and edit using free Autodesk software and tools. The DWF format uses the .dwf file extension.
- **DGN format** — Drawing files used with Bentley Microstation. The DGN format uses the .dgn file extension.
- **PCG format** — Point cloud files used by Autodesk® software and tools. The PCG format uses the .pcg file extension.
- **ISD format** — Point cloud files used by CAD.direct Drafter. The ISD format uses the .isd file extension.
13.4.1 Attaching a PDF underlay
Attaching a .pdf file is similar to attaching an image file.

To attach a PDF underlay

1. On the ribbon, choose Insert > PDF Underlay (in Data).
2. On the menu, choose Insert > PDF Underlay.
3. Type pdfattach and then press Enter.
4. Choose the .pdf file you want to attach.
5. Click Open.
6. Specify which page of the .pdf file to attach.
7. Select an insertion point.
8. Enter the scale in which to insert the .pdf file.
9. Enter the rotation to use for the insertion.

13.4.2 Attaching a DWF underlay
Attaching a .dwf file is similar to attaching an image file.

To attach a DWF underlay

1. Use one of the following methods:
   1. On the ribbon, choose Insert > DWF Underlay (in Data).
   2. On the menu, choose Insert > DWF Underlay.
   3. Type dwfattach and then press Enter.
2. Choose the .dwf file you want to attach.
3. Click Open.
4. Select an insertion point.
5. Enter the scale in which to insert the .dwf file.
6. Enter the rotation to use for the insertion.
13.4.3 Attaching a DGN underlay

Attaching a .dgn file is similar to attaching an image file.

To attach a DGN underlay

1. Use one of the following methods:
   - On the ribbon, choose Insert > DGN Underlay (in Data).
   - On the menu, choose Insert > DGN Underlay.
   - Type dgnattach and then press Enter.
2. Choose the .dgn file you want to attach.
3. Click Open.
4. Select an insertion point.
5. Enter the scale in which to insert the .dgn file.
6. Enter the rotation to use for the insertion.

13.4.4 Attaching a point cloud underlay

A point cloud is a set of 3D points that represents the surface of an entity in three dimensions. Point cloud files are typically created by 3D-scanners. Attaching a point cloud file (.pcg or .isd file) is similar to attaching an image file.

To attach a point cloud underlay

1. Do one of the following to choose Point Cloud Underlay
   - On the ribbon, choose Insert > Point Cloud Underlay (in Data).
   - On the menu, choose Insert > Point Cloud Underlay.
   - Type pointcloudattach and then press Enter.
2. Choose the .pcg or .isd file you want to attach.
3. Click Open.
4. Select an insertion point.
5. Enter the scale in which to insert the point cloud file.
6. Enter the rotation to use for the insertion.
13.5 Working with images

You can modify and view raster images directly inside of CAD.direct Drafter. You can load, edit, and modify multiple images as overlays or underlays to your CAD.direct Drafter drawings. The images can be selected for use with CAD.direct Drafter commands by selecting the image frame, which can be turned on or off for printing or selection purposes.

CAD.direct Drafter supports numerous image file formats, including BMP, JPG, GIF, EMF, TIF, PNG, WMF, SID, and many more.

13.5.1 Attaching images

When you attach an image to a drawing, the image displays in the drawing but is not saved in the drawing. The image file remains saved in its original location on your computer, network, or other media.

If you send or receive drawings that contain images, it is important to include with the drawing all of the image files attached to it. When you open a drawing that contains images, the source image files must be accessible for the images to display in the drawing.

To attach an image

1. Do one of the following to choose Attach Image:
   • On the ribbon, choose Insert > Attach Image (in Data).
   • Choose Insert > Image > Attach Image.
   • On the Image toolbar, click the Attach Image tool.
   • Type imageattach and then press Enter.
2. Specify a file to attach, and then click Open.
3. In Image Path will be Saved As, enter a different image file location, if necessary. You can click [ > ] to choose how you want to save the image path:
   • Full Path — The image is referenced using its full path, for example, c:\My Pictures\MyImage.jpg. Use this option if the image is saved in a folder unrelated to the current drawing folder.
   • Relative Path — The image is referenced using a path relative to the current drawing folder, for example, ..\My Pictures\MyImage.jpg. Use this option if the image is stored in a subfolder of the current drawing folder.
   • File Name Only — The image is referenced using its file name in the current drawing folder, for example, MyImage.jpg. Use this option if the image is saved in the same folder as the current drawing.
4. In the Attach Image dialog box, specify the position, scale, rotation, transparency, and clipping options, and then click OK.

**NOTE** Transparency works for images that support alpha transparency, that is, images that have at least one color that can be viewed as a transparent color.

5. In the drawing, specify an insertion point, scale, and rotation if you chose to specify those on the screen.
You can also attach images using the Image Manager or CAD.direct Drafter Explorer:

Choose Insert > Image > Image Manager, and then click Attach to specify an image and then attach it, or if you want to quickly add another occurrence of an image already located in the drawing, select the image in the Image Manager and then click Add. Or, choose Tools > CAD.direct Drafter Explorer and attach an image as an externally reference file.

13.5.2 Modifying images

You can modify an image by changing its brightness, contrast, fade, size, rotation, or transparency. These changes affect the image in the drawing only — not the original image file.

In addition to modifying a single image or multiple images that you select, you can also modify all occurrences of an image within a drawing. For example, if your company logo appears in multiple locations throughout a drawing, you can use the Image Manager to specify the changes once and apply them to all occurrences of the logo.

You can use other CAD.direct Drafter commands for typical modifications, such as Delete, Move, Layer, and more.

To modify images

1. Do one of the following to choose Image Manager:
   • On the ribbon, choose Insert > Image Manager (in Data).
   • On the menu, choose Insert > Image > Image Manager.
   • On the Image toolbar, click the Image Manager tool.
   • Type image and then press Enter.

   TIP You can also modify images by selecting one or more images in a drawing, and then choosing Modify > Properties.

2. In the Images list, select the image you want to modify. If there is more than one occurrence of the image in the drawing, do one of the following:
   • To modify all occurrences of the image, select a top-level image in the list.
   • To modify a single occurrence of the image, expand a top-level image in the list, and then select the individual image.

3. Adjust the Brightness, Contrast, and Fade by moving the slider to the setting you want or by entering an exact number. The image preview shows how your changes will affect the image.

   TIP If you want to restore the image to the default brightness, contrast, and fade settings, click Reset.
4. Adjust the Size by making changes to the width (X) and height (Y) in drawing units. Mark Keep Aspect Ratio if you want the width and height to change together to retain the aspect ratio of the image.

5. Adjust the Rotation by entering the number of degrees you want to rotate the image to the left. Zero degrees indicates no rotation.

6. Mark Use Transparency if you want entities located under the image to be visible (for images that support alpha transparency, that is, images that have at least one color that can be viewed as a transparent color).

7. Mark Show Clipping Boundary if you want to show the image clipped, if a clip-ping boundary is defined for the image. Unmarking this option displays the whole image, even if a clipping boundary is defined.

8. Click OK.
13.5.3 Changing the display of images

You can change the following for how all images display in a drawing:

- Image quality — Images can display in high or low resolution.
- Image frames — Images can display with or without frames on their edges.

Changing the display quality for all images

High quality displays images in high resolution and requires more system resources. Draft quality displays images in low resolution and consumes fewer system resources. Changing the quality setting affects all images in the drawing.

To change the display quality for all images

1. Do one of the following to choose Image Quality:
   - On the ribbon, choose Insert > Image Quality (in Data).
   - On the menu, choose Insert > Image > Image Quality.
   - On the Image toolbar, click the Image Quality tool.
   - Type image quality and then press Enter.
2. Choose High or Draft.

13.5.4 Turning image frames on or off for all images

When image frames are turned on, a frame displays and prints on the edge of all images in the drawing. When image frames are turned off, none of the images display or print with a frame, which also makes images unselectable. Each image frame displays with the properties (layer, color, linetype, etc.) that are assigned to the image.

Turning image frames off may be helpful, for example, if the images are part of a background in the drawing.

To turn image frames on or off for all images

1. Do one of the following to choose Display Image Frame:
   - On the ribbon, choose Insert > Display Image Frame (in Data).
   - On the menu, choose Insert > Image > Display Image Frame.
   - On the Image toolbar, click the Display Image Frame tool.
   - Type image frame and then press Enter.
2. Choose On or Off.

*TIP* You can use *IMAGEFRAMEMODE* to turn image frames on or off while display and printing images.

### 13.5.5 Clipping images

You can clip images so that only a portion of the image is visible in a drawing. The visible portion (or the invisible portion for inverted clips) can be in the shape of a rectangle or polygon.

Image clipping can be turned on and off. If you turn off clipping for an image, the entire image is visible provided that the image is on a layer that is on and thawed. The clipping information is retained however, and you can turn clipping back on at any time.

If you delete clipping from an image, the clipping is removed permanently but the image itself remains in the drawing.

### 13.5.6 Clipping images in the shape of a rectangle

**To clip an image in the shape of a rectangle**

1. Make sure that image frames are turned on — so you can select images — by choosing Image > Display Image Frame, and then choose On.

2. Do one of the following to choose Clip Image:
   - On the ribbon, choose Insert > Clip Image (in Data).
   - On the menu, choose Insert > Image > Clip Image.
   - On the Image toolbar, click the Clip Image tool.
   - Type image clip and then press Enter.

3. Select the edge of the image you want to clip.

4. If prompted, choose New to create a new clipping boundary.

5. Choose Rectangle. If you want to invert the clip, that is, hide the area inside the boundary, choose Invert clip before choosing Rectangle.

6. Define the first corner of the clipping rectangle.

7. Define the opposite corner of the clipping rectangle.

Only the portion of the image located within the clipping rectangle is visible.
13.5.7 Clipping images in the shape of a polygon

To clip an image in the shape of a polygon

1. Make sure that image frames are turned on — so you can select images — by choosing Image > Display Image Frame, and then choose On.

2. Do one of the following to choose Clip Image:
   - On the ribbon, choose Insert > Clip Image (in Data).
   - On the menu, choose Insert > Image > Clip Image.
   - On the Image toolbar, click the Clip Image tool.
   - Type imageclip and then press Enter.

3. Select the edge of the image you want to clip.

4. If prompted, choose New to create a new clipping boundary.

5. Choose Polygon. If you want to invert the clip, that is, hide the area inside the boundary, choose Invert clip before choosing Polygon.

6. Select the points for the polygon, and then press Enter when the polygon is complete.

Only the portion of the image located within the clipping polygon is visible.

13.5.8 Turning clipping on or off for images

To turn clipping on or off for an image

1. Make sure that image frames are turned on — so you can select images — by choosing Image > Display Image Frame, and then choose On.

2. Do one of the following to choose Clip Image:
   - On the ribbon, choose Insert > Clip Image (in Data).
   - On the menu, choose Insert > Image > Clip Image.
   - On the Image toolbar, click the Clip Image tool.
   - Type imageclip and then press Enter.

3. Select the edge of the image for which you want to turn clipping on or off.

4. Choose On or Off.
13.5.9 Removing clipping from images

To remove clipping from an image

1. Make sure that image frames are turned on — so you can select images — by choosing Image > Display Image Frame, and then choose On.

2. Do one of the following to choose Clip Image:
   - On the ribbon, choose Insert > Clip Image (in Data).
   - On the menu, choose Insert > Image > Clip Image.
   - On the Image toolbar, click the Clip Image tool.
   - Type image clip and then press Enter.

3. Select the edge of the image for which you want to remove clipping.

4. Choose Delete.

13.5.10 Unloading and reloading images

If you find that including an image affects system performance, you can unload it so only the image frame displays to mark its location. If you want an unloaded image to print, reload it before printing. You may also want to reload an image if the original file contains new content.

To unload and reload an image

1. Do one of the following to choose Image Manager:
   - On the ribbon, choose Insert > Image Manager (in Data).
   - On the menu, choose Insert > Image > Image Manager.
   - On the Image toolbar, click the Image Manager tool.
   - Type image and then press Enter.

2. In the Images list, select the desired image. If there is more than one occurrence of the image in the drawing, do one of the following:
   - To unload or reload all occurrences of the image, select a top-level image in the list.
   - To unload or reload a single occurrence of the image, expand a top-level image in the list, and then select the individual image.
3. Do one of the following:
   - To unload the image so only its outer edge displays, click Unload.
   - To reload the image so its contents display and print, click Reload.

13.5.11 Changing the path for images

If the file associated with an image is renamed or moved to a different location, the program displays a message indicating that it cannot load the image. You can re-establish the link to the file by changing the path for the image.

To change the path for an image

1. Do one of the following to choose Image Manager:
   - On the ribbon, choose Insert > Image Manager (in Data).
   - On the menu, choose Insert > Image > Image Manager.
   - On the Image toolbar, click the Image Manager tool.
   - Type image and then press Enter.

2. In the Images list, select the desired image. If there is more than one occurrence of the image in the drawing, do one of the following:
   - To change the path for all occurrences of the image, select a top-level image in the list.
   - To change the path for a single occurrence of the image, expand a top-level image in the list, and then select the individual image.

3. Click the [...] button.

4. Select the file with its new name or in its new location, and then click Open.

5. Click Set Path.
13.5.12 Deleting images

Once an image is no longer required in the drawing, you can delete it from the drawing. Deleting an image removes it from the drawing, and from the list of images in the Image Manager dialog box.

To delete an image

1. Do one of the following to choose Image Manager:
   - On the ribbon, choose Insert > Image Manager (in Data).
   - On the menu, choose Insert > Image > Image Manager.
   - On the Image toolbar, click the Image Manager tool.
   - Type image and then press Enter.

2. In the Images list, select the image you want to delete. If there is more than one occurrence of the image in the drawing, do one of the following:
   - To delete all occurrences of the image, select a top-level image in the list.
   - To delete a single occurrence of the image, expand a top-level image in the list, and then select the individual image.

3. Click Detach.
14 Printing drawings

You can print a copy of your drawing exactly as you created it, or you can add formatting and specify print controls to change how your drawing looks when it is printed.

Sometimes you may require multiple printed drawings, each with a different look or layout. For example, you may need one printed drawing for a client presentation, along with several other variations for production contractors. For each type of printed drawing that you require, you can create a layout that defines its characteristics, including scale, area to print, print style tables, and more.

This section explains how to:

- Start printing right away.
- Set up a drawing to print multiple layouts from paper space on a Layout tab.
- Customize how you want your drawing to look when it is printed.
- Define how to print your drawing further using print styles.
- Print or plot your drawing.
- Publish your drawing.

14.1 Getting started printing

When you create a drawing, you do most of your work on the Model tab. At any time you can print your drawing to see how it looks on paper. It’s easy to get started printing, and then later create layouts and custom print settings to enhance your printed output.

To start printing

1. From the Model tab, do one of the following to choose Print:
   - On the ribbon, choose the Application button then choose Print, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Print.
   - On the Standard toolbar, click the Print tool.
   - Type print and then press Enter.

2. Click Print.

There are many print options detailed in this section, such as the scale of the drawing, print area, print style tables, and more.
Type qprint and then press Enter to print the current viewport.

_The Print dialog box is bypassed and the drawing is sent directly to the selected printer._

### 14.2 Defining layouts for printing

You can print your drawing directly from the Model tab where you created it, or you can create custom layouts for printing on Layout tabs.

When printing from the Model tab, you can print your drawing exactly the way it appears, or you can modify the drawing before printing by adding dimensions, a leg-end, or a title block.

You typically use the Layout tabs for printing if you require multiple print layouts. You may also want to use a Layout tab for printing even if you want your drawing printed only one way. For example, if you want to include large amounts of text on your printed drawing, you can add the text to a Layout tab so it does not clutter your drawing while you work on the Model tab.

#### 14.2.1 Understanding layouts

When you create a drawing, you do most of your work on the Model tab. Each drawing that you create can contain numerous layouts that simulate the paper on which you will print a copy of the drawing. Each of these layouts is created on a Layout tab.

You can prepare a separate layout for each way you want to print your drawing. The layout allows you to organize different views to control which portion of your drawing prints and at what scale.

Before you print, you can also include additional entities and layout settings that control how your drawing prints. Additional items only appear on the Layout tab, not on the Model tab. For example, a layout can contain dimensions, title blocks, legends, or keynotes that print with your model, but do not clutter the screen when you work with your model on the Model tab.

Use these general steps to prepare your drawing for printing multiple layouts:

1. On the Model tab, create your drawing.

2. Create a new layout. You can use an existing Layout1 or Layout2 tab, or you can create a new Layout tab. For details, see “Creating a new layout” on page 453 in this chapter.

3. Create at least one layout viewport on the Layout Tab. Use each viewport to help control which portion of the drawing prints and at what scale. For details, see “Working with layout viewports” on page 456 in this chapter.

4. Include any additional items that may be required for the specific layout, such as dimensions, a legend, or a title block.
5. Specify additional settings for the layout, such as the scale of the drawing, print area, print style tables, and more. For details, see “Customizing and reusing print settings” on page 462 in this chapter.

6. Print or plot your drawing. For more details, see “Printing or plotting your drawing” on page 486 in this chapter.

14.2.2 Understanding paper space and model space

When you start a drawing session, your initial working area is called model space. Model space is an area in which you create two-dimensional and three-dimensional entities based on either the World Coordinate System (WCS) or a user coordinate system (UCS). You view and work in model space while using the Model tab.

Your view of this area is a single viewport that fills the screen. You can create additional views on the Model tab, called viewports, which can show the same or different two-dimensional or three-dimensional views, all of which are displayed in a tiled manner. You can work in only one of these viewports at a time on the Model tab, and you can print only the current viewport.

CAD.direct Drafter provides an additional work area, called paper space. The contents of paper space represent the paper layout of your drawing. In this work area, you can create and arrange different views of your model similar to the way you arrange detail drawings or orthogonal views of a model on a sheet of paper. You can also add dimensions, keynotes, annotations, borders, title blocks, and other print-related entities in paper space, which reduces clutter when you work with your model in model space.
You view and work in paper space while using a Layout tab. Each view, or layout viewport, that you create in paper space provides a window of your drawing in model space. You can create one layout viewport or several. You can place layout viewports anywhere on the screen; their edges can be touching or not; and you can print them all at the same time.

You do not need to use paper space to print your drawing, but it offers several advantages:

- Print the same drawing with different print settings that you save with each layout, for example, printer configuration files, print style tables, lineweight settings, drawing scale, and more.
- Add print-related entities that are not essential to the model itself, such as key-notes or annotations, to reduce clutter when you work with your model in model space on the Model tab.
- For a single layout, create multiple layout viewports that print the model at different views and scales.

You can copy and move entities between model space and paper space.

*Choose Modify > Change Space, then select the entities you want to copy or move from paper space to model space or from model space to paper space.*
14.2.3 Viewing drawings in paper space and model space

When you work in paper space on a Layout tab, you can still view your drawing in model space. First you need to create a layout viewport in paper space; this allows you to view your model space entities from paper space.

Within a layout viewport you can modify and snap to model space entities while working in model space and even snap to model space entities from paper space. Snapping to model space entities from paper space allows you to accurately dimension model space entities in paper space. And although it is generally more convenient to modify entities on the Model tab, there are often times when it is convenient to make modifications from a layout viewport on a Layout tab.

Zooming or panning the drawing in model space or paper space affects the entire drawing, unless you use multiple windows or viewports. Additionally, if you are working from paper space, you can lock the layout viewport so the viewport scale and view center do not change while panning and zooming in the layout viewport.

To view a drawing in model space on the Model tab

Do one of the following:

- Click the Model tab.
- Right-click the Model/Paper Space toggle in the status bar, and then choose Model.

To view a drawing in paper space on a Layout tab

Do one of the following:

- Click one of the Layout tabs.
- Type layout and then press Enter. In the prompt box, choose Set. Type a name for the layout you want to make current, and then press Enter.
- Double-click the Model/Paper Space toggle in the status bar. For example, double-click “Model” or “M:Tab Name” in the status bar to switch to paper space.
- While using a Layout tab, type pspace and then press Enter.
- While using a Layout tab, double-click outside of the layout viewport.
- To view a drawing in model space on a Layout Tab Do one of the following:
  - Click the desired Layout tab, and then create and view a layout viewport. For more details, see “Working with layout viewports” on page 456 in this chapter.
  - Double-click the Model/Paper Space toggle in the status bar. For example, double-click “P:Tab Name” in the status bar to switch to model space on the current Lay-out tab.
  - Type mspace and then press Enter.
  - While using a Layout tab, double-click inside of the layout viewport.
14.2.4 Displaying the Model and Layout tab

The Model and Layout tabs can be hidden, if desired. You may want to hide the tabs if you only work on the Model tab or if you use the command bar and status bar to switch between tabs.

To turn the Model and Layout tabs display on or off

Do one of the following:

- On the ribbon, choose View > Model and Layout tabs (in Display).
- Choose View > Display > Model and Layout tabs.
- Choose Tools > Options > Display tab, and choose Show Tabs.

14.2.5 Creating a new layout

In CAD.direct Drafter, you can create multiple layouts for a single drawing. Each layout represents a sheet of paper. For each layout, you can specify the print area, print styles, print scale, lineweight scale, pen mappings, and add viewports, dimensions, a title block, and other geometry specific to the layout.

The entities you add to a layout in paper space do not appear in model space.

Each layout requires at least one layout viewport, which is created automatically when you create a new layout. This viewport displays the drawing’s model space entities.

When you create a new drawing, the drawing automatically contains two default layouts: Layout1 and Layout2. You can start by using one of the default layouts, you can create your own, or you can create a new layout from another template (.dwt) file, drawing (.dwg) file, or drawing interchange (.dxf) file. You can also use CAD.direct Drafter Explorer to create and manage layouts.

Each drawing can contain up to 255 layouts.

To create a new layout using the Layout1 or Layout2 tab

1. Click the Layout1 or Layout2 tab.

2. If necessary, set up at least one layout viewport. For details, see “Working with layout viewports” on page 456 in this chapter.

3. If desired, rename the layout. For details, see “To rename a layout” on page 455 in this chapter.
To create a new layout using a new Layout tab

1. Do one of the following to choose New Layout:

   • On the ribbon, choose View > New Layout (in Layouts).
   • Choose Insert > Layout > New Layout.
   • On the Layouts toolbar, click the New Layout tool.
   • Type layout, press Enter, and choose New.

2. Type a unique name for your layout and then press Enter.

   The name can be up to 255 characters in length and can contain letters, numbers, the dollar sign ($), hyphen (-), and underscore (_), or any combination.

3. Set up at least one layout viewport. For details, see “Working with layout view-ports” on page 456 in this chapter.

To create a new layout from an existing file

1. Do one of the following: to choose Layout from Template On the ribbon, choose View > Layout from Template (in Layouts).

   • On the menu, choose Insert > Layout > Layout from Template.
   • On the Layouts toolbar, click the Layout from Template tool.
   • Type layout, press Enter, and choose Template.
   • Right-click a Layout tab and choose From Template.

2. Select the desired template, drawing, or drawing interchange file that contains the layout you want, and then click Open.

3. Select the layout(s), and then click OK. You can choose multiple layouts by holding down Ctrl while selecting layout names.

14.2.6 Reusing layouts from other files

Save time by reusing layouts that you have already created. Within the same drawing, you may want to make a copy of a layout that contains most of the settings you want, and then make changes to the new copy. If you created layouts that you want to use again when you create new drawings, you can save the layouts as a drawing template.
To make a copy of a layout
1. Type layout and then press Enter.
2. In the prompt box, choose Copy.
3. Type the name of the layout you want to copy, and then press Enter.
4. Type a name for the new layout, and then press Enter.

To save a layout as a drawing template
1. Type layout and then press Enter.
2. In the prompt box, choose Save.
3. Type the name of the layout that you want to save, and then press Enter.
4. Specify the file name and location for the template, and then click Save.

After you save a layout as a template, you can use the template when you create new drawings. You can also import the template’s layouts into another drawing.

14.2.7 Managing layouts in a drawing
You can rename layouts, delete layouts, and view a list of all layouts available in a drawing. You can also change the order in which the Layout tabs appear; the Model tab is always stationary.

If you want to rename, delete, or reorder a layout when the Layout tabs are hidden, you can type layout to make your changes or choose View > Display > Model and Layout Tabs to display the tabs.

To rename a layout
1. Right-click the Layout tab to rename.
2. Type a new name for the layout.
3. Click OK.

The name can be up to 255 characters in length and can contain letters, numbers, the dollar sign ($), hyphen (-), and underscore (_), or any combination.
To delete a layout

1. Right-click the Layout tab to delete.
2. Click OK to confirm the deletion.

You cannot delete the Model tab or the last remaining Layout tab.

To delete all geometry from the Model tab or a Layout tab, first select all geometry and then use the Erase command.

To reorder the Layout tabs

1. Right-click the Layout tab you want to move.
2. Do one of the following:
   - Choose Move Right, and then choose a new location.
   - Choose Move Left, and then choose a new location.

To view a list of all layouts

1. Type layout and then press Enter.
2. In the prompt box, choose ? to list all layouts.
3. Type s or press Enter to scroll through the layouts.

14.2.8 Working with layout viewports

A layout viewport is a window in a Layout tab (paper space) that displays all or a portion of a drawing’s model space entities.

14.2.9 Understanding layout viewports

When you begin working in a drawing on the Model tab, it consists of a single view of your model. You may have created additional views by dividing the drawing space into multiple windows; each window is a separate viewport on the Model tab.

Similarly, when you begin working in a drawing on a Layout tab, it consists of a single view from paper space of your model. You can also create multiple layout view-ports that display unique views of your model. Each layout viewport functions as a window into your model space drawing — with each window looking different from the next. You can customize the view center, scale, layer visibility, and contents of each layout viewport. Each layout viewport is created as a separate entity that you can move, copy, or delete.
Click any layout viewport to make it the current viewport, and then add or modify model space entities in that viewport, even while snapping to model space entities from paper space. Any changes you make in one layout viewport are immediately visible in the other viewports (if the other layout viewports are displaying that portion of the drawing). Zooming or panning in the current viewport affects only that view-port.

This section focusses on working with layout viewports in paper space on a Layout tab. For additional information about viewports in model space, see “Dividing the current window into multiple views” on page 172.

### 14.2.10 Creating layout viewports

The first time you switch to a Layout tab, your model displays in a default layout viewport. You can create other layout viewports anywhere inside the drawing area. You can control the number of viewports created and the arrangement of the view-ports.

**To create layout viewports**

1. Do one of the following to choose Layout Viewports:
   - On the ribbon, choose View > Layout Viewports (in Layouts).
   - On the menu, choose View > Viewports > Layout Viewports.
   - On the Viewports toolbar, click the Layout Viewports tool.
   - Type mview and then press Enter.

2. Specify two opposing corners to create a custom rectangular viewport, or in the prompt box, choose one of the following:
   - Fit To View — Creates a layout viewport that fills the screen.
   - Entity — Converts a closed entity to a layout viewport. You can convert a circle, ellipse, closed polyline, spline, or region.
   - Polygonal — Creates a non-rectangular layout viewport.
   - Create 2 Viewports, Create 3 Viewports, Create 4 Viewports — Creates two, three, or four layout view-ports using an orientation that you specify. You can select whether to arrange the viewports to fill the current graphic area or a rectangular area that you specify.

The border of a new layout viewport is created on the current layer.

You can make layout viewport borders invisible by creating a new layer before you create layout viewports and then turning off that layer after you create the layout viewports. To select a layout viewport’s borders, you must turn that layer back on before you can rearrange or modify the layout viewport.
14.2.11 Viewing and scaling layout viewports

If you have created numerous layout viewports, your system performance may be affected. If necessary, you can turn a layout viewport on or off. Turning off a layout viewport does not delete the viewport or its contents; it simply turns off its display.

You can also change how you view items within a layout viewport by specifying a scale factor, which changes how large or small model space entities appear within the layout viewport.

While working in a layout viewport, you can use the Maximize Viewport command to enlarge the view to full size and emulate model space, allowing you to easily work on the geometry in that view. When done, use the Minimize Viewport command to switch back to the original scale and center point of the layout viewport.
To turn layout viewports on or off

1. Click the desired Layout tab.

2. Do one of the following to choose Layout Viewports:
   - On the ribbon, choose View > Layout Viewports (in Layouts).
   - On the menu, choose View > Viewports > Layout Viewports.
   - On the Viewports toolbar, click the Layout Viewports tool.
   - Type mview and then press Enter.

3. Choose On or Off.

4. Select the edge of the layout viewport to turn on or off, and then press Enter.

To maximize a layout viewport

1. On a Layout tab, select a layout viewport. Or, skip this step to maximize the current layout viewport.

2. Do one of the following:
   - On the ribbon, choose View > Maximize Viewport (in Model Viewports).
   - On the menu, choose View > Viewports > Maximize Viewport.
   - On the status bar, click Maximize Viewport.
   - Type vpmx and then press Enter.

The layout viewport is enlarged.

To minimize a layout viewport (if it is maximized)

1. Do one of the following:
   - On the ribbon, choose View > Minimize Viewport (in Model Viewports).
   - On the menu, choose View > Viewports > Minimize Viewport.
   - On the status bar, click Minimize Viewport.
   - Type vpmx and then press Enter.

The layout viewport returns to its original scale and centerpoint.
To change the layout viewport scale

1. Do one of the following to choose Properties:
   - On the ribbon, choose View > Properties (in Display).
   - On the menu, choose Modify > Properties.
   - On the Modify toolbar, click the Properties tool.
   - Type entprop and then press Enter.

2. Select the edge of the layout viewport.

3. In Custom Scale, enter the scale at which you want to view model space entities from within the layout viewport.

4. Click OK.

To change the scale of model space entities relative to paper space

1. Click the Model tab.

2. Click a viewport to make it current.

3. Choose View > Zoom > Zoom.

4. Type the zoom scale factor relative to paper space by appending the suffix xp to the scale factor, and then press Enter.

For example, to increase the scale of the entities in the viewport on the Model tab to twice the size of paper space units, type 2xp. To decrease the scale to half the size of paper space units, type .5xp.

14.2.12 Modifying layout viewports

After you create layout viewports, you can modify them as needed. On the Layout tab, you can snap to the viewport borders using entity snaps. You can copy, delete, move, scale, and stretch layout viewports as you would any other drawing entity.

Additionally, you can lock a layout viewport so the viewport scale and view center do not change in model space while panning or zooming in the layout viewport. If you are working on model space entities from a Layout tab, locking the layout viewport prevents you from constantly changing the layout viewport scale and view center.

And assigning a UCS to each viewport allows you to quickly switch between layout viewports and immediately draw in a different UCS. This can greatly increase productivity, especially when creating complex 3D models.

Modifying a layout viewport on a Layout tab does not affect the model space entities within the layout viewport.
To modify layout viewport properties

1. Click the desired Layout tab.

2. Do one of the following to choose Properties:
   - On the ribbon, choose View > Properties (in Display).
   - On the menu, choose Modify > Properties.
   - On the Modify toolbar, click the Properties tool.
   - Type entprop and then press Enter.

3. Select the edge of the layout viewport you want to modify.

4. Adjust the center point, width, or height of the viewport.

5. In Custom Scale, enter the scale at which you want to view model space entities from within the layout viewport.

6. In Display Locked, choose True to lock the viewport scale and view in model space while panning or zooming in the layout viewport.

7. Mark UCS per Viewport if you want to use a unique UCS for each layout viewport.

8. Click OK.

You can select only layout viewports for modification.

If you click a viewport on the Model tab, it makes that viewport active, not available for modification.

14.2.13 Clipping layout viewports

You can clip layout viewports so that only a portion of the viewport is visible on a Layout tab. You can clip layout viewports in the shape of a new polygon or an existing circle, ellipse, closed spline, closed polyline, or region.

If you delete clipping from a layout viewport, the clipping is removed permanently but the viewport itself and its contents remain in the drawing.
To clip a layout viewport in the shape of an existing entity

1. Click a Layout tab, and select the desired layout viewport.

2. Type vpclip and then press Enter.

3. In the drawing, select an existing circle, ellipse, closed spline, closed polyline, or region to use as a clipping boundary.

To clip a layout viewport in the shape of a new polygon

1. Click a Layout tab, and select the desired layout viewport.

2. Type vpclip and then press Enter.

3. Press Enter to create a new clipping boundary.

4. Define the first point of the clipping polygon.

5. Define additional points.

6. Press Enter when done.

To delete a clipping boundary

1. Click a Layout tab, and select the desired layout viewport.

2. Type vpclip and then press Enter.

3. Choose Delete, and then press Enter.
14.3 Customizing and reusing print settings

Most drawings require adjustments to print settings in order to print the way you want. You can make adjustments to the print settings each time you print, but you can also create page setups, which save the print settings and assign them to different lay-outs in your drawing. If you have several perspectives of your drawing that require printing, using page setups is the most efficient way to print.

14.3.1 Working with page setups

Page setups store printer information for specific models or layouts, which eliminates the need to completely reconfigure your print settings each time you print a drawing and helps ensure that each perspective of a drawing prints as planned.

Assigning a page setup to a model or layout

Because the main model on the Model tab and the various layouts for printing on the Layout tabs all may require unique print settings, the model and each layout can be assigned a separate page setup. If some layouts use the same print settings, those layouts can be assigned the same page setup.

Assigning a page setup to a model or layout doesn't mean it will always print with the specified settings. All of the print settings specified for a page setup can be overridden at print time.

To assign a page setup to a model or layout

1. Click the Model tab or Layout tab that you want to assign a page setup.

2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Page Setup Manager.
   - On the Format toolbar, click the Page Setup Manager tool.
   - Type pagesetup and then press Enter.

3. Select the desired page setup.

4. Click Set Current.

5. Click OK.

You can also choose a page setup at print time.

_In the Print dialog box, select a different page setup from the Page Setup list before you click Print._
14.3.2 Creating a page setup

There are two types of page setups:

- Model page setup — Contains print settings available for the model on the Model tab.
- Layout page setup — Contains print settings available for one or more layouts on the Layout tabs.

CAD.direct Drafter comes with two default page setups — one model page setup and one lay-out page setup. You can create as many additional page setups, of either type, as required for any drawing. Each page setup specifies many aspects of printing, including page size, default printer or plotter, page orientation, print scale, and more.

To create a page setup

1. To create a model page setup, click the Model tab. To create a layout page setup, click any Layout tab.

2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Page Setup Manager.
• On the Format toolbar, click the Page Setup Manager tool.
• Type pagesetup and then press Enter.

3. Click Add.

You can create a new page setup based on the print settings of an existing page setup.

Select an existing page setup in the list, then click Add. The new page setup uses the print settings of the existing page setup as a starting point.

4. Enter a name for the page setup, then click OK.

5. Select the desired print options.

6. Click OK.
A Displays "Layout" if creating a layout page setup or "Model" if creating a model page setup.
B Enter any changes to page setup name.
C Click to specify options for the selected printer.
D Select the printer and view its details.
E Select a paper size supported by the selected printer.
F Select a predefined print scale, or choose Custom to specify your own.
G Select to fit the specified print area to the current paper size.
H Specify the custom scale for the print area by typing the ratio of drawing units to printed inches or printed millimeters.
I Click to specify drawing units and paper size in millimeters or inches.
J Select to center the print area on the printed page.
K Type x- and y-coordinates to specify the origin of the print area.
L Click to select the area of the drawing that you want to print.
M Type the x- and y-coordinates of the two opposing corners of the rectangular area to print, or click Select Print Area to specify coordinates in the drawing window. (Available only if Window is selected for What to print.)
N Select to print the drawing upside down on your printer.
O Select portrait (vertical) or landscape (horizontal) orientation.
P Select how to print lineweights and print styles.
Q Select to prevent paperspace entities from printing.
R Select to print paperspace entities after printing modelspace entities.
S Select to show print styles when viewing the layout.
T Select to print entities with their assigned lineweights. If you turn off lineweight printing, entities print with a default outline.
U Select options for shaded viewports. Quality and DPI are not currently implemented.
V Select a print style table to apply during printing, or select None. Click [...] to modify the selected print style table.
14.3.3 Modifying an existing page setup

You can change any of the print settings associated with a page setup, which eliminates the need to override the settings when it comes time to print the model or each layout that is assigned the page setup.

If you change the settings for a layout print setup, all layouts assigned that print setup will print using the new settings.

To modify an existing page setup

1. To modify a model page setup, click the Model tab. To modify a layout page setup, click any Layout tab.

2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Page Setup Manager.
   - On the Format toolbar, click the Page Setup Manager tool.
   - Type pagesetup and then press Enter.

3. Select the page setup you want to change.

4. Click Modify.

5. Select the desired print options.

6. Click OK.

14.3.4 Deleting a page setup

If you delete a page setup that is assigned to the model or a layout, that model or layout will no longer be assigned a page setup.

To delete a page setup

1. To delete a model page setup, click the Model tab. To delete a layout page setup, click any Layout tab.

2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
• On the menu, choose File > Page Setup Manager.
• On the Format toolbar, click the Page Setup Manager tool.
• Type pagesetup and then press Enter.

3. Select the page setup you want to delete.

4. Click Delete.

5. Click Yes to confirm the deletion.

### 14.3.5 Setting the paper size and orientation

You can specify a paper size and paper orientation for all drawings. You can also adjust the orientation by printing a drawing upside down on the paper. Each layout in your drawing can specify whether to print upside down.

#### To select the paper size and orientation

1. Click the Layout tab or Model tab for which you want to set paper size and orientation.

2. Do one of the following to choose Page Setup Manager:
   • On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   • On the menu, choose File > Page Setup Manager.
   • On the Format toolbar, click the Page Setup Manager tool.
   • Type pagesetup and then press Enter.

3. Select the desired page setup, then click Modify.

4. In Paper size, select a paper size supported by the currently selected printer.

5. In Orientation, select the following settings:
   • Portrait or Landscape — Select Portrait for vertical paper orientation or Landscape for horizontal paper orientation.
   • Print upside down — Select to print the drawing upside down on your printer.

6. Click OK.

7. Click OK.
14.3.6 Selecting a printer or plotter

You can specify a printer or plotter to be used when printing any drawing. You can print your drawing on any printer or plotter that is compatible with Windows, including raster printers.

To select a printer or plotter

1. Click the Layout tab or Model tab for which you want to select a printer.

2. Do one of the following to choose Page Setup Manager:
   • On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   • On the menu, choose File > Page Setup Manager.
   • On the Format toolbar, click the Page Setup Manager tool.
   • Type pagesetup and then press Enter.

3. Select the desired page setup, then click Modify.

4. From the Printer Name list, select a printer or plotter.

5. If desired, click Properties to choose options for the currently selected printer.

6. Click OK.

7. Click OK.

14.3.7 Setting the scale and view

You can print or plot the entire drawing or a selected portion of a drawing. You can choose to print what is visible on the screen, or you can specify to print an area of the drawing.

You can control the position of the drawing on the paper by specifying the origin of the print area, the location of the lower left corner of the print area, in relation to the lower left corner of the paper. The origin is normally set to 0,0, which places the lower left corner of the print area as close to the lower left corner of the paper as the printer or plotter will allow. You can specify a different origin, however, by specifying different coordinates.

When you create a drawing, you generally draw entities full-size. When you print the drawing, you can specify the scale of the resulting print or let the program adjust the size of the drawing to fit the paper. To print the drawing at a specific scale, specify the scale as a ratio of drawing units to printed units.

If you are printing from a Layout tab, the scale and view options you specify can be different for each layout that you create.
To automatically scale the drawing for printing

1. Click the Layout tab or Model tab for which you want to set to scale automatically.

2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Page Setup Manager.
   - On the Format toolbar, click the Page Setup Manager tool.
   - Type pagesetup and then press Enter.

3. Select the desired page setup, then click Modify.

4. In Print Scale, select Fit to Paper to scale the drawing to fit on one printed page.

5. Click OK.

6. Click OK.

To specify the scale factor yourself

1. Click the Layout tab or Model tab for which you want to specify the scale factor.

2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Page Setup Manager.
   - On the Format toolbar, click the Page Setup Manager tool.
   - Type pagesetup and then press Enter.

3. Select the desired page setup, then click Modify.

4. In Print Scale, do one of the following:
   - Select a predefined scale in the Scale list. For example, choose 1:2 if you want 1 printed unit (inch or millimeter) to equal 2 drawing units. The list of available scales is set up using the Scales List command. For more details, see “Customizing the scales list” on page 57.
   - Type the ratio of printed units of measure (inches or millimeters) to drawing units.

5. To specify the printed units of measure, choose Inches or Millimeters.
6. Click OK.
7. Click OK.

**To specify a portion of the drawing to print**

1. Click the Layout tab or Model tab for which you want to specify the area to print.

2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Page Setup Manager.
   - On the Format toolbar, click the Page Setup Manager tool.
   - Type pagesetup and then press Enter.

3. Select the desired page setup, then click Modify.

4. In What to Print, click one of the following:
   - Display — Prints the view on the screen.
   - Extents — Prints the area that contains entities in the drawing.
   - Limits — Prints to the limits defined for the drawing. (Available for model page setups only.)
   - Layout — Prints to the edge of the layout. (Available for layout page setups only.)
   - View — Prints the selected saved view. (Available for drawings that have saved views.)
   - Window — Prints the portion of the drawing contained in the specified window, maintaining the aspect ratio of the windowed area to the drawing.

If you clicked Window, you must specify the window. Under Windowed Print Area, enter the diagonal x- and y-coordinates of the window, or select the area on the screen.

5. Click OK.
6. Click OK.
To specify the print area origin

1. Click the Layout tab or Model tab for which you want to set the paper size and orientation.

2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Page Setup Manager.
   - On the Format toolbar, click the Page Setup Manager tool.
   - Type pagesetup and then press Enter.

3. Select the desired page setup, then click Modify.

4. Under Print Offset, do one of the following:
   - To center the specified print area on the printed page, select Center on Page.
   - To specify an origin for the print area, type the x- and y-coordinates.

5. Click OK.

6. Click OK.

14.3.7 Specifying print options specifically for layouts

Each layout in your drawing can specify certain print settings that apply only to layouts: lineweight scaling, print style display, and paper space print options.

To set print options for only layouts

1. Click a Layout tab.

2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Page Setup Manager.
   - On the Format toolbar, click the Page Setup Manager tool.
   - Type pagesetup and then press Enter.

3. Select the desired page setup, then click Modify.
4. In the Layout Tab Options area, choose the desired print settings:
   - Scale lineweights — Select to print lineweights in proportion to the specified Print Scale settings; if not selected, lineweights print at their assigned size. Note that print styles can also affect how lineweights print.
   - Display print styles — Select to show print styles when viewing the layout.
   - Print paper space last — Select to print paper space entities after printing model-space entities. By default, paper space entities print first.
   - Hide paper space entities — Select to prevent paper space entities from printing.

5. Click OK.

6. Click OK.

14.3.8 Specifying shaded viewport print options

Each model page setup can specify how to print shaded viewports: as displayed, wire-frame, hidden, or rendered. Note that Quality and DPI are not currently implemented.

To set print options for shaded viewports

1. Click the Layout tab or Model tab for which you want to set shaded viewport settings.

2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Page Setup Manager.
   - On the Format toolbar, click the Page Setup Manager tool.
   - Type pagesetup and then press Enter.

3. Select the desired page setup, then click Modify.

4. In the Shaded Viewport Options area, choose the desired settings:
   - Shade — Select how to print shaded viewports
   - Quality — Select the resolution to use for the printed viewport. (Not currently implemented.)
   - DPI — Enter the custom dots per inch to use for printing the viewport shading. Available only if Quality is set to Custom. (Not currently implemented.)

5. Click OK.

6. Click OK.
14.3.9 Specifying pen and line printing options

Each layout in your drawing can specify certain print settings that apply only to lay-outs: lineweight scaling, print style display, and paper space print options.

To set pen and line printing options

1. Click the Layout tab or Model tab for which you want to set pen and line printing options.

2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Page Setup Manager.
   - On the Format toolbar, click the Page Setup Manager tool.
   - Type pagesetup and then press Enter.

3. Select the desired page setup, then click Modify.

4. Choose the desired settings:
   - Print style table — Select a print style table to apply during printing, or select None. If you select a print style table, you can click [...] to modify its settings.
   - Print with entity lineweights — Select to print entities with their assigned lineweights. If you turn off lineweight printing, entities print with a default outline. This option is available if Print with Print Styles option is disabled.
   - Print with print styles — Select to print according to the print style settings in the currently selected print style table. Entity lineweights are ignored.

5. Click OK.

6. Click OK.

14.3.10 Using printer configuration files

Printer configuration files store the printer information you use for specific drawings or layouts, which eliminates the need to completely reconfigure your print settings each time you print a drawing. Printer configuration files also allow you to share and reuse print settings between different drawings and layouts.

CAD.direct Drafter supports the printer configuration files (PCP and PC3 files) used by Auto-CAD. This feature makes it possible to use existing PCP files saved in AutoCAD, as well as to save your CAD.direct Drafter print configuration settings to a PC3 format.
You can convert an AutoCAD PC2 file to PCP format using the Device And Default selection feature in the AutoCAD Print dialog box.

**To save printer settings in a PC3 file**

1. Do one of the following to choose Options
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Printing tab.
3. Click Add or Configure Printers.
4. To add a PC3 file, click Add to create a new PC3 file. In the Add Printer Configuration File dialog box that opens, select the desired printer for the new PC3 file, click Continue, and select the options you want for the PC3 file. If you don’t select any custom options, a PC3 file will not be created.
5. To modify or delete a PC3 file, select the desired file in the list and click Modify or Delete.
6. Click OK.

**To assign a PCP file**

1. If necessary, click the desired Layout tab or the Model tab.
2. Do one of the following:
   - Choose File > Print.
   - On the Standard toolbar, click the Print tool.
   - Type print and then press Enter.
3. In Name for the printer, select the printer configuration file from the list.
14.3.11 Using plotter drivers

To print your drawing, the program sends the output to any printer driver in up to 256 colors, but with no width specified. Initially, the printed output will have a uniform fine width that is the finest line that the plotter device can produce.

The driver then passes colored vectors to the printer, which creates color output on color printers and grayscale output on laser printers. (Color output that converts to grayscale on a laser printer usually is unacceptable by CAD users for final printing.)

With print style tables, you can map all colors to black and set all lineweights to a width you choose. You must use a value appropriate to your printing capabilities. With these features, you can meet most non-presentation print needs.

14.4 Using print styles

CAD.direct Drafter uses print styles to change the appearance of your printed drawing without modifying the actual entities in your drawing. Assigning print styles allows you to customize the color, pen width, linetype, and lineweight that are used to print your drawing.

Print styles help you control what your drawing looks like when it is printed. Rather than describe what an entity looks like on your screen, print styles describe what an entity will look like when you print it. For example, you can map all yellow entities in your drawing to print in blue without modifying the actual entities. You could also map all yellow entities to print with whatever lineweight, linetype, or pen width that you specify.

Because print styles are saved in print style tables, which are files located on your computer, disk, or server, you can reuse them to help eliminate the need to reconfigure your print settings each time you print a drawing. For example, you may have multiple clients who have their own printing preferences. You can save print styles in a named file for each of your clients. You can even share the file with co-workers, or store the files on a network to ensure that everyone in your office uses the same standards.

14.4.1 Understanding print style tables

A print style table is a collection of print styles that allows you to change the appearance of your printed drawing without modifying the actual entities in your drawing. Each print style table is saved in a file that can be located on your computer, disk, or server.

A drawing can use one type of print style table at a time. There are two types of print style tables:

- Color-dependent print style tables (CTB) contain a collection of print styles based on each of the 255 index colors available in a drawing. True colors and color books are not applicable to color-dependent print style tables.
Named print style tables (STB) contain a collection of print styles that you define. They can vary regardless of color.

With color-dependent print style tables, you cannot assign print styles to individual entities or layers. To use these print styles, you assign a specific color to an entity or layer. When you specify a color-dependent print style table at printing time, the entity colors and layer colors map to color-based print styles in the print style table that you specify.

With named print style tables, you can assign named print styles to individual entities and layers. Entities and layers assigned print styles are printed according to the print style table that you specify at printing time. If you specify a print style for a specific entity, that print style overrides any print style assigned to the layer on which the entity resides.

Sometimes a named print style assigned to an entity or layer is not located in the print style table that is assigned to a layout or drawing. This can happen if the print style has been deleted from the named print style table or if you assign a different named print style table to the drawing that does not contain the named print style. In this case, the entity is printed using its default properties, which is similar to assigning the Normal print style to an entity or layer. If you plan on interchanging named print style tables within the same drawing, it’s a good idea to coordinate the tables to use the same print style names.

If a new drawing is based on a template, the new drawing uses the same type of print style table as the template. If a new drawing is created without a template, the type of print style table is specified in the New Drawing Wizard; by default, the new drawing uses the print style table type specified in Tools > Options on the Printing tab. Every drawing is designed to use print style tables, but you decide whether to implement them.

<table>
<thead>
<tr>
<th>Comparison of print style table types</th>
<th>Color-dependent print style table (CTB)</th>
<th>Named print style table (STB)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Description</strong></td>
<td>Contains pre-defined print styles according to color; there is one print style for each of the 256 index colors available in the drawing. Entities with the same color are printed the same way.</td>
<td>Contains unique print styles that you create. Entities with the same color can have different print settings.</td>
</tr>
<tr>
<td><strong>Example</strong></td>
<td>All blue entities print with a .5 millimeter linewidth.</td>
<td>One entity prints with a .7 millimeter linewidth; a second blue prints with a .5 millimeter linewidth.</td>
</tr>
<tr>
<td><strong>Number of print styles</strong></td>
<td>255 (fixed).</td>
<td>At least one (varies).</td>
</tr>
<tr>
<td><strong>Print style names</strong></td>
<td>Print style names range from &quot;Color_1&quot; to &quot;Color_255&quot;. You cannot rename print styles.</td>
<td>You define new print style names. You can rename all print styles except the Normal print style.</td>
</tr>
<tr>
<td><strong>Add, delete, and modify print styles</strong></td>
<td>You can modify the existing print styles, but you cannot add or delete print styles.</td>
<td>You can add and delete print styles. You can modify all print styles except the Normal print style, which uses the default characteristics of the entity.</td>
</tr>
</tbody>
</table>
14.4.2 Implementing print style tables

Every drawing is designed to use print style tables, but you decide whether to implement them. Even if you use one of the default print style tables available with CAD.direct Drafter, using print style tables requires planning ahead of time to ensure that your drawing prints as planned.

For example, a single drawing of a floor plan might require the printing of the following drawing sheets:

- Main Floor Plan Walls print with thick, black lines.
- Electrical Plan Walls print with normal gray lines, indicating that they are not the focus.
- HVAC Plan Walls print with normal gray lines, indicating that they are not the focus.
- Roof Plan Walls print with thin, gray lines and a hidden linetype, indicating that they are hidden under the roof in a plan view.

In this example, you can create four named print style tables, each containing a print style named “WallPstyle”. Each print style table contains its own settings for “WallPstyle” to control how the walls print. Assign WallPstyle to either the wall entities or to a wall layer. Then, assign a different named print style table each time you print, or create four layouts and assign a different print style table to each layout.

The following table describes, in order, the steps to get you started using both color-dependent and named print style tables.
The following table describes how to further customize how print styles work within your drawings.

### Getting started using print style tables

<table>
<thead>
<tr>
<th>Color dependent</th>
<th>Named</th>
<th>Task</th>
<th>Command</th>
<th>Where to get details</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>Create a new drawing. Select a drawing template that uses the desired print style table type or choose it in the New Drawing Wizard.</td>
<td>File &gt; New</td>
<td>Creating a new drawing, page 42</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>(Optional) Create a new print style table.</td>
<td>File &gt; Print Styles Manager</td>
<td>Creating new print style tables, page 479</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td>Assign colors to entities and layers that correspond with print style table settings.</td>
<td>Modify &gt; Properties Tools &gt; CAD direct Drafter Explorer</td>
<td>Setting the current entity color, page 47; Modifying the properties of entities, page 396; Setting the layer color, page 318</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td>Set the current print style assigned to new entities.</td>
<td>Tools &gt; Drawing Settings &gt; Entity Creation tab; status bar, printstyle Modify &gt; Properties Entity Properties toolbar; printstyle</td>
<td>Setting the current print style, page 82</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td>Assign print styles to entities.</td>
<td>Tools &gt; CAD direct Drafter Explorer</td>
<td>Modifying the properties of entities, page 205</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td>Use CAD direct Drafter Explorer to assign print styles to layers.</td>
<td></td>
<td>Setting the layer print style, page 220</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>Assign a print style table to the Model tab, a layout, or to all layouts in the drawing.</td>
<td>File &gt; Print &gt; Advanced tab File &gt; Print Styles Manager File &gt; Print &gt; Advanced tab File &gt; Print</td>
<td>Assigning print style tables, page 478</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td>(Optional) Make changes to the assigned print style table.</td>
<td>File &gt; Print</td>
<td>Modifying print style tables, page 480</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>Print the drawing.</td>
<td>Tools &gt; Options &gt; Printing tab</td>
<td>Printing or plotting your drawing, page 488</td>
</tr>
</tbody>
</table>

### Further customizing print style tables

<table>
<thead>
<tr>
<th>Task</th>
<th>Command</th>
<th>Where to get details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy, rename, or delete print style tables.</td>
<td>File &gt; Print Styles Manager</td>
<td>Copying, renaming, or deleting print style tables, page 483</td>
</tr>
<tr>
<td>Change a drawing to use another type of print style table, for example, change a drawing that uses color-dependent print style tables to one that uses named print style tables.</td>
<td>convertstyles</td>
<td>Changing the print style table type of a drawing, page 483</td>
</tr>
<tr>
<td>Convert a color-dependent print style table to a named print style table.</td>
<td>convertdb</td>
<td>Converting print style tables, page 484</td>
</tr>
<tr>
<td>Change the default location where print style tables are stored.</td>
<td>Tools &gt; Options &gt; Paths/Files tab</td>
<td>Changing the options on the Paths/Files tab, page 582</td>
</tr>
<tr>
<td>Customize how print styles work with new drawings that you create and older drawings that you open.</td>
<td>Tools &gt; Options &gt; Printing tab</td>
<td>Changing the options on the Printing tab, page 602</td>
</tr>
</tbody>
</table>
14.4.3 Assigning print style tables

Select a print style table before printing if you want to change how your drawing appears when you print it. Print style tables can modify how colors, pen widths, line-types, and lineweights look when they are printed.

You can assign print style tables globally for all layouts (including the Model tab), or individually for the Model tab or a Layout tab. Assigning a print style table to an individual layout allows you to further customize the layouts you use to print a drawing.

However, assigning different named print style tables to various layouts may result in mismatched print style names; a named print style assigned to an entity or layer may not be located in the assigned print style table at print time. In this case, entities are printed using their default properties, which is similar to assigning the Normal print style to an entity or layer.

To assign a print style table at the same time you print

1. If necessary, click the desired Layout tab, or click the Model tab. 2 Do one of the following to choose Print:
   - On the ribbon, choose the Application button then choose Print, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Print.
   - Type print and then press Enter.

You can assign a print style table to a page setup.

Use the Page Setup Manager to assign a print style table to a page setup that you use for printing. For more details, see Specifying pen and line printing options.

3. Under Print Style Table (Pen Assignments), select a print style table that you created or one of the following:
   - None — Applies no print style table. Entities print according to their own properties.
   - Icad — Uses the default print style table and its color assignments.
   - Monochrome — Prints all colors as black.

4. Select Save Changes to Layout, and then click OK.

When a drawing is first created it is assigned to use either color-dependent or named print style tables.

For details on converting a drawing to use a different type of print style table, see “Understanding print style tables” on page 474 in this chapter.
14.4.4 Creating new print style tables

CAD.direct Drafter offers several print style tables to help you get started. If you want to customize your print output further, you can create your own print style table. You can create a new print style table entirely from scratch, based on CAD.direct Drafter registry settings, or by importing a printer configuration file (PCP file).

To create new print style tables

1. Do one of the following to choose Print Styles Manager:
   - On the ribbon, choose the Application button then choose Print > Print Styles Manager, or choose Output > Print Styles Manager (in Plot).
   - On the menu, choose File > Print Styles Manager or choose Format > Print Styles Manager.
   - On the Format toolbar, click the Print Styles Manager tool.
   - Type stylesmanager and then press Enter.

2. Click Add.

3. Complete the setup wizard.

On the last wizard page, you can click Print Style Table Editor to set up the print styles for the table. For more details about the Print Style Table Editor options, see the next section.

![Print Styles Manager](image_url)
14.4.5 Modifying print style tables

When your drawing was created, it was set up to use color-dependent or named print style tables:

- Color-dependent print style tables (.ctb files) — You can modify individual print styles within the table, but you cannot add, rename, or delete print styles. Color-dependent print style tables always have 255 print styles, each named for a specific color. Your changes affect all entities and layers assigned that color.
- Named print style tables (.stb files) — You can add, modify, rename, and delete individual print styles within the table. However, you cannot modify, rename, or delete the Normal print style. Your changes affect all entities and layers that are assigned that print style name.

Use a system variable to determine the type of print style table your drawing uses.

If you can’t remember what type of print style table is assigned to your drawing, use the PSTYLEMODE system variable to determine the print style table type.

Each print style within a print style table specifies a color, pen numbers, linetype, and lineweight. CAD.direct Drafter recognizes additional characteristics for compatibility with AutoCAD only, including: dither, grayscale, screening, adaptive, line end style, line join style, and fill style.

When specifying print style characteristics, be sure to consider the limitations of your output device.

It is recommended that you only modify print style tables that you have created.

*If you modify a default print style table that came with CAD.direct Drafter, you overwrite the original information which is then lost.*

**To modify print style tables**

1. Do one of the following to choose Print Styles Manager:
   - On the ribbon, choose the Application button then choose Print > Print Styles Manager, or choose Output > Print Styles Manager (in Plot).
   - On the menu, choose File > Print Styles Manager or choose Format > Print Styles Manager.
   - On the Format toolbar, click the Print Styles Manager tool.
   - Type stylesmanager and then press Enter.
2. Select the print style table you want to modify.
3. Click Modify.
4. Click the General tab, and then do any of the following:
   - Enter a new table description.
   - Select Apply Global Scale Factor to Non-ISO Linetypes to apply the scale factor to non-ISO linetypes used for any print style in the current print style table. This also applies to fill patterns, which are not used in CAD.direct Drafter, but are recognized for compatibility with AutoCAD.
   - Enter a scale factor to apply to non-ISO linetypes used for any print style in the current print style table.

5. Click the Form View tab, and then do any of the following:
   - Make format changes to a print style by selecting it in the Print Styles list, then make color, pen map, linetype, or lineweight changes for the print style. Your changes are saved automatically for the selected print style.
   - Add a new print style by clicking Add Style. Enter a new name, and then click OK. Select the options for the print style. (Available for named print styles only.)
   - Rename a print style by selecting it in the Print Styles list. Single-click the print style again, and then enter a new name. (Available for named print styles only.)
   - Delete a print style by selecting it in the Print Styles list. Click Delete Style. (Available for named print styles only.)

6. Click OK.
A. Select a print style to modify it.
B. Enter a description for the selected print style.
C. Click to create a new print style. (Named print style tables only.)
D. Click to delete the selected print style. (Named print style tables only.)
E. Click to modify the list of available lineweights for the current print style table.
F. Click to save the print style table with a new name or in a new location.
G. Choose a fill style for the selected print style.
H. Choose a line join style for the selected print style.
I. Choose a line end style for the selected print style.
J. Choose a lineweight for the selected print style.
K. Choose whether to adjust the linetype scale automatically to complete the linetype pattern when necessary.
L. Choose a linetype for the selected print style.
M. Select the level of color intensity for the selected print style: 100 is full intensity, 0 is white. (Dither must be on.)
N. Type or scroll to the width of the virtual pen for the selected print style (for printers that don’t have physical pens, such as laser or inkjet printers).
O. Type or scroll to the width of the physical pen for the selected print style.
P. Choose whether to print the selected print style in grayscale.
Q. Choose whether to turn on dithering for the selected print style.
R. Choose a color for the selected print style.
14.4.6 Copying, renaming, or deleting print style tables

Copy, rename, or delete a print style table just as you would any other file on your computer. Regardless of which print style table type your drawing uses, you can use the Print Style Manager to manage both color-dependent and named print style tables.

To delete print style tables

1. Do one of the following to choose Print Styles Manager:
   - On the ribbon, choose the Application button then choose Print > Print Styles Manager, or choose Output > Print Styles Manager (in Plot).
   - On the menu, choose File > Print Styles Manager or choose Format > Print Styles Manager.
   - On the Format toolbar, click the Print Styles Manager tool.
   - Type stylesmanager and then press Enter.
2. Select a print style table, then click Delete.

Color-dependent print style tables are .ctb files and named print style tables are .stb files.

To copy, rename, or delete print style tables

1. On your computer, open the folder that stores print style tables, for example, \\CompanyName\ProductVersion\Print Styles.
2. Copy, rename, or delete the print style table just as you would any other file on your computer.

14.4.7 Changing the print style table type of a drawing

When your drawing was created, it was set up to use color-dependent print style tables (.ctb files) or named print style tables (.stb files). A drawing can use one type of print style table at a time. If necessary, after a drawing is created you can convert the drawing to use the other type of print style table.

If you can’t remember what type of print style table is assigned to your drawing, use the PSTYLEMODE system variable to determine the print style table type.
To change a drawing to use named print style tables

1. If you want to reuse any of the existing print style information, convert your color-dependent print style tables to named print style tables. For details, see “To convert a color-dependent print style table to a named print style table” on page 485 in this chapter.

2. Open the drawing that uses color-dependent print style tables (.ctb files).

3. Type convertpstyles, and then press Enter.

4. If you have already converted your individual color-dependent print style tables to named tables, click OK in the prompt that displays.

   If you have not converted the tables, click Cancel. First use convertctb to convert your color-dependent print style tables to named tables. If you do not, all of the print style information you specified in your drawing will be lost.

5. Select a named print style table (.stb file) that you want to use with the drawing.

6. Click Open.

   Errors will occur if you have not converted print style tables.

   *If you have not converted a color-dependent print style table to a named print style table, you will be warned that the table you have selected does not contain color mapping and the drawing cannot be converted.*

To change a drawing to use color-dependent print style tables

1. Open the drawing that uses named print style tables (.stb files).

2. Type convertpstyles, and then press Enter.

3. If you are sure you want to convert the drawing and lose all print style assignments, click OK in the prompt that displays.

   If you do not want to lose the print style assignments, click Cancel.

Converting a drawing to use color-dependent print style tables will remove all of the named print style information from entities and layers.

*However, the named print style tables are not deleted from your computer.*
14.4.8 Converting print style tables

You can convert a color-dependent print style table to a named print style table. You cannot convert a named print style table to a color-dependent print style table because color-dependent tables contain only print styles that are named after the 255 colors to which they map.

Converting a color-dependent print style table to a named print style table can be helpful in the following situations:

- You don’t want to create a named print style table from scratch.
- You want to create a named print style table that has the same settings as a color-dependent print style table, but with some new print styles or other custom settings.
- You want to convert a drawing to use named print style tables and you want to reuse most of print styles already defined in a color-dependent print style table.

To convert a color-dependent print style table to a named print style table

1. Type convertctb, and then press Enter.
2. Select the color-dependent print style table (.ctb file) that you want to convert.
3. Click Open.
4. Enter a name for the new named print style table (.stb file).
5. Click Save.

The print styles in the new table are named Style 1, Style 2, and so on. If you want to use different print style names, rename the print styles before you assign them to entities and layers in your drawing. If you rename the print styles after assigning them, they will not match when you print your drawing. For information about renaming print styles, see “Modifying print style tables” on page 480 in this chapter.

14.4.9 Turning print style tables on or off

When you turn off print style tables, entities print according to their own properties. However, all of the print style information is saved so you can easily turn on print styles again. Actual print style table files are not deleted, and for drawings that use named print style tables, entities and layers retain their assigned print styles.

To turn off print style tables

1. Click the Layout tab or Model tab for which you want to turn on or off print style tables.
2. Do one of the following to choose Page Setup Manager:
   - On the ribbon, choose the Application button then choose Page Setup Manager, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Page Setup Manager.
   - On the Format toolbar, click the Page Setup Manager tool.
   - Type pagesetup and then press Enter.
3. Select the desired page setup, then click Modify.
4. In Print style table, select a print style table to turn on print style tables, or select None to turn off print style tables.
5. Click OK.
6. Click OK.

14.5 Printing or plotting your drawing

After you have configured your drawing and any layouts for printing, you are ready to print. If desired, you can preview your page before printing.

14.5.1 Previewing a drawing before printing

Viewing a drawing before printing gives you a preview of what your drawing will look like when it is printed. This helps you see if there are any changes you want to make before actually printing the drawing.

If you are using print style tables, the preview shows how your drawing will print with the assigned print styles. For example, the preview may display different colors or lineweights than those used in the drawing because of assigned print styles.

To preview a drawing before printing

1. If necessary, click the desired Layout tab or the Model tab.
2. Do one of the following to choose Print Preview:
   - On the ribbon, choose the Application button then choose Print > Print Preview, or choose Output > Page Setup Manager (in Plot).
   - On the menu, choose File > Print Preview.
   - On the Standard toolbar, click the Print Preview tool.
   - Type ppreview and then press Enter.
3. After checking the preview image, do one of the following:

- To print the drawing, click Print.
- To return to the drawing, click Cancel.
14.5.2 Printing a drawing

The Print dialog box has print settings described in the previous sections for page set-ups.

You cannot print a rendered image directly to a printer.

*To print a rendered image, you must first save the drawing to a different format and then print it from another graphics program.*

**To print a drawing**

1. If necessary, click the desired Layout tab or the Model tab.

2. Do one of the following to choose Print:
   - On the ribbon, choose the Application button then choose Print, or choose Output > Print (in Plot).
   - On the menu, choose File > Print.
   - On the Standard toolbar, click the Print tool.
   - Type print and then press Enter.

3. In Page Setup Name, select the page setup to apply for printing. The print options in the Print dialog box change to reflect the settings of the selected page setup.

4. Make any necessary adjustments, including for the following options that are available only at print time (not when setting up a page setup):
   - Print to file — Select to print to a file instead of a printer.
   - Number of copies — Enter the number of copies to print.
   - Print in background — Print in the background of other tasks being performed by the computer.
   - Print stamp on — Select to print with a header and footer. Click [...] to modify the text of the print stamp.
   - Save changes to layout — Select to save the print settings for the model or layout.

5. Click Print.
14.5.3 Saving print settings for a model or layout

All print settings can be saved with a model or layout, which can be particularly helpful if you don’t use page setups. The next time you print the model or layout, the saved print settings automatically load in the Print dialog box.

Saved print settings are also used when publishing.

*If you’re publishing drawings using sheets that don’t have a page setup assigned, the print settings saved for the model or layout are used by default.*
To save print settings with a model or layout

1. Click the desired Layout tab or the Model tab for which you want to save print settings.

2. Do one of the following to choose Print:
   - On the ribbon, choose the Application button then choose Print, or choose Output > Print (in Plot).
   - On the menu, choose File > Print.
   - On the Standard toolbar, click the Print tool.
   - Type print and then press Enter.

3. Make your print selections.

4. Click Apply to Layout.

5. Do one of the following:
   - Click OK to print and close the dialog box.
   - Click Cancel to close the dialog box without printing.

14.6 Publishing drawings

Rather than print one drawing at a time, you can use the Publish command to save and print a collection of drawings and their layouts.

First you create a sheet list by specifying the desired layouts, which can be a combination of model space and paper space layouts from any drawing. Save the sheet list, then print it.

14.6.1 Creating a sheet list to publish

A sheet list is a collection of sheets that you want to publish. Each sheet in the list references a layout, which can be model space or a paper space layout from any drawing.

Sheet lists are saved as Drawing Set Description files (.dsd files).

To create a sheet list to publish

1. Do one of the following to choose Publish:
   - On the ribbon, choose the Application button then choose Print > Publish, or choose Output > Publish.
   - On the menu, choose File > Publish.
• On the Standard toolbar, click the Publish tool.
• Type publish and then press Enter.

2. To add sheets, do the following:
• Click Add.
• Select one or more drawings that contain the models and layouts you want to add as sheets.
• Click Open.

3. To add sheets from all open drawings, mark Automatically Load All Open Drawings. The models and layouts from all drawings that are currently open will be added as sheets.

4. To remove unwanted sheets from the sheet list, select a sheet, then click Remove.

5. Click Save.

6. In the Save DSD File dialog box, enter a name for the sheet list, then click Save.

14.6.2 Modifying an existing sheet list
Open, or load, an existing sheet list (.dsd file) to modify it. During loading, drawings that are specified in the sheet list must also be accessible in the referenced folder location.

To modify a sheet list
1. Do one of the following to choose Publish:
• On the ribbon, choose the Application button then choose Print > Publish, or choose Output > Publish.
• On the menu, choose File > Publish.
• On the Standard toolbar, click the Publish tool.
• Type publish and then press Enter.

2. Click Load.

3. Locate and select the .dsd file to modify.

4. Click Open.

5. To add sheets, do the following:
• Click Add, or press insert when a sheet is selected.
• Select one or more drawings that contain the models and layouts you want to add as sheets.
• Click Open.
6. To remove unwanted sheets from the sheet list, select a sheet, then click Remove or press delete.

7. To change the page setup assigned to a sheet, select the sheet and click Change. You can also double-click the sheet.

8. Click Save.

14.6.3 Publishing a sheet list

Publishing a sheet list prints all referenced sheets at the same time. The sheets are printed to the printer named in the assigned page setup for each sheet. If the Page Setup column indicates None, each sheet is published using the print options specified for the layout.

To publish a sheet list

1. Do one of the following to choose Publish:
   
   • On the ribbon, choose the Application button then choose Print > Publish, or choose Output > Publish.
   • On the menu, choose File > Publish.
   • On the Standard toolbar, click the Publish tool .
   • Type publish and then press Enter.

2. Open the desired sheet list:
   
   • Click Load.
   • Locate and select the .dsd file to publish.
   • Click Open.

3. Verify the status of each sheet in the list:
   
   • No Errors — The sheet is ready for publishing.
   • Layout Not Initialized — The sheet’s layout is not assigned a valid printer. If the sheet is assigned a page setup, choose File > Page Setup and specify a valid printer for the page setup. If no page setup is assigned, open the source drawing file, click the referenced Model or Layout tab, choose File > Print, specify a printer, then click Apply to Layout.

4. Specify any of the following options:
   
   • Number of copies — Enter the number of copies to print.
   • Include print stamp — Select to print with a header and footer. Click [...] to modify the text of the header and footer.
   • Publish in background — Print in the background of other tasks being performed by the computer.
5. Click Publish.
15. Drawing in three dimensions

Paper drawings typically represent two-dimensional views of three-dimensional objects. With CAD.direct Drafter, you can create three-dimensional models of three-dimensional objects.

This section explains how to:

- View entities in three dimensions.
- Create three-dimensional entities.
- Edit entities in three-dimensional space.
- Edit three-dimensional solids.
- Display hidden-line and shaded views of three-dimensional entities.

The tools and commands for many of the functions described in this section appear on the Draw 3D toolbar and the Insert menu, respectively, when you set the program to the Advanced experience level.

15.1 Viewing entities in three dimensions

You can view an CAD.direct Drafter drawing from any position in three-dimensional space. From any selected viewing position, you can add new entities and modify existing entities. You can also generate hidden-line and shaded views from any viewing position.

You view three-dimensional drawings by setting the viewing direction. The viewing direction establishes the viewing position, the Cartesian coordinate corresponding to the viewpoint looking back at the origin point, the 0,0,0 coordinate. When you view a drawing from the default viewpoint (0,0,1), you see a plan view of the drawing.

On the View toolbar, you can view a three-dimensional drawing using any of the following methods:

- Preset Viewpoints
- Dynamic View Control
- Plan View
15.1.1 Setting a new viewing direction

You can change the viewing direction to look at the drawing from a different vantage point or to work on a three-dimensional model from a different orientation.

To set a new viewing direction

1. Do one of the following to choose Preset Viewpoints:
   - On the ribbon, choose View > Preset Viewpoints (in Views).
   - On the menu, choose View > Preset Viewpoints.
   - On the View toolbar, click the Preset Viewpoints tool.
   - Type `setvpoint` and then press Enter.
2. Click the preset view you want to use.
15.1.2 Setting a viewing direction dynamically

You can dynamically rotate the viewpoint within the xy plane and relative to the xy plane, and you can pan and zoom the drawing. As you change the viewpoint settings, the drawing display automatically updates.

To dynamically set a view direction

1. Do one of the following to choose Dynamic View Control:
   
   • On the ribbon, choose View > Dynamic View Control (in Views).
   • On the menu, choose View > Dynamic View Control.
   • On the View toolbar, click the Dynamic View Control tool.
   • Type viewctl and then press Enter.

2. Make your selections to change the viewpoint.

3. To complete the command, click OK.
To set a view direction interactively with the drawing

1. Do one of the following to choose Dynamic View Control:
   - On the ribbon, choose View > Dynamic View Control (in Views).
   - On the menu, choose View > Dynamic View Control.
   - On the View toolbar, click the Dynamic View Control tool.
   - Type viewctl and then press Enter.

2. Click Adjust.

3. Make your selections to change the 3D viewing direction within the drawing.

4. Click OK.

5. To complete the command, click OK.
15.1.3 Displaying a plan view of the current drawing

You can set the current viewing direction to the plan view of the current user coordinate system (UCS), a previously saved UCS, or the World Coordinate System (WCS).

To display a plan view of the current drawing

1. Do one of the following to choose Plan View:
   - On the ribbon, choose View > Plan View (in Views).
   - On the menu, choose View > Plan View.
   - On the View toolbar, click the Plan View tool.
   - Type plan and then press Enter.

2. In the prompt box, choose one of the following:
   - Current displays the plan view of the current UCS.
   - UCS displays the plan view of a saved UCS. The program prompts you for the name of the UCS.
   - World displays the plan view of the WCS.

15.2 Creating three-dimensional entities

CAD.direct Drafter supports the following types of three-dimensional models:

- Wire-frame models, which consist of lines and curves that define the edges of a three-dimensional entity. You can create a wire-frame model by drawing lines, arcs, polylines, and other two-dimensional entities anywhere in three-dimensional space. Wire-frame models have no surfaces; they always appear as outlines. Because you must individually draw and position each entity that makes up a wire-frame model, creating one can be exacting and time-consuming.

- Surface models, which consist of both edges and the surfaces between those edges. You can create a surface model by applying elevation and thickness to two-dimensional planar entities or by using specific three-dimensional entity-creation commands. Surface models consist of individual planes forming a faceted, polygonal mesh.

- 3D solids, which are three-dimensional ACIS entities that consist of faces and edges. 3D solids appear to have volume and are easier to work with than wire-frame and surface models. CAD.direct Drafter supports viewing and limited editing of 3D solids, including moving, rotating and scaling. Additionally, some versions of CAD.direct Drafter allow you to create and more completely edit 3D solids.
15.2.1 Applying elevation and thickness

By default, the program creates new two-dimensional entities with a zero elevation and thickness. The easiest way to create a three-dimensional entity is to change the elevation or thickness property of an existing two-dimensional entity.

The elevation of an entity is its z-coordinate position in relation to the xy plane in which the entity is drawn. An elevation of 0 indicates that the entity is drawn on the xy plane of the current UCS. Positive elevations are above this plane; negative elevations are below it.

The thickness of an entity is the distance it is extruded above or below its elevation. A positive thickness extrudes the entity upward in the positive z direction of the entity; a negative thickness extrudes it downward in the negative z direction. The thickness is applied uniformly to the entire entity. You can extrude any two-dimensional entity into a three-dimensional entity by changing the thickness of the entity to a nonzero value. For example, a circle becomes a cylinder, a line becomes a three-dimensional plane, and a rectangle becomes a box.

You can create three-dimensional entities using any of the following methods:

- Draw two-dimensional entities in three-dimensional space.
- Convert two-dimensional planar entities into three-dimensional entities by applying elevation and thickness.
- Convert two-dimensional planar entities into three-dimensional entities by revolving or extruding.
- Create three-dimensional entities such as boxes, cylinders, cones, domes, spheres, and wedges.

Three-dimensional solids are drawn as true solids with versions of CAD.direct Drafter that support three-dimensional ACIS solids.
Three-dimensional solids that you can create include: box, cone, cylinder, dish, dome, pyramid, sphere, torus, and wedge.

You can change the default elevation and thickness values to create new entities with an elevation and thickness already applied.

**To set the current elevation**

1. Do one of the following to choose Elevation:
   - On the ribbon, choose Draw > Elevation (in Settings).
   - On the menu, choose Format > Elevation.
   - On the Format toolbar, click the Elevation tool.
   - Type elev and then press Enter.
2. Specify the New Current Value For Elevation, and then press Enter.

**To set the current thickness**

1. Do one of the following to choose Thickness:
   - On the ribbon, choose Draw > Thickness (in Settings).
   - On the menu, choose Format > Thickness.
   - On the Format toolbar, click the Thickness tool.
   - Type thickness and then press Enter.
2. Specify the New Current Value For Thickness, and then press Enter.

**To set the current elevation and thickness using a dialog box**

1. Do one of the following to choose Drawing Settings:
   - On the ribbon, choose Home > Drawing Settings (in Utilities) or choose Tools > Drawing Settings (in Manage).
   - On the menu, choose Tools > Drawing Settings.
   - On the Tools toolbar, click the Drawing Settings tool.
   - Type settings and then press Enter.
2. Click the 3D Settings tab.
3. In the Change Settings For list, click Surfaces.
4. To change the current thickness, in the Current 3D Thickness box, type a new thickness value or click the arrows to select a new thickness.

5. To change the current elevation, in the Current 3D Elevation box, type a new elevation value or click the arrows to select a new elevation.

6. Click OK.

To change the thickness and elevation of an existing entity

1. Do one of the following to choose Properties:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Modify > Properties.
   - On the Modify toolbar, click the Properties tool.
   - Type entprop and then press Enter.

2. Select the entity, and then press Enter. CAD.direct Drafter displays the Properties palette (its exact appearance depends on the type of entity you select).

3. To change the thickness, in the Thickness box, type a new thickness value or click the arrows to select the new thickness.
4. To change the elevation, in the Z coordinate box (or some entities have an Elevation box), type a new elevation value or click the arrows to select the new elevation.

5. Click OK.

When you change the thickness of an entity, you do not change the entity type.

*If you want to extrude an entity and convert it to a three-dimensional solid, use the Extrude command.*
15.2.2 Creating three-dimensional faces

You can create a three-dimensional face, which consists of a section of a plane in three-dimensional space. You define a three-dimensional face by specifying the x,y,z coordinates of three or more corners. After you specify the fourth point, the program continues to prompt you for additional faces by alternating prompts for the third point and fourth point to allow you to build a complex three-dimensional entity. Each three- or four-sided plane is created as a separate three-dimensional face entity.

To create a three-dimensional face

Advanced experience level

1. Do one of the following to choose Face:
   • On the ribbon, choose Draw 3D > 3D Face (in Draw 3D Meshes).
   • On the menu, choose Draw > 3D Meshes > Face.
   • On the Draw 3D Meshes toolbar, click the Face tool.
   • Type face and then press Enter.
2. Specify the first point of the three-dimensional face.
3. Specify the second, third, and fourth points.
4. Specify the third and fourth points for additional faces.
5. To complete the command, press Enter.

Any or all edges of a three-dimensional face can be invisible to allow you to more accurately model entities with holes in them.

As the program prompts you for the corner points, in the prompt box, choose Invisible Edge to make the next edge invisible.
15.2.3 Creating rectangular meshes

You can create a three-dimensional rectangular mesh consisting of four-sided polygons. You determine the size of the mesh by specifying the number of vertices along the primary (M-direction) and secondary (N-direction) mesh axes and then specifying the coordinates for each vertex.

To create a rectangular mesh

Advanced experience level

1. Do one of the following to choose Mesh:
   - On the ribbon, choose Draw 3D > Meshes (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Mesh.
   - On the Draw 3D Meshes toolbar, click the Mesh tool.
   - Type mesh and then press Enter.
2. Specify the number of vertices along the primary mesh axis.
3. Specify the number of vertices along the secondary mesh axis.
4. Specify the coordinates for each vertex.

Specifying the coordinates for the last vertex completes the mesh and ends the command.

Although creating rectangular meshes manually can be exacting, they are useful for representing complex surfaces such as three-dimensional terrain models.

The Mesh tool is most useful when combined with scripts or LISP programs that mathematically calculate the coordinates of the vertices.

An example of a three-dimensional terrain model created using rectangular meshes.
15.2.4 Creating polyface meshes

You can create a polygon mesh consisting of faces connecting three or more vertices. You first determine the coordinates of each vertex and then define each face by entering the vertex numbers for all the vertices of that face. As you create each face, you can control the visibility and color of each edge and assign each edge to specific layers.

To create a polyface mesh

Advanced experience level

1. Do one of the following to choose Polyface Mesh:
   - On the ribbon, choose Draw 3D > Polyface Mesh (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Polyface Mesh.
   - On the Draw 3D Meshes toolbar, click the Polyface Mesh tool.
   - Type pface and then press Enter.

2. Specify the coordinates of each vertex.

After each vertex that you specify, the next vertex number is displayed, and you are prompted for the coordinates of the vertex. Specify the coordinates, and then press Enter. Continue to specify the coordinates for each numbered vertex.

3. To finish specifying vertex coordinates, press Enter.

4. Specify the vertex numbers that define the first face.

You specify the face by entering the vertex numbers that were defined when you specified coordinates in step 2. Each face can be composed of three or more numbered vertices.

5. To finish defining the first face, press Enter.

6. Specify the next face by entering its vertex numbers.

7. To complete the command, press Enter.

Edges can be made invisible.

_Type the vertex number as a negative value._
15.2.5 Creating ruled surface meshes

You can create a ruled surface, which is a three-dimensional polygon mesh that approximates the surface between two existing entities. You select the two entities that define the ruled surface. These entities can be arcs, circles, lines, points, or polylines.

**To create a ruled surface mesh**

Advanced experience level

1. Do one of the following to choose Ruled Surface:
   - On the ribbon, choose Draw 3D > Ruled Surface (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Ruled Surface.
   - On the Draw 3D Meshes toolbar, click the Ruled Surface tool.
   - Type `rulesurf` and then press Enter.

2. Select the first defining entity.

3. Select the second defining entity.

The value of the Number of M-Direction Surfaces controls the density of the mesh.

*Choose Tools > Drawing Settings, and then click the 3D Settings tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the Number Of M-Direction Surfaces value. Or, on the Tools toolbar, use the Drawing Settings tool to display that dialog box.*
15.2.6 Creating extruded surface meshes

You can create an extruded surface, which is a three-dimensional polygon mesh that approximates the surface generated by extruding a path curve along a direction vector. You select the two entities that define the path curve and direction vector. The length of the direction vector determines the distance the path curve is moved along the direction vector. The extruded entity can be an arc, circle, line, or polyline. You can choose a line or open polyline as the direction vector. The resulting mesh consists of a series of parallel polygonal planes running along the specified path.

To create an extruded surface mesh

Advanced experience level

1. Do one of the following to choose Extruded Surface:
   - On the ribbon, choose Draw 3D > Extruded Surface (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Extruded Surface.
   - On the Draw 3D Meshes toolbar, click the Extruded Surface tool.
   - Type tabsurf and then press Enter.

2. Select the entity to extrude.

3. Select the extrusion path.

The value of the Number of M-Direction Surfaces controls the density of the mesh. Choose Tools > Drawing Settings, and then click the 3D Settings tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the Number Of M-Direction Surfaces. Or, on the Tools toolbar, use the Drawing Settings tool to display that dialog box.

An extruded mesh is different from an extruded solid. If you want to extrude an entity and convert it to a three-dimensional solid, use the Extrude command.
15.2.7 Creating revolved surface meshes

You can create a surface of revolution, which is a three-dimensional polygon mesh that approximates the surface generated by rotating a two-dimensional profile around an axis. You select the two entities that define the profile and the axis. You also specify the starting angle and the number of degrees to revolve the profile.

Revolving the profile 360 degrees creates a closed three-dimensional mesh. The Number Of M-Direction Surfaces value determines the mesh density (the number of mesh segments) in the M-direction (around the axis of revolution). The N-Direction Mesh Density value determines the mesh density (the number of mesh segments) in the N-direction (along the axis of revolution).

To create a revolved surface mesh

Advanced experience level

1. Do one of the following to choose Revolved Surface:
   - On the ribbon, choose Draw 3D > Revolved Surface (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Revolved Surface.
   - On the Draw 3D Meshes toolbar, click the Revolved Surface tool.
   - Type revsurf and then press Enter.
2. Select the entity to revolve.
3. Select the entity to be used as the axis of revolution.
4. Specify the starting angle.
5. Specify the number of degrees to revolve the entity.
The values of the Number of M-Direction Surfaces and N-Direction Mesh Density control the density of the mesh.

*Choose Tools > Drawing Settings, and then click the 3D Settings tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the Number Of M-Direction Surfaces and N-Direction Mesh Density values. Or on the Tools toolbar, use the Drawing Settings tool to display that dialog box.*

### 15.2.8 Creating edge-defined Coons surface patch meshes

You can create a surface called a Coons surface patch, a mesh connecting four edges. You select the entities that define the edges. Edge entities can be arcs, lines, or polylines. The four edge entities must form a closed loop and share endpoints. A patch is a bicubic surface (one curve extends in the M-direction and the other in the N-direction) interpolated between the four adjoining edges. You can select the edges in any order. The first edge you select determines the M-direction of the mesh.

#### To create an edge-defined Coons surface patch mesh

Advanced experience level

1. Do one of the following to choose Coons Surface:
   - On the ribbon, choose Draw 3D > Coons Surface (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Coons Surface.
   - On the Draw 3D Meshes toolbar, click the Coons Surface tool.
   - Type edgesurf and then press Enter.

2. Select the first edge.

3. Select the second, third, and fourth edges.
The values of the Number of M-Direction Surfaces and N-Direction Mesh Density control the density of the mesh.

*Choose Tools > Drawing Settings, and then click the 3D Settings tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the Number Of M-Direction Surfaces and N-Direction Mesh Density values. Or on the Tools toolbar, use the Drawing Settings tool to display that dialog box.*

### 15.2.9 Creating boxes

You can create rectangular boxes, or cubes. A box consists of six rectangular surface planes. The base of the box is always parallel with the xy plane of the current UCS. You position the box by specifying either a corner or the center of the box. You determine the size of the box by either specifying a second corner and the height; defining the box to be a cube and then providing its length; or specifying the length, width, and height.

**To create a box as an ACIS solid**

1. Do one of the following to choose Box:
   - On the ribbon, choose Draw 3D > Box (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Box.
   - On the Draw 3D Solids toolbar, click the Box tool.
   - Type box and then press Enter.
2. Specify the first corner of the base.
3. Specify the opposite corner of the base.
4. Specify the height.

**To create a box as a 3D mesh**

1. Do one of the following to choose Box:
   - On the ribbon, choose Draw 3D > Box (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Box.
   - On the Draw 3D Meshes toolbar, click the Box tool.
   - Type ai_box and then press enter.
2. Specify the first corner of the base.
3. Specify the opposite corner of the base.
4. Specify the height.

15.2.10 Creating wedges

You can create three-dimensional wedges consisting of five surface planes. The base of the wedge is always parallel with the xy plane of the current UCS with the sloped face opposite the first corner. The height is always parallel with the z-axis. You position the wedge by specifying either a corner or the center of the wedge. You determine the size of the wedge by either specifying a second corner and the height; defining the wedge based on a cube having a given length; or specifying the length, width, and height.

To create a wedge as an ACIS solid

1. Do one of the following to choose Wedge:
   - On the ribbon, choose Draw 3D > Wedge (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Wedge.
   - On the Draw 3D Solids toolbar, click the Wedge tool.
   - Type wedge and then press Enter.
2. Specify the first corner of the base.
3. Specify the opposite corner of the base.
4. Specify the height.
To create a wedge as a 3D mesh

- On the ribbon, choose Draw 3D > Wedge (in Draw 3D Meshes).
- On the menu, choose Draw > 3D Meshes > Wedge.
- On the Draw 3D Meshes toolbar, click the Wedge tool.
- Type ai_wedge and then press Enter.

2. Specify the first corner of the base.

3. Specify the opposite corner of the base.

4. Specify the height.

15.2.11 Creating cones

You can create three-dimensional cones defined by a circular base and tapering to a point perpendicular to the base. The base of the cone is always parallel with the xy plane of the current UCS; the height of the cone is always parallel with the z-axis. You position the cone by specifying the center of the base. You determine the size of the cone by specifying either the radius or the diameter of the base and the height.

To create a cone as an ACIS solid

1. Do one of the following to choose Cone:
   - On the ribbon, choose Draw 3D > Cone (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Cone.
   - On the Draw 3D Solids toolbar, click the Cone tool.
   - Type cone and then press Enter.

2. Specify the center of the base of the cone.
3. Specify the radius or diameter.
4. Specify the height.

To create a cone as a 3D mesh

1. Do one of the following to choose Cone:
   - On the ribbon, choose Draw 3D > Cone (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Cone.
   - On the Draw 3D Meshes toolbar, click the Cone tool.
   - Type ai_cone and then press Enter.
2. Specify the center of the base of the cone.
3. Specify the radius or diameter.
4. Specify the height.

15.2.12 Creating pyramids

You can create tetrahedrons (three-sided pyramids) or four-sided pyramids. The sides of the resulting pyramid can meet at a point (the apex) or can form a three- or four-edged top. The sides of a four-sided pyramid can also meet along a ridge defined by two points. The base of the pyramid is always parallel with the xy plane of the current UCS. You position the pyramid by specifying a corner of the base. You determine the size of the pyramid by specifying the base points and either the apex, the corners of the top surface, or the endpoints of the ridge.
To create a tetrahedron as an ACIS solid
1. Do one of the following to choose Pyramid:
   • On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Solids).
   • On the menu, choose Draw > 3D Solids > Pyramid.
   • On the Draw 3D Solids toolbar, click the Pyramid tool.
   • Type pyramid and then press Enter.
2. Specify the first point for the base of the pyramid.
3. Specify the second and third points.
4. In the prompt box, choose Tetrahedron.
5. Specify the apex of the tetrahedron.

To create a tetrahedron as a 3D mesh
1. Do one of the following to choose Pyramid:
   • On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Meshes).
   • On the menu, choose Draw > 3D Meshes > Pyramid.
   • On the Draw 3D Meshes toolbar, click the Pyramid tool.
   • Type ai_pyramid and then press Enter.
2. Specify the first point for the base of the pyramid.
3. Specify the second and third points.
4. In the prompt box, choose Tetrahedron.
5. Specify the apex of the tetrahedron.

The first point (A), second point (B), and third point (C) of the base, and the apex (D).
To create a pyramid with a planar top as an ACIS solid

1. Do one of the following to choose Pyramid:
   • On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Solids).
   • On the menu, choose Draw > 3D Solids > Pyramid.
   • On the Draw 3D Solids toolbar, click the Pyramid tool.
   • Type pyramid and then press Enter.

2. Specify the first point for the base of the pyramid.

3. Specify the second, third, and fourth points.

4. In the prompt box, choose Top Surface.

5. Specify the first point on the top surface of the pyramid.

6. Specify the second, third, and fourth points.

To create a pyramid with a planar top as a 3D mesh

1. Do one of the following to choose Pyramid:
   • On the ribbon, choose Draw 3D > Pyramid (in Draw 3D Meshes).
   • On the menu, choose Draw > 3D Meshes > Pyramid.
   • On the Draw 3D Meshes toolbar, click the Pyramid tool.
   • Type ai_pyramid and then press Enter.

2. Specify the first point for the base of the pyramid.

3. Specify the second, third, and fourth points.

4. In the prompt box, choose Top Surface.

5. Specify the first point on the top surface of the pyramid.

6. Specify the second, third, and fourth points.
15.2.13 Creating cylinders

You can create cylinders defined by a circular base. The base of a cylinder is always parallel with the xy plane of the current UCS; the height of a cylinder is always parallel with the z-axis. You position a cylinder by specifying the center of the base. You determine the size of a cylinder by specifying either the radius or diameter of the base and the height.

To create a cylinder as an ACIS solid

1. Do one of the following to choose Cylinder:
   - On the ribbon, choose Draw 3D > Cylinder (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Cylinder.
   - On the Draw 3D Solids toolbar, click the Cylinder tool.
   - Type cylinder and then press Enter.
2. Specify the center of the base of the cylinder.
3. Specify the radius or diameter.
4. Specify the height.
To create a cylinder as a 3D mesh

1. Do one of the following to choose Cylinder:
   - On the ribbon, choose Draw 3D > Cylinder (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Cylinder.
   - On the Draw 3D Meshes toolbar, click the Cylinder tool.
   - Type ai_cylinder and then press Enter.

2. Specify the center of the base of the cylinder.

3. Specify the radius or diameter.

4. Specify the height.

15.2.14 Creating spheres

You can create spheres. The latitude lines of a sphere are always parallel with the xy plane of the current UCS; the central axis is always parallel with the z-axis. You position a sphere by specifying its center point. You determine the size of a sphere by specifying either its radius or its diameter.

To create a sphere as an ACIS solid

1. Do one of the following to choose Sphere:
   - On the ribbon, choose Draw 3D > Sphere (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Sphere.
   - On the Draw 3D Solids toolbar, click the Sphere tool.
   - Type sphere and then press Enter.
2. Specify the center of the sphere.
3. Specify the radius or diameter.

**To create a sphere as a 3D mesh**

1. Do one of the following to choose Sphere:
   - On the ribbon, choose Draw 3D > Sphere (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Sphere.
   - On the Draw 3D Meshes toolbar, click the Sphere tool.
   - Type ai_sphere and then press Enter.
2. Specify the center of the sphere.
3. Specify the radius or diameter.
4. Specify the number of longitudinal sections that are perpendicular to the xy plane.
5. Specify the number of latitudinal sections that are parallel to the xy plane.
15.2.15 Creating dishes

You can create a three-dimensional dish. The latitude lines of a dish are always parallel with the xy plane of the current UCS; the central axis is always parallel with the z-axis. You position a dish by specifying its center point. You determine the size of a dish by specifying either its radius or its diameter.

To create a dish as an ACIS solid

1. Do one of the following to choose Dish:
   - On the ribbon, choose Draw 3D > Dish (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Dish.
   - On the Draw 3D Solids toolbar, click the Dish tool.
   - Type dish and then press Enter.
2. Specify the center of the dish.
3. Specify the radius or diameter.

To create a dish as a 3D mesh

1. Do one of the following to choose Dish:
   - On the ribbon, choose Draw 3D > Dish (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Dish.
   - On the Draw 3D Meshes toolbar, click the Dish tool.
   - Type ai_dish and then press Enter.
2. Specify the center of the dish.
3. Specify the radius or diameter.
15.2.16 Creating domes

You can create a three-dimensional dome. The latitude lines of a dome are always parallel with the xy plane of the current UCS; the central axis is always parallel with the z-axis. You position a dome by specifying its center point. You determine the size of a dome by specifying either its radius or its diameter.

To create a dome as an ACIS solid

1. Do one of the following to choose Dome:
   - On the ribbon, choose Draw 3D > Dome (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Dome.
   - On the Draw 3D Solids toolbar, click the Dome tool.
   - Type dome and then press Enter.
2. Specify the center of the dome.
3. Specify the radius or diameter.

To create a dome as a 3D mesh

1. Do one of the following to choose Dome:
   - On the ribbon, choose Draw 3D > Dome (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Dome.
   - On the Draw 3D Meshes toolbar, click the Dome tool.
   - Type ai_dome and then press Enter.
2. Specify the center of the dome.
3. Specify the radius or diameter.
15.2.17 Creating tori

You can create a three-dimensional donut or ring-shaped entity known as a torus. The diameter of a ring is always parallel with the xy plane of the current UCS. A torus is constructed by revolving a circle about a line drawn in the plane of the circle and parallel with the z-axis of the current UCS. You position a torus by specifying its center point. You determine the size of a torus by specifying its overall diameter or radius and the diameter or radius of the tube (the circle being revolved).

To create a torus as an ACIS solid

1. Do one of the following to choose Torus:
   - On the ribbon, choose Draw 3D > Torus (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Torus.
   - On the Draw 3D Solids toolbar, click the Torus tool.
   - Type torus and then press Enter.
2. Specify the center of the whole torus.
3. Specify the radius or diameter of the whole torus.
4. Specify the radius or diameter of the body of the torus.

To create a torus as a 3D mesh

1. Do one of the following to choose Torus:
   - On the ribbon, choose Draw 3D > Torus (in Draw 3D Meshes).
   - On the menu, choose Draw > 3D Meshes > Torus.
   - On the Draw 3D Meshes toolbar, click the Torus tool.
   - Type ai_torus and then press Enter.
2. Specify the center of the whole torus.
3. Specify the radius or diameter of the whole torus.
4. Specify the radius or diameter of the body of the torus.
5. Specify the number of longitudinal sections that are perpendicular to the xy plane.
6. Specify the number of latitudinal sections that are parallel to the xy plane.
15.2.18 Creating regions

You can convert a closed entity into a two-dimensional region. After you create a region, you can modify it using the various three-dimensional tools. For example, you can create a region from a square, and then extrude the square to create a three-dimensional cube.

You can create regions from closed entities, such as polylines, polygons, circles, ellipses, closed splines, and donuts.

Creating regions typically has no visible effect on a drawing. However, if the original entity had a width or line-weight, that information is lost when you create the region.

To create a region

1. Do one of the following to choose Region:
   - On the ribbon, choose Draw 3D > Region (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Region.
   - On the Draw 3D Solids toolbar, click the Region tool.
   - Type region and then press Enter.

2. Select the entities to create the region.

3. Press Enter.

The command bar displays a message that describes how many regions were created.
15.2.19 Creating extruded solids

You can create three-dimensional solids by extruding closed entities, such as polylines, polygons, circles, ellipses, closed splines, donuts, and regions. You can extrude the entity along a selected path, or you can specify its height and taper angle.

To create an extruded solid

1. Do one of the following to choose Extrude:
   - On the ribbon, choose Draw 3D > Extrude (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Extrude.
   - On the Draw 3D Solids toolbar, click the Extrude tool.
   - Type extrude and then press Enter.
2. Select the entity to extrude.
3. Select the extrusion path, or specify the height.

Select the entity to extrude (A) and the extrusion path (B). The resulting extruded solid.
15.2.20 Creating revolved solids

You can create three-dimensional solids by revolving closed entities, such as polylines, polygons, circles, ellipses, and regions. You can revolve the entity about a defined axis, line, polyline, or two points.

To create a revolved solid

1. Do one of the following to choose Revolve:
   - On the ribbon, choose Draw 3D > Revolve (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Revolve.
   - On the Draw 3D Solids toolbar, click the Revolve tool.
   - Type `revolve` and then press Enter.

2. Select the entity to revolve.

3. Do one of the following to define the axis of revolution:
   - Specify a start point and an end point.
   - Type `o` and press Enter to select an entity that determines the axis.
   - Type `x` and press Enter to select the x-axis.
   - Type `y` and press Enter to select the y-axis.

4. Specify the angle of revolution.
15.2.21 Creating lofted solids and surfaces

Creates a three-dimensional solid or surface between two or more cross sections. Cross sections can be open or closed entities. Open cross sections create three-dimensional surfaces. Closed cross sections create three-dimensional solids or surfaces, depending on the specified mode.

Cross sections can be 2D polylines, lines, arcs, circles, ellipses, elliptical arcs, 2D splines, helices, traces, edges of entities, faces of a solid or surface, points of the first or last cross section, regions, and 2D solids.

Guides can be 2D polylines with a single segment, 3D polylines, lines, arcs, elliptical arcs, 2D and 3D splines, and edges of entities.

Paths can be 2D and 3D polylines, lines, arcs, circles, ellipses, elliptical arcs, 2D and 3D splines, helices, and edges of entities.

To create a lofted solid or surface

1. Do one of the following to choose Loft:
   - On the ribbon, choose Draw 3D > Loft (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Loft.
   - On the Draw 3D Solids toolbar, click the Loft tool.
   - Type loft and then press Enter.

2. Select the cross sections in the order you want them to loft. You must select at least two cross sections.

3. If desired, choose Point to taper the loft entity. Select the taper point on a cross section, then press Enter.

4. If desired, choose Join multiple edges to create a cross section from edges. Select the edges, which must share start and end points, to be considered as a cross section. When done selecting edges, press Enter.

5. If needed, choose Mode to change whether a three-dimensional solid or surface is created, then press enter.

6. Press Enter to continue.

7. Choose one of the following:
   - Guides — Creates the loft entity using guide curves which help shape the entity. Select the guide curves for the loft entity. Guide curves must intersect each cross section and begin and end at the first and last cross section. You can also combine multiple edges to form a guide.
   - Path — Creates the loft entity along a path. Select the path for the lofted entity. The path must intersect the solid or surface on all planes.
• Cross sections only — Creates the loft entity between the cross sections without using guides or paths.
• Settings — Opens the Loft Settings dialog box to specify various settings.

15.2.22 Creating swept solids and surfaces

You can create three-dimensional solids or surfaces by sweeping an entity along a path.

Entities that you can sweep include 2D polylines, lines, arcs, circles, ellipses, elliptical arcs, 2D and 3D splines, 3D solid faces, and 2D solids.

Entities that can be the path include 2D and 3D polylines, lines, arcs, circles, ellipses, elliptical arcs, 2D and 3D splines, helices, and edges of solids, surfaces, or meshes.

To create a swept solid or surface

1. Do one of the following to choose Sweep:
   • On the ribbon, choose Draw 3D > Sweep (in Draw 3D Solids).
   • On the menu, choose Draw > 3D Solids > Sweep.
   • On the Draw 3D Solids toolbar, click the Sweep tool.
   • Type sweep and then press Enter.

2. Select one or more entities to sweep.

You can choose Mode to change whether a three-dimensional solid or surface is created.

3. Select the path.

4. If desired, choose any of the following options:
   • Alignment — Aligns the sweep entity to be perpendicular (normal) to the tangent direction of the sweep path.
   • Base point — Determines the base point of the sweep entity.
   • Scale — Determines the scale factor for the sweep entity. If there are multiple sweep entities, the scale factor is applied to each entity. You can also choose Reference to select reference points in the drawing for scaling.
   • Twist — Determines the degrees in which to rotate the sweep entity along the path. If there are multiple sweep entities, the twist angle is applied to each entity. You can also choose Bank to determine whether the sweep entity being swept rotates along a 3D path such as a 3D polyline, spline, or helix.
15.2.23 Creating polysolids

You can create three-dimensional solids with a rectangular profile from a new polyline that you draw or from an existing line, arc, polyline, or circle.

**To create a polysolid without converting any entities**

1. Do one of the following to choose Polysolid:
   - On the ribbon, choose Draw 3D > Polysolid (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Polysolid.
   - On the Draw 3D Solids toolbar, click the Polysolid tool.
   - Type polysolid and then press Enter.

2. Select the start point of the polysolid.

3. Continue selecting points. You can choose Arc to create an arc segment. You can also choose Undo to erase the previous point.

4. Choose Height and specify the height of the polysolid. The default height is specified by the PSOLHEIGHT system variable.

5. Choose width and specify the width of the polysolid. The default height is specified by the PSOLWIDTH system variable.

6. Choose Justify to specify whether the width and height should be justified to the left, center, or right. Justification orientation is determined according to the direction of the first profile segment.

**To create a polysolid from an existing entity**

1. Do one of the following to choose Polysolid:
   - On the ribbon, choose Draw 3D > Polysolid (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Polysolid.
   - On the Draw 3D Solids toolbar, click the Polysolid tool.
   - Type polysolid and then press Enter.

2. Choose Entity, then press Enter.

3. Select the entity you want to convert to a polysolid. You can select a line, arc, polyline, or circle.

4. Choose Height and specify the height of the polysolid. The default height is specified by the PSOLHEIGHT system variable.
5. Choose width and specify the width of the polysolid. The default height is specified by the PSOLWIDTH system variable.

6. Choose Justify to specify whether the width and height should be justified to the left, center, or right. Justification is determined according to the direction of the first profile segment.

15.2.24 Creating composite solids

You can create composite three-dimensional solids by combining, subtracting, and finding the intersection of two or more solids.

To combine solids

1. Do one of the following to choose Union

   • On the ribbon, choose Draw 3D > Union (in Solids Editing).
   • On the menu, choose Modify > Solids Editing > Union.
   • On the Solids Editing toolbar, click the Union tool.
   • Type union and then press Enter.

2. Select the entities to combine.
To subtract solids

1. Do one of the following to choose Subtract:
   - On the ribbon, choose Draw 3D > Subtract (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Subtract.
   - On the Solids Editing toolbar, click the Subtract tool.
   - Type subtract and then press Enter.
2. Select the entities to subtract from one another.

![Diagram of solids before and after subtraction](image)

To intersect solids

1. Do one of the following to choose Intersect:
   - On the menu, choose Modify > Solids Editing > Intersect.
   - On the Solids Editing toolbar, click the Intersect tool.
   - Type intersect and then press Enter.
2. Select the entities to intersect.

![Diagram of solids before and after intersection](image)
15.3 Editing in three dimensions

You can copy, move, rotate, array, mirror, and align two-dimensional and three-dimensional entities in both two-dimensional and three-dimensional space. You can also change and edit properties of three-dimensional entities much like you change and edit properties for two-dimensional entities. When you modify three-dimensional entities in two-dimensional space, you modify the entity in relation to the current UCS.

15.3.1 Rotating in three dimensions

You can rotate selected entities about a specified axis in three-dimensional space. You select the entities to rotate and then define the axis of rotation either by specifying two points; selecting an existing entity; aligning the axis with the x-, y-, or z-axis of the current UCS; or aligning the axis with the current view.

To rotate an entity about an axis in three dimensions

1. Do one of the following to choose 3D Rotate:
   - On the ribbon, choose Edit > 3D Rotate (in Modify).
   - On the menu, choose Modify > 3D Rotate.
   - On the Modify toolbar, click the 3D Rotate tool.
   - Type rotate3D and then press Enter.
2. Select the entities to rotate, and then press Enter.
3. Choose from one of the following options: Entity, Last, View, Xaxis, Yaxis, Zaxis.
4. Specify the rotation angle.
5. Specify the reference angle.
15.3.2 Arraying in three dimensions

You can copy selected entities and arrange them in a three-dimensional rectangular or polar (circular) pattern. For a rectangular array, you control the number of copies in the array by specifying the number of rows and columns and the number of levels. You also specify the distance between each. For a polar array, you specify the axis around which to array the entities, the number of copies of the entities to create, and the angle subtended by the resulting array.

To create a three-dimensional rectangular array

1. Do one of the following to choose 3D Array:
   • On the ribbon, choose Edit > 3D Array (in Modify).
   • On the menu, choose Modify > 3D Array.
   • On the Modify toolbar, click the 3D Array tool.
   • Type 3Darray and then press Enter.
2. Select the entities, and then press Enter.
3. In the prompt box, choose Rectangular.
4. Type the number of rows in the array.
5. Type the number of columns.
6. Type the number of levels.
7. Specify the vertical distance between the rows.
8. Specify the horizontal distance between the columns.
9. Specify the depth between the levels.
To create a three-dimensional polar array

1. Do one of the following to choose 3D Array:
   - On the ribbon, choose Edit > 3D Array (in Modify).
   - On the menu, choose Modify > 3D Array.
   - On the Modify toolbar, click the 3D Array tool.
   - Type 3Darray and then press Enter.

2. Select the entities, and then press Enter.

3. In the prompt box, choose Polar.

4. Type the number of copies to make, including the original selection set.

5. Specify the angle the array is to fill, from 0 to 360 degrees.

   The default setting for the angle is 360 degrees. Positive values create the array in a counterclockwise direction; negative values create the array in a clockwise direction.

6. In the prompt box, choose one of the following:
   - Yes-Rotate Entities to rotate entities as they are arrayed.
   - No-Do Not Rotate to retain the original orientation of each copy as it is arrayed.

7. Specify the center point of the array.

8. Specify a second point along the central axis of the array.
15.3.3 Mirroring in three dimensions

You can create a mirror image of selected entities in three-dimensional space. You mirror the entities about a mirror plane that you define by either specifying three points; selecting an existing two-dimensional planar entity; aligning the plane parallel with the xy, yz, or xz plane of the current UCS; or aligning the plane with the current view. You can delete or retain the original entities.

To mirror an entity about a three-dimensional plane

1. Do one of the following to choose 3D Mirror:
   - On the ribbon, choose Edit > 3D Mirror (in Modify).
   - On the menu, choose Modify > 3D Mirror.
   - On the Modify toolbar, click the 3D Mirror tool.
   - Type mirror3D and then press Enter.
2. Select the entities, and then press Enter.
3. In the prompt box, choose 3 Points, or press Enter to select the default.
4. Specify the first point on the mirror plane.
5. Specify the second and third points on the plane.
6. In the prompt box, choose one of the following:
   - Yes-Delete Entities to delete the original entities.
   - No-Keep Entities to retain the original entities.

Select the entity to mirror (A), and then specify the first point (B), second point (C), and third point (D) defining the mirror plane.
15.3.4 Aligning in three dimensions

You can align one or more selected entities with other entities in three-dimensional space. First you select the entities you want to move and align, then you specify pairs of points to move and align the selected entities:

- One pair of points — Moves selected entities.
- Two pairs of points — Moves then rotates selected entities. The second pair of points can also determine the scale of moved entities (scaling is available only when using two pairs of points).
- Three pairs of points — Moves, rotates, then again rotates selected entities.

To align entities by moving them

1. Do one of the following to choose Align:
   - On the ribbon, choose Edit > Align (in Modify).
   - On the menu, choose Modify > Align.
   - On the Modify toolbar, click the Align tool.
   - Type align and then press Enter.

2. Select the entities that will be moved, and then press Enter. Do not include destination entities in the selection set.

3. Specify the first source point.

4. Specify the first destination point, then press Enter.
To align entities by moving and rotating them

1. Do one of the following to choose Align:
   - On the ribbon, choose Edit > Align (in Modify).
   - On the menu, choose Modify > Align.
   - On the Modify toolbar, click the Align tool.
   - Type align and then press Enter.

2. Select the entities that will be moved and rotated, and then press Enter. Do not include destination entities in the selection set.

3. Specify the first source point then the first destination point.

4. Specify the second source point then the second destination point, then press Enter.

5. If desired, choose Yes to scale the moved entities. Otherwise, choose No. If scaling, the selected entities scale proportionately so that the distance between the two source points is the same as the distance between the two destination points.

The scaling option is available only when selecting two pairs of points.
To align entities by moving and then rotating them twice

1. Do one of the following to choose Align:
   • On the ribbon, choose Edit > Align (in Modify).
   • On the menu, choose Modify > Align.
   • On the Modify toolbar, click the Align tool.
   • Type align and then press Enter.

2. Select the entities that will be moved and rotated, and then press Enter. Do not include destination entities in the selection set.

3. Specify the first source point then the first destination point.

4. Specify the second source point then the second destination point.

5. Specify the third source point then the third destination point, then press Enter.
15.4 Editing three-dimensional solids

You can edit three-dimensional solids in several unique ways, including: chamfer, fillet, section, and slice. You can also modify individual faces and edges of solids, as well as imprint, separate, shell, and check solids.

You can edit three-dimensional ACIS solids, including: boxes, cones, cylinders, dishes, domes, pyramids, spheres, tori, and wedges.

15.4.1 Chamfering and filleting solids

You can chamfer or fillet a three-dimensional solid much like you chamfer or fillet a two-dimensional entity.

To chamfer a solid

1. Do one of the following to choose Chamfer:
   - On the ribbon, choose Edit > Chamfer (in Modify).
   - On the menu, choose Modify > Chamfer.
   - On the Modify toolbar, click the Chamfer tool.
   - Type chamfer and then press Enter.

2. Select the edge of the base surface to chamfer. (One of two surfaces adjacent to the selected edge will be highlighted.)

3. Do one of the following:
   - To select a different surface, type n and press Enter.
   - To use the current surface, press Enter.

4. Specify the base surface distance (measured from the selected edge to the base surface).

5. Specify the adjacent surface distance (measured from the selected edge to the adjacent surface).

6. Do one of the following:
   - Specify the edges to chamfer.
   - To select all edges around the base surface, type l and press Enter.
To fillet a solid

1. Do one of the following to choose Fillet:
   - On the ribbon, choose Edit > Fillet (in Modify).
   - On the menu, choose Modify > Fillet.
   - On the Modify toolbar, click the Fillet tool.
   - Type fillet and then press Enter.

2. Select the edge of the solid to fillet.

3. Specify the fillet radius.

4. Select additional edges to fillet, and press Enter to fillet.

15.4.2 Sectioning and slicing solids

You can section or slice a three-dimensional solid, region, or body (typically a sheet).

When you section a solid, you obtain an “inside view” by creating a cross-section through the solid as a region or block. When you section a region or body, the resulting intersections are curves.

When you slice a solid, region, or body, you create a new entity by cutting the original entity and removing a specific side.

To section an entity

1. Do one of the following to choose Section:
   - On the ribbon, choose Draw 3D > Section (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Section.
   - On the Draw 3D Solids toolbar, click the Section tool.
   - Type section and then press Enter.

2. Select the entities to cross-section.

3. Do one of the following:
   - Specify three points to define the cross-section plane. (The first point defines the origin, while the second point defines the x-axis and the third point defines the y-axis.)
   - Type o and press Enter to select an entity that defines the cross-sectional plane.
   - Specify an axis by typing the appropriate letter and pressing Enter.
To slice an entity

1. Do one of the following to choose Slice:
   - On the ribbon, choose Draw 3D > Slice (in Draw 3D Solids).
   - On the menu, choose Draw > 3D Solids > Slice.
   - On the Draw 3D Solids toolbar, click the Slice tool.
   - Type slice and then press Enter.

2. Select the entities to slice.

3. Do one of the following:
   - Specify three points to define the cross-section plane. (The first point defines the origin, while the second point defines the x-axis and the third point defines the y-axis.)
   - Type o and press Enter to select an entity that defines the cross-sectional plane.
   - Specify an axis by typing the appropriate letter and pressing Enter.

4. Specify which side to retain, or type b to retain both sides.

15.4.3 Modifying faces

You can edit three-dimension solids by extruding, moving, rotating, offsetting, tapering, deleting, or copying individual faces. You can also change the color of individual faces.

Extruding solid faces

To extrude a solid face

1. Do one of the following to choose Extrude Face:
   - On the ribbon, choose Draw 3D > Extrude Face (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Extrude Face.
   - On the Solids Editing toolbar, click the Extrude Face tool.

2. Select the entity with the face you want to extrude.

3. Select the face(s) to extrude, and press Enter.

4. Do one of the following:
   - Specify the height of extrusion.
   - Type p and press Enter to select a path for extrusion.
5. If you specified a height, specify a taper angle.

Moving solid faces

1. Do one of the following to choose Move Face:
   • On the ribbon, choose Draw 3D > Move Face (in Solids Editing).
   • On the menu, choose Modify > Solids Editing > Move Face.
   • On the Solids Editing toolbar, click the Move Face tool.
2. Select the entity with the face you want to move.
3. Select the face(s) to move, and press Enter.
4. Specify a base point.
5. Specify an end point.
**Rotating solid faces**

**To rotate a solid face**

1. Do one of the following to choose Rotate Face:
   - On the ribbon, choose Draw 3D > Rotate Face (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Rotate Face.
   - On the Solids Editing toolbar, click the Rotate Face tool.

2. Select the entity with the face you want to rotate.

3. Select the face(s) to rotate, and press Enter.

4. Specify a base point.

5. Specify another point on the rotation axis.

6. Specify the rotation angle.

---

**Offsetting solid faces**

**To offset a solid face**

1. Do one of the following to choose Offset Face:
   - On the ribbon, choose Draw 3D > Offset Face (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Offset Face.
   - On the Solids Editing toolbar, click the Offset Face tool.
2. Select the entity with the face you want to offset.
3. Select the face(s) to offset, and press Enter.
4. Specify an offset distance.

![Tapering solid faces](image)

*Tapering solid faces*

**To taper a solid face**

1. Do one of the following to choose Taper Face:
   - On the menu, choose Modify > Solids Editing > Taper Faces.
   - On the Solids Editing toolbar, click the Taper Face tool.
2. Select the entity with the face you want to taper.
3. Select the face(s) to taper, and press Enter.
4. Specify a base point.
5. Specify another point along the axis.
6. Specify a taper angle.
Deleting solid faces

To delete a solid face

1. Do one of the following to choose Delete Face:
   - On the ribbon, choose Draw 3D > Delete Face (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Delete Face.
   - On the Solids Editing toolbar, click the Delete Face tool.
2. Select the entity with the face you want to delete.
3. Select the face(s) to delete, and press Enter.
Copying solid faces

To copy a solid face

1. Do one of the following to choose Copy Face:
   - On the ribbon, choose Draw 3D > Copy Face (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Copy Face.
   - On the Solids Editing toolbar, click the Copy Face tool.
2. Select the entity with the face you want to copy.
3. Select the face(s) to copy, and press Enter.
4. Specify a base point.
5. Specify an end point.

Coloring solid faces

To color a face

1. Do one of the following to choose Color Face:
   - On the ribbon, choose Draw 3D > Color Face (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Color Face.
   - On the Solids Editing toolbar, click the Color Face tool.
2. Select the entity with the face you want to color.
3. Select the face(s) to color, and press Enter.
4. Specify a color.

![Select the entity, and then specify the face(s) to color (A). The resulting entity with the face colored.]

**15.4.4 Modifying edges**

In addition to modifying faces of solids, you can modify individual edges. You can copy individual edges or change the color of individual edges.

**To copy an edge**

1. Do one of the following to choose Copy Edge:
   - On the ribbon, choose Draw 3D > Copy Edge (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Copy Edge.
   - On the Solids Editing toolbar, click the Copy Edge tool.
2. Select the entity with the edge you want to copy.
3. Select the edge(s) to copy, and press Enter.
4. Specify a base point.
5. Specify an end point.
To color an edge

1. Do one of the following to choose Color Edge:
   - On the menu, choose Modify > Solids Editing > Color Edge.
   - On the Solids Editing toolbar, click the Color Edge tool.
2. Select the entity with the edge you want to color.
3. Select the edge(s) to color, and press Enter.
4. Specify a color.
15.4.5 Imprinting solids

You can modify the face of a solid by imprinting another entity on it. For example, you can imprint a line, arc, or polyline onto the face of a box.

To imprint a solid entity

1. Do one of the following to choose Imprint:
   - On the menu, choose Modify > Solids Editing > Imprint.
   - On the Solids Editing toolbar, click the Imprint tool.
2. Select the solid entity you want to imprint.
3. Select the entity you want to imprint on the solid.

15.4.6 Separating solids

You can separate solids that have been combined. After you separate them, they are separated into individual solids.

To separate solids

1. Do one of the following to choose Separate:
   - On the ribbon, choose Draw 3D > Separate (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Separate.
   - On the Solids Editing toolbar, click the Separate tool.
2. Select the solid you want to separate.
15.4.7 Shelling solids

You can create a shell or a hollow thin wall from your 3D solid entity. CAD.direct Drafter offsets existing faces to create new faces.

To shell a solid

1. Do one of the following to choose Shell:
   - On the ribbon, choose Draw 3D > Shell (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Shell.
   - On the Solids Editing toolbar, click the Shell tool.
2. Select the entity you want to shell.
3. Remove any faces you don’t want to include.
4. Specify an offset distance.
15.4.8 Cleaning solids
You can remove redundant edges or vertices from solids when they are not needed.

To clean a solid
1. Do one of the following to choose Clean:
   - On the ribbon, choose Draw 3D > Clean (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Clean.
   - On the Solids Editing toolbar, click the Clean tool.
2. Select the entity you want to clean.

15.4.9 Checking solids
You can check whether a selected entity is a valid three-dimensional ACIS solid. If it is a valid 3D solid, you can modify the entity using the 3D solid editing commands; if not, you cannot edit the entity using these commands.

To check a solid
1. Do one of the following to choose Check:
   - On the ribbon, choose Draw 3D > Check (in Solids Editing).
   - On the menu, choose Modify > Solids Editing > Check.
   - On the Solids Editing toolbar, click the Check tool.
2. Select the entities to check.

15.4.10 Converting solids to polyface meshes
You can convert three-dimensional solids to polyface meshes using the 3DConvert command.

To convert a solid
1. Type 3dconvert and press Enter.
2. Select the entities you want to convert.
15.5 Hiding, shading, and rendering

As you create three-dimensional entities, the program displays both wire-frame and surface models in wire-frame view, which makes it difficult to visualize your three-dimensional models. To better visualize the model, you can remove all the lines that are hidden behind other entities or surfaces when seen from the current viewpoint.

Shading goes a step further by removing hidden lines and then assigning flat colors to the visible surfaces, making them appear solid. Shaded images are useful when you want to quickly visualize your model as a solid entity, though they lack depth and definition.

Rendering provides an even more realistic image of your model, complete with light sources, shadows, surface material properties, and reflections, giving your model a photo-realistic look. As shown in the following illustrations, when you render a model, the program removes hidden lines and then shades the surfaces as though they were illuminated from imaginary light sources.

15.5.1 Creating hidden-line images

Creating a hidden-line view of your drawing removes all the lines that are hidden behind other surfaces when seen from your vantage point. When you remove hidden lines or shade a model, the program treats the entities differently, depending on how you created them. Wire-frame models always appear transparent, because they have no surfaces. Surface models appear filled, with surfaces applied to all visible sides.
To create a hidden-line image

- Type hide and then press Enter.

Use a visual style.

*Choosing View > Visual Styles > 3D Hidden is similar to using the Hide command. For more details, see “Displaying a drawing with a visual style” on page 170.*

---

15.5.2 Creating shaded images

Creating a shaded image of your drawing removes hidden lines and then applies shading to the visible surfaces based on their entity color. Because they are intended to provide a quick visualization, shaded images do not have a light source and use continuous colors across surfaces, causing them to appear flat and unrealistic.

To create a shaded image

- Type shade and then press Enter. To control the appearance of the shaded image, choose Tools > Drawing Settings, and then click the 3D Settings tab and select the options you want. You can shade the surfaces and edges of the model in four ways:
  - Faces shaded; edges not highlighted.
  - Faces shaded; edges highlighted in the background color.
  - Faces filled in the background color; edges drawn using the entity color (similar to a hidden-line view).
  - Faces filled using the entity color; edges highlighted in the background color.

Use a visual style.

*Choosing View > Visual Styles > 3D Realistic is similar to using the Shade command. For more details, see “Displaying a drawing with a visual style” on page 170.*
15.5.3 Creating rendered images

Creating a rendered image of your drawing removes hidden lines and then shades the surface as though it were illuminated from multiple light sources.

Full rendering creates a photo-realistic image of your model, complete with light sources, shadows, surface material properties, and reflections. You can illuminate your image with spotlights, distant lighting to simulate sunshine, and ambient light. If you choose not to customize the light sources, the program generates default light sources for you.

Rays from these imaginary light sources are traced as they reflect off and refract through the surfaces of the model, a process called ray tracing. Ray tracing determines where shadows fall and how reflections on shiny materials such as metal and glass appear. You can modify the reflective properties of the materials that make up your model to control how the light rays reflect off its surfaces.

Full rendering automatically creates a base on which your model is displayed, if you don’t already have one, so it does not appear suspended in space. A background is also automatically added to the image. A background such as a cloudy sky or an imported raster graphic such as a stone wall can also be added behind the image, making it even more realistic.

To create a quickly rendered image

Do one of the following to choose Render:

- On the ribbon, choose View > Render Settings (in Rendering).
- On the menu, choose View > Rendering > Render.
- On the Rendering toolbar, click the Render tool.
- Type render and then press Enter.

To create a fully rendered image

Do one of the following to choose Full Render:

- On the ribbon, choose View > Render Settings (in Rendering).
- On the menu, choose View > Rendering > Full Render.
- On the Rendering toolbar, click the Full Render tool.
- Type fullrender and then press Enter.
15.5.4 Creating custom rendered images

CAD.direct Drafter allows you to create custom rendered images by applying materials, backgrounds, and lighting (including shadows) to your drawing:

- **Materials** Specify materials for different surfaces and define how the materials map to those surfaces. Predefined materials are available in the materials library, which can be customized further using the built-in editor. You can choose to use procedural or bitmap materials.

- **Backgrounds** Specify the background or backdrop for a rendered image. Several predefined backgrounds are available. By default, no background is used, and it appears black. The background is an infinite, planar surface and reflects off of any reflective surfaces in your model. The background is not affected by lighting how-ever, so no shadows or highlights are seen on the background.

- **Lighting** Specify the placement of lights, light color, and light intensity to deter-mine how your drawing or scene is lit, including shadows and reflections in the scene. Lights can be placed either outside the field of view or inside to illuminate different areas of the scene. Several predefined lighting controls are available, including ambient lighting, diffuse lighting, specular reflections, specular high-lights, and transparency.
To apply materials, backgrounds, and lighting

1. Do one of the following to choose Materials, Backgrounds, or Lighting:
   - On the ribbon, choose View > Materials, Backgrounds, or Lighting (in Rendering).
   - On the menu, choose View > Rendering, and then choose Materials, Backgrounds, or Lighting.
   - On the Rendering toolbar, click the Materials, Backgrounds, or Lighting tool.
   - Type materials, backgrounds, or lighting and then press Enter.

2. Make your selections.

You can specify additional rendering options.

Choose View > Rendering > Render Settings. For more information about creating custom rendered images, click Help in any of the Render dialog boxes.

15.5.5 Printing a rendered image

You cannot print a rendered image directly to a printer. Instead, you must first save the drawing to a different format — either a bitmap (.bmp), JPEG (.jpg), TIFF (.tif), TrueVision TGA (.tga), or Portable Network Graphic (.png). After you save a rendered image, you can print it from another graphics program.

To save a rendered image of your drawing

1. Create a rendered image of the drawing.

2. Do one of the following to choose Render Settings:
   - On the ribbon, choose View > Render Settings (in Rendering).
   - On the menu, choose View > Rendering > Render Settings.
   - On the Rendering toolbar, click the Render Settings tool.
   - Type setrender and then press Enter.

3. On the Rendering tab, click Save Last Image.

4. Enter a file name and path.

5. In Save As Type, choose the file format.

6. Click Save.
15.5.6 Rendering in Artisan Renderer

Similar to the Full Render command in CAD.direct Drafter, Artisan Renderer allows you to create a photorealistic image of your model. However, many users prefer using Artisan Renderer to speed up the design process with access to a wide range of pre-set materials and lighting setups, along with the ability to create custom realistic materials.

Creating a rendered image with Artisan Renderer

To create a rendered image in Artisan Renderer

1. Save the drawing.

2. Do one of the following to choose Artisan Render:
   - On the ribbon, choose View > Artisan (in Rendering).
   - On the menu, choose View > Rendering > Artisan.
   - On the Artisan Rendering toolbar, click the Artisan tool.
   - Type artisan and then press Enter.

3. If the Artisan Settings dialog box displays, choose from the following options:
   - Units Select the units.
   - Language Select the language. To use the operating system language, choose Use System Locale.
   - Facet resolution Set the resolution of shaded three-dimensional entities and faces when exporting to Artisan Renderer.
   - Smoothing angle Set the angle of smoothing applied to crease edges when exporting to Artisan Renderer.
   - Show on Startup Choose to display the Artisan Settings dialog each time you use the Artisan or Artisan Sync command in CAD.direct Drafter.

4. Click OK.

Artisan Renderer opens and displays your model for you to add materials and other effects. For more details about using Artisan Renderer, choose Help > Help in Artisan Renderer.
To synchronize your latest model with Artisan Renderer

1. Save the drawing.

2. Do one of the following to choose Artisan Sync:
   - On the ribbon, choose View > Artisan Sync (in Rendering).
   - On the menu, choose View > Rendering > Artisan Sync.
   - On the Artisan Rendering toolbar, click the Artisan Sync tool.
   - Type artisan-sync and then press Enter.

Artisan Renderer is updated with the latest model from CADconv Connect, which is helpful if you’re working in CAD.direct Drafter and Artisan Renderer at the same time and you change the model in CAD.direct Drafter.

Working with lights for Artisan Renderer

In Artisan Renderer, you can select from several interior and exterior lighting scenes to create your rendering quickly. For more details about lighting in Artisan Renderer, choose Help > Help in Artisan Renderer.

If you want individual lights that will create a specific lighting scene, you can create specific lights in CAD.direct Drafter to light the model in Artisan Renderer. There are two types of lights that you can create in CAD.direct Drafter:

   - Point light A point light shines light from its location in all directions when the drawing is rendered.
   - Spot light A spot light shines light in the shape of a cone from its location towards the direction you specify when the drawing is rendered.

These lights can be used with Artisan Renderer and other third-party CAD programs. These point lights and spot lights do not work with IntelliCAD’s Full Render command.

To create a point light

1. Do one of the following to choose Point Light:
   - On the ribbon, choose View > Point Light (in Rendering).
   - On the menu, choose View > Rendering > Point Light.
   - On the Artisan Rendering toolbar, click the Point Light tool.
   - Type pointlight and then press Enter.

2. Enter the x-, y-, and z-coordinates of where to place the point light, or click the location in the drawing.
To create a spot light for Artisan Renderer

1. Do one of the following to choose Spot Light:
   
   • On the ribbon, choose View > Spot Light (in Rendering).
   • On the menu, choose View > Rendering > Spot Light.
   • On the Artisan Rendering toolbar, click the Spot Light tool.
   • Type spotlight and then press Enter.

2. Enter the x-, y-, and z-coordinates of where to place the spot light, or click the location in the drawing.

3. Then enter the x-, y-, and z-coordinates of the location you want to shine light, or click the location in the drawing.

Edit point lights and spot lights.

You can move and copy point lights and spot lights in your drawing, just as you would any other entity. To specify settings for the point or spot light, such as shadows and attenuation, right-click the point light, choose Properties, and make your selections in the Properties pane.
16 Working with other programs

CAD.direct Drafter offers great flexibility in its capability to be used with other programs. You can include an CAD.direct Drafter drawing in a Microsoft® Word document or insert a Microsoft® Excel spreadsheet containing a parts list into an CAD.direct Drafter drawing. To include CAD.direct Drafter drawings in other programs and documents from other programs in CAD.direct Drafter drawings, you either link or embed them. You can also save CAD.direct Drafter drawings in other file formats that can be used directly with other programs or send CAD.direct Drafter drawings to coworkers via e-mail.

This section explains how to:

- Save and view snapshots.
- Use object linking and embedding.
- Export CAD.direct Drafter drawings to other file formats.
- Convert one or more drawings to other file formats.
- Send drawing files via e-mail.
- Use CAD.direct Drafter with the Internet.

16.1 Saving and viewing snapshots

You can save snapshots of a drawing to view later. A snapshot saves the current drawing in either *.emf, *.wmf, or *.sld format exactly as it appears on the screen. A snapshot is not a drawing file. You cannot edit or print the snapshot; you can only view it.

You can use snapshots in the following ways:

- Make presentations by showing snapshots of your drawings.
- Reference a snapshot of a drawing while working on a different drawing.
- Present a number of snapshots as a slide show by using scripts.

When you view a snapshot, it temporarily replaces the current drawing. When you refresh the display of the current drawing (by redrawing, panning, zooming, minimizing, maximizing, or tiling), the snapshot image disappears, and you are returned to the current drawing.

16.1.1 Creating snapshots

You create a snapshot by saving the current view as a snapshot. A snapshot does not include any entities on layers that are not currently visible. The contents of the snapshot also depend on the current drawing space. In model space, the snapshot shows only the current viewport. In paper space, the snapshot contains all visible viewports.
**To create a snapshot**

1. Display the drawing exactly as you want to capture it as a snapshot.

2. Do one of the following to choose Make Snapshot:
   - On the ribbon, choose Tools > Make Snapshot (in Manage).
   - On the menu, choose Tools > Make Snapshot.
   - On the Tools toolbar, click the Make Snapshot tool.
   - Type msnapshot and then press Enter.

3. In the Create Snapshot dialog box, specify the name of the snapshot file you want to create.

4. From the Files Of Types list, choose either *.emf, *.wmf, or *.sld.

5. Click Save.

The current drawing remains on the screen, and the snapshot is saved to the directory that you specify.

**16.1.2 Viewing snapshots**

You can view previously saved snapshots, and you can also view snapshots created using AutoCAD.

**To view a snapshot**

1. Do one of the following:
   - On the ribbon, choose Tools > View Snapshot (in Manage).
   - Choose Tools > View Snapshot.
   - On the Tools toolbar, click the View Snapshot tool.
   - Type vsnapshot and then press Enter.

2. In the View Snapshot dialog box, specify the name of the snapshot file you want to view.

3. Click Open.

CAD.direct Drafter displays the snapshot in the current drawing window.
16.2 Using data from other programs in CAD.direct Drafter drawings

You can include data from other programs in CAD.direct Drafter drawings by using either embedding or linking. The method you choose depends on the type of object or file you want to include in your CAD.direct Drafter drawing and what you want to do with it after it is there.

16.2.1 Embedding objects into drawings

Embed an object into your CAD.direct Drafter drawing when you want to keep all the data you work with in one file or if you want to transfer the file to other computers. You can embed data from programs that support object linking and embedding.

For example, if you want to distribute data about a department’s computer equipment along with a CAD.direct Drafter drawing of the department’s floor plan, you can embed a Microsoft® Excel spreadsheet into the floor plan.

When you embed data from another program, CAD.direct Drafter becomes the container for that data. The object embedded in the CAD.direct Drafter drawing becomes part of the CAD.direct Drafter file. When you edit the data, you open its program from within the CAD.direct Drafter drawing.

Any changes you make to the embedded data exist only in the CAD.direct Drafter drawing, so it is not necessary to keep that data in a separate file. If the data does exist in a separate file, the original file does not change when you modify the embedded object in CAD.direct Drafter. Also, changes to the original file do not affect the embedded object in the CAD.direct Drafter drawing.

To embed another program’s object into an CAD.direct Drafter drawing

1. Open the file that contains the data you want.

2. In the file, select the data you want to embed in the CAD.direct Drafter drawing.

3. Choose that program’s command to place data on the Clipboard.

Usually, you choose Edit > Copy.

4. In the CAD.direct Drafter window, display the drawing in which you want to embed the object.

5. Do one of the following to choose Paste:
   - On the ribbon, choose Home > Paste (in Clipboard) or choose Edit > Paste (in Modify)
   - On the menu, choose Edit > Paste.
   - On the Standard toolbar, click the Paste tool.
   - Type paste and then press Enter.
The data on the Clipboard is pasted into the drawing as an embedded object. The object appears in the center of the view, but you can select and move it by moving the cursor.

**To embed an object from an existing file within CAD.direct Drafter**

1. Do one of the following:
   - On the ribbon, choose Insert > Object (in Data).
   - On the menu, choose Insert > Object.
   - Type insertobj and then press Enter.
2. In the Insert Object dialog box, click Create From File.
3. Specify the file by doing one of the following:
   - Type a path and file name in the File box.
   - Click Browse to select a file.
4. Select Display As Icon if you want that program’s icon to appear in the drawing instead of the data.
5. Click OK.

The first page of the file appears in the CAD.direct Drafter drawing, unless you chose to display it as an icon. You can select the object and drag to reposition it.

**To create a new embedded object from within CAD.direct Drafter**

1. Do one of the following:
   - On the ribbon, choose Insert > Object (in Data).
   - On the menu, choose Insert > Object.
   - Type insertobj and then press Enter.
2. In the Insert Object dialog box, click Create New.
3. From the Object Type list, select the type of object you want to create, and then click OK.

The program for creating that object opens within CAD.direct Drafter. If the program is compatible with ActiveX, it opens in place (within the other program) in the CAD.direct Drafter drawing; otherwise, the program opens in its full window.

4. Create the object in the other program.
5. If the program is running within the other document (in place), click anywhere outside the embedded object to close the program.

If the program is running in its full window, choose File > Exit.

16.2.2 Linking objects to drawings

If another program supports ActiveX, you can link its data to CAD.direct Drafter drawings. Use linking when you want to include the same data in many files. When you update the data, all links to other files reflect the changes.

For example, if you created your company logo in an ActiveX-compatible drawing program, and you want to include it in the title block of every drawing you create with CAD.direct Drafter, you can link it to each CAD.direct Drafter drawing. When you change the original logo in the drawing program, the CAD.direct Drafter drawing updates automatically.

When you link data from another program, the CAD.direct Drafter drawing stores only a reference to the location of the file in which you created the data. You link data from a saved file, so CAD.direct Drafter can find the data and display it.

Because linking adds only a reference to a file, the data does not significantly increase the file size of the CAD.direct Drafter drawing. However, links require some maintenance. If you move any of the linked files, you need to update the links. In addition, if you want to transport linked data, you must include all linked files.

You can update a linked object automatically every time you open the drawing, or you can do so only when you specify. Anytime a link is updated, changes made to the object in its original file also appear in the CAD.direct Drafter drawing, and the changes also appear in the original file if they were made through CAD.direct Drafter.

**To link a file to an CAD.direct Drafter drawing**

1. Save the original file.

   Because a link consists of a reference to the original file, you must save the file before you can link to it.

2. In the original file, select the data you want in the CAD.direct Drafter drawing.

3. Choose that program’s command to place data on the Clipboard.

   Usually, you choose Edit > Copy.

4. Display the CAD.direct Drafter drawing to which you want to link the file.

5. In CAD.direct Drafter, choose Edit > Paste Special.
6. In the Paste Special dialog box, select Paste Link.
7. Click OK.

**To create a linked object from within CAD.direct Drafter**

1. Display the CAD.direct Drafter drawing in which you want to display the linked object.
2. Do one of the following:
   - On the ribbon, choose Insert > Object (in Data).
   - On the menu, choose Insert > Object
   - Type insertobj and then press Enter.
3. In the Insert Object dialog box, click Create From File.
4. Specify the file by doing one of the following:
   - Type a path and file name in the File box.
   - Click Browse to select the file using a file dialog box.
5. Select the Link check box.
6. Select Display As Icon if you want that program’s icon to appear in the drawing instead of the data.
7. Click OK.

The first page appears in the CAD.direct Drafter drawing, unless you chose to display it as an icon. To reposition the object, select and drag it.

**16.3 Editing an embedded or linked object from within CAD.direct Drafter**

You can modify an embedded or linked object in its original program from within CADconv Connect. When you modify an embedded object, you change the object only in CAD.direct Drafter, not its original file (if you pasted the object from an existing file). When you modify a linked file, however, you open and change the original file.

Most programs include a submenu of actions you can perform on an embedded or linked ActiveX object. Usually, the commands for editing ActiveX objects are Edit and Open. If the object is embedded and its program supports in-place editing, the Edit command opens the object in place. The Open command opens the object in the full program window. In CAD.direct Drafter, this command appears at the bottom of the Edit menu.
To edit an embedded or linked object

- In the CAD.direct Drafter drawing, double-click the object

If the object is embedded and the program in which you created the object supports in-place editing, the object opens in place.

If the object is linked, or if its program does not support in-place editing, the other program opens in its full window and displays the object.

16.3.1 Importing files created in other formats

You can import files that have the following formats:

- Autodesk DXFä format — Autodesk Drawing Exchange Format is an ASCII description of a drawing file with a .dxr file extension.
- Autodesk DXBä format — Autodesk Drawing Exchange Format is a binary description of a drawing file with a .dxb file extension.
- Autodesk DWFä format — Autodesk Design Web Formatä (used with .dwf files) is used to distribute a drawing for others to view in a Web browser, review, and edit using free Autodesk® software and tools. The DWF format uses the .dwf file extension.
- DWT format — Drawing templates contain predefined settings that you can reuse when you create new drawings. Drawing templates use the .dwt file extension.
- DGN format — Drawing files used with Bentleyâ Microstationâ. The DGN format uses the .dgn file extension.
- Spatial Technologies ACIS format — Three-dimensional ACIS solids saved as an .sat file.
- DAE format — Collada files are an interactive three-dimensional graphics file format used by 3D graphics applications (three-dimensional entities are exported, including ACIS entities). Collada files use the .dae file extension.

Importing a DXF, DWF, DWT, DGN, or DAE format file

*Importing .dxr files, two-dimensional .dwf files, .dwt, .dae, and .dgn files is similar to opening a standard drawing file.*
To import a DXF, DXB, DWF, DWT, DGN, or DAE format file

1. Do one of the following to choose Import:
   - On the ribbon, choose the Application button then choose Import, or choose Insert > Import.
   - On the menu, choose File > Import.
   - On the Standard toolbar, click the Open tool.
   - Type open and then press Enter.
2. Choose the folder that contains the drawing.
3. In Files of Type, choose the type of drawing you want to import.
4. Choose the file you want to open.
5. Click Open.

Importing a DXB format file

A DXB format file is a binary description of a drawing file with a .dxb file extension.

To import a DXB format file

1. Do one of the following:
   - On the ribbon Application button, choose Import > DXB In.
   - On the menu, choose Insert > Drawing Exchange Binary.
   - Type dxbin and then press Enter.
2. Choose the file you want to open.
3. Click Open.

Importing an ACIS format file

An ACIS format file contains three-dimensional solids, regions, or bodies that are saved as an ASCII .sat file.

To import an ACIS format file

1. Do one of the following:
   - On the ribbon Application button, choose Import > ACIS In.
   - On the menu, choose File > ACIS In or choose Insert > ACIS File.
   - Type acisin, and then press Enter.
2. Choose the directory containing the .sat file.
3. Choose the .sat file you want to open.
4. Click Open.

**16.4 Using CAD.direct Drafter data in other programs**

You can use any of the following methods to include CAD.direct Drafter data in a document created in another program:

- Embedding
- Linking
- Dragging
- Exporting
- E-mailing

The method you choose depends on the capabilities of the other program and how you want to work with the CAD.direct Drafter data after you've placed it in the other document.

Each method except exporting uses ActiveX to integrate data from different programs. With ActiveX, you can open CAD.direct Drafter drawings from within the other program to modify the CAD.direct Drafter drawings.

**16.4.1 Embedding drawings**

When you embed an CAD.direct Drafter drawing, it becomes part of the other program’s document file. When you edit the drawing, you edit only the version that is embedded in the other document.

Embedding is useful when you don’t want to maintain a link to the CAD.direct Drafter drawing for the data you include in the other document. Edits made to the new drawing do not affect the original drawing. To transfer the file to other computers, you can transfer all the data in one file, but embedded objects increase the file size.

From within a document in a program that supports ActiveX, such as Microsoft® Word, you can either create a new embedded CAD.direct Drafter drawing or embed an existing CAD.direct Drafter drawing.

**To create an CAD.direct Drafter drawing in another document**

1. In the document, choose Insert > Object (or the equivalent command for that program).
2. In the dialog box, click the options for creating a new file.
3. Under Object Type, choose CAD.direct Drafter Drawing, and then click OK.
4. Create the CAD.direct Drafter drawing.

5. If CAD.direct Drafter is running in its own window, choose File > Exit.
   If CAD.direct Drafter is running within the other document (in place), click somewhere in the document outside
   the CAD.direct Drafter drawing to close CAD.direct Drafter.

6. To edit the CAD.direct Drafter drawing from within the document, double-click the drawing.
   You can also embed an existing CAD.direct Drafter drawing from within another document. Follow step 1 in
   the preceding procedure, and then click the option for creating an object from an existing file.

**To embed selected CAD.direct Drafter entities**

1. In CAD.direct Drafter, select the entities you want to embed.
2. Choose Edit > Copy (or press Ctrl+C).
3. Open the document in which you want to embed the entities.
4. Choose Edit > Paste (or the equivalent command).

**To embed an entire CAD.direct Drafter drawing**

1. Open the document in which you want to embed the drawing.
2. Do one of the following:
   - On the ribbon, choose Insert > Object (in Data).
   - On the menu, choose Insert > Object
   - Type insertobj and then press Enter.
3. Click Create From File.
4. Click Browse, and then choose the file you want to embed.
5. Click Insert, and then click OK.

**16.4.2 Editing an embedded CAD.direct Drafter object in place**

In many ActiveX-compatible programs you can edit an embedded CAD.direct Drafter object without leaving
the program (or container application). This is called in-place editing. A different set of CAD.direct Drafter
menus and toolbars temporarily replaces most of the menus and controls in the active window while you edit
the CAD.direct Drafter object.
To edit an embedded CAD.direct Drafter object in place

1. In the container application, double-click the embedded CAD.direct Drafter object.

A different set of CAD.direct Drafter menus and controls appears.

2. Edit the CAD.direct Drafter drawing.

3. Click anywhere outside the drawing window to exit the in-place editing controls.

16.4.3 Linking drawings

When you link an CAD.direct Drafter drawing to another document, the other document contains only a reference to the CAD.direct Drafter drawing file, rather than the actual drawing. You link data in a saved CAD.direct Drafter file so that the other program can find the data and display it.

Linking works well when you want to include the same CAD.direct Drafter data in more than one document. When you update the data, you need update it in only one location. The versions that are linked to other documents reflect the changes automatically.

Linking an CAD.direct Drafter file to another document does not increase the file size the way embedding an CAD.direct Drafter object does. However, links require more maintenance. To transport the data, you must make sure to transfer all linked files to the other computer.

To link an CAD.direct Drafter file to another document

1. Open the drawing you want to link.

Because a link is a reference to a file, the referenced file must be saved on a local or remote disk.

*If you haven’t saved the drawing you want to link, choose File > Save.*

2. In the other program, open the document in which you want to include the CAD.direct Drafter drawing.

3. Choose that program’s command for inserting objects.

In Microsoft® Office programs, choose Insert > Object. In the Object dialog box, click the Create From File tab. Specify the name of the drawing file you want to link. Select the Link To File check box, and then click OK.

The drawing appears in the document, with a link to the original CAD.direct Drafter file.
16.4.4 Dragging CAD.direct Drafter drawings into other programs

If the other program in which you want to include CAD.direct Drafter drawings is compatible with ActiveX, an alternative to pasting drawings with menu commands is to drag drawing file icons from Windows Explorer into the other document. Dragging and dropping drawings does not use the Clipboard, so data on the Clipboard is not affected.

When you drag an CAD.direct Drafter drawing file from Windows Explorer, you link or embed the entire drawing in the other document. When you drag the file, the cursor changes in response to the action you take.

<table>
<thead>
<tr>
<th>Cursor appearance</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frame3D.dwg</td>
<td>Drag to embed the selected file to the other document.</td>
</tr>
<tr>
<td>Frame3D.dwg</td>
<td>Cannot drop drawings in that document.</td>
</tr>
</tbody>
</table>

For easy drag-and-dropping, position the application windows side by side.

*Before you drag a drawing, position the Windows Explorer window and the other program’s window so you can see the file icon and the document in which you want to drop it.*

**To drag and embed drawings into another document**

- Select the icon for the drawing file, and then drag the drawing into the document.
16.4.5 Exporting drawings

You can save or export CAD.direct Drafter drawings in a number of different formats for use with other programs. When you save a drawing in a different format, the program saves all the entities in the drawing to the new file. Or, you can choose which entities are included in the new file.

File formats that can be exported

The following table describes the file formats that can be exported.

<table>
<thead>
<tr>
<th>Format</th>
<th>File extension</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bitmap</td>
<td>.bmp</td>
<td>Graphics file</td>
</tr>
<tr>
<td>Enhanced Windows Metafile</td>
<td>.emf</td>
<td>Graphics file</td>
</tr>
<tr>
<td>Windows Metafile</td>
<td>.wmf</td>
<td>Graphics file</td>
</tr>
<tr>
<td>Portable Document Format</td>
<td>.pdf</td>
<td>Distribute your drawing in 2D or 3D to others for using with Adobe® Acrobat® Reader® and Adobe® Acrobat</td>
</tr>
<tr>
<td>Design Drawing</td>
<td>.dgn</td>
<td>Distribute your drawing to others for using with other CAD programs such as drawing to others for review, editing, and markup using other CAD programs such as Bentley® Microstation®</td>
</tr>
<tr>
<td>Design Web Format</td>
<td>.dwf</td>
<td>Distribute your drawing to others for using with Autodesk® software and tools</td>
</tr>
<tr>
<td>Scalable Vector Graphics</td>
<td>.svg</td>
<td>Graphics file and Web development language</td>
</tr>
<tr>
<td>Stereolithography</td>
<td>.stl</td>
<td>Graphics file used for prototyping three-dimensional models</td>
</tr>
<tr>
<td>Collaborative Design Activity (Collada)</td>
<td>.dae</td>
<td>Interactive three-dimensional graphics file format used by 3D graphics applications (three-dimensional entities are exported, including ACIS entities)</td>
</tr>
</tbody>
</table>

You can also export ACIS solids, regions, and surfaces to an ASCII file (*.sat) that you can use in other programs.

*Exporting to a BMP, EMF, WMF, STL, DAE, or SVG format file.*

Exporting to a file is similar to saving a standard file.
To export a drawing to a .bmp, .emf, .wmf, .stl, .dae, or .svg file

1. Do one of the following:
   • On the ribbon, choose the Application button then choose Export, or choose Output > Export.
   • On the menu, choose File > Export.
   • Type export and then press Enter.

2. In the Export Drawing As File dialog box, under Save As Type, choose the file format.

3. Specify the name of the file you want to create.

4. Click Save.

5. If the selection prompt box displays, choose the entity-selection method, and then create the selection set.

6. When you have finished selecting entities, press Enter.

16.4.6 Exporting to a PDF format file

PDF format files allow you to distribute your drawing to others for viewing in Adobe® Acrobat® Reader®, which is free software that users can download. PDF files can also be viewed, reviewed, and edited in Adobe® Acrobat.

You can export drawings to two-dimensional and three-dimensional PDF files.

To export a drawing to a .pdf file

1. Do one of the following:
   • On the ribbon, choose the Application button then choose Export, or choose Output > Export.
   • On the menu, choose File > Export.
   • Type export and then press Enter.

2. In Save As Type, choose Portable Document Format (pdf).

3. Specify the name of the file you want to create.

4. Click Save.

5. Choose the entity-selection method, and then create a selection set that contains the entities you want to export.

6. When you have finished selecting entities, press Enter.

7. To create a 3D .pdf file instead of 2D, mark Enable Layer Support and then mark 3D PDF Export.
8. Choose additional options for how you want to export to the .pdf file. Click [?] to see details about each option.

9. Click Export.

16.4.7 Exporting to a DWF format file

DWF format files allow you to publish your drawings so they can be viewed on the Internet using a Web browser. CAD.direct Drafter exports your drawing to a Design Web Format (.dwf) file, which can be viewed in a Web browser if Autodesk Design Review is also installed on the computer. Design Review is a free tool from Autodesk.

You can export your drawing to a 2D .dwf file or a 3D .dwf file. 2D .dwf files have smaller file sizes, but cannot be viewed in three dimensions. 3D .dwf files can be viewed in three dimensions using the Autodesk® Design Review, but have larger file sizes.

To export a drawing to a .dwf file

1. Do one of the following:
   • On the ribbon, choose the Application button then choose Export, or choose Output > Export.
   • On the menu, choose File > Export.
   • Type export and then press Enter.

2. In Save As Type, choose Design Web Format (dwf).

3. Specify the name of the file you want to create.

4. Click Save.

5. Choose the entity-selection method, and then create a selection set that contains the entities you want to export.

6. Choose how you want to export:
   • DWF File Version — Choose the file version you want. Version 4.2 can export entities on the Model tab only (no layouts). Version 5.5 can export the current layout only. Version 6.0 can export the current layout or all layouts.
   • DWF File Format — Choose the desired file format. Compressed binary files have a smaller file size than uncompressed binary files (both are 2D .dwf files). ASCII files have the largest file size for 2D .dwf files, but 3D .dwf files have larger file sized and can be viewed in three dimensions.
   • Layout to Export — Choose whether to export the current layout only, or all layouts in the drawing.
7. Click OK.

8. When you have finished selecting entities, press Enter.

### 16.4.8 Exporting to a DGN format file

DGN format files allow you to distribute your drawing to others for review, editing, and markup using other CAD programs such as Bentley® Microstation®. Files are exported to DGN version 8 files.

**To export a drawing to a .dgn file**

1. Do one of the following:
   - On the ribbon, choose Output > DGN Out (in Export).
   - Type dgnexport and then press Enter.
2. Specify the name of the file you want to create.
3. Click Save.
4. At the prompt, choose a master unit for the .dgn file such as kilometers or feet.
5. At the prompt, choose a sub unit for the .dgn file such as inches or mils.

The drawing is exported.

### 16.4.9 Exporting to an ACIS format file

You can export ACIS entities such as surfaces, regions, and solids to an ACIS format file in ASCII (SAT) format.

**To export an ACIS format file**

1. Do one of the following:
   - On the ribbon, choose the Application button then choose Export, or choose Output > Export.
   - On the menu, choose File > ACIS Out.
   - Type acisout and then press Enter.
2. Select the ACIS entities you want to save.
3. Specify the name of the file you want to create.
4. Click Save.
16.4.10 Converting drawings to other file versions and formats

Several types of drawings can be converted to other file versions and formats. You can convert a batch of drawings in a folder or specify a single drawing to convert.

The following formats can be converted from and converted to:

- Autodesk DWG format   Autodesk Drawing Format is a drawing with a .dwg file extension.
- Autodesk DXF format   Autodesk Drawing Exchange Format is an ASCII description of a drawing file with a .dxf file extension.
- DGN format — Drawing files used with Bentley® Microstation®. The DGN format uses the .dgn file extension.

To convert a single drawing

1. Do one of the following to choose CAD.direct Drafter Converter:
   - On the ribbon, choose the Application button then choose Drawing Utilities > CAD.direct Drafter Converter, or choose Tools > CAD.direct Drafter Converter (in Manage).
   - On the menu, choose File > CAD.direct Drafter Converter.

Type intelliconvert and then press Enter.

2. Choose Single file, then click next.

3. Select an input file. Click [...] to browse to the location.

4. Name an output file. Click [...] to browse to the location.

5. In Convert to version, select the file format and version for the output file.

6. If you are converting to a .dgn file, select any of the following:
   - Master unit — Assigns the selected master unit to the output .dgn file.
   - Sub unit — Assigns the selected sub unit to the output .dgn file.
   - Bind external references when possible — Makes external references a permanent part of the .dgn file, similar to a block, if external references are found in the input drawing.

7. If you have more files to convert, mark Convert more files.

8. Click Finish.

A log file is created automatically if converting to a .dgn file and errors occur.

The file <output_dgnfilename>.log is saved in the same folder where the output .dgn file is created.
To convert a batch of drawings

1. Do one of the following to choose CAD.direct Drafter Converter:
   - On the ribbon, choose the Application button then choose Drawing Utilities > CAD.direct Drafter Converter, or choose Tools > CAD.direct Drafter Converter (in Manage).
   - On the menu, choose File > CAD.direct Drafter Converter.
   - Type intelliconvert and then press Enter.

2. Choose Multiple files, then click Next.

3. Specify the input files by doing the following:
   - Enter an input folder. Click [...] to browse to the location.
   - To include files located in subfolders within the input folder, mark Process subfolders.
   - Choose which files to include: .dwg, .dxf, and .dgn.

4. Click Next.

5. Review the list of files that are found, then click Next to proceed using all of the named files. You can also click Back to specify different files.

6. Enter an output folder. Click [...] to browse to the location.

7. Mark Convert, then select the output format and file version.

8. To audit and fix files during the conversion, mark Audit files and fix errors. You can also choose to save audit log files, which will also be saved in the output folder.

9. Select what to do, if while processing, files with the same name are found in the output folder:
   - Replace existing — Replaces existing files with the new files. To make a backup copy of the existing file before it is overwritten, mark Create backup files (*.bak), and backup files will be created in the same output folder.
   - Skip existing — Skips adding a new file if an existing file is found with the same name.
   - Add suffix to output files — Adds the specified suffix to all new files created in the output folder.
10. If you are converting to a .dgn file, select any of the following:
   • Master unit — Assigns the selected master unit to the output .dgn file.
   • Sub unit — Assigns the selected sub unit to the output .dgn file.
   • Bind external references when possible — Makes external references a permanent part of the .dgn file, similar to a block, if external references are found in the input drawing.

11. Click Next.

New files are generated based on your specifications.

A log file is created automatically if converting to a .dgn file and errors occur. The file <output_dgnfilename>.log is saved in the output folder that was specified for batch file conversion.

16.4.11 Sending drawings through e-mail

You can send a CAD.direct Drafter drawing CAD.direct Drafter is compatible with e-mail Messaging Application Program Inter-face (MAPI) protocol.

To include a drawing file in an e-mail message

1. While the drawing file is open, choose File > Send Mail.

If your mail program is not already running, it starts; a new e-mail message containing the CAD.direct Drafter icon and file name appears.

2. Address the e-mail, type a message, and send the e-mail message as you would any other message.

To view an CAD.direct Drafter file sent by e-mail

   • Open the e-mail message, and then double-click the CAD.direct Drafter icon. CAD.direct Drafter software must be installed on the computer used to open drawings from e-mail.
16.5 Using CAD.direct Drafter with the Internet

You can use CAD.direct Drafter to access the Internet and exchange drawing information and perform other tasks, including:

- Add hyperlinks to a drawing.
- Publish drawings to the Internet.
- Drag drawings (.dwg files) directly from a Web site into CAD.direct Drafter.
- Access the Internet during a drawing session.

You need an Internet browser to use hyperlinks.

*Internet Explorer Version 5.0 or later is required to access to the Internet to fully use these features.*

16.5.1 Adding hyperlinks to a drawing

In your CAD.direct Drafter drawings, you can include hyperlinks, which are pointers that take you to another location, such as a Web address or a file on a particular computer. You can attach a hyperlink to any entity in your drawing. Then, when you select that entity, you can open the link and jump to the specific Web address or file location. You can create absolute hyperlinks, which store the full path to a file, or relative hyperlinks, which store a partial path relative to a base folder or a Uniform Resource Locator (URL).

The PICKFIRST system variable must be set to on.

*Files associated with hyperlinks can be opened only if the PICKFIRST system variable is turned on.*

To create a hyperlink

1. Type hyperlink and then press Enter.
2. Select an entity or entities that you would like to associate with a hyperlink; then press Enter to display the Edit Hyperlink dialog box.
3. Do one of the following:
   - Click Browse to specify a file.
   - In the Link to File or URL box, type a Web address.
4. If you want to use a common path for all hyperlinks in the drawing, select the Use relative path for hyperlinks check box. Relative paths provide flexibility if you move files to a different folder, since you can change multiple hyperlink paths at once, rather than change them all individually.
5. Click OK to close the Edit Hyperlink dialog box.
The HYPERLINKBASE system variable defines the relative path used for all hyperlinks in the current drawing.

To use the default drawing path, leave the value blank by entering a period (".").

To remove a hyperlink

1. Type hyperlink and then press Enter.
2. Select an entity or entities with a hyperlink; then press Enter to display the Edit Hyperlink dialog box.
3. Click Remove Link.
4. Click OK to close the Edit Hyperlink dialog box.

To access a hyperlink

1. Select an entity with a hyperlink.
2. Right-click anywhere in the drawing area.
3. In the pop-up menu, choose Open Link.
16.5.2 Publishing drawings to the Internet

You can publish your drawings so they can be viewed on the Internet using a Web browser. CAD.direct Drafter exports your drawing to a Design Web Format (.dwf) file, which can be viewed in a Web browser if Design Review is also installed on the computer. Design Review is a free tool from Autodesk®.

For details about creating a DWF file, see “Click Export.” on page 568 in this chapter.

16.5.3 Inserting drawings from a Web site

Some Web sites are configured to allow you to drag drawings from the Web site directly into your drawing. You can drag-and-drop drawings from any Web site that supports the Autodesk® i-drop technology.

To insert a drawing from a Web site

1. Open your Web browser.
2. Navigate to a Web site that supports Autodesk® i-drop.
3. Position the Web browser and CAD.direct Drafter windows so they are both visible.
4. Click the drawing in your Web browser and drag it to your drawing in CADconv Connect.

The drawing file is downloaded and inserted into your drawing in CAD.direct Drafter.

16.5.4 Accessing the CAD.direct Drafter Web site during a drawing session

In addition to using hyperlinks to access the Internet, you can access a company Web site at any time. At the Web site, you can obtain company information as well as product information and news.

To access the CAD.direct Drafter Web site

1. Do one of the following:
   - On the ribbon, choose Help > CAD.direct Drafter on the Web.
   - On the menu, choose Help > CAD.direct Drafter on the Web.
   - Type onweb and then press Enter.
2. Navigate to the section of your choice on the CAD.direct Drafter Web site.
17. Customizing CAD.direct Drafter

You can customize CAD.direct Drafter in a number of ways. For example, you can change the appearance of many aspects of the program and modify the existing menus and toolbars or create new ones. This section explains how to:

- Set the program’s preferences.
- Customize menus and toolbars.
- Customize the keyboard.
- Create aliases for frequently used commands.
- Customize entities.
- Create and use scripts.
- Use add-on programs with CAD.direct Drafter.
- Use a digitizer tablet for menu selection and calibrated drawing.

17.1 Setting and changing options

You can change many of the options that control the program's behavior and appearance, such as setting the experience level, specifying file paths and default files, configuring display features, and configuring how certain features work.
17.1.1 Changing the options on the General tab

In the Options dialog box, the General tab contains settings for experience level and save options. You can also set VBA security.

A Click to enable AutoSave feature.
B Select the default file format that displays when saving drawings using the Save As dialog box.
C Select to check all drawings for errors when using the Open command, and attempt recovery, as needed.
D Select to hide warning messages when opening drawings, if the check box Open Drawings using Recover is marked.
E Displays the name of the current profile selected on the Profiles tab.
F Click to turn off error reporting when a crash issue is encountered while running CAD.direct Drafter.
G Click to disable VBA CommonProject macros on startup. (Available if supported by your version of CAD.direct Drafter.)
H Click to select which filetypes are associated with CAD.direct Drafter.
I Click to send a complete report of crash data. (Available if error reporting is turned on.)
J Type the file extension for AutoSaved files.
K Enter frequency of AutoSave in minutes.
L Select the experience level.
17.1.2 Setting the experience level

You can control which menus and tools are available by setting the experience level. You can choose from the following experience levels:

- Beginner Menus and toolbars display only basic commands.
- Intermediate Menus and toolbars display most two-dimensional entity creation and modification commands.
- Advanced Menus and toolbars display all available commands.
- To set the experience level

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the General tab.
4. When you have finished, click OK.

17.1.3 Saving your drawings automatically

To avoid losing data in the event of a power failure or other system error, save your drawing files often. You can configure the program to periodically save your drawings automatically. The Minutes setting determines the interval between automatic saves. The program restarts this interval timer whenever you save the drawing file.

When AutoSave is enabled, the program creates a copy of your drawing. The file is saved in the folder specified in Options > Paths/Files for Temporary Files, with the file extension specified in the AutoSave Drawing Extension box (by default, .SV$).
To set how drawings are saved automatically

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the General tab.
3. Under AutoSave, select the check box to enable the AutoSave feature, and select the frequency.
   If you want to change the default extension assigned to your AutoSave files, type the new extension in AutoSave Drawing Extension.
4. When you have finished, click OK.

17.1.4 Setting the default SaveAs format

You can control the default file format that you want to display in the Save Drawing As dialog box. For example, if you use the Save As command to save most of your drawings in a legacy file format, you can select that file format as the default so you don’t have to select it each time you save a drawing using the Save As command. This setting has no effect on saving existing or new drawings using commands other than Save As — CAD.direct Drafter always saves existing drawings in their current file format and saves new drawings with the most current file format.

To set the default Save As format

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the General tab.
3. Under Save As, select the default drawing format that displays when using the Save As command. You can always specify a different format in the Save Drawing As dialog box.
4. When you have finished, click OK.
17.1.5 Setting how drawings are opened

There are several options that determine how drawings are opened in CAD.direct Drafter. You can specify which file extensions are associated with CAD.direct Drafter, allowing you to open files such as .dwg files automatically using CAD.direct Drafter.

Additionally, you can set up CAD.direct Drafter to open drawings automatically using the Recover command, for example, if you are a new CAD.direct Drafter user and your original drawings were created using different CAD software and those drawings regularly contain errors or damaged data. The Open Drawings using Recover option automatically checks all drawings for errors when using the Open command, and attempts recovery, as needed. Viewing warning messages when opening drawings allows you to know which files are being fixed by CAD.direct Drafter and what errors have occurred; however, you can also choose to hide the warnings.

To set how drawings are opened

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the General tab.
3. To specify the file types that open automatically using CAD.direct Drafter, click Set Fil Association and make your selections.
4. If you want to use the Recover command automatically each time you use the Open command, mark the check box for Open Drawings using Recover.
5. If you want to hide warnings when errors are found in a drawing, mark the check box for Hide Warnings when Opening Drawings using Recover. Errors will still be logged in an ASCII file with an .adt extension.
6. When you have finished, click OK.
17.1.6 Setting error reporting options

- Error reporting occurs when CAD.direct Drafter encounters a crash issue. You can specify whether error reporting occurs and whether a full report is generated. It is recommended to generate the full report only if requested for troubleshooting purposes. The completed report of crash data can be up to 100MB in size, and while it contains helpful information for troubleshooting issues, is more likely to fail during transmission due to its file size.

To change the options on the General tab

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the General tab.
3. If you want to turn off error reporting, mark the check box for Disable Error Reporting.
4. If you want to generate a full report when error reporting is turned on, mark the check box for Generate Full Report.
5. When you have finished, click OK.

17.1.7 Disabling VBA CommonProject macros

Each time you start CAD.direct Drafter, macros are automatically loaded for the Visual Basic Application(VBA) CommonProject. If you do not plan to use VBA, disabling the macros may improve performance. In addition, disabling the macros can enhance security if you are running CAD.direct Drafter at a low security level.

To change the options on the General tab

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the General tab.
3. If you do not want the CommonProject macros to be loaded when you start CAD.direct Drafter, under VBA Security, click the check box for Disable VBA CommonProject Macros On Startup.

4. When you have finished, click OK.

Changing the options on the Paths/Files tab

You can specify locations for various file types such as those used for drawings, fonts, and menus in the Options dialog box on the Paths/Files tab. You can even specify multiple paths for the same file type. In addition, you can change the names of the default system files that are used for functions such as font mapping and error logging.

17.1.8 Specifying the user paths

You can enter paths to your CAD.direct Drafter directories by selecting them in the Options dialog box. This feature includes directories for drawings, fonts, help, external references, menus, hatch patterns, blocks, print style tables, print output files, temporary files, templates, and color books. CAD.direct Drafter searches directories for support files in the following order:

- The CAD.direct Drafter program directory.
- The current drawing directory.
- The Windows search path.
- The search path specified in the Options dialog box.

You can enter multiple paths for each item

If, for example, the Drawings item has more than one directory associated with it, click Add to specify additional paths. You can also separate multiple paths with a semicolon if typing them. CAD.direct Drafter searches the directories in the order in which they are listed.

To specify a user path

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Paths/Files tab.
3. In the upper half of the dialog box, do one of the following:
• Right-click and choose from the shortcut menu of options.
• Click a category to view its search paths, then single-click the path you want to modify, and type the path.

If you do not know the path or directory name, click Browse, and then browse to the location of the directory you want.

4. When you have finished, click OK.

17.1.9 Changing the default system files

You can change the default system files, including the log file, default template, alternate font, and font mapping file.

To change a default system file

1. Do one of the following to choose Options:
   • On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   • On the menu, choose Tools > Options.
   • Type config and then press Enter.

2. Click the Paths/Files tab.

3. In the lower half of the dialog box, under Program Files, do one of the following:
   • Right-click and choose from the shortcut menu of options.
   • Click the file name for the default system file you want to change, and type a new file name.

If you don’t know the file name, click Browse, and then browse to the location of the file you want.

4. When you have finished, click OK.
A Click to view default paths. Click or press the F2 key to modify a selected path. Double-click a path to open the path in Windows Explorer.

B Click or press the Insert key to add a new path for the current category.

C Click or press the Delete key to remove the selected path.

D Select the default file to change.

E Click to locate and specify a new default file.

F Click to move the selected path up one position in search order.

G Click to move the selected path down one position in search order.

H Click to remove custom paths and use the default paths for the selected category.

I Click to locate and specify a new path.
17.1.10 Changing the options on the Display tab

In the Options dialog box, the Display tab contains settings for displaying the command bar, CAD.direct Drafter window, menus, mouse actions, and program language.

17.1.11 Setting how the command bar works

The command bar is a dockable window in which you type CAD.direct Drafter commands and view prompts and other program messages. To display the command bar, choose View > Display > Command Bar. To customize how the command bar works, change the options on the Display tab.
To set how the command bar works

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.

2. Click the Display tab.

3. In Command Lines to Track, enter the desired number of previous command and command prompts that are tracked in the command bar. The default value is 256. You can also display the commands in the Prompt History window by pressing F2. To close the window, press F2 again.

4. In Font Size, enter the desired font size. The default is 16.

5. Mark the Use Up/Down Arrows for Command History Navigation check box if you want to scroll the command history text when using the Up and Down arrows on the keyboard. This can be a convenient way to review and even repeat previous commands. If unchecked, using the keyboard arrows pans your view of the drawing.

Use alternate keyboard shortcuts.

For panning, you can use Alt+arrow keys. For scrolling the command history, you can use Ctrl+K and Ctrl+L.

6. Mark the Enable AutoComplete check box to use the AutoComplete feature when typing commands in the command bar. For more details about AutoComplete, see “Customizing how suggestions display in the command bar” on page 587 in this chapter.

7. When you have finished, click OK.

17.1.12 Customizing how suggestions display in the command bar

When you type in the command bar, CAD.direct Drafter suggests names of matching commands as you type. The suggested names appear in an AutoComplete window that automatically opens when you type and closes when you activate a command.

Using AutoComplete is an efficient way to select commands, and it is also a convenient way to view a list of related commands. For example, if you type “LA” in the command bar to work with layers, all layer-related commands that begin with “LA” display in the AutoComplete window.
In addition to command names, suggestions can include names of external commands, system variables, aliases, and LISP functions. Each name displays with a colored icon that indicates its type:

- Red — CAD.direct Drafter command
- Green — External command
- Yellow — System variable
- Blue — LISP function

**To customize how suggestions display in the command bar**

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.

2. Click the Display tab.

3. Mark the Enable AutoComplete check box to turn on automatic suggestions of names as you type in the command bar.

4. Click AutoComplete Options.

Use a shortcut

*Type INPUTSEARCHOPTIONS and then press enter to access autocomplete options directly from the command bar.*

5. In AutoComplete Timeout, enter the number of milliseconds to wait between key-strokes before displaying the AutoComplete window. The higher the number, the longer the delay allowed between keystrokes (the AutoComplete window displays less frequently).

Fast typists usually increase the timeout setting

*If the AutoComplete window often conflicts with your typing in the command bar, try setting the number of milliseconds to 1,000 or more.*

6. In Minimum Length of Text, enter the number of letters to be typed in the command bar before displaying the AutoComplete window.

7. In Transparency, enter the percentage of transparency, between 0 and 50, in which to display the AutoComplete window. The higher the number, the more transparent the window is. Enter zero for an opaque window.
8. Determine how selection works:

- Mark Use Recent Commands to search for and automatically select a recently used command, when possible.
- Mark Show Suggestions in Command Line to pre-fill the command line with the name as you scroll the list. If turned off, the name does not pre-fill in the command line, however, you can still select the desired name in the AutoComplete window by clicking it or pressing CTRL + Enter.
- Mark Cycle Selection if you want to allow Arrow key scrolling from the end to beginning (and vice versa) in the list.
- Mark Mouse-Over Selection to allow selection by hovering the mouse, and not clicking it, over the desired name.

9. Mark Show Command Icons to display icons, if available, for each command in the list.

10. Mark Use Command Line Colors to display the AutoComplete window using the same background and text colors that are selected for the command bar. For more details about selecting command bar colors, see “Setting colors of the main window” on page 591 in this chapter.

11. Mark which items to include in the list of suggested names: aliases, external commands, system variables, and/or LISP functions. If selected, LISP functions display when you enter a parenthesis,“(“, when first typing.

12. Click OK.

13. Click OK.
17.1.13 Setting the main window options

The main CAD.direct Drafter window can be customized in many ways to best accommodate your work style. For example, hiding window elements if you do not use them can help increase drawing space in the CAD.direct Drafter window.

To set the main window options

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Display tab.

3. Mark the Show Paper Sheet in Paper Space checkbox if you want to display a bounded sheet of paper for Layout tabs. When unmarked, the paper sheet does not display.

4. Mark the Show Tabs checkbox if you want to display the Model tab and Layout tabs in the main window. When unmarked, the tabs do not display, which can be helpful if you only work on the Model tab or if you use the command bar and status bar to switch between tabs.

5. Mark the Show Scroll Bars checkbox if you want to display the scroll bars on the right side and bottom of the CAD.direct Drafter window or viewport. When unmarked, the scroll bars do not display, which can improve performance and can also be helpful if you only use the Pan command to scroll drawings.

6. Unmark the Hardware Acceleration check box if you experience performance problems or issues during rendering. By default, Hardware Acceleration is turned on, but infrequently it can complicate performance and rendering.

7. Mark the Pointer Defaults to Crosshairs checkbox if you want to use crosshairs as the default pointer shape (instead of a small box).

8. In Cursor Size, enter or scroll to a number for the percentage of the screen to be used by the crosshairs cursor. Note that depending on your graphics device, a large percentage can negatively affect display performance.

9. When you have finished, click OK.

17.1.14 Setting colors of the main window

You can control the color of many aspects of the main drawing window, such as background color, crosshairs color, and more.

To set colors of the main drawing window

1. Do one of the following to choose Options:
   • On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   • On the menu, choose Tools > Options.
   • Type config and then press Enter.
2. Click the Display tab.
3. Click Color Scheme.
4. In Context, select the area that contains items for which you want to specify colors.
5. In Items, select the item for which you want to specify a color.

6. In Colors, select a color or choose Select Color for more options.

7. Click On/Off to show or hide the item (available only if the selected item can be turned off).

8. When you have finished, click Apply & Close.
To save and open color schemes

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.

2. Click the Display tab.

3. Click Color Scheme.

4. Make any adjustments before you save the settings.

5. Click Save to save the current color selections as a color scheme file.

6. Click Load to select a color scheme (.xml or .clr file) and load it.

7. Click Apply & Close.

*Color schemes are an easy way to reuse favorite color settings. If you work on more than one computer, save a color scheme to a file and load the file on another computer.*

To restore colors to their defaults

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.

2. Click the Display tab.

3. Click Color Scheme.

4. Do one of the following:
   - Reset a single item — Select the item you want to revert to the default color, then click Current Item.
   - Reset all items in a context — Select the context, then click Current Context. All items in the current context will be reverted to their default colors.
   - Reset all colors — Click All Colors. All items in all context will be reverted to their default colors.

5. Click Apply & Close.
17.1.15 Setting mouse options

Mouse actions can be customized to best accommodate your work style. For example, you may prefer to repeat a recent command when right-clicking the mouse if you do not use shortcut menus.

To set the mouse options

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.

2. Click the Display tab.

3. Mark the Reverse Mouse Wheel Zoom Direction check box if you want to reverse the zoom direction of the mouse wheel, that is, spin the wheel forward to zoom out and spin it backward to zoom in. This can be especially helpful if you use the mouse with your left hand. When unmarked (the default), you spin the mouse wheel forward to zoom in and spin it backward to zoom out.

4. To set the action to take when you right-click the mouse in a drawing, click Right-Click Action and choose from the following options:
   - No Selection — To repeat the previously used command if you right-click when entities are not selected, choose Repeat Last Command. To display a shortcut menu if you right-click when entities are not selected, select Show Shortcut Menu.
   - Entities Are Selected — To repeat the previously used command if you right-click when entities are selected, choose Repeat Last Command. To display a shortcut menu that displays options specific to the selected entities if you right-click, select Show Shortcut Menu. You can right-click anywhere in the drawing with entities selected and the shortcut menu for the selected entities will display.

5. When you have finished, click OK.

17.1.16 Setting how menus display

The display of menus can be customized, including whether prompt menus and right-click shortcut menus display, whether menus load automatically, and the number of drawing files that display on the File menu.
To set how menus display

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Display tab.
3. Mark the Display Prompt Boxes check box if you want to show prompt boxes, which display the same options for commands that display on the status bar and the command bar. Turning prompt boxes off may save screen space and may minimize mouse clicks.
4. Mark the Display Grip Menus check box if you want grip menus to display when the mouse pauses over a grip that has an associated menu.
5. In Recent Drawing List Size, enter how many recently opened drawings are listed on the File menu.
6. When you have finished, click OK.

17.1.17 Setting user interface options

User interface options include how the title bar displays file names, themes that affect how CAD.direct Drafter windows look, and the language used to show options throughout CAD.direct Drafter.

The list of available languages depends on which languages were installed on your computer. If the desired language doesn’t appear in the list, repair or re-install the application with customized settings for the desired language.

To set the user interface options

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Display tab.
3. Click Set Language and in Language Selection Method, choose one of the following options:

- Manual selection — Uses the language selected in the Installed Languages list.
- Automatically match regional settings — Matches the language set for the geographical region
- Automatically match system locale — Matches the language set for the operating system.

4. Click OK.

5. Mark the Show Full Drawing Path in Title Bar check box if you want to display the drive and folder location of the drawing in the drawing title bar in addition to the filename. When unmarked (the default), only the filename displays in the drawing title bar.

6. In Theme, select the look you want for all CAD.direct Drafter windows.

7. When you have finished, click OK.
17.1.18 Changing the options on the Profiles tab

CAD.direct Drafter allows you to customize the settings that control your drawing environment, and then save and restore those settings in a profile. For example, if you prefer working with custom menus and toolbars, you can save these settings as your own profile.

Profiles can be helpful if you have multiple users with different preferences, or if you are a single user who works on various projects that require unique settings. You can even export your profile and bring it with you when you work on a different computer.

Understanding the settings saved in profiles

Profiles save many settings that control the drawing environment. Once you start using a profile, it automatically tracks and stores changes that you make to your drawing environment.

Some settings are saved immediately, but some require that you exit CAD.direct Drafter and then start CAD.direct Drafter again. This is because profiles save settings from your computer’s registry and some settings are only saved to the registry when you exit CAD.direct Drafter.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Location</th>
<th>When saved</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toolbar settings</td>
<td>Tools &gt; Customize, Toolbars tab</td>
<td>Exit and restart of CAD.direct Drafter</td>
</tr>
<tr>
<td>Menu settings</td>
<td>Tools &gt; Customize, Menus tab</td>
<td>Drafter Immediately</td>
</tr>
<tr>
<td>Keyboard settings</td>
<td>Tools &gt; Customize, Keyboard tab</td>
<td>Immediately</td>
</tr>
<tr>
<td>Alias settings</td>
<td>Tools &gt; Customize, Aliases tab</td>
<td>Immediately</td>
</tr>
<tr>
<td>Window elements on/off status</td>
<td>View &gt; Display &gt; Command Bar</td>
<td>Exit and restart of CAD.direct Drafter</td>
</tr>
<tr>
<td>and their various settings</td>
<td>View &gt; Display &gt; Model and Layout Tabs</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View &gt; Display &gt; Prompt History</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Window</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View &gt; Display &gt; Scroll Bars</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View &gt; Status Bar</td>
<td></td>
</tr>
<tr>
<td>Tablet configurations</td>
<td>Tools &gt; Tablet</td>
<td>Immediately</td>
</tr>
<tr>
<td>User paths</td>
<td>Tools &gt; Options, Paths/Files tab</td>
<td>Immediately</td>
</tr>
<tr>
<td>System variables</td>
<td>Typed in command bar</td>
<td>Varies — some saved immediately and some upon exit and restart of CAD.direct Drafter</td>
</tr>
</tbody>
</table>
17.1.19 Creating profiles

Create profiles if you want to save your custom drawing environment settings. This can be helpful if you have two or more drawing environments that you use regularly.

When you create a new profile, the current drawing environment settings are automatically saved with the new profile.

To create a profile

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Profiles tab.
3. Click Create.
4. Enter a name, a description (optional), and then click OK.
5. In the Options dialog box, click OK.
6. Make changes to your drawing environment.
   CAD.direct Drafter automatically saves the settings to the new profile.

Some cases require you to exit and restart CAD.direct Drafter before settings are saved with the profile.

This is because profiles save settings from your computer’s registry and some settings, such as toolbar settings, are only saved to the registry when you exit CAD.direct Drafter.
17.1.20 Loading a profile

While you work in CAD.direct Drafter, you can load the custom settings of any profile. The current profile when you exit CAD.direct Drafter is automatically loaded when you start CAD.direct Drafter again.

To load a profile

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Profiles tab.
3. Select the desired profile.
4. Click Set Current.

17.1.21 Restoring the default settings

At any time you can return to the default drawing environment settings that were installed with CAD.direct Drafter.

If the Default profile is unchanged, simply load it to restore the default settings. If the Default profile is deleted or changed, reset an existing profile (one that you no longer need) to replace its contents with the default settings.

To restore default settings using an unchanged Default profile

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Profiles tab.
3. Select the Default profile.
4. Click Set Current.

To restore default settings without using the Default profile

Resetting a profile erases all of the profile’s custom settings

Do this only if you are certain you no longer need the selected profile.

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Profiles tab.
3. Select a profile that you no longer need; all of its custom settings will be erased. If necessary, create or copy a profile to use for restoring the default settings.

4. Click Reset.

**17.1.22 Managing profiles**

Once you start using profiles, you may need to rename, copy, or delete them. Copying a profile is a quick way to create a new profile based on an existing profile.

**To rename a profile**

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.

2. Click the Profiles tab.

3. Select the profile you want to rename.

4. Click Rename.

5. Make any necessary changes to the name or description, and then click OK.

**To copy a profile**

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.

2. Click the Profiles tab.

3. Select the profile you want to copy.

4. Click Copy.

5. Enter a new name, a description (optional), and then click OK.
To delete a profile

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Profiles tab.
3. Select the profile you want to delete.
4. Click Delete.

17.1.23 Working with profiles on multiple computers

If you use multiple computers and you like to work with our own drawing environment settings, save time by bringing your profile with you.

On your computer, export your profile to an .arg file. Bring the file with you to the other computer using a disk, E-mail, network, or some other method. When you start working at another computer, simply open and load your profile instead of recreating your preferred drawing environment.

To export a profile to a file

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Profiles tab.
3. Select the profile to export.
4. Click Export.
5. Specify a location and name for the exported file, and then click Save.

To open a profile from a file

1. Do one of the following to choose Options:
• On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
• On the menu, choose Tools > Options.
• Type config and then press Enter.

2. Click the Profiles tab.

3. Click Import.

4. Locate and select the profile (.arg file), and then click Open.

5. Make any necessary changes to the name or description, and then click OK. 6 (Optional) To load the imported profile, select it, and then click Set Current.

17.1.24 Changing the options on the Printing tab

In the Options dialog box, on the Printing tab, you can determine several print settings, including the default printer, headers, footers, printer configuration files (PC3 files), and print styles that change the appearance of your printed drawing without modifying the actual entities in your drawing.
17.1.25 Setting the default printer

A default printer, or output device, is assigned to all new drawings. Select the device you use most often when printing drawings. Later, if needed, you can assign a different printer for any existing drawing.

To set the default printer

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options then click the Printing tab or choose File > Print Options.
   - Type config, press Enter, then click the Printing tab.
2. In Default Output Device, select a printer to assign to new drawings.
3. When you have finished, click OK.

17.1.26 Setting default print styles

Default print style settings affect only specific drawings: new drawings created without a template and older drawings when opened (older drawings that were created before print styles were available, for example, before AutoCAD 2000). Drawings that are currently opened are not affected.

For more details about print styles and print style tables, see “Using print styles” on page 474.

To set default print style settings for new drawings

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options then click the Printing tab or choose File > Print Options.
   - Type config, press Enter, then click the Printing tab.
2. Click Print Style Settings.
3. Select to use color-dependent or named print style tables for new drawings created without a template.
4. Select a default print style table to use with new drawings.
5. For named print style tables, select both the print style to assign to layer zero and to new entities. For color-dependent tables, the print style is BYCOLOR and is not selectable.
6. Click OK.

7. When you have finished, click OK.

17.1.27 Specifying a header and footer

You can include information such as a date and time stamp, your name and company name, or other information that you want to appear at the top or bottom of drawings when you print them.

Header and footer settings are set globally for all drawings, although they don’t have to be included with each drawing you print. When printing, in the Print dialog box mark or unmark Print Stamp On accordingly.

To specify a header and footer for all drawings

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options then click the Printing tab or choose File > Print Options.
   - Type config, press Enter, then click the Printing tab.

2. Click Print Stamp Settings.

3. Type the content for the header and footer, or select an optional automatic field from the lists. To align text to the left, middle, or right in a header or footer, separate the text with commas.

4. Click Advanced.

5. Customize settings for any of the following:
   - Orientation Select Horizontal to place the header and footer on the top and bottom of the drawing. Select Vertical to rotate the header and footer 90 degrees on the left and right of the drawing.
   - X Offset Enter the distance to offset the header and footer from the edge of the printable area in the x-direction.
   - Y Offset Enter the distance to offset the header and footer from the edge of the printable area in the y-direction.
   - Offset Relative To Select whether to measure the offset from the edge of the paper or the printable area.
   - Font Select the font for the header and footer text.
   - Height Select the height for the header and footer text.
Units Select Inches or Millimeters as the unit of measure for the print stamp X Offset, Y Offset, and Height.

Add Print Event into Log File Select to include print stamp information in the print log file.

6. Click OK.

7. When you have finished, click OK.

17.1.28 Setting up printer configuration files

Printer configuration files (PC3 files) store the printer information you use for specific drawings or layouts. You can add, modify, and delete PC3 files.

For more details about printer configuration files, see “Customizing and reusing print settings” on page 462.

To set up printer configuration files

1. Do one of the following to choose Options:

   • On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   • On the menu, choose Tools > Options then click the Printing tab or choose File > Print Options.
   • Type config, press Enter, then click the Printing tab.

2. Click Add or Configure Printers.

3. To create a new PC3 file, do the following:

   • Click Add.
   • In the Add Printer Configuration File dialog box, select the desired printer for the new PC3 file.
   • Click Continue.
   • Select the options you want for the PC3 file. If you don’t select any custom options, a PC3 file will not be created.
   • Click OK.

4. To modify a PC3 file, do the following:

   • Select the desired file in the list.
   • Click Modify.
   • Select the options you want for the PC3 file.
   • Click OK.
5. To delete a PC3 file, select the desired file in the list and click Delete.

6. Click OK.

7. When you have finished, click OK.

17.1.29 Changing the options on the Snapping tab

In the Options dialog box, on the Snapping tab, you can control how entity snaps work, including fly-over snapping. Fly-over snapping is a visual aid to help you see and use entity snaps more efficiently.

To change the options on the Snapping tab

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.

2. Click the Snapping tab.

3. Select the options you want.

4. When you have finished, click OK.
A Select to display an extra image on the cursor to show which entity snap is active. (Available even if fly-over snapping is turned off.)
B Select to turn on fly-over snapping.
C Select to turn on fly-over snap tooltips, which indicate the type of snap that was used to select the marked location.
D Select to turn on the fly-over snap aperture box. Entities found within the aperture box are available for selection, making it easier to find and select entity snap points.
E Type or scroll to the tolerance size for the fly-over snap aperture box. Higher numbers increase the distance from the cursor in which entities are found.
F Click to turn on entity snapping to hatches.
G Click to turn on entity snapping to files that are attached as underlays to drawings.
H Click to turn on entity snapping to .pdf files that are attached to drawings. (Available only if entity snapping to underlays is turned on.)
I Click to turn on entity snapping to .dwf files that are attached to drawings. (Available only if entity snapping to underlays is turned on.)
J Click to turn on entity snapping to .dgn files that are attached to drawings. (Available only if entity snapping to underlays is turned on.)
K Click to turn on entity snapping to entities that have a negative z value when using a dynamic UCS.
L Type or scroll to the thickness of the fly-over snap marker.
M Type or scroll to the size of the fly-over snap marker.
N Click to choose the color of the fly-over snap marker.
O Select to turn on the display of fly-over snap markers in all views when you are using more than one viewport.
P Select to turn on fly-over snap markers, which mark snap points on entities.
17.1.30 Changing the options on the Clipboard tab

You can control what formats are supported when copying content to the clipboard from CAD.direct Drafter. Copying all supported formats to the clipboard impacts performance—it is best to select only the necessary formats.

**To change the options on the Clipboard tab**

1. Do one of the following to choose Options:
   - On the ribbon, choose the Application button then choose Options, or choose Tools > Options (in Manage).
   - On the menu, choose Tools > Options.
   - Type config and then press Enter.
2. Click the Clipboard tab.
3. Select the options you want.
4. When you have finished, click OK.
17.2 Customizing menus

You can customize a current menu and save your changes as a menu file. Menus files can also be loaded. Menu file formats can be any of the following: CAD.direct Drafter (*.icm files), Customizations (.cui files), and AutoCAD (*.mnu, *.mns files).

17.2.1 Understanding menu compatibility

CUI format menu files are created by newer versions of AutoCAD. MNU format files are menu files created by all AutoCAD releases, and MNS format files are included in AutoCAD Releases 13, 14, and 2000. CAD.direct Drafter reads all file formats, even when menu macros include AutoLISP code. This feature allows you to continue using your existing AutoCAD menus.

CAD.direct Drafter supports all sections of CUI format files required for menus and toolbars customization. For MNU and MNS format file compatibility, see the following table.

<table>
<thead>
<tr>
<th>Menu section</th>
<th>Definition</th>
<th>IntelliCAD support</th>
</tr>
</thead>
<tbody>
<tr>
<td>***POP0</td>
<td>Cursor menu</td>
<td>Supported</td>
</tr>
<tr>
<td>***POPn</td>
<td>Pull-down menus</td>
<td>Supported</td>
</tr>
<tr>
<td>***AUXn</td>
<td>Auxiliary menus</td>
<td>Not supported</td>
</tr>
<tr>
<td>***BUTTONn</td>
<td>Button menus</td>
<td>Supported</td>
</tr>
<tr>
<td>***ICON</td>
<td>Icon menus</td>
<td>Not supported</td>
</tr>
<tr>
<td>***SCREEN</td>
<td>Screen menus</td>
<td>Not supported</td>
</tr>
<tr>
<td>***TABLETn</td>
<td>Tablet menus</td>
<td>Supported</td>
</tr>
</tbody>
</table>

To see how CAD.direct Drafter reads AutoCAD menu source files

1. Type menu and then press Enter.
2. Under Files Of Type, select AutoCAD Menu File (mnu).
3. In the Open Menu dialog box, go to the AutoCAD Support folder and select the Acad.mnu file (or Acad.mns for Releases 13, 14, and 2000).
4. To load the AutoCAD menu file into CAD.direct Drafter, click Open.

The CAD.direct Drafter menu bar now looks identical to the AutoCAD menu bar.
5. To see how it works, choose a few commands from the menu bar, such as File > Open or Draw > Line.
6. To restore CAD.direct Drafter to its default menu, choose Tools > Customize, click the Menus tab, and then click Reset.

7. To restore the CAD.direct Drafter default toolbars, choose Tools > Customize, and then click the Toolbars tab and click Reset.

17.2.2 Creating new menus and commands

You can create a new menu by inserting a menu item at the top level of the Menu Tree. Then you can add commands to the new menu item. You can also add sub-menus and modify existing menu names and commands by adding, deleting, and rearranging them.

*Bullet colors indicate whether a command is available at the current experience level.*

*A green bullet in front of a menu item or command indicates that the menu item or command is available; a red bullet in front of a menu item or command indicates that the menu item or command is not available for you to use at the experience level you have set. To change your experience level, choose Tools > Options.*
To create a new menu

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Menus tab.
3. In the Menu Tree, select the menu name above which you want to add a new menu.
4. Choose Insert > Menu Item.
5. Type a name for the new pull-down menu, and then press Enter.
6. Click Close.

To see the new menu, you must perform the following steps for adding a command to the menu.

To add a command to a menu

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Menus tab.
3. In the Menu Tree, select the menu to which you want to add the new command.
4. Choose Insert > Menu Sub-Item.
5. Type a name for the new command, and then press Enter.
6. Assign a command string to the command you added by doing one of the following:
   - In the Available Commands list, choose the command, and then click Add Command.
   - In the Command box, type the command string, and then click Add Command.
7. In the Help String box, type the text to be displayed in the status bar when the cursor is positioned over the new command.
8. To add another command, repeat steps 3 through 7.

9. When you have finished, click Close.

You can specify an access key by including an ampersand.

When you type the name of the command, include the ampersand (&) immediately preceding the letter you want to use as the access key. Be sure not to assign the same access key to more than one menu or command within a menu. For example, if you add a command named Quick Line to the Insert menu, including an ampersand immediately preceding the letter Q causes that letter to appear underlined in the menu. You can then select that command by displaying the menu and pressing the Alt+Q keys.

Add three ^C (Ctrl+C) characters before a command to cancel any active commands.

When a command is selected from a menu, these characters will cancel any active commands or dialogs.

To rename a menu item

1. Do one of the following to choose Customize:
   • On the ribbon, choose Tools > Customize (in Manage).
   • On the menu, choose Tools > Customize.
   • Type customize and then press Enter.

2. Click the Menus tab.

3. In the Menu Tree, select the menu item you want to rename.

4. Click Rename.

5. Type a new name for the menu item by typing over the highlighted name, and then press Enter.

6. Click Close.

To delete a menu item

1. Do one of the following to choose Customize:
   • On the ribbon, choose Tools > Customize (in Manage).
   • On the menu, choose Tools > Customize.
   • Type customize and then press Enter.

2. Click the Menus tab.

3. In the Menu Tree, select the menu item you want to delete.
4. Click Delete.
5. In the Confirmation dialog box, click Yes to delete the menu item.
6. Click Close.

Some menu items have sub-items below them.

Deleting a menu item that has sub-items below it in the Menu Tree also deletes all of those sub-items.

17.2.3 Setting the experience levels for menus

You can set the experience levels for menu items you create, and you can change the experience levels for existing commands.

To set the experience levels for a command

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Menus tab.
3. In the Menu Tree, select the command.
4. Click Options.
5. In the Menu Customization Options dialog box, under Experience Level, select the experience levels that you want for the command.
6. Click OK.
7. Click Close.

Select all the experience levels above the lowest level you want to use.

Intermediate without also selecting Advanced, the commands will appear only when you set the experience level to Intermediate.
17.2.4 Saving menu files

CAD.direct Drafter automatically saves any changes you make to the current menu. You can also create and save custom menus as files. You can choose to save a menu file in CUI format, ICM format, or MNU format.

Saving a menu does not save any toolbars that you created or modified.

For details about editing a .cui file manually after saving it, see “Customizing the main window using a .cui file” on page 642 in this chapter.

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.

2. Click the Menus tab.

3. Click Export.

4. In the Export Menu dialog box, specify the directory and file name you want to use to save the menu file.

5. In Files Of Type, select the desired format.

6. Click Save.

7. Click Close.

17.2.5 Loading menu files

You can replace the current menu file with other custom menus. The program loads Customizations (*.cui), AutoCAD (*.mnu, *.mns), and CAD.direct Drafter (*.icm) menu files.

For details about editing a .cui file manually before loading it, see “Customizing the main window using a .cui file” on page 642 in this chapter.

To load a menu file

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.

2. Click the Menus tab.
3. Click Import.

4. From the Files Of Type list, choose either *.icm, *.cui, *.mnu, or *.mns.

5. Select the menu to load.

6. Click Open.

7. Click Close.

_Loading a new menu replaces only the menu._

_It does not replace any custom toolbars you may have defined._

### 17.3 Customizing the ribbon

The Customize dialog box displays with a Ribbon tab for versions of CAD.direct Drafter that include a ribbon in the main drawing area. You can customize the ribbon and save your changes as a .cui file. You can also load .cui files.

The CUI format is the newest user interface format and also supports all legacy user interface elements such as menus, toolbars, tablet, etc. The CUI format is the only menu format the supports the ribbon interface, so if you are creating a menu file that will support the ribbon, use the CUI format.

#### 17.3.1 Creating a new ribbon tab and child panels

You can create a new ribbon tab by inserting a tab at the top level of the Ribbon Tree. Then you can add panels, or groups, to the new ribbon tab and add commands. You can also modify existing names and commands by adding, deleting, and rearranging them.

_Bullet colors indicate whether a command is available at the current experience level._

_A green bullet in front of a ribbon item or command indicates that the item is available; a red bullet indicates that the item is not available for you to use at the experience level you have set. To change your experience level, choose Tools > Options._
To create a new ribbon tab

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.

2. Click the Ribbon tab.

3. In the Ribbon Tree, select the ribbon tab name above which you want to add a new menu.

4. Choose Insert > Insert Tab.
5. Type a name for the new tab, and then press Enter.

6. Click Close.

Note that a blank tab will not appear. To see the new ribbon tab, you must perform the following steps for adding a panel and command to the ribbon.

**To add a panel and command to a ribbon tab**

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.

2. Click the Ribbon tab.

3. In the Ribbon Tree, select the ribbon tab to which you want to add the new panel and command.

4. Choose Insert > Insert Panel.

5. Type a name for the new panel, and then press Enter.

6. Select the panel.

7. Choose Insert > Insert Child Row.

8. Select the row item.

9. Choose Insert > Insert Child Command button.

10. Enter a name for the new command, and then press Enter.

11. Assign a command string to the command you added by doing one of the following:
   - In the Available Commands list, choose the command, and then click Add Command.
   - In the Command box, type the command string, and then click Add Command.

12. In the Help String box, type the text to be displayed in the status bar when the cursor is positioned over the new command.

13. To add another command, repeat the steps above.

14. When you have finished, click Close.

*Add three ^C (Ctrl+C) characters before a command to cancel any active commands.*

*When a command is selected from a ribbon, these characters will cancel any active commands or dialogs.*
To rename a ribbon item

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Ribbon tab.
3. In the Ribbon Tree, select the ribbon item you want to rename.
4. Click Rename.
5. Type a new name for the ribbon item by typing over the highlighted name, and then press Enter.
6. Click Close.

To delete a ribbon item

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Ribbon tab.
3. In the Ribbon Tree, select the ribbon item you want to delete.
4. Click Delete.
5. In the Confirmation dialog box, click Yes to delete the ribbon item.
6. Click Close.

Some ribbon items have sub-items below them.

Deleting a ribbon item that has sub-items below it in the Ribbon Tree also deletes all of those sub-items.
17.3.2 Setting the experience levels for commands on the ribbon

You can set the experience levels for commands on the ribbon.

**To set the experience levels for a command**

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Ribbon tab.
3. In the Ribbon Tree, select the command.
4. Click Options.
5. In the Ribbon Customization Options dialog box, under Experience Level, select the experience levels that you want for the command.
6. Click OK.
7. Click Close.

*Select all the experience levels above the lowest level you want to use.*

*Commands appear in the menu only at the experience levels you specify. If you select Intermediate without also selecting Advanced, the commands will appear only when you set the experience level to Intermediate.*

17.3.3 Saving the ribbon to a file

CAD.direct Drafter automatically saves any changes you make to the current ribbon. You can also create and save custom ribbons as files. Ribbon files are saved in CUI format.

Saving a ribbon does not save any menus or toolbars that you created or modified.

For details about editing a .cui file manually after saving it, see “Customizing the main window using a .cui file” on page 642 in this chapter.
To save the ribbon to a file

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Ribbon tab.
3. Click Export.
4. In the Export Ribbon dialog box, specify the directory and file name you want to use to save the menu file.
5. Click Save.
6. Click Close.

17.3.4 Loading ribbon files

You can replace the current ribbon with another custom ribbon by loading a customization (*.cui) file. For details about editing a .cui file manually before loading it, see “Customizing the main window using a .cui file” on page 642 in this chapter.

To load a ribbon file

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Ribbon tab.
3. Click Import.
4. Select the ribbon file (.cui file) to load.
5. Click Open.
6. Click Close.

*Loading a new ribbon replaces only the ribbon. It does not replace any custom menus or toolbars you may have defined. To import a ribbon, menus, and toolbars, click Import All in the Customize dialog box.*
17.4 Customizing toolbars

CAD.direct Drafter provides toolbars so that you can access frequently used commands. When a toolbar is turned on, it is always available, or on top, and in the same location so it is easy to find and use. However, toolbars occupy drawing display space and reduce the area available for working in drawings.

You can customize these toolbars by adding or removing tools or by rearranging the organization of tools. You can also create custom toolbars. You customize toolbars using the Customize dialog box and clicking the Toolbars tab.

17.4.1 Creating a new toolbar

You can create a new toolbar by dragging a tool from the Customize dialog box and dropping it anywhere except on another toolbar. CAD.direct Drafter immediately creates a new toolbar and assigns it a default name. Then you can add tools to the new toolbar. You can also add, delete, or modify tools on any existing toolbar.

When you create a toolbar using tools from the Buttons area of the Customize dialog box, the ToolTip, Help String, and Command fields are filled in automatically with default information. You can edit this information for each tool.
**To create a new toolbar**

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Toolbars tab.
3. In the Categories list, choose a category to display its associated tools.
4. Click and drag a tool outside the Customize dialog box and onto an open area of the screen.
5. Modify the ToolTip, Help String, and Command fields as needed.
6. Click Close.

*Add three `^C (Ctrl+C)` characters before a command to cancel any active commands.*

*When a command is selected from a toolbar, these characters will cancel any active commands or dialogs.*

**To add a tool to a toolbar**

1. Make sure the toolbar you want to modify is visible. 2. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
3. Click the Toolbars tab.
4. In the Categories list, choose a category to display its associated tools.
5. Click and drag a tool onto the toolbar.
6. Modify the ToolTip, Help String, and Command fields as needed.
7. To add another tool, repeat steps 4 through 6.
8. Click Close.
**To delete a tool from a toolbar**

Make sure the toolbar you want to modify is visible.

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.

2. Click the Toolbars tab.

3. Drag the tool you want to delete off of the toolbar.

4. Click Close.

**To add space between tools on a toolbar**

Make sure the toolbar you want to modify is visible.

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.

2. Click the Toolbars tab.

3. On the toolbar, drag the tool away from the tool beside it. To avoid accidentally deleting a tool, do not drag a tool more than halfway past the edge of the toolbar.

4. Click Close.

**17.4.2 Naming toolbars**

When you create a toolbar, the program assigns it an arbitrary name, such as ToolBar1, ToolBar2, and so on. When you hover over a floating toolbar, its name appears. You can rename a toolbar at any time.

In the Select Toolbars dialog box, you can rename toolbars, turn the display of toolbars on and off, choose to display large or small tools, choose to display toolbar tools in color or black and white, and control the display of ToolTips.
To rename a toolbar

1. Do one of the following:
   - On the ribbon, choose View > Toolbars (in Display).
   - On the menu, choose View > Toolbars.
   - Right-click anywhere on a toolbar (docked, undocked, or the toolbar area at the top of the window) to display the toolbar shortcut menu, and then choose Toolbars. You can also select the toolbars you want displayed directly on the shortcut menu.
   - Type tbconfig and then press Enter.

2. From the Toolbars list, choose the toolbar that you want to rename.

3. Click Rename.

4. Type a new name for the toolbar.

5. Click OK.
**17.4.3 Creating flyouts**

A flyout displays a set of additional tools under a single toolbar tool. CAD.direct Drafter uses flyouts to organize related tools and to conserve space on toolbars. A flyout is indicated by a small triangle in the lower right corner of a tool. When you click a flyout tool, the other tools on the flyout extend from the original tool so you can select one of them. The flyout tool you select then becomes the default tool on the toolbar. You can add your own flyouts to toolbars.

**To add a flyout to a toolbar**

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.

2. Click the Toolbars tab.

3. In the list, choose a toolbar name to display its associated tools in the Buttons area.

4. From the Buttons area, click and drag a tool outside the Customize dialog box and drop it onto an existing tool where you want to create a flyout. If the existing toolbar is horizontal, drop the new tool on the bottom of the existing tool. If the existing toolbar is vertical, drop the new tool on the right side of the existing tool.

5. Modify the ToolTip, Help String, and Command fields as needed.

6. To add another flyout tool, repeat steps 4 through 6.

7. Click Close.

**17.4.4 Setting the experience levels for tools**

You can set the experience levels for toolbar tools you create, and you can change the experience levels for existing tools.

**To set the experience levels for a tool**

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.

2. Click the Toolbars tab.
3. Go outside the Customize dialog box to a toolbar, and click a tool to select it.

4. Go back to the Customize dialog box, and click Options.

5. Under User Level, select the experience levels you want for that tool.

6. Click OK.

7. Click Close.

Select all the experience levels above the lowest level you want to use.

Tools appear in toolbars only at the experience levels you specify. If you select Intermediate without also selecting Advanced, the tool will appear only when you set the experience level to Intermediate.

17.4.5 Creating custom toolbar tools

CAD.direct Drafter provides tools for most of the available CAD.direct Drafter commands. These tools appear on the Toolbars tab of the Customize dialog box. You can also create your own custom tools and incorporate them into your custom toolbars. To add a custom tool to a toolbar, you must first add one of the program’s standard tools and then replace it on the toolbar with your custom tool.

You create custom tools as bitmap (*.bmp) files using any paint or illustration pro-gram capable of saving to a bitmap. Because you can configure toolbars to display either large or small tools and to display tools either in color or monochrome, create four different bitmaps for each custom tool. Create custom tools using the following dimensions:

- Small bitmaps: 16 x 16 pixels.
- Large bitmaps: 32 x 32 pixels.

For best results, bitmaps should be 32-bit ARGB format with an alpha transparent background.

Bitmaps that do not match these dimensions are stretched or reduced by the program to fit the specified size. The resulting tools may not appear as originally intended.

To customize a tool on a toolbar

Make sure the toolbar you want to modify is visible.

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Toolbars tab.

3. Go outside the Customize dialog box to a toolbar, and click a tool in the toolbar to select it.

4. Go back to the Customize dialog box, and click Options.

5. In the Toolbar Customization Options dialog box, under Button Bitmaps, click the browse tool (indicated by an ellipsis) adjacent to the Small, Color Button list to display the Select Bitmap dialog box.

   Note that black and white icons are used for high contrast which is used by color blind users or others with visual impairments. See Section 508 compliance.

6. Select the bitmap you want to use for the small color tool.

7. Click Open.

8. Repeat steps 5 through 7 for the Large Color Button, Small Black and White Button, and Large Black and White Button versions of your custom tool.

9. When you have finished, click OK.

10. Click Close.
17.4.6 Importing toolbars

Toolbars are saved as integral parts of CAD.direct Drafter. In CAD.direct Drafter, you can load tool-bars created as part of menu files (*.mnu, *.mns). Importing a menu file from the Toolbars tab of the Customize dialog box loads only the toolbar section of the menu file, not the current pulldown menus.

To import a menu file

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Toolbars tab.
3. Click Import.
4. Select the menu file that contains the toolbar settings you want to load.
5. Click Open.
6. Click Close.

Importing a menu file may replace custom toolbars. Importing a menu file from the Toolbars tab of the Customize dialog box replaces any custom toolbars you may have defined. Importing the menu file in this way, however, does not affect the current pulldown menus.

17.4.7 Creating toolbars that you can share as files

With CAD.direct Drafter, the easiest way to share toolbars is to export them to a file and share that file with other CAD.direct Drafter users. You can also manually create toolbars that you can share.

Toolbars can also be customized manually using .cui files. For more details, see “Customizing the main window using a .cui file” on page 642 in this chapter.

To save the current toolbars to a file

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Toolbars tab.

3. Click Export.

4. In the Select Toolbar dialog box, select the toolbars you want to export.

5. In the Select Toolbar File dialog box, specify the directory and file name you want to use to save the menu file.

6. In the Files Of Type list, select the desired format.

7. Click Save.

8. Click Close.

To manually create a toolbar that you can share

1. Open any ASCII or Unicode text editor.

2. Use the following toolbar syntax to type the toolbar definitions:

   ***MENUGROUP=group_name

   ***TOOLBARS **toolbar_name

   ID_toolbar_name [ _Toolbar ("toolbar_name", orient, visible, xval, yval, rows)]

   ID_button_name [ _Button ("button_name", id_small, id_large)]command

   ***HELPSTRINGS ID_button_name [help_string]
3. Save the file to the CAD.direct Drafter folder with a *.mnu extension. Example Toolbar File Contents ***MENUGROUP=example

***TOOLBARS **NewDraw

ID_ NewDraw [_Toolbar("NewDraw " , _Bottom, _Show, 200, 200, 1)] ID_Line_0 [_Button("Line", Iline.bmp, IL_line.bmp)]^C^C_line ID_Hatch [_Button("Hatch", Ihatch.bmp, IL_hatch.bmp)]^C^C_hatch ID_Dtext [_Button("Dtext", Idtext.bmp, IL_dtext.bmp)]^C^C_dtext ID__0 [_Button("Circle Rad", Icirad.bmp, IL_cirad.bmp)]^C^Ccircle; ID_Erase [_Button("Erase", Ierase.bmp, IL_erase.bmp)]^C^Cerase;

***HELPSTRINGS

ID_Line_0 [Creates straight line segments]
ID_Hatch [Fills an enclosed area with a non associative hatch pattern] ID_Dtext [Displays text on screen as it is entered]
ID__0 [Allows user to draw a circle with a radius value] ID_Erase [Removes objects from a drawing]

To copy an existing toolbar

1. Make sure the toolbar you want to copy is visible.

2. Do one of the following to choose Customize:
   • On the ribbon, choose Tools > Customize (in Manage).
   • On the menu, choose Tools > Customize.
   • Type customize and press Enter.

3. Click the Toolbars tab.

4. Go outside the Customize dialog box and select a tool on the existing toolbar that you want to copy.
5. Copy the information from the ToolTip, Help String, and Command boxes and paste it into the corresponding lines in the text file.

6. Save the file to the CAD.direct Drafter folder with a *.mnu extension.

**To open the toolbar file on another computer**

1. Copy the toolbar (MNU) file and all related custom bitmap (*.bmp) files to the CAD.direct Drafter folder on the other computer.

2. Open CAD.direct Drafter.

3. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and press Enter.

4. Click the Toolbars tab.

5. Click Import.


7. Select the Append To Current Menu check box, and then click Open.

If you don’t select this box, the custom shortcut menu deletes all current menus.

8. Click Close.

**To restore the toolbar defaults**

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and press Enter.

2. Click Reset.

**17.5 Customizing the keyboard**

CAD.direct Drafter provides keyboard shortcuts so you can access frequently used commands. You can customize these shortcuts and add new shortcuts using the Customize dialog box.
17.5.1 Customizing the keyboard

To customize the keyboard

1. Do one of the following to choose Customize:
   • On the ribbon, choose Tools > Customize (in Manage).
   • On the menu, choose Tools > Customize.
   • Type customize and then press Enter.

2. Click the Keyboard tab.

3. To define a new shortcut key, enter the shortcut in the Press New Shortcut Key box.

4. To define a new command string, enter the command string in the Command box.

5. To import an existing keyboard shortcut file, click Import.

6. To save a keyboard shortcut to a file, click Export.

7. To add a command selected in the Available Commands pane to the shortcuts, click Add Command.

8. To insert a new keyboard shortcut, click New.
17.5.2 Creating a keyboard shortcut

You can assign macros to special keys and certain combinations of keys to create a keyboard shortcut. A macro consists of one or more commands that are displayed on the status bar as follows:

- A single command, such as QSAVE.
- A command with options, such as ARC;\A;\.
- More than one command, such as ^C^C^CZOOM;E;QSAVE;QPRINT.

Keyboard shortcuts are more powerful than aliases. An alias lets you abbreviate a single command name; a keyboard shortcut contains one or more macros. To activate a macro, you press the shortcut key; you do not need to press Enter as you do with an alias. A shortcut consists of the following keys:

- The function and the cursor control keys, as well as alphanumeric keys pressed in combination with the Ctrl, Alt, and Shift keys. The Shift key must be used in conjunction with the Ctrl, Alt, and/or function keys.
- Alphanumeric keys are those labeled A through Z and 1 though 0.
- The cursor keys are the up, down, left, and right arrows and the Page Up, Page Down, Home, End, Insert, and Delete keys.
- The function keys are those labeled F1 through F12.

To create a keyboard shortcut

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Keyboard tab.
3. Click New.
4. In the Press New Shortcut Key field, press Alt+A. The program adds Alt+A to its list of Defined Keys.
5. In the Available Commands list, select Arc Center-Start-Angle.
6. Click Add Command.

The program adds the command to the Command field and enters the complete syntax for you:

^C^C^C_ARC;C;\A;
7. To save your changes and close the dialog box, click Close.

8. To activate the Arc command with the center, start, and angle options, press Alt+A.

**To redefine an existing keyboard shortcut**

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Keyboard tab.
3. In the Defined Keys list, select the shortcut you want to change.
4. In the Command field, change the command string assigned to the keyboard shortcut by doing one of the following:
   - Use the text cursor to delete the current command string, choose a new command in the Available Commands list, and then click Add Command.
   - Edit the command string in the Command field.
5. Click Close.

**To delete an existing keyboard shortcut**

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Keyboard tab.
3. In the Defined Keys list, select the shortcut you want to delete.
4. Click Delete.
5. Click Close.
17.5.3 Saving keyboard shortcut files

CAD.direct Drafter automatically saves any changes you make to the current keyboard short-cuts. You can also create and save your own keyboard shortcut files. The program saves keyboard shortcut files with the *.ick file extension.

To save the current keyboard shortcuts to a file

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Keyboard tab.
3. Click Export.
4. Specify the directory and file name you want to use to save the keyboard shortcut file.
5. Click Save.
6. Click Close.

17.5.4 Loading keyboard shortcut files

You can replace the current keyboard shortcut file with other custom keyboard short-cut files.

To load a keyboard shortcut file

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Keyboard tab.
3. Click Import.
4. Select the file to load.
5. Click Open.
6. Click Close.
17.6 Creating aliases

CAD.direct Drafter provides aliases for many commands. You can use aliases to issue frequently used commands by entering one or two letters rather than the entire command name.

The program also uses aliases to maintain command-name compatibility with AutoCAD. You can use the same aliases and keyboard shortcuts used by AutoCAD. In addition, CAD.direct Drafter has enhanced several AutoCAD commands. For example, CAD.direct Drafter added two useful options to the rectangle command: you can draw a rectangle as a square, and you can rotate a rectangle at an angle.

You can customize aliases, and you can add new aliases. You customize aliases using the Customize dialog box.

17.6.1 Creating, redefining, and deleting aliases

To create a new command alias, you first define the alias and then assign it one of the available CAD.direct Drafter commands.

To display the Customize dialog box

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Aliases tab.
To create a new alias

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Aliases tab.
3. Click New.
4. In the Alias field, type the new alias.
5. In the Available Commands list, select the command you want to assign to the alias.
6. Click Assign.
7. Click Close.
To redefine an existing alias

1. Do one of the following to choose Customize:
   • On the ribbon, choose Tools > Customize (in Manage).
   • On the menu, choose Tools > Customize.
   • Type customize and then press Enter.
2. Click the Aliases tab.
3. In the Aliases list, select the alias you want to change.
4. In the Available Commands list, select the command you want to assign to the alias.
5. Click Assign.
6. Click Close.

To delete an existing alias

1. Do one of the following to choose Customize:
   • On the ribbon, choose Tools > Customize (in Manage).
   • On the menu, choose Tools > Customize.
   • Type customize and then press Enter.
2. Click the Aliases tab.
3. In the Aliases list, select the alias you want to delete.
4. Click Delete.
5. Click Close.

17.6.2 Saving alias files

CAD.direct Drafter automatically saves any changes you make to the current aliases. You can also create and save your own alias files. The program saves alias files with the *.ica file extension. You can also save alias files for use with AutoCAD by saving the files with the *.pgp file extension.
To save the current aliases to a file

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.

2. Click theAliases tab.

3. Click Export.

4. From the Save As Type list, choose either *.ica or *.pgp.

5. Specify the directory and file name you want to use to save the alias file.

6. Click Save.

7. Click Close.

17.6.3 Loading alias files

You can replace the current alias file with other custom alias files. The program loads both AutoCAD (*.pgp) and CAD.direct Drafter (*.ica) alias files.

To load an alias file

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.

2. Click theAliases tab.

3. Click Import.

4. From the Files Of Type list, choose either *.ica or *.pgp.

5. Select the alias file to load.

6. Click Open.

7. Click Close.
17.7 Customizing the main window using a .cui file

Many users customize areas of the CAD.direct Drafter main window, namely menus and tool-bars, using the Customize command. Another method is to edit a single .cui file using any ASCII or Unicode text editor to contain the settings you want for the following areas of the CAD.direct Drafter main window:

- Ribbon
- Workspaces
- Menus
- Toolbars

17.7.1 Customizing a .cui file using an editor

A .cui file is an XML file format, which can be edited using any ASCII or Unicode text editor. However, it is best to edit .cui files using an XML editor such as Visual Studio or Notepad++. If you are developing with CAD.direct Drafter, you already have Visual Studio.

Use caution when manually editing a .cui file and use the following tips about the format of the file:

- Content of .cui files is case-sensitive. For example, the following is correct; no errors will be shown but ID attribute will be ignored:

  <ToolTip id="123">Help</ToolTip>

  The following is also correct; ID will be equal to 123:

  <ToolTip ID="123">Help</ToolTip>

- Content of .cui files contains special symbols, similar to an .xml file: & (ampersand), ‘ (quote), and more. Replace these special symbols with corresponding escape sequence or use XML CDATA structure instead. For example, the following is not correct:

  <ToolTip id="123">&Help</ToolTip>

  Correct:

  <ToolTip ID="123">&amp;Help</ToolTip>

  Not correct: <Command>’_HELP</Command>

  Correct: <Command> <![CDATA[’_HELP]]></Command>

- Properties of several entity types can be described in both node-style and attribute-style. For example, the following two toolbar buttons are the same:

  <ToolbarButton UID="unique-id" IsSeparator="true
To customize a .cui file using an editor

1. Do one of the following to choose Customize:
   - On the ribbon, choose Tools > Customize (in Manage).
   - On the menu, choose Tools > Customize.
   - Type customize and then press Enter.
2. Click the Menus tab, then click Export.
3. Specify the directory and file name you want to use to save the menu file.
4. In Save as Type, select CUI Customizations file (.cui).
5. Click Save, then Close.
6. In any ASCII or Unicode text editor, open the .cui file and make changes according to the following format.

   There are many editors, but if you are developing with CAD.direct Drafter, you already have Visual Studio, which is a good XML editor for .cui files.

17.7.2 Understanding versioning of a .cui file

Each .cui file has a node that controls versioning:

   <FileVersion MajorVersion="1" MinorVersion="2" UserVersion="0" IncrementalVersion="91"/>

   - IncrementalVersion Must be incremented with any change in the lcad.cui file.
   - UserVersion Incremented automatically when a user customizes CAD.direct Drafter. In the default lcad.cui file, this must be always equal to 0 and never edited manually.
   - MinorVersion Must be incremented with a change or creation of a versioned entity (PopMenu, Toolbar,
MenuMacro->Macro, ...).

- MajorVersion Must be incremented with the following:
- Change of Icad.cui file schema (for example, added/deleted sections or added new type of entities).
- Deletion of a versioned entity.
- Change of UID attribute of an existing versioned entity or change of Name
- If MajorVersion is incremented, the user’s case of a Workspace entity. .cui file will be replaced with an updated .cui file.

The .cui file also contains versioned entities: Workspace, MenuMacro->Macro, Pop-Menu, Toolbar, AppButton, QuickAccessToolbar, RibbonPanelSource, and RibbonTabSource. Each versioned entity also has a node:

```xml
<ModifiedRev MinorVersion="2"/>
```

After a versioned entity is modified or created, FileVersion->MinorVersion must be incremented, and then the result must be assigned to ModifiedRev->MinorVersion of the modified entity.
17.7.3 Understanding the format of a .cui file

A .cui file can contain settings for the following areas of the CAD.direct Drafter main window:

- Ribbon
- Workspaces
- Menus
- Toolbars

<table>
<thead>
<tr>
<th>CUI file format</th>
<th>Values (Default Value)</th>
<th>Required?</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FileVersion</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MajorVersion</td>
<td>4 byte integer</td>
<td>Yes</td>
<td>Major version of the .cui file. For details, see &quot;Understanding versioning of a .cui file&quot; on page 644 in this chapter.</td>
</tr>
<tr>
<td>MinorVersion</td>
<td>4 byte integer</td>
<td>Yes</td>
<td>Minor version of the .cui file. For details, see &quot;Understanding versioning of a .cui file&quot; on page 644 in this chapter.</td>
</tr>
<tr>
<td>IncrementalVersion</td>
<td>4 byte integer</td>
<td>Yes</td>
<td>Incremental version of the .cui file. For details, see &quot;Understanding versioning of a .cui file&quot; on page 644 in this chapter.</td>
</tr>
<tr>
<td>UserVersion</td>
<td>4 byte integer</td>
<td>Yes</td>
<td>User version of the .cui file. For details, see &quot;Understanding versioning of a .cui file&quot; on page 644 in this chapter.</td>
</tr>
<tr>
<td>AppButton</td>
<td></td>
<td></td>
<td>The application button.</td>
</tr>
<tr>
<td>UID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of an AppButton. Unique among all UIDs.</td>
</tr>
<tr>
<td>LargeImage</td>
<td>Text(&quot;&quot;)</td>
<td>No</td>
<td>Image resource ID of AppButton's icon or path to local file.</td>
</tr>
<tr>
<td>LargeImageHighContrast</td>
<td>Text(&quot;&quot;)</td>
<td>No</td>
<td>Image resource ID of AppButton's high contrast icon or path to local file.</td>
</tr>
<tr>
<td>Name</td>
<td>Text(&quot;**&quot;)</td>
<td>No</td>
<td>Name or tooltip of an AppButton.</td>
</tr>
<tr>
<td>AppButtonItem</td>
<td></td>
<td></td>
<td>Regular command button or separator line.</td>
</tr>
<tr>
<td>UID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of an AppButtonItem. Unique among all UIDs.</td>
</tr>
<tr>
<td>MenuMacroID</td>
<td>Text</td>
<td>Yes/No</td>
<td>ID of referenced MenuMacro. Not required in case of separator button. Required in all other cases.</td>
</tr>
<tr>
<td>IsSeparator</td>
<td>true/false(true)</td>
<td>No</td>
<td>Determines whether an item is a separator line or regular command button.</td>
</tr>
<tr>
<td>AppButtonPopItem</td>
<td></td>
<td></td>
<td>Sub-menu that contains a set of AppButtonItem items.</td>
</tr>
<tr>
<td>UID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of an AppButtonPopItem. Unique among all UIDs.</td>
</tr>
<tr>
<td>LargeImage</td>
<td>Text(&quot;&quot;)</td>
<td>No</td>
<td>Image resource ID of AppButtonPopItem's icon or path to local file.</td>
</tr>
<tr>
<td>LargeImageHighContrast</td>
<td>Text(&quot;&quot;)</td>
<td>No</td>
<td>Image resource ID of AppButtonPopItem's high contrast icon or path to local file.</td>
</tr>
<tr>
<td>Name</td>
<td>Text(&quot;**&quot;)</td>
<td>No</td>
<td>Name or tooltip of an AppButtonPopItem.</td>
</tr>
<tr>
<td>QuickAccessToolbar</td>
<td></td>
<td></td>
<td>The Quick Access toolbar.</td>
</tr>
<tr>
<td>UID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of a QuickAccess toolbar. Unique among all UIDs.</td>
</tr>
<tr>
<td>QuickAccessToolbarStandardItem</td>
<td></td>
<td></td>
<td>Regular command button.</td>
</tr>
<tr>
<td>UID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of a QuickAccessToolbarStandardItem. Unique among all UIDs.</td>
</tr>
<tr>
<td>MenuMacroID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of referenced MenuMacro.</td>
</tr>
<tr>
<td>Workspace</td>
<td></td>
<td></td>
<td>Consists of the following sections: WSRoot, WSToolbarRoot, and WSRibbonRoot.</td>
</tr>
<tr>
<td>DefaultWorkspace</td>
<td>true/false (false)</td>
<td>No</td>
<td>Whether a workspace is selected by default.</td>
</tr>
<tr>
<td>Name</td>
<td>Text</td>
<td>Yes</td>
<td>Name of workspace.</td>
</tr>
</tbody>
</table>
### CUI file format

<table>
<thead>
<tr>
<th>Item</th>
<th>Values (Default Value)</th>
<th>Required?</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WSPop</td>
<td>0/1 (0)</td>
<td>No</td>
<td>In-workspace declaration of a pop-menu.</td>
</tr>
<tr>
<td>Display</td>
<td></td>
<td>No</td>
<td>Whether to display (1) or not to display (0) pop-menu in the MenuBar.</td>
</tr>
<tr>
<td>pUID</td>
<td>Text</td>
<td>Yes</td>
<td>UID of a referenced pop-menu. Unique among all UIDs.</td>
</tr>
<tr>
<td>WSToolbar</td>
<td>0/1 (0)</td>
<td>No</td>
<td>In-workspace declaration of a toolbar.</td>
</tr>
<tr>
<td>Display</td>
<td></td>
<td>No</td>
<td>Whether to display (1) or not to display (0) a toolbar.</td>
</tr>
<tr>
<td>pUID</td>
<td>Text</td>
<td>Yes</td>
<td>UID of a referenced toolbar. Unique among all UIDs.</td>
</tr>
<tr>
<td>ToolbarOrient</td>
<td>top/left/bottom/right (float)</td>
<td>No</td>
<td>Toolbar orientation.</td>
</tr>
<tr>
<td>rows</td>
<td>4 byte integer (1)</td>
<td>No</td>
<td>Number of button rows for a toolbar.</td>
</tr>
<tr>
<td>xval</td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>X-coordinate of a toolbar (relative in case of docked toolbar).</td>
</tr>
<tr>
<td>yval</td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Y-coordinate of a toolbar (relative in case of docked toolbar).</td>
</tr>
<tr>
<td>WSRibbonTabSourceReference</td>
<td></td>
<td>No</td>
<td>In-workspace declaration of a ribbon tab. Consists of a set of WSRibbonPanelSourceReference items.</td>
</tr>
<tr>
<td>Show</td>
<td>true/false (false)</td>
<td>No</td>
<td>Whether to show or not to show a ribbon tab.</td>
</tr>
<tr>
<td>TabId</td>
<td>Text</td>
<td>Yes</td>
<td>UID of a referenced ribbon tab.</td>
</tr>
<tr>
<td>WSRibbonPanelSourceReference</td>
<td></td>
<td>No</td>
<td>In-workspace declaration of a ribbon panel.</td>
</tr>
<tr>
<td>Show</td>
<td>true/false (false)</td>
<td>No</td>
<td>Whether to show or not to show a ribbon panel.</td>
</tr>
<tr>
<td>PanelId</td>
<td>Text</td>
<td>Yes</td>
<td>UID of a referenced ribbon panel.</td>
</tr>
<tr>
<td>RibbonPanelSource</td>
<td></td>
<td></td>
<td>Ribbon panel definition. Consists of a set of RibbonRow items.</td>
</tr>
<tr>
<td>UID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of a RibbonPanelSource. Unique among all UIDs.</td>
</tr>
<tr>
<td>Name</td>
<td>Text</td>
<td>Yes</td>
<td>Name of a RibbonPanelSource.</td>
</tr>
<tr>
<td>RibbonSplitButton</td>
<td></td>
<td></td>
<td>Ribbon button with sub-items. Consists of RibbonCommandButton items.</td>
</tr>
<tr>
<td>UID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of a RibbonSplitButton. Unique among all UIDs.</td>
</tr>
<tr>
<td>ButtonStyle</td>
<td>LargeWithText/SmallWithoutText/SmallWithText (SmallWithoutText)</td>
<td>No</td>
<td>Style of a button.</td>
</tr>
<tr>
<td>RibbonCommandButton</td>
<td></td>
<td></td>
<td>Regular command button.</td>
</tr>
<tr>
<td>UID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of a RibbonCommandButton. Unique among all UIDs.</td>
</tr>
<tr>
<td>MenuMacroID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of referenced MenuMacro.</td>
</tr>
<tr>
<td>ButtonStyle</td>
<td>LargeWithText/SmallWithoutText/SmallWithText (SmallWithoutText)</td>
<td>No</td>
<td>Style of a button.</td>
</tr>
<tr>
<td>RibbonSeparator</td>
<td></td>
<td></td>
<td>Ribbon Separator element.</td>
</tr>
</tbody>
</table>
### CUI file format

<table>
<thead>
<tr>
<th>Item</th>
<th>Values (Default Value)</th>
<th>Required?</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>UID</strong></td>
<td>Text</td>
<td>Yes</td>
<td>ID of a RibbonSeparator. Unique among all UIDs.</td>
</tr>
<tr>
<td><strong>SeparatorStyle</strong></td>
<td>Line/Spacer (Spacer)</td>
<td>No</td>
<td>Separator style can be either a line or a spacer.</td>
</tr>
<tr>
<td><strong>RibbonControl</strong></td>
<td></td>
<td></td>
<td>Ribbon control. Can be one of these predefined types: color, linetype, lineweight, layer, print style, text style, or dimension style.</td>
</tr>
<tr>
<td><strong>UID</strong></td>
<td>rbnctrl-layer/rbnctrl-color/rbnctrl-linetype/rbnctrl-lineweight/rbnctrl-printstyle/rbnctrl-textstyle/rbnctrl-dimstyle</td>
<td>Yes</td>
<td>Unique among all UIDs. Any other UID is not allowed.</td>
</tr>
<tr>
<td><strong>RibbonTabSource</strong></td>
<td></td>
<td></td>
<td>Ribbon tab definition. Consists of a set of RibbonPanelSourceReference items.</td>
</tr>
<tr>
<td><strong>UID</strong></td>
<td>Text</td>
<td>Yes</td>
<td>ID of a RibbonTabSource. Unique among all UIDs.</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>Text</td>
<td>Yes</td>
<td>Name of a RibbonTabSource.</td>
</tr>
<tr>
<td><strong>MenuGroup</strong></td>
<td>Text (&quot;ICAD&quot;)</td>
<td>No</td>
<td>Name of a menu group.</td>
</tr>
<tr>
<td><strong>MenuMacro</strong></td>
<td></td>
<td></td>
<td>ID of a MenuMacro. Unique among all UIDs.</td>
</tr>
<tr>
<td><strong>UID</strong></td>
<td>Text</td>
<td>Yes</td>
<td>ID of a MenuMacro. Unique among all UIDs.</td>
</tr>
<tr>
<td><strong>Macro.Name.ID</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Text resource id of macro name. Used to extract localized text.</td>
</tr>
<tr>
<td><strong>Macro.Name</strong></td>
<td>Text (&quot;&quot;&quot;)</td>
<td>No</td>
<td>Default macro name.</td>
</tr>
<tr>
<td><strong>Macro.ToolTip.ID</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Text resource id of macro tooltip. Used to extract localized text.</td>
</tr>
<tr>
<td><strong>Macro.ToolTip</strong></td>
<td>Text</td>
<td>Yes</td>
<td>Default macro tooltip.</td>
</tr>
<tr>
<td><strong>Macro.HelpString.ID</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Text resource id of macro help string. Used to extract localized text.</td>
</tr>
<tr>
<td><strong>Macro.HelpString</strong></td>
<td>Text</td>
<td>Yes</td>
<td>Default macro help string.</td>
</tr>
<tr>
<td><strong>Macro.Command</strong></td>
<td>Text</td>
<td>Yes</td>
<td>Command of a macro.</td>
</tr>
<tr>
<td><strong>Macro.SmallImage</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Image resource id of small icon or path to local file.</td>
</tr>
<tr>
<td><strong>Macro.LargeImage</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Image resource id of large icon or path to local file.</td>
</tr>
<tr>
<td><strong>Macro.SmallImageHighContrast</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Image resource id of small high contrast icon or path to local file.</td>
</tr>
<tr>
<td><strong>Macro.LargeImageHighContrast</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Image resource id of large high contrast icon or path to local file.</td>
</tr>
<tr>
<td><strong>Macro.AcadToolbarConversion</strong></td>
<td>Text (&quot;&quot;&quot;)</td>
<td>No</td>
<td>Used to extract MenuMacro icon.</td>
</tr>
<tr>
<td>Item</td>
<td>Values (Default Value)</td>
<td>Required?</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>------------------------</td>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Macro.Visibility</td>
<td>Text</td>
<td>No</td>
<td>Determines the visibility of MenuMacro, constructed as a comma-separated concatenation of the following values, calculated with a logical OR applied to all values:</td>
</tr>
<tr>
<td>Visibility Value</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_LEV_BEG</td>
<td>User level: Beginner</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_LEV_INT</td>
<td>User level: Intermediate</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_LEV_EXP</td>
<td>User level: Expert</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_LEV_ALL</td>
<td>User level: Any</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_MDI_OPN</td>
<td>MDI Window: At least one open</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_MDI_CLS</td>
<td>MDI Window: No MDI windows</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_MDI_ALL</td>
<td>MDI Window: Either MDI state</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_OLE_SEM</td>
<td>OLE: Server, embedded</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_OLE_SIP</td>
<td>OLE: Server, in-place</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_OLE_CLI</td>
<td>OLE: Client</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_OLE_ALL</td>
<td>OLE: Any OLE state</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_VIS_ALL</td>
<td>CUI_LEV_ALL,CUI_MDI_ALL,CUI_OLE_ALL</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_SPL_RCM</td>
<td>Context (right-click) menu only</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_SPL_HIDE</td>
<td>Hide this menu or button</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_SPL_OSNAP</td>
<td>Temporary osnap mode (shift right click when command is active)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_SPL_CTRL</td>
<td>Button is a control]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_SPL_NOENT</td>
<td>Ignore all entity visibility flags]</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CUI_DEFAULT</td>
<td>Default visibility:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>CUI_LEV_ALL,CUI_MDI_OPN,CUI_MDI_CLS, CUI_OLE_CLI</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## CUI file format

<table>
<thead>
<tr>
<th>Item</th>
<th>Values (Default Value)</th>
<th>Required?</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Macro.EntityVisibility</td>
<td>Text (RCM_ENT_ALL)</td>
<td>No</td>
<td>Determines the entity visibility of Menu.Macro, constructed as a comma-separated concatenation of the following values, calculated with a logical OR applied to all values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><strong>Entity Visibility</strong> Value Description</td>
</tr>
<tr>
<td>RCM_ENT_PNT</td>
<td>Point</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_LIN</td>
<td>Line</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_RAY</td>
<td>Ray</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_XLN</td>
<td>XLine</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_ARC</td>
<td>Arc</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_CIR</td>
<td>Circle</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_ELL</td>
<td>Ellipse</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_SHP</td>
<td>Shape</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_TRC</td>
<td>Trace</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_SLD</td>
<td>Solid</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_3DF</td>
<td>3D Face</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_3DS</td>
<td>3D Solid</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_2DP</td>
<td>2D Polyline</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_3DP</td>
<td>3D Polyline</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_PFM</td>
<td>Polyface Mesh</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_3DM</td>
<td>3D Mesh</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_PLN</td>
<td>All types of polylines:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>RCM_ENT_2DP, RCM_ENT_3DP, RCM_ENT_PFM, RCM_ENT_3DM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_TXT</td>
<td>Text</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT INS</td>
<td>Insert</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_ATD</td>
<td>AttDef</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_DIM</td>
<td>Dimension</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_LDR</td>
<td>Leader</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_TOL</td>
<td>Tolerance</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_SPL</td>
<td>Spline</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_MTX</td>
<td>Mtext</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_MLN</td>
<td>Mine</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_GRP</td>
<td>Group</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_IMG</td>
<td>Image</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_VPT</td>
<td>Viewport</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_HAT</td>
<td>Hatch</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_RGN</td>
<td>Region</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_BDY</td>
<td>Body</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_XRF</td>
<td>Xreferences</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_ACS</td>
<td>All ACIS entities:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>RCM_ENT_3DS, RCM_ENT_RGN, RCM_ENT_BDY</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_ALL</td>
<td>Any entity</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RCM_ENT_MUL</td>
<td>Hide this item if multiple entities are selected</td>
<td>No</td>
<td>Controls whether the button or menu item is in checked state based on value of the system variable.</td>
</tr>
<tr>
<td>Item</td>
<td>Value (Default Value)</td>
<td>Required?</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------</td>
<td>-----------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Macro.GrayedOutExpression</td>
<td>Text (*)</td>
<td>No</td>
<td>Controls whether the button or menu item is grayed-out (disabled) based on the value of the system variable.</td>
</tr>
<tr>
<td>Macro.HideExpression</td>
<td>Text (*)</td>
<td>No</td>
<td>Controls whether the button or menu item is visible based on the value of the system variable.</td>
</tr>
<tr>
<td>PopMenu UID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of a PopMenu. Unique among all UIDs.</td>
</tr>
<tr>
<td>Alias</td>
<td>Text</td>
<td>Yes</td>
<td>Language independent tear-off-name, usually &quot;POPNN&quot; where NN is a number.</td>
</tr>
<tr>
<td>Name.ID</td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Text resource id of popup menu. Used to extract localized menu name.</td>
</tr>
<tr>
<td>Name</td>
<td>Text</td>
<td>Yes</td>
<td>Default popup menu name.</td>
</tr>
<tr>
<td>MenuItemMacroRef.Name</td>
<td>Text (*)</td>
<td>No</td>
<td>Default menu item name.</td>
</tr>
<tr>
<td>MenuItemMacroRef.Name</td>
<td>Text (*)</td>
<td>No</td>
<td>Id of a macro to be bound to this menu item.</td>
</tr>
<tr>
<td>pUID</td>
<td>Text</td>
<td>Yes</td>
<td>ID of a popup menu to be bound to this menu item as a sub-menu. Unique among all UIDs.</td>
</tr>
<tr>
<td>ToolTip.ID</td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Text resource id of menu item tooltip. Used to extract localized text.</td>
</tr>
<tr>
<td>ToolTip</td>
<td>Text</td>
<td>Yes</td>
<td>Default menu item tooltip.</td>
</tr>
<tr>
<td>HelpString.ID</td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Text resource id of menu item help string. Used to extract localized text.</td>
</tr>
<tr>
<td>HelpString</td>
<td>Text</td>
<td>Yes</td>
<td>Default menu item help string.</td>
</tr>
<tr>
<td>Visibility</td>
<td>Text (CUI_DEFAULT)</td>
<td>No</td>
<td>Determines the visibility of PopMenuRef, constructed as a comma-separated concatenation of values, calculated with a logical OR applied to all values. For details about available values, see &quot;Visibility Value Description&quot; on page 848 in this chapter.</td>
</tr>
<tr>
<td>EntityVisibility</td>
<td>Text (RCM_ENT_ALL)</td>
<td>No</td>
<td>Determines the entity visibility of PopMenuRef, constructed as a comma-separated concatenation of the values and calculated with a logical OR applied to all values. For details about available values, see &quot;Entity Visibility Value Description&quot; on page 849 in this chapter.</td>
</tr>
<tr>
<td>CheckedExpression</td>
<td>Text (*)</td>
<td>No</td>
<td>Controls whether the button or menu item is checked state based on value of the system variable.</td>
</tr>
<tr>
<td>GrayedOutExpression</td>
<td>Text (*)</td>
<td>No</td>
<td>Controls whether the button or menu item is grayed-out (disabled) based on the value of the system variable.</td>
</tr>
<tr>
<td>HideExpression</td>
<td>Text (*)</td>
<td>No</td>
<td>Controls whether the button or menu item is visible based on the value of the system variable.</td>
</tr>
</tbody>
</table>
# CUI file format

<table>
<thead>
<tr>
<th>Item</th>
<th>Values (Default Value)</th>
<th>Required?</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Toolbar</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>UID</strong></td>
<td>Text</td>
<td>Yes</td>
<td>ID of a Toolbar. Unique among all UIDs.</td>
</tr>
<tr>
<td><strong>ToolbarOrient</strong></td>
<td>float/top/left/right/bottom (float)</td>
<td>No</td>
<td>Specifies toolbar orientation.</td>
</tr>
<tr>
<td><strong>ToolbarVisible</strong></td>
<td>hide/show (hide)</td>
<td>No</td>
<td>Specifies whether to show or hide toolbar.</td>
</tr>
<tr>
<td><strong>rows</strong></td>
<td>4 byte integer (1)</td>
<td>No</td>
<td>Number of button rows for a toolbar.</td>
</tr>
<tr>
<td><strong>xval</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>X coordinate of a floating toolbar and zero-based position index of a docked toolbar.</td>
</tr>
<tr>
<td><strong>yval</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Y coordinate of a floating toolbar and zero-based position index of a docking row for a docked toolbar.</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>Text</td>
<td>Yes</td>
<td>Name of a toolbar.</td>
</tr>
<tr>
<td><strong>UseOwnIcon</strong></td>
<td>true/false (false)</td>
<td>No</td>
<td>Specifies whether to use single icon when toolbar is used as flyout.</td>
</tr>
<tr>
<td><strong>ToolbarButton</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>UID</strong></td>
<td>Text</td>
<td>Yes</td>
<td>ID of a ToolbarButton. Unique among all UIDs.</td>
</tr>
<tr>
<td><strong>IsSeparator</strong></td>
<td>true/false (false)</td>
<td>No</td>
<td>Defines whether the button is a separator.</td>
</tr>
<tr>
<td><strong>NameRef.ID</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Text resource id of button name. Used to extract localized button tooltip.</td>
</tr>
<tr>
<td><strong>NameRef</strong></td>
<td>Text (&quot;&quot;)</td>
<td>No</td>
<td>Default button name and tooltip.</td>
</tr>
<tr>
<td><strong>MenuCmd.MacroRef.MenuMacroID</strong></td>
<td>Text (&quot;&quot;)</td>
<td>No</td>
<td>ID of a macro to be bound to this button.</td>
</tr>
<tr>
<td><strong>ToolbarFlyout</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>pTargetId</strong></td>
<td>8 byte integer</td>
<td>Yes</td>
<td>ID of a popup menu to be bound to this item as a fly-out.</td>
</tr>
<tr>
<td><strong>ToolTip.ID</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Text resource id of tooltip. Used to extract localized text.</td>
</tr>
<tr>
<td><strong>ToolTip</strong></td>
<td></td>
<td>Yes</td>
<td>Default fly-out tooltip.</td>
</tr>
<tr>
<td><strong>HelpString.ID</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Text resource id of help string. Used to extract localized text.</td>
</tr>
<tr>
<td><strong>HelpString</strong></td>
<td>Text</td>
<td>Yes</td>
<td>Default fly-out help string.</td>
</tr>
<tr>
<td><strong>SmallImage</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Image resource id of small icon.</td>
</tr>
<tr>
<td><strong>LargeImage</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Image resource id of large icon.</td>
</tr>
<tr>
<td><strong>SmallImageHighContrast</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Image resource id of small high contrast icon.</td>
</tr>
<tr>
<td><strong>LargeImageHighContrast</strong></td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Image resource id of large high contrast icon.</td>
</tr>
<tr>
<td><strong>AcadToolbarConversion</strong></td>
<td>Text (&quot;&quot;&quot;)</td>
<td>No</td>
<td>Used to extract fly-out icon.</td>
</tr>
<tr>
<td><strong>Visibility</strong></td>
<td>Text (CUI_DEFAULT)</td>
<td>No</td>
<td>Determines the visibility of the fly-out, constructed as a comma-separated concatenation of values, calculated with a logical OR applied to all values. For details about available values, see &quot;Visibility Value Description&quot; on page 648 in this chapter.</td>
</tr>
<tr>
<td>Item</td>
<td>Values (Default Value)</td>
<td>Required?</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>------------------------</td>
<td>-----------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>EntityVisibility</td>
<td>Text (RCM_ENT_ALL)</td>
<td>No</td>
<td>Determines the entity visibility of the fly-out, constructed as a comma-separated concatenation of the values and calculated with a logical OR applied to all values. For details about available values, see “Entity Visibility Value Description” on page 649 in this chapter.</td>
</tr>
<tr>
<td>CheckedExpression</td>
<td>Text (&quot;&quot;)</td>
<td>No</td>
<td>Controls whether the button or menu item is in the checked state based on the value of the system variable.</td>
</tr>
<tr>
<td>GreyedOutExpression</td>
<td>Text (&quot;&quot;)</td>
<td>No</td>
<td>Controls whether the button or menu item is grayed-out (disabled) based on the value of the system variable.</td>
</tr>
<tr>
<td>HideExpression</td>
<td>Text (&quot;&quot;)</td>
<td>No</td>
<td>Controls whether the button or menu item is visible based on the value of the system variable.</td>
</tr>
<tr>
<td>ToolbarControl</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>UID</td>
<td>tblctrl-color/tblctrl-linetype/tblctrl-linewidth/tblctrl-printstyle/tblctrl-textstyle/tblctrl-dimensionstyle</td>
<td>Yes</td>
<td>ID of an AppButton. Unique among all UIDs. Any other UID is not allowed.</td>
</tr>
<tr>
<td>HelpString.ID</td>
<td>4 byte integer (0)</td>
<td>No</td>
<td>Text resource id of help string. Used to extract localized text.</td>
</tr>
<tr>
<td>HelpString</td>
<td>Text</td>
<td>Yes</td>
<td>Default control help string.</td>
</tr>
<tr>
<td>Visibility</td>
<td>Text (CUI_DEFAULT)</td>
<td>No</td>
<td>Determines the visibility of the toolbar, constructed as a comma-separated concatenation of the values, calculated with a logical OR applied to all values. For details about available values, see “Visibility Value Description” on page 648 in this chapter.</td>
</tr>
</tbody>
</table>
17.8 Customizing entities

CAD.direct Drafter provides ways to customize entities beyond common formats, dimensions, and layers. Further customization includes using custom audio notes and using custom shape files.

17.8.1 Working with audio notes

In CAD.direct Drafter you can record and attach audio notes, which are sound clips attached to entities and available for playback at any time. For example, audio notes in a factory floor plan can describe maintenance activities for specific areas of the factory and employees can play the audio notes to hear instructions.

When you include audio notes in your drawing, they are saved in the drawing file — not in a separate audio file. Note that this can increase the file size of your drawing. Audio notes created from an existing *.wav file are also saved in the drawing file and the separate *.wav file remains unchanged.

You can play audio notes in CAD.direct Drafter only.

17.8.2 Attaching audio notes

Audio notes can be created from existing *.wav files. You can also record an audio note using any microphone that works with your computer. Many computers have a built-in microphone. If you do not have a microphone and you record an audio note, the audio note will contain no sound.

An audio note icon displays on entities that have attached audio notes. The icon is for display only and cannot be selected.

To record and attach an audio note to entities

1. Do one of the following to choose Audio Note:
   - On the ribbon, choose Tools > Audio Note (in Manage).
   - On the menu, choose Tools > Audio Note.
   - On the Tools toolbar, click the Audio Note tool.
   - Type audionote and then press Enter.
2. Select the desired entities, and then press Enter.
3. Choose Record.
4. Click Record to begin the audio note, and then speak into the microphone.
5. Click Stop to end the audio note.
6. To test the audio note, click Test, and then use Pause and Stop in the Test Audio Note area.

7. If necessary, you can record the audio note again. This overwrites the previous audio note for the entities you selected in Step 2.

8. Click Attach.

*You can modify an audio note after you attach it to an entity.*

*Select the entity and re-record the audio note using the previous steps.*

**To attach an audio note to entities using a .wav file**

1. Do one of the following to choose Audio Note:
   
   - On the ribbon, choose Tools > Audio Note (in Manage).
   - On the menu, choose Tools > Audio Note.
   - On the Tools toolbar, click the Audio Note tool.
   - Type audionote and then press Enter.

2. Select the desired entities, and then press Enter.

3. Choose Attach.

4. Select the desired *.wav file, and then click Open.
17.8.3 Selecting audio notes

Audio notes themselves cannot be selected. Instead, you select the entity that corresponds to the desired audio note.

An audio note icon displays on entities that have attached audio notes. The icon is for display only and cannot be selected.

An audio note icon displays on an entity, signifying that an audio note is attached to the entity.

To select audio notes

1. Do one of the following to choose Audio Note:
   - On the ribbon, choose Tools > Audio Note (in Manage).
   - On the menu, choose Tools > Audio Note.
   - On the Tools toolbar, click the Audio Note tool.
   - Type audionote and then press Enter.

2. Select the entity that is attached to the desired audio note, and then press Enter. You cannot select the audio note icon that displays on the entity.

3. Choose an option to continue working with audio notes.

   Use the system variables.

   *You can change the appearance of audio note icons using the AUDIOICON, AUDIO-ICONCOLOR, and AUDIOICONSCALE system variables.*
**17.8.4 Playing audio notes**

**To play audio notes**

1. Do one of the following to choose Audio Note:
   
   - On the ribbon, choose Tools > Audio Note (in Manage).
   - On the menu, choose Tools > Audio Note.
   - On the Tools toolbar, click the Audio Note tool.
   - Type audionote and then press Enter.

2. Select the entity that has the audio note you want to play, and then press Enter.

3. Choose Playback.

4. In the Playback dialog box, do the following:
   
   - Click Play to begin playback.
   - To pause the audio note temporarily, click Pause and then click Resume to continue.
   - Click Stop to end playback.

5. Click OK.

**17.8.5 Deleting audio notes**

You can remove audio notes from selected entities. In some cases, you may want to remove extra audio notes to reduce the drawing file size.

When you remove an audio note from an entity, the audio note is removed permanently and cannot be recovered. However, if the audio note was created using an existing *.wav file, that *.wav file is not removed.

**To delete audio notes**

1. Do one of the following to choose Audio Note:
   
   - On the ribbon, choose Tools > Audio Note (in Manage).
   - On the menu, choose Tools > Audio Note.
   - On the Tools toolbar, click the Audio Note tool.
   - Type audionote and then press Enter.

2. Select entities that have the audio notes you want to delete, and then press Enter.

3. Choose Delete.
17.8.6 Using shape files

Shapes are entities that you define for use as drawing symbols and text fonts. You can specify the scale and rotation to use for each shape as you add it.

To use shape files, you first load the compiled shape file that defines the shape. Then you use insert shapes from the file into your drawing.

To load a shape file

1. Type load and then press Enter.
2. In the Load Shape File dialog box, select a shape file.
3. Click OK to close the Load Shape File dialog box.

To use a shape file

1. Type shape and then press Enter.
2. Type a shape name and press Enter.
3. Specify an insertion point.
4. Specify a height.
5. Specify a rotation angle.

17.9 Creating and replaying scripts

CAD.direct Drafter can record anything you type on the keyboard and any points you select in a drawing. You can save all of these actions to a script file (with the *.scr extension) and then repeat them by replaying the script. You can use scripts for successively repeating commands, showing snapshots in a slide show, or batch printing. You can also load and run script files created for use with AutoCAD.

17.9.1 Understanding scripts

CAD.direct Drafter supports most AutoCAD customization files, including menus, script files, and LISP routines. CAD.direct Drafter uses compatible linetypes, hatch patterns, units translation, and command aliases, but you can also substitute your own files for these. This feature allows you to continue to work with your favorite customized drafting environment.
A script is a form of text file. A script file contains one line of text or other data for each action. For example, when you type a command and press Enter, it is recorded on a line in the script file. When you select a point in a drawing, the coordinate of that point is recorded on a line in the script file. You can also create script files outside CAD.direct Drafter using a text editor (such as Microsoft® Notepad or Microsoft® WordPad) or a word-processing program (such as Microsoft® Word) that saves the file in ASCII format. The file type and extension must be .scr.

Script files can contain comments. Any line that begins with a semicolon is considered a comment. The program ignores these lines when replaying the script. The Undo feature reverses the last command performed by the script.

CAD.direct Drafter improves on scripts, AutoLISP, and ADS by providing additional functions. For scripts, CAD.direct Drafter includes a Script Recorder that records both command line entries and screen picks you make with your mouse.

### 17.9.2 Recording scripts

After you activate the Script Recorder, every keyboard entry you make and any points you select in a drawing are recorded until you stop the Script Recorder. You can play back your script at any time.

*CAUTION:*

_The Script Recorder does not record your use of toolbars, menus, or dialog boxes. Using these elements while recording a script causes unpredictable results._

**To record a script**

1. Do one of the following to choose Record Script:
   - On the ribbon, choose Tools > Record Script (in Applications).
   - On the menu, choose Tools > Record Actions > Record Script.
   - On the Tools toolbar, click the Record Script tool.
   - Type `recscript` and then press Enter.

2. Specify the name of the script file you want to create.

3. Click Save.

4. Type commands on the keyboard.

The Script Recorder records all keyboard entries and all points you select in the drawing, saving everything to the script file.
To stop recording

1. Do one of the following to choose Stop Recording:
   - On the ribbon, choose Tools > Stop Recording (in Applications).
   - On the menu, choose Tools > Record Actions > Stop Recording.
   - On the Tools toolbar, click the Stop Recording tool.
   - Type stopscript and then press Enter.

17.9.3 Replaying scripts

To replay a script

1. Do one of the following to choose:
   - On the ribbon, choose Tools > Run Script (in Applications).
   - On the menu, choose Tools > Record Actions > Run Script.
   - On the Tools toolbar, click the Run Script tool.
   - Type script and then press Enter.

2. In the Run Script dialog box, specify the name of the script file you want to run.

3. Click Open.

The program immediately runs the script, performing all the actions originally recorded.

*Double-click a script file.*

*To invoke a script automatically when you load CAD.direct Drafter, in Windows Explorer, double-click a script file.*

17.9.4 Modifying scripts

To append to a script

1. Do one of the following to choose Record Script:
   - On the ribbon, choose Tools > Record Script (in Applications).
   - On the menu, choose Tools > Record Actions > Record Script.
   - On the Tools toolbar, click the Record Script tool.
   - Type rescript and then press Enter.
2. In the Record Script dialog box, select the Append To Script check box.
3. Select the existing script file to append.
4. Click Save.
5. Click Yes to the prompt asking whether you want to replace the existing script.
6. Repeat the procedure to enter additional commands and steps.

17.10 Programming CAD.direct Drafter

Another way you can customize CADconv Connect is to add custom programs written in any of several programming languages that run within CAD.direct Drafter, including the following: TX, .NET, LISP, SDS, DCL, VBA and VSTA, and DIESEL.

In CAD.direct Drafter, you can run many programs originally created for use with AutoCAD. Specifically, you can use programs written entirely in AutoLISP with no modification. In addition, you can run many ADS programs originally written for use with AutoCAD after first recompiling them using the CAD.direct Drafter runtime libraries. Many AutoCAD third-party programs are compatible with CAD.direct Drafter.

Use the online Help.

For information about programming for CAD.direct Drafter, see the online Help for the IntelliCAD Developer’s Reference.

17.10.1 Using TX

The TX interface is available for developers to create custom entities and applications.

To load a TX/IRX custom application Advanced experience level

1. Do one of the following:
   - On the ribbon, choose Tools > Load Application (in Applications).
   - On the menu, choose Tools > Load Application.
   - Type appload and then press Enter.
   - Drag and drop the TX or IRX file into CAD.direct Drafter.
2. In the Load Application Files dialog box, click Add File.
3. Select the TX or IRX file that you want to load, and then click Open.
4. Click OK.
To run a TX/IRX custom application

Advanced experience level

1. Do one of the following:
   - On the ribbon, choose Tools > Load Application (in Applications).
   - On the menu, choose Tools > Load Application.
   - Type appload and then press Enter.

2. In the Load Application Files dialog box, choose the routine you want to run (make sure that it is the only one selected), and then click Load.

For more information

- See the sample TX and IRX applications.
- Read the online documentation for TX and IRX, available in the Developer Reference of CAD.direct Drafter Help.

17.10.2 Using .NET applications

CAD.direct Drafter supports the .NET programming language in two ways:

- .NET Classic — More closely matches the .NET interface used by AutoCAD.
- .NET based on COM — Initial .NET interface supported by CAD.direct Drafter.

To prepare a .NET custom application

1. In the .NET application, inherit the IIcadPlugin interface that is defined in CAD.direct Drafter as:

   ```csharp
   public interface IIcadPlugin
   {
   
   void PluginLoaded(object sender, EventArgs e);

   void PluginUnLoading(object sender, EventArgs e);
   }
   
   Where PluginLoaded is called on plug-in load, the sender argument is a COM Interop model class CAD.direct Drafter.Application for working with (storing it as a class member), and PluginUnLoading is called right before the plug-in is unloaded.

To load a .NET Classic custom application
1. Do one of the following:
   • On the menu, choose Tools > Load Classic .NET Application.
   • Type netloadclassic and then press Enter.

2. In the Open an Assembly dialog box, select the .NET .dll file that you want to load, and then click Open.

**To automatically load a .NET Classic custom application when CAD.direct Drafter Starts**

1. Create an ASCII file named ICAD.NET that contains the path to a .NET plug-in file on each line of the file.
2. Place ICAD.NET in the same folder as ICAD.EXE.
3. Run CAD.direct Drafter.

**To load a .NET custom application based on COM**

1. Do one of the following:
   • On the ribbon, choose Tools > Load .NET Application (in Applications).
   • Type netload and then press Enter.
2. Select the .NET .dll file that you want to load, and then click Open.
3. Click OK.

**17.10.3 Using LISP routines**

CAD.direct Drafter supports the LISP programming language and is compatible with AutoLISP, the implementation of the LISP language in AutoCAD. This means that you can load and run any AutoLISP program written for use with AutoCAD.

**To load a LISP routine**

Advanced experience level

1. Do one of the following:
   • On the ribbon, choose Tools > Load Application (in Applications).
   • On the menu, choose Tools > Load Application.
   • Type appload and then press Enter.
Drag and drop the LISP file into CAD.direct Drafter.

2. In the Load Application Files dialog box, click Add File.

3. Select the LISP file that you want to load, and then click Open.

4. Click OK.

17.10.4 Load LISP routines from the command bar.

In the command bar, type `(load "d:/path/routine.lsp")`, making sure to include the parentheses and the quotation marks, where d:/path is the drive and path where the LISP routine is located on your computer, and routine.lsp is the LISP routine file name.

To run a LISP routine

Advanced experience level

1. Do one of the following:
   - On the ribbon, choose Tools > Load Application (in Applications).
   - On the menu, choose Tools > Load Application.
   - Type `appload` and then press Enter.

2. In the Load Application Files dialog box, choose the routine you want to run (make sure that it is the only one selected), and then click Load.

Some LISP routines are created in such a way that you can run them by simply typing the name of the routine, or by typing a keyword, directly in the command bar. If nothing happens when you attempt to run the LISP routine from within the Load Application Files dialog box, turn on the display of the command bar or Prompt History window by choosing View > Display > Command Bar or View > Display > Prompt History Window, and look for an entry that is similar to the following:

`Loading D:\path\routine.lsp`

`C:KEYWORD`

where D:\path\routine.lsp is the complete drive, path, and file name of the LISP routine. You may need to scroll back several lines in the command bar or Prompt History window to find the lines indicating where the LISP routine was loaded. You can run the LISP routine by typing the name of the routine or keyword appearing after the C drive designation.

For example, if you loaded a LISP routine named drawbox.lsp and see the designation C:DRAWBOX in the command bar or Prompt History window, you can run the LISP routine by typing drawbox in the command bar.
17.10.5 Using SDS applications

To write AutoCAD applications in C or C++, Autodesk® uses the ADS (AutoCAD Development System). This is an API (applications programming interface) that provides a library to access AutoCAD-specific functions and drawing data.

The equivalent in CAD.direct Drafter is called SDS™, the Solutions Development System™. SDS is a C/C++ language interface compatible with the ADS interface in AutoCAD. Like scripts and AutoLISP, you can run your existing ADS applications in CAD.direct Drafter. Simply recompile the source code using the SDS libraries provided on the CAD.direct Drafter CD-ROM, or, if you use an AutoCAD program written by a third-party vendor, contact that vendor for the CAD.direct Drafter version.

CAD.direct Drafter provides the Sds.H file, which redefines ADS function names to their SDS equivalents. SDS supports the AutoCAD dialog control language (DCL), which is used by ADS to define the look of a dialog box. You can use all DCL files unmodified within SDS.

Understanding SDS compatibility

The primary difference between ADS and SDS is that all SDS functions have an sds_ prefix, and ADS functions have a variety of prefixes, such as ads_, acad_, and acrx_. The exception is dialog-related SDS functions, which have a dlg_ prefix. CAD.direct Drafter accepts either prefix. Other differences include the additional SDS functions listed in the following table.

<table>
<thead>
<tr>
<th>SDS function name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sds_grclear</td>
<td>Clears all graphics from the drawing window; similar to the LISP (grclear) function.</td>
</tr>
<tr>
<td>sds_name_clear</td>
<td>Clears the entity name or selection set.</td>
</tr>
<tr>
<td>sds_name_equal</td>
<td>Verifies whether two entity names or selection sets are equal.</td>
</tr>
<tr>
<td>sds_name_nil</td>
<td>Verifies whether the entity name or selection set has been cleared.</td>
</tr>
<tr>
<td>sds_name_set</td>
<td>Copies one entity name or selection set to another drawing.</td>
</tr>
<tr>
<td>sds_pmtssget</td>
<td>Similar to the ads_sssget function, but allows you to display a prompt appropriate for the specific command, rather than the generic “Select object” prompt.</td>
</tr>
<tr>
<td>sds_point_set</td>
<td>Copies a point from one variable to another.</td>
</tr>
<tr>
<td>sds_progresspercent</td>
<td>Displays the percentage done in a progress bar.</td>
</tr>
<tr>
<td>sds_progressstart</td>
<td>Starts the progress bar.</td>
</tr>
<tr>
<td>sds_progressstop</td>
<td>Ends the progress bar.</td>
</tr>
<tr>
<td>sds_readaliasfile</td>
<td>Loads the PGP file into CAD.direct Drafter.</td>
</tr>
<tr>
<td>sds_sendmessage</td>
<td>Sends a message to the CAD.direct Drafter command line. Flips</td>
</tr>
<tr>
<td>sds_swapscreen</td>
<td>the off-screen device context to the display.</td>
</tr>
</tbody>
</table>
Some ADS functions are not supported in SDS, including: `ads_arxload`, `ads_arxloaded`, `ads_arxunload`, `ads_ssgetx`, `ads_ssGetKwordCallbackPtr`, `ads_ssGetOtherCallbackPtr`, `adsw_acadMainWnd`, and `adsw_acadDocWnd`.

For more information

- Read the online documentation for SDS functions.
- See the \CAD.direct Drafter\Api\Sds folder, which contains the SDS include, header, and library files.
- See the \CAD.direct Drafter\Api\Dcl folder, which contains the core DCL files.

17.10.6 Using DDE applications

CAD.direct Drafter supports the DDE API, which allows you to execute CAD.direct Drafter commands at the command line from an external application. CAD.direct Drafter includes a sample command-line application that reads a script file and sends it to CAD.direct Drafter for step-by-step execution.

To see a sample of DDE script execution

1. Compile the source code of the DDESample project. The sample application is Source\CAD.direct Drafter\api\DDE\Samples
2. Run CADconv Connect.
3. Run the DDESample application with the sample script file that is included in the VC project.

CAD.direct Drafter shows the results.

Using DCL with CAD.direct Drafter completely supports the AutoCAD DCL (dialog control language). DCL is used by AutoLISP functions to define the look of dialog boxes. You can use all DCL files unmodified within CAD.direct Drafter.

17.10.7 Using VBA and VSTA

CAD.direct Drafter can be customized using Visual Basic for Applications (VBA) and Visual Tools for Applications (VSTA) through an integrated interface, available from the CAD.direct Drafter Tools menu. CAD.direct Drafter features a broad range of objects, giving you the power to write your own custom applications that can run within CAD.direct Drafter.
To load a VBA project
Advanced experience level

1. Do one of the following:
   • On the ribbon, choose Tools > Load VBA Project (in Applications).
   • On the menu, choose Tools > Visual Basic > Load VBA Project.
   • Type vbiload and then press Enter.

2. Locate and select the Visual Basic project file (.vbi file) to load, then click Open.

To run a VBA macro
Advanced experience level

1. Do one of the following:
   • On the ribbon, choose Tools > Macros (in Applications).
   • On the menu, choose Tools > Visual Basic > Macros.
   • Type vbarun and then press Enter.

2. In the Run CAD.direct Drafter VBA Macro dialog box, enter the name of an existing VBmacro, and then click Run.

   You can also create, delete, and edit VBA macros from this dialog box.

To edit a VBA macro
Advanced experience level

1. Do one of the following:
   • On the ribbon, choose Tools > Visual Basic Editor (in Applications).
   • On the menu, choose Tools > Visual Basic > Visual Basic Editor.
   • Type vba and then press Enter.

2. Use the Visual Basic Editor to write or debug VBA macros.
To load a VSTA project

Advanced experience level

1. Do one of the following:
   - On the ribbon, choose Tools > VSTA Add-In Manager (in Applications).
   - Type vstaload and then press Enter.
2. Click Add.
3. Locate and select the VSTA application (.dll file) to load, then click Open.

To run a VSTA method

Advanced experience level

1. Type -vstarun and then press Enter.
2. Enter the name of the method to run, for example: C:\App.dll!MyMacro.

The macro name uses the following format:
<file_name>[!<macro_name>]

where:
<file_name> is the path to an external dll.
<macro_name> is the name of the dll method to run.

To run a .NET application

Advanced experience level

1. Do one of the following:
   - Type netload and then press Enter.
2. Locate and select the .NET .dll file, then click Open.
Unload a .NET application.

Type netunload and specify the .NET DLL application filename to unload, for example, c:\App.dll.

For more information

- Read the online documentation for VBA and VSTA, available both from the editor Help menu and from the CAD.direct Drafter Help menu.
- Many publications are available that explain how to program in VBA and VSTA.

17.10.8 Using DIESEL with CAD.direct Drafter

supports AutoCAD DIESEL (Direct Interactively Evaluated String Expression Language). DIESEL is a separate interpretive programming language that allows you to customize the following:

- Status bar
- Menus
- LISP functions

For more information

- Read the online documentation for DIESEL, available from the CAD.direct Drafter Help.
- Several publications and tutorials are available online that explain how to use DIESEL.
17.11 Using a digitizer tablet

CAD.direct Drafter supports tablets compatible with the Tablet Works driver and has its own tablet overlay. For instructions on installing the tablet driver and using the buttons on your pointing device, refer to your hardware documentation.

Three options are available with the Tablet command:

- **Configure** Maps the tablet overlay to the tablet itself. Configure the tablet if you plan to select CAD.direct Drafter tools from the tablet overlay.
- **Calibrate** Maps points on the tablet, in absolute coordinates, to points on a drawing. Calibrate the tablet if you intend to digitize points. This process is convenient for tracing paper drawings.
- **Tablet ON/OFF** Turns tablet calibration (digitizer mode) on and off. Use this to switch between tool selection and digitizer input. To use the tablet for tool selection, tablet mode must be turned off.

17.11.1 Configuring the tablet

Before you begin to configure the tablet, slip the tablet overlay underneath the tablet’s plastic cover, and align it in accordance with the directions for your tablet. If your tablet does not have a plastic cover, aliCAD.direct Drafter provides a default configuration for tablets measuring 12” by 12”. If you choose to accept the default, be sure to verify that the commands in the grid are activated correctly. If the default alignment does not work for your tablet, you’ll need to begin the configuration process again and align the tablet yourself.

**To configure the tablet for menu input**

1. Do one of the following:
   - On the menu, choose Tools > Tablet > Configure.
   - Type tablet, choose Configure, and then press Enter.
2. In response to the prompt to align the tablet, do one of the following:
   - If your tablet is 12” by 12”, choose No to accept the default alignment and conclude the configuration process.
   - To align the tablet yourself, choose Yes, and then continue with step 3.
3. Click the tablet pointer on the upper left alignment point of the overlay.
4. Click the tablet pointer on the lower left alignment point of the overlay.
5. Click the tablet pointer on the lower right alignment point of the overlay.
6. Click the tablet pointer on the lower left alignment point of the Workspace area of the overlay.
7. Click the tablet pointer on the upper right alignment of the Workspace area of the overlay.

![Image](image-url)

Click points in the order shown to configure your tablet for menu input.

**To turn tablet mode on or off**

1. Do one of the following:
   - Choose Tools > Tablet > Tablet On (or Tablet Off).
   - Type tablet, choose On or Off, and then press Enter.
   - Press the F4 key to toggle tablet mode on or off.
   - On the status bar, double-click TABLET to turn tablet mode on or off.

**17.11.2 Calibrating the tablet**

You must specify at least two points for tablet calibration. However, the more points you specify, the more accurate the transformation between the tablet and the screen points. Specifying additional points is particularly useful if you plan to trace a paper drawing that is not orthogonal, such as an aerial photograph.
17.11.3 Understanding transformation types

Depending on the number of points specified, you have a choice of transformation types to use, along with the type recommended for CAD.direct Drafter.

Transformation refers to the calculation of the points on the screen that correspond to points you digitize on the tablet.

- **Orthogonal** Preserves all angles between lines, preserves all relative distances, and, in general, preserves shapes. If you specify only two points, an orthogonal transformation is automatically generated. The orthogonal transformation type yields the most precise mapping between the digitized points on the tablet and the corresponding points on the screen.

- **Affine** Preserves parallel lines, but not necessarily the angles between intersecting lines. If you specified three points, CAD.direct Drafter can no longer represent this mapping as an exact orthogonal transformation. Therefore, you have a choice of an exact affine transformation or a “best fit” orthogonal transformation.

- **Projective** Does not preserve parallel lines or angles. If you specify exactly four points, you have a choice of an exact projective transformation or a “best fit” orthogonal or affine transformation.

Choose the recommended type unless you know it will not be appropriate for what you are digitizing. The most appropriate type is not always the one with the least error; for example, you might digitize three points and select the orthogonal transformation, even though the affine transformation would yield a closer representation of your calibration entries.
Digitizing by selecting points (1, 2, 3, and 4) on the tablet.

Corresponding screen coordinates:
1 Coordinate specification X0, Y0, Z0
2 Coordinate specification X0, Y5, Z0
3 Coordinate specification X5, Y5, Z0
4 Coordinate specification X5, Y0, Z0

Screen result of orthogonal transformation after tracing polyline on tablet.
Screen result of affine transformation after tracing polyline on tablet.
Screen result of projective transformation after tracing polyline on tablet.
To calibrate your tablet for digitizing points

1. Do one of the following:
   • Choose Tools > Tablet > Calibrate.
   • Type tablet, choose Calibrate, and then press Enter.

2. Click a point on the tablet to define as the first calibration point.

3. Specify a point within the CAD.direct Drafter drawing window to correspond to the poi you digitized on the tablet, or enter coordinate values in the command bar.

4. Click a point on the tablet to define as the second calibration point.

Specify a point within the CAD.direct Drafter drawing window to correspond to the point you digitized on the tablet, or enter coordinate values in the command bar. To specify more than the two points required, click a point on the tablet to define as the third calibration point. You can enter up to 10 points.

5. Choose the transformation type, and then press Enter.

17.11.4 Customizing the tablet interface

You can customize the digitizer tablet interface by using the LISP commands integrated with CAD.direct Drafter, even if you are not familiar with LISP. For instructions, see “Customizing the Tablet Interface” in the CAD.direct Drafter online Help.
Glossary

2D,
Two-dimensional locations defined by x- and y-coordinates.

3D,
Three-dimensional locations defined by x-, y-, and z-coordinates.

3D solids,
Three-dimensional ACIS entity.

absolute coordinates,
Coordinates defined in relation to the origin point of the current user coordinate system. See also coordinate system, coordinates, origin, relative coordinates, user coordinate system, and World Coordinate System.

ActiveX,
A mechanism for exchanging information between different programs whereby a copy of a source document is embedded or a pointer to a source document is linked to a target document. See also embed and link.

acute angles,
Angles of fewer than 90 degrees.

alias,
An abbreviation or alternative word for a CAD.direct Drafter command.

aligned dimension,
A dimension aligned parallel to an entity or measuring the distance between two points at any angle.

angle,
The difference in direction between two nonparallel linear entities, measured in degrees or radians.

angular dimension,
A dimension measuring the angle between two lines or subtended by an arc.

angular unit,
The unit of measurement for angles. Angular units can be measured in decimal degrees, degrees/minutes/seconds, grads, and radians.

annotation,
Any text, dimensions, tolerances, or notes added to a drawing.
ANSI,
    Acronym for American National Standards Institute. In the context of text, a standard character set defined by ANSI used in computer-aided drafting. arc A segment of a circle or ellipse.

area,
    Measurement of a planar region or the calculated space within an entity.

array,
    Multiple copies of selected entities in a circular or rectangular pattern.

ASCII,
    Acronym for American Standard Code for Information Interchange, a commonly used system for assigning numbers to printable alphanumeric characters, punctuation, and symbols.

attribute,
    A component of a block containing specific text or numeric information. You can copy the information contained in an attribute from the drawing to an external database.

attribute definition,
    An entity composed of a name, prompt for information, display characteristics, and default text that, when incorporated into a block, creates an attribute when the block is inserted into a drawing.

attribute name,
    Text that identifies an attribute within a block.

attribute text,
    The text containing an attribute’s information within a block.

B-spline curve,
    See spline.

base point,
    A point on an entity that serves as its reference or insertion point. A point of reference when specifying relative distances.

baseline,
    The line on which text characters appear to sit. The descenders of individual characters drop below the baseline.

baseline dimension,
    Multiple parallel dimensions measured from the same baseline origin.

bind,
    To convert an externally referenced drawing into a standard block definition.
**blips,**
Temporary screen markers displayed in a drawing when you select a point. Also called *marker blips.*

**block,**
One or more entities grouped together to create a single entity. See also *nested block.*

**block definition,**
The name, base point, and entities grouped together when creating a block.

**boundary polyline,**
A selected area bounded by a single closed entity or by multiple entities that intersect.

**BYBLOCK,**
A property whereby an entity inherits the color, linetype, lineweight, or print style of any block that contains it.

**BYLAYER,**
A property whereby an entity inherits the color, linetype, lineweight, or print style of its associated layer.

**CAD,**
Acronym for computer-aided design.

**Cartesian coordinates,**
Coordinates defined using three perpendicular axes (x, y, and z) to define locations in three-dimensional space. See also *cylindrical coordinates,* *polar coordinates,* and *spherical coordinates.*

**center line,**
A line used to indicate the center of a circle or an arc, usually consisting of a center mark and lines extending slightly beyond the diameter of the circle or the arc.

**center mark,**
A cross marking the center of a circle or an arc.

**chamfer,**
A beveled edge between two lines.

**chord,**
A line connecting two points on a circle or an arc.

**circumference,**
The measurement of the distance around a circle.

**closed,**
A condition whereby the start point and endpoint of an entity are the same.
color-dependent print style table,
A collection of print styles that determine how entities print according to their assigned color. See print style table.

comma-delimited,
Data that is separated by a comma to represent the end of a field.

command bar,
A dockable window in which you type CAD.direct Drafter commands and view prompts and other program messages.

cone,
A three-dimensional entity where a vertex exists above or below the circular shape and where a surface has been applied between the vertex and the circular shape.

contiguous,
Connected, unbroken, or uninterrupted. Entities that share the same endpoint.

continued dimension,
A dimension measured from the previous extension line of an existing dimension, resulting in two or more dimensions positioned end to end.

control point,
A point used to define a spline.

Coons patch,
A surface interpolated among three or four boundary curves.

coordinate filter,
A function that extracts individual x-, y-, and z-coordinate values from different points to create a new composite point.

coordinate system,
A system of points that represents the drawing space in relation to an origin (0,0,0) and a set of axes that intersect at the origin. In two dimensions, the x- and y-axes represent horizontal and vertical directions, respectively. In three dimensions, the z-axis represents locations above and below the two-dimensional xy plane. Locations in the drawing can be represented using two-dimensional and three dimensional rectangular (Cartesian) coordinates, two-dimensional polar coordinates, three-dimensional polar (cylindrical) coordinates, and three-dimensional spherical coordinates. See also polar coordinates, relative coordinates, spherical coordinates, user coordinate system, and World Coordinate System.

coordinates,
A set of values that determines a location in two-dimensional or three dimensional space. See also ab-
solute coordinates, Cartesian coordinates, polar coordinates, relative coordinates, and spherical coordinates.

coplanar,
Lying within the same plane.

crosshairs,
A cursor that consists of two or three lines that intersect at the cursor location.

crosshatch,
To fill an area with a pattern of evenly spaced perpendicular lines. See also hatch.

crossing circle,
An entity-selection method that selects entities contained within or crossing the boundary of a circular selection window.

crossing polygon,
An entity-selection method that selects entities contained within or crossing the boundary of a polygon selection window.

crossing window,
An entity-selection method that selects entities contained within or crossing the boundary of a rectangular selection window.

cube,
A boxed, three-dimensional, geometric shape where length, width, and height are equal.

cursor,
The insertion-point symbol on the screen. The appearance of the cursor changes based on the current task.

curve,
A smooth, continuous path made up of linear and arc segments. Curve types include arcs, splines, circles, and ellipses.

cylindrical coordinates,
Coordinates describing a point in three-dimensional space based on its distance from the origin, its angle in the xy plane, and its z-coordinate value. See also polar coordinates and spherical coordinates.

datum-line dimensioning,
See ordinate dimension.

default,
An initial or predefined setting.
**detach,**
To remove an external reference from a drawing. See also **external reference**.

**diameter,**
The distance across a circle or sphere.

**digitizer tablet,**
A hardware input device that incorporates an electronic pad and a hand-held pointer similar to a mouse. A digitizer tablet serves two purposes: (1) You can select tools from paper representations attached to the pad (called an overlay), providing access to all tools at once while freeing your screen space; and (2) you can input digital points into the computer that correspond to points on a paper drawing, photograph, or blueprint attached to the pad.

**dimension,**
A measurement, as in height or width. In the context of drafting, a set of lines, arrowheads, and text used to indicate a measurement.

**dimension style,**
A named group of dimension variable settings that determines the appearance of the dimension. You can save multiple dimension styles for reuse.

**dimension text,**
The measurement value. Dimension text can include prefixes, suffixes, tolerances, and other annotations.

**dimension text rotation,**
The angle in degrees between the x-axis and the dimension text baseline.

**dimension tolerance,**
A value specifying the allowed variation of a dimension (+ or – n).

**dish,**
The lower half of a sphere. See also **dome**. The point to which a base, or reference, point will be relocated when moving or copying entities.

**distance,**
The measure of space between two points.

**dock,**
To position a toolbar or the command bar at the edge of the drawing window, where it locks into place. See also **float**.

**dome,**
The upper half of a sphere. See also **dish**.
donut,
   A filled circle or flat ring created as a polyline.

drawing extents,
   See extents.

drawing limits,
   See limits.

drawing unit,
   The linear measurement system used in a drawing. The user determines what a drawing unit represents, such as one inch, one centimeter, one foot, or one meter.

DWF,
   Acronym for Autodesk Design Web Formatä, a file format for viewing twodimensional or three-dimensional drawings in a Web browser and distributing for review using free Autodesk® software and tools.

.dwg,
   A standard file extension used by CAD programs to store drawing files of the DWG format.

.dwt,
   A standard format used by CAD programs to store drawing templates, which are drawings that contain predefined settings that you can use when creating a new drawing. See also template.

DXF,
   Acronym for Drawing Exchange Format, a standard ASCII or binary file format for importing and exporting files between most CAD programs.

elevation,
   The z value measured from the xy plane. Positive values are above the xy plane; negative values are below the xy plane.

embed,
   A technique for exchanging information between different programs whereby a copy of the source document is stored in the target document. See also ActiveX and link.

EMF,
   Acronym for Enhanced Metafile, a file format with the type and extension of .emf. It is a native internal file format of Windows 98. EMF supports both raster and vector information and 24-bit RGB color. Most Windows-based programs support this format.

endpoint,
   The point at which a line or curve ends.
**entity,**
Any single basic item in a drawing. Entities include arcs, attributes, blocks, circles, dimensions, ellipses, elliptical arcs, infinite lines, lines, polylines, rays, and text.

**entity data,**
Any of a variety of additional information, such as text, numbers, and distances, that can be attached to drawing entities.

**entity snap,**
A technique for accurately locating and specifying key geometric points on entities, such as endpoints and midpoints of lines, and center points and tangents of arcs and circles.

**entity snap override,**
To disable or change an entity snap mode for a single input. See also entity snap and running entity snap.

**Esnap,**
See entity snap.

**explode,**
The conversion of a complex entity into its basic entities.

**extension lines,**
Lines extending away from an entity being dimensioned so that you can place the dimension line away from the entity. Also called projection lines.

**extents,**
The smallest rectangle that can contain all the entities in a drawing. Infinite lines and rays do not affect a drawing’s extents. See also limits.

**external reference,**
A drawing that is linked to another drawing.

**extrude,**
The process of converting a two-dimensional entity into a three-dimensional entity by stretching (extruding) the two-dimensional entity along a straight path. Changing the thickness of a two-dimensional entity effectively extrudes it along its z-axis. See also tabulated surface.

**face,**
A planar surface defined by three or four points.

**fence,**
An entity-selection method that selects entities crossing a multisegmented line.
**fillet,**  
An arc that smoothly connects the end of one line to another.

**float,**  
To position a toolbar or the command bar away from the edges of the drawing window where it can be moved independently. See also **dock**.

**freeze,**  
To suppress the display of, and ignore the entities on, a specified layer when regenerating a drawing, thus accelerating the display of the drawing. See also **thaw**.

**grid,**  
An adjustable, regularly spaced pattern of dots on the screen, used as an aid in drawing and aligning entities. The grid is not printed.

**grip,**  
A small square displayed at key positions on an entity when the entity is selected that can be used to modify the entity by clicking and dragging.

**halfwidth,**  
The distance from the center of a wide polyline to its edge.

**hatch,**  
To fill a selected area either with lines, crosshatching, or a hatch pattern. See also **crosshatch**.

**hatch pattern,**  
A pattern, often representing a material such as steel, wood, or sand, for filling selected areas.

**hidden-line removal,**  
A visualization technique in which all lines that are hidden behind other entities or surfaces from your viewpoint are clipped or removed, giving the image the appearance of a solid entity.

**horizontal dimension,**  
A linear dimension measuring a horizontal distance.

**infinite line,**  
A line extending infinitely in both directions.

**insertion point,**  
The point where you place an entity into a particular space. A reference point by which an entity is inserted in a drawing.
intersection,
The point where two entities meet or cross.

isometric drawing,
A drawing aligned with an isometric plane.

isometric plane,
One of three planes representing the left, right, or top sides of an implied three-dimensional, orthogonal entity. Snap and grid points are aligned with the plane to constrain drawings.

layer,
The computer equivalent of overlays used in manual drafting. A tool by which drawing components can be organized into related sets, such as plumbing, framing, and electrical systems of a house, each being drawn on its own layer.

layout,
Similar to a sheet of paper, a representation of how a drawing will look when printed.

layout viewport,
A window in a Layout tab (paper space) that displays all or a portion of a drawing’s model space entities. See also paper space and model space.

leader,
A line leading from a feature of a drawing to an annotation.

limits,
The user-defined boundary of a drawing, defined by its lower left and upper right corner coordinates. See also extents.

limits tolerance,
Dimension text in which the measured dimension is replaced by the largest and smallest dimensions allowed, with the upper limit displayed above the lower limit. See also tolerance and variance tolerance.

linetype,
The appearance of a line, defined as a solid (continuous) line or as a pattern of dashes, dots, and blank spaces.

lineweight,
The width of a line, defined in millimeters or inches.

link,
A technique for exchanging information between different programs whereby the target document maintains a pointer to the original source document. Any changes to the source document are reflected in all target documents containing links to the source. See also ActiveX and embed.
LISP,  
Acronym for List Processing Language, a computer language invented in the late 1950s by John Mc-Carthy for use in artificial intelligence. Because it is interpreted rather than compiled, and is relatively straightforward, it is a convenient language for users to write routines to extend the set of commands and functionality of CAD.direct Drafter.

lock,  
Prevents unauthorized access to drawing layers.

M direction,  
In a polygon mesh, the direction from the first to the second row. See also N direction.

macro,  
In menus and toolbars, several commands grouped together as one. Also Visual Basic for Applications code.

major axis,  
The longest distance across an ellipse, from one end to the other. See also minor axis.

marker blips,  
Temporary screen markers displayed in a drawing when you select a point. Also called blips.

MDI,  

mesh,  
A set of connected polygon faces approximating a curved surface.

minor axis,  
The shortest distance across an ellipse, from one side to the other. See also major axis.

mirror,  
To create a reverse-image copy of selected entities by reflecting the entities symmetrically about a line or plane.

model space,  
The primary drawing area in which you create entities. See also paper space.

multiple-document interface,  
The ability to view and work with different drawings simultaneously.

N direction,  
In a polygon mesh, the direction from the first to the second column. See also M direction.
**named print style table,**
A collection of print styles that determine how entities print according to the print styles you create and assign to entities and layers. See **print style table**.

**named view,**
A saved view that can be recalled at a later time by specifying its name.

**nested block,**
A block contained as part of the definition of another block. See also **block**.

**nonassociative hatch,**
A hatch that is not associated with or linked to an entity.

**oblique,**
Geometric lines or planes that are not parallel or perpendicular.

**offset,**
See **parallel**.

**OLE,**
Acronym for Object Linking and Embedding. See **ActiveX**.

**ordinate dimension,**
A measurement of the horizontal (x-ordinate) or vertical (y-ordinate) distance from an established reference base point or datum.

**origin,**
The intersection point of the coordinate system axes. In a Cartesian coordinate system, the origin is the point at which the x-, y-, and z-axes intersect (the 0,0,0 coordinate).

**orthogonal,**
Having perpendicular slopes or tangents at the point of intersection.

**orthogonal mode (ortho),**
A drawing mode in which the entity creation is constrained to parallel the horizontal and vertical axes relative to the current snap angle.

**orthographic projection,**
A drafting technique by which a three-dimensional item is described in two dimensions by showing it from various directions, most commonly front, top, and side views.

**outside circle,**
An entity-selection method that selects entities falling completely outside a circular selection window.
outside polygon,
An entity-selection method that selects entities falling completely outside a polygon selection window.

outside window,
An entity-selection method that selects entities falling completely outside a rectangular selection window.

pan,
To shift the displayed view of a drawing without changing the magnification. See also zoom.

paper space,
A two-dimensional work area similar to a sheet of paper, in which you can arrange different views of your model as layout viewports. See also model space.

parallel,
Two or more coplanar lines that never intersect one another.

parallel dimension,
See baseline dimension.

PDF,
Acronym for Portable Document Format. PDF files can be viewed using Adobe® Acrobat Reader, which is free software that users can download; they can also be viewed, reviewed, and edited using Adobe® Acrobat.

perimeter,
The distance around the boundary of an entity.

perpendicular,
Entities at right angles to one another.

planar,
Entities whose extents are situated entirely within a plane.

plane,
Two-dimensional surface.

plan view,
A view of the drawing from above, looking down the z-axis perpendicular to the xy plane of the current UCS.

point,
A location in space specified by its x-, y-, and z-coordinates. A drawing entity consisting of a single x,y,z-coordinate location and represented by one of several symbols.
point filter,
   See coordinate filter.

polar array,
   Multiple copies of selected entities in a circular pattern.

polar coordinates,
   Coordinates describing a two-dimensional point on a twodimensional plane based on the point’s distance from the origin and its angle in the plane. See also Cartesian coordinates, coordinates, cylindrical coordinates, relative coordinates, and spherical coordinates.

polygon,
   A closed single entity with three or more sides.

polyline,
   A drawing entity composed of one or more connected line or arc segments treated as a single entity.

print style,
   A collection of settings, including color, pen width, linetype, and lineweight, that determine how a drawing looks when it is printed. See print style table.

print style table,
   A collection of print styles that you can assign to the Model tab or to a Layout tab. Print style tables change how a drawing looks when you print it without modifying the actual entities. See print style.

profile,
   File that contains your preferred drawing environment settings.

projection lines,
   See extension lines.

prompt box,
   A list of options displayed when a command or tool provides several choices.

Prompt History window,
   A window containing a history of the most recent commands and prompts issued since you started the current session of CAD.direct Drafter.

quadrant,
   One-fourth of a circle, arc, or ellipse entity. In the context of entity snaps, the option that snaps to points on a circle, arc, or ellipse at each quadrant.

radial dimension,
   A dimension that measures the radius of a circle or arc.
radian,
A unit of angular measurement; 360 degrees equals 6.283185 or 2\(\pi\) radians.

radius,
The distance from the center of a circle or sphere to its periphery.

ray,
A line that starts at a designated point and runs infinitely.

ray tracing,
A visualization technique in which rays from imaginary light sources are traced as they refract off the surfaces of a model, determining where shadows fall and how reflections on shiny materials such as metal and glass appear.

rectangle,
A four-sided, closed entity whereby opposite sides are equal in length.

rectangular array,
Multiple copies of selected entities in a rectangular pattern consisting of a specified number of columns and rows.

redo,
To reverse the effect of previous undo commands. See also undo.

redraw,
To quickly update or refresh the drawing screen display. See also regenerate.

regenerate,
To update or refresh the drawing screen display by recalculating the drawing from its database. See also redraw.

region,
A two-dimensional closed, surfaced, planar boundary.

relative coordinates,
Coordinates expressed in relation to a previous coordinate. See also absolute coordinates.

render,
A visualization technique in which all surfaces of a model are shaded as though they were illuminated from an imaginary light source located behind you as you face the screen. Rendered images are photo-realistic, having depth, shadow, reflection, and texture.
revolve,
  Creating a three-dimensional surface entity by rotating a two-dimensional profile around an axis.

right-hand rule,
  A visual aid for remembering the relative directions of the positive x-, y-, and z-axes of a Cartesian coordinate system and the positive rotation direction about an axis.

rotate,
  To change the orientation of an entity, without modifying it, by repositioning it equidistant from, but at a new angle with respect to, a point or axis.

rotation angle,
  The angle by which an entity is displaced from its original location when rotating it about a point or axis.

rubber-band line,
  A ghosted image line that stretches dynamically on the screen with the movement of the cursor. The line extends between a fixed point and the cursor position to provide dynamic feedback.

ruled surface,
  A three-dimensional polygon mesh that approximates a smooth surface between two entities.

running entity snap,
  Setting an entity snap so that it continues for subsequent selections. See also entity snap and entity snap override.

scale,
  To resize an entity. To draw according to the proportions of an entity.

script,
  A set of commands stored in an ASCII script file and replayed in sequence by running the script.

SDS,
  Acronym for Solutions Development System, a C programming interface for developing specialized programs to run inside CAD.direct Drafter.

segment,
  Any part of an entity bounded by two points.

selection set,
  One or more drawing entities selected on which one can operate as a single unit.

shade,
  To fill planar entities with solid colors for easier visualization.
**snap angle,**
The angle around which the snap grid is rotated.

**snap grid,**
An invisible grid that locks entity creation to a specified alignment and snap increment when Snap is enabled.

**snap resolution,**
The spacing between points on the snap grid.

**snapshot,**
A raster representation of the current view of one’s drawing.

**spherical coordinates,**
Coordinates describing a point in three-dimensional space based on its distance from the origin, its angle in the xy plane, and its angle up from the xy plane. See also Cartesian coordinates, coordinates, cylindrical coordinates, and polar coordinates.

**spline,**
A curve generated along the path of three or more control points. The curve passes through the start point and endpoint, but does not necessarily pass through the intermediate control points.

**status bar,**
The bar at the bottom of the CAD.direct Drafter window that displays information about the selected command or tool as well as the cursor coordinates, the name of the current layer, mode settings, and other information about drawing settings.

**surface model,**
A three-dimensional model consisting of both edges and the surfaces between those edges. See also wire-frame model.

**surface of revolution,**
A three-dimensional polygon mesh that approximates the surface generated by rotating a two-dimensional profile around an axis.

**SVG,**
An acronym for Scalable Vector Graphic, which is a file format for working with interactive graphics, including a Web development language.

**system variable,**
A setting or value that stores operating environment and command information (such as the drawing limits or global linetype scale factor).
tabulated surface,
A three-dimensional polygon mesh that approximates the surface generated by extruding a curve along a vector. See also extrude.

tangent,
A line that passes through a single point on a curve.

template,
A drawing with preset layers, linetypes, and other settings (and entities) that can be used as the basis for creating a new drawing. Templates are saved with a .dwt file extension.

text style,
A named, saved collection of format settings that determines the appearance of text.

thaw,
To redisplay a layer that was frozen. See also freeze.

thickness,
An entity's depth, as measured along its z-axis. The distance an entity is extruded above or below its elevation. See also elevation and extrude.

through point,
In creating a parallel entity, a point through which the new entity passes.

tolerance,
Dimension text indicating how much the actual dimension of a manufactured component can vary from the specified dimension. See also limits tolerance and variance tolerance.

tolerance command,
A command that creates a feature-control frame used in mechanical geometric dimensioning and tolerancing.

toolbar,
A collection of tools arranged on a palette that can be moved and resized anywhere on the screen.

torus,
A donut-shaped, three-dimensional entity.

transparent command,
A command started while another command is already active. You can use a command transparently by preceding it with an apostrophe.
**true color,**
Colors defined using 24-bit color. There are more than 16 million true colors from which you can choose.

**UCS,**
Acronym for user coordinate system. See **user coordinate system**.

**UCS icon,**
A user coordinate system icon that shows the orientation of the coordinate axes, the location of the coordinate system origin, and the viewing direction relative to the xy plane.

**undo,**
To reverse the effect of previous commands. See also **redo**.

**unit,**
See **drawing unit**.

**unlock,**
Free access to layers in a drawing that would be otherwise locked, thus prohibiting them from being viewed or edited by another user.

**user coordinate system,**
A Cartesian coordinate system with origins and orientation defined by the user. See also **World Coordinate System**.

**variance tolerance,**
Dimension text in which a plus/minus value is appended to the specified dimension to indicate how much the actual dimension of a manufactured component can vary from the specified dimension. See also **limits tolerance** and **tolerance**.

**VBA,**
Acronym for Visual Basic for Applications, a macro programming language embedded in programs that allows the user to customize the program.

**vector,**
A means of describing a displacement using magnitude and orientation. For example, you can create a line entity, or move an entity, by specifying an initial point, a direction, and a distance.

**vertex,**
The point of intersection of the sides of an angle. The start points or endpoints of a line or arc segment in a polyline.

**vertical dimension,**
A linear dimension measuring a vertical distance.
**view,**
A representation of a drawing or portion of a drawing from a specific viewpoint in three-dimensional space.

**viewpoint,**
A location in three-dimensional space for viewing one’s drafting.

**viewport,**
A window that displays all or a portion of a drawing’s model space entities while in model space on the Model tab. *See also* model space and paper space.

**viewport configuration,**
A named arrangement of windows that can be saved and restored.

**WCS,**
Acronym for World Coordinate System. *See World Coordinate System.*

**wedge,**
A three-dimensional entity that resembles a box divided along one side from one corner to the opposite corner; for example, a doorstop or a ramp.

**window circle,**
An entity-selection method that selects entities contained entirely within a circular selection window.

**window inside,**
An entity-selection method that selects entities contained entirely within a rectangular selection window.

**window polygon,**
An entity-selection method that selects entities contained entirely within a polygon selection window.

**wipeout,**
An entity that displays with the current background color, so the details behind it do not display or print.

**wire-frame model,**
A three-dimensional model consisting of lines and curves that define the edges of a three-dimensional entity. *See also* surface model.

**WMF,**
Acronym for Windows metafile, a format containing vector and color information to render entities.

**World Coordinate System,**
The fixed Cartesian coordinate system used as the basis for defining other coordinate systems. *See also* user coordinate system.
xref,
   See external reference.

zoom,
   To increase or decrease the magnification of the display of a drawing. See also pan.